fedora-qa
LOGS
15:03:21 <adamw> #startmeeting fedora-qa
15:03:21 <zodbot> Meeting started Mon Jun 11 15:03:21 2012 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:03:37 <adamw> #meetingname fedora-qa
15:03:37 <zodbot> The meeting name has been set to 'fedora-qa'
15:03:47 <adamw> #topic roll call
15:03:53 <adamw> who's around for some qa meetage?
15:03:57 * pschindl is here
15:04:00 * mkrizek is here
15:04:14 * maxamillion is here
15:04:24 * tflink is here
15:04:29 * strace is here
15:04:30 * nirik is lurking
15:05:07 * jskladan lurking
15:05:18 * Cerlyn is here
15:05:21 * kparal around
15:05:54 <adamw> excellent...then i shall UNLEASH THE HOUNDS
15:06:07 * kparal flees
15:06:15 <adamw> #topic previous meeting review
15:06:21 <adamw> #topic previous meeting follow-up
15:06:22 <adamw> sigh.
15:06:33 <adamw> #chair kparal tflink
15:06:33 <zodbot> Current chairs: adamw kparal tflink
15:06:40 <adamw> here, use this chair to fend off the hounds...if you can.
15:06:58 <adamw> #info adamw to review F17 retrospective and come up with an action plan
15:07:12 <adamw> didn't get this done yet; as you probably saw on friday i got up to clearing through the f16 trac tickets
15:07:12 * tflink grabs a whip and strikes a lion/hound taming pose
15:07:31 <adamw> so i'm working around to it
15:07:52 <adamw> any questions/notes/personal insults?
15:08:34 <adamw> #info adamw to work with rbergeron to make sure housekeeping gets done for f16/f17/f18
15:08:47 <adamw> oh looky, another one i didn't do yet! well, robyn and i have chatted about housekeeping a bit, but not complete yet.
15:09:26 <adamw> #info neither retrospective nor housekeeping tasks are complete yet, but adamw is working on both
15:09:41 <adamw> #action adamw to review F17 retrospective and come up with an action plan
15:09:47 <adamw> #action adamw to work with rbergeron to make sure housekeeping gets done for f16/f17/f18
15:09:52 <adamw> i'll just throw 'em back on there for next week.
15:09:58 <adamw> anything else?
15:10:19 <maxamillion> not that I can think of :)
15:10:55 <adamw> okely dokely, moving on
15:11:09 <adamw> #topic Fedora 18 check-in
15:11:22 <adamw> probably nothing doing here, but i thought we'd zoom by just in case
15:11:26 <maxamillion> check-in?
15:11:38 <adamw> just a general f18 topic
15:11:45 <adamw> first on the list, any news on anaconda?, i think the answer's no.
15:12:53 <adamw> second, check through f18 features - seemed a good thing to do quickly in a meeting, to see if there's anything else scary on the f18 agenda yet
15:13:00 <adamw> https://fedoraproject.org/wiki/Releases/18/FeatureList
15:13:34 <adamw> anyone see anything that leaps out?
15:13:35 <maxamillion> depends on your defenition of scary I suppose
15:13:54 <adamw> 'things that will require love and care to make sure they bleedin' well work and don't screw up release validation'
15:14:09 <adamw> those kerberos changes, for e.g., look like the sort of thing that might break remote login...
15:14:11 <maxamillion> I'll be partaking in the openshift origin efforts, we'd like to have a test day once we're at that point in the release cycle
15:14:24 <maxamillion> ah, rgr
15:14:41 <strace> I will be helping with OpenShift Origin also
15:14:50 <adamw> cool. that would be handled fine by a test day, yeah.
15:15:34 * tflink doesn't see anything else that jumps out as potentially problematic
15:15:52 <maxamillion> tflink: +1
15:16:16 <adamw> there's usermode migration', but that shouldn't be horrible, most central stuff is PK already and we understand it well enough that hopefully nothing will break in migration..
15:16:30 <adamw> so yeah, looks like so far, no really scary features outside of anaconda new UI.
15:16:44 * j_dulaney waves
15:16:54 <tflink> the package group changes could be interesting but that page is a little light on the details
15:17:01 * j_dulaney is still recovering from SELF
15:17:34 <adamw> tflink: yeah, that's notting's baby
15:17:38 <adamw> hi dulaney
15:17:59 <adamw> tflink: i think he's thinking more about the post-install, 'groups you see in packagekit' side, but i agree it's light on detail
15:19:07 <tflink> it's mostly the upgrade stuff that sounds like it could be interesting
15:19:08 * j_dulaney wonders about the specific topic here
15:19:24 <adamw> j_dulaney: right, sorry - we're reviewing the F18 feature list at https://fedoraproject.org/wiki/Releases/18/FeatureList
15:19:35 <tflink> "Users who install Fedora 18 and later upgrade will automatically get group changes for the groups that they have installed."
15:19:37 <adamw> just checking through to make sure we don't see anything scary from a QA perspective there
15:19:41 <j_dulaney> RGR
15:19:46 <adamw> tflink: ah, nice catch. yeah, that'll be worth testing.
15:19:57 <adamw> though it sounds like it mostly affects 19.
15:20:09 <tflink> although I'm not clear if that applies to people upgrading to F18 or from F18
15:20:18 <adamw> hey, that's the first time i officially referred to fedora 19 anywhere. *raises small flag*
15:20:28 <adamw> to me it reads like it applies to upgrades from 18->19 and later.
15:20:43 <tflink> that would make more sense, regardless of the phrasing
15:22:24 <adamw> #agreed the current F18 feature list contains no features we find particularly sensitive from a QA standpoint aside from the new anaconda UI. other features to keep an eye on are the package group re-organization, /tmp-on-tmpfs and the kerberos changes.
15:23:10 <j_dulaney> RPM upgrade may need some poking?
15:23:16 <j_dulaney> Or should that be fine?
15:23:32 <adamw> that's the kind of thing that everyone will be testing all the time, unavoidably
15:23:42 <j_dulaney> Ah
15:23:44 <adamw> so it likely doesn't need any special poking - we should catch anything that comes up
15:23:59 <j_dulaney> Same with user mode migration, I imagine?
15:24:24 <adamw> broadly, yeah, and given that we've been converting things to PK for years, we ought to have the hang of it by now.
15:25:16 <adamw> next thing on the list was 'retrospective tasks', if i'd done them yet, but i haven't. so, we'll skip that!
15:25:25 <adamw> #topic Bugzilla upgrade work
15:26:01 <adamw> okay, so this is a callback to something that came up during f17 final validation - see https://fedoraproject.org/wiki/QA/Meetings/20120514
15:26:46 <adamw> bugzilla got a big version upgrade late in the f17 cycle, and that has impacts on several things that we use in QA. tflink provided a list and we said we'd work on fixing up anything that needs fixing after f17 was done. well, f17 is done now =)
15:26:59 <adamw> tflink: shall we take the things on the list one at a time?
15:27:16 <tflink> adamw: works for me
15:27:46 <adamw> #topic Bugzilla upgrade work - Blocker wiki page will no longer work
15:28:01 <adamw> so, with the BZ upgrade, the script that updates https://fedoraproject.org/wiki/Current_Release_Blockers is broken
15:28:14 <adamw> tflink and I updated it manually till we were done with f17, but now it's just stuck
15:28:19 <adamw> had you had some ideas here, tflink?
15:28:24 <tflink> I've looked at the script a little bit and have fixed a few things but it's not done yet
15:28:48 <tflink> in the past, we've talked about possible other solutions for tracking blockers that don't rely on MW or scripts being run
15:29:06 <tflink> I figure that it's a good time to think about that since our previous solution isn't working, anyways
15:29:43 <adamw> what's on the list?
15:29:52 <tflink> adamw: the list?
15:30:16 <nirik> there's a new python-bugzilla.
15:30:25 <nirik> needs mucho testing by everyone. ;)
15:30:30 <adamw> tflink: the list of alternative solutions.
15:30:40 <tflink> nirik: yeah but the scripts using it still need to be updated AFAIK
15:30:55 <tflink> but it isn't crashing as much any more - still hitting proxy errors last I tried, though
15:31:09 <tflink> adamw: anything we do would pretty much be custom
15:31:32 <adamw> you have any ideas you like? throw me a bone =)
15:31:44 <tflink> the options would be to keep it scripted and on the wiki, keep it scripted and generate static html or start making it a more dynamic webapp that can do better tracking
15:31:59 <tflink> like keep track of previous blockers, offer different filters of the bugs to view etc.
15:32:35 * tflink is just not sure how much interest there is and whether it would be worth the time needed to write such an app
15:33:03 <j_dulaney> It would be cool, but I don't think worth the effort
15:33:18 <adamw> has anyone felt like they wished the current blocker page could do more?
15:33:43 <adamw> i guess i'm with dulaney, it seems to do the job as is
15:33:58 <mkrizek> +1
15:34:12 <tflink> it might be worth the effort to switch to HTML generation instead of MW
15:34:40 <adamw> on the idea that it's more robust?
15:34:52 <tflink> less wonky syntax
15:34:57 <tflink> in theory
15:35:13 <adamw> i guess it wouldn't be a huge effort?
15:35:24 <tflink> we could also get some new features without worrying about app hosting or a db
15:35:34 <tflink> ie build the filters into the HTML
15:35:50 * nirik might suggest running it in fedora infrastructure... that way we have people who can watch it and knows where it runs, etc.
15:36:19 <adamw> wouldn't be difficult to get permission, would it?
15:36:28 <tflink> the other problem with MW is password expiration - we had several times where the page wasn't updated because the updater's pw was only saved for so long
15:37:09 * j_dulaney is starting to lean +1 for HTML
15:37:46 <adamw> yeah, if it's not much trouble to do, that seems like the sensible route. using MW isn't gaining us anything in particular, the page is always just used alone.
15:38:12 <tflink> we'd be decreasing the number of edits to the wiki that jlaska is making :)
15:38:21 <j_dulaney> LOL
15:38:24 <nirik> tflink: yeah, for those things we setup a bot account that has no password or doesn't expire it's password or the like.
15:38:30 <nirik> but html works fine too.
15:38:49 <tflink> nirik: we probably should have done that, yeah
15:39:26 <nirik> we already run things that do both... generate html/static pages, and edit the wiki... so either one works.
15:39:44 <adamw> okay, i think we talked this one out
15:39:51 <adamw> tflink, are you happy to work on this? or does anyone else want it?
15:40:06 <tflink> I can do it but I'm not really going to stop others from doing it, either
15:40:41 <tflink> er, would be happy if someone else wanted to do it, rather
15:40:43 <adamw> if any tooling person is looking for a task and finds this interesting, speak it
15:40:44 <kparal> let's wait until we have some interns in Brno :)
15:40:45 <adamw> speak up *
15:41:03 <adamw> kparal: what's the timeframe on that? we'd want the new page up for alpha, obviously
15:41:23 <kparal> hmm, hiring date is mid July
15:41:33 <tflink> when is alpha?
15:41:35 <kparal> provided we find someone suitable
15:41:44 <tflink> when do we branch, rather
15:41:50 <adamw> http://rbergero.fedorapeople.org/schedules/f-18/f-18-quality-tasks.html
15:42:01 <kparal> http://fedoraproject.org/wiki/Releases/18/Schedule
15:42:14 <adamw> branch date is july 31
15:42:15 <kparal> 2012-08-07	 Branch Fedora 18 from Rawhide-- Branch Freeze
15:42:22 <adamw> huh
15:42:24 <kparal> interesting
15:42:29 <adamw> different on http://rbergero.fedorapeople.org/schedules/f-18/f-18-releng-tasks.html
15:42:33 <adamw> i dunno which wins
15:42:37 <tflink> first blocker meeting is 2012-07-20
15:42:48 <adamw> but either way, sounds like slightly tight timing
15:43:59 <tflink> yeah, I'd rather get it done sooner than later in case there are issues with python-bugzilla
15:44:02 <adamw> i'd rather have it taken care of by someone who's around now in that case
15:44:02 <adamw> yup
15:44:31 <adamw> okay, for now i'll assign to tflink, we can change it if needed
15:44:54 <adamw> #action tflink to fix up blocker bug page for new bugzilla, probably as fedora-hosted static HTML rather than in MW
15:44:55 <tflink> works for me, I need to update my blocker meeting prep scripts anyways
15:45:09 <adamw> tflink: one of us should file a trac ticket too.
15:45:10 <tflink> and they have some codebase overlap with the wiki update script
15:45:26 <adamw> #topic Bugzilla upgrade work - Other scripts using python-bugzilla will likely not work after upgrade
15:45:30 <adamw> for instance =)
15:45:32 <adamw> what others are there?
15:45:46 <tflink> adamw: I assume you mean a qa trac ticket to cover the blocker tracking page stuff? If so, I can do that
15:45:59 <tflink> nothing that I'm aware of in QA land
15:46:15 <adamw> tflink: yeah.
15:47:03 <adamw> tflink: there's https://fedoraproject.org/wiki/QA/SOP_Test_Day_management#Do_a_post-event_review , which is not a script but an ugly hack i dreamed up for getting a list of bugs from a wiki page. should be trivial to patch up if it needs it.
15:47:27 * tflink wonders if we should try to put our scripts in more of a single place
15:47:44 <j_dulaney> Or at least list them all out
15:48:28 <adamw> there is https://fedoraproject.org/wiki/QA/Tools ./
15:48:43 <adamw> which looks like it may need an update.
15:48:51 <tflink> we could request a git repo for the fedora-qa fedorahosted account
15:48:54 <tflink> if there isn't one already
15:49:32 <tflink> the more I think about that, the more it sounds like a good idea
15:49:59 <tflink> at the very least, it could be a base for other scripts - bug output formatting, wiki scraping etc
15:50:08 <adamw> sure, sounds smart
15:50:17 <j_dulaney> +1
15:50:21 <tflink> sounds like /me has multiple actions :)
15:50:31 <kparal> what about using https://github.com/kparal/fedoraqa ?
15:50:39 <adamw> #action tflink to set up QA git account
15:50:47 <adamw> kparal: i'd much rather use a fedorahosted git for 'official' stuff.
15:51:03 <tflink> it's also not tied to a single persons' account
15:51:06 <kparal> I have no problem with that, I'll move my scripts there
15:51:36 <adamw> #topic Bugzilla upgrade work - Bodhi
15:51:41 <adamw> the final thing on this list was "Waiting on testing this week to find out how badly bodhi will be impacted"
15:51:54 <adamw> did bodhi get fixed wrt new bugzilla yet?
15:52:02 <tflink> AFAIK, there was an issue but it's been fixed now
15:52:06 <lmacken> before the new BZ was deployed, yes.
15:52:40 <adamw> eeeeeek, we've been jackwagoned
15:52:43 <adamw> thanks luke
15:52:46 <lmacken> :)
15:53:09 <adamw> #info Bugzilla upgrade work: tflink will take care of the current blockers page, we aren't aware of any other scripts that need fixing, and bodhi has been fixed
15:53:16 * kparal needs to go, bye
15:53:22 <adamw> kparal: anything for autoqa, quickly?
15:53:34 <kparal> none
15:53:43 <adamw> okey dokey! catch you later
15:53:55 <adamw> anyone have anything else on the new bugzilla?
15:54:05 <adamw> is it just me, or does the 'distribution release' field not exist/show up any more?
15:54:47 * tflink hadn't noticed but isn't sure if he used it before
15:55:30 <robatino> click on Detailed Bug Information (not terribly obvious)
15:55:41 <adamw> ah. thanks, andre
15:55:51 <adamw> alright, moving on quickly
15:55:56 <adamw> #topic autoqa update
15:56:02 <adamw> tim, do you have anything for this one?
15:56:16 <tflink> nope, I've been working on other stuff, mostly
15:56:45 <tflink> oh, there was some movement in RATS
15:56:49 * tflink double checks email
15:57:29 <tflink> nothing major, though
15:57:43 <tflink> so, no updates from me
15:57:46 <adamw> okay
15:57:53 <adamw> #info some minor RATS movement, nothing else from autoqa
15:58:00 <adamw> i guess work will be ramping up again soon?
15:58:12 <tflink> hopefully, yes
15:58:15 <adamw> cool.
15:58:19 <adamw> alrighty, very quickly...
15:58:21 <adamw> #topic open floor
15:58:32 <adamw> anything else anyone can think of we need to talk about?
15:58:34 <j_dulaney> adamw:  Two things from SELF
15:59:17 <j_dulaney> Firstly, I don't know if this has been communicated to QA at large or not, but Robyn said that Spot will be closing EOL bugs in Bugzilla
15:59:44 <adamw> j_dulaney: aha, great. that was on the agenda for earlier. i'll check in with them on that one
15:59:56 <adamw> #info j_dulaney reports that spot will be handling the EOL bug backlog
16:00:05 <j_dulaney> Secondly, there was some discussion about ARM going primary
16:00:22 <adamw> #info SELF hosted further discussion of ARM as a primary arch
16:00:42 <j_dulaney> My side was QA's role in that, but this would probably be better discussed as a full on topic next week
16:00:54 <j_dulaney> That way we can try to get some of the ARM folks involved
16:01:11 <adamw> sure.
16:01:18 <adamw> thanks!
16:01:31 <j_dulaney> Indeed
16:01:45 <j_dulaney> If you'll drop that on next week's agenda, that's it
16:02:33 <adamw> sure.
16:02:36 <adamw> anyone else?
16:03:31 * adamw sets fuse for X minutes
16:03:52 <tflink> do we have to solve for X now? This feels like math class :-/
16:04:04 <j_dulaney> Is that Roman Numeral X, or X -1 = 0?
16:04:16 <adamw> who knows!
16:04:33 <tflink> it's a mystery
16:04:34 <j_dulaney> dx/dy = sin x
16:04:58 <nirik> e^(i*pi)
16:05:29 <adamw> you're all wrong! X is now.
16:05:31 <adamw> thanks everyone
16:05:33 <j_dulaney> nirik, why did you have to get all imaginary?
16:05:33 <adamw> #endmeeting