fedora-kernel
LOGS
18:00:29 <jwb> #startmeeting
18:00:29 <zodbot> Meeting started Fri May 25 18:00:29 2012 UTC.  The chair is jwb. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:29 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:40 <jwb> #meetingname fedora-kernel
18:00:40 <zodbot> The meeting name has been set to 'fedora-kernel'
18:00:51 <jwb> #meetingtopic Fedora Kernel
18:01:02 <jwb> #topic Release overview
18:01:13 <davej> woop woop
18:01:20 <jforbes> fun
18:01:34 <jwb> start with f15?
18:01:40 <davej> yeah
18:01:47 <jwb> #Release overview - F15
18:01:53 <jwb> #topic Release overview - F15
18:01:59 <davej> a month until eol, and it might as well be dead already tbh.
18:02:11 <jwb> yeah
18:02:15 <davej> we've had 20 bugs opened against it in the last month (compared to the 191 for f16)
18:02:22 <jwb> i believe we've decided to stick with 3.3.x
18:02:23 <jforbes> 3.3.7 is sitting in updates-testing
18:02:56 <davej> the last couple of weeks of its life will be just security fixes, so hopefully not too many updates next month.
18:03:13 <jwb> i plan on doing whatever gregkh releases for 3.3.y, and that's about it
18:03:19 <davej> 307 f15 bugs still open. I suspect a bunch of those will become 16 (or newer) bugs next month
18:03:48 <davej> it's been stuck around the 300 mark for a few months now, we've mostly closed as many as come in for that release.
18:04:24 <jwb> anything else on this one?
18:04:29 <davej> I don't think it's worth mass-migrating them all to f16 bugs though, rather let the users do it if necessary.
18:04:41 <davej> I see it as an opportunity to clean out some deadwood bugs
18:04:43 <jwb> yeah, good point
18:05:01 <davej> that's all I have for 15
18:05:24 <jwb> #info F15 to stay on 3.3.y until EOL
18:05:45 <jwb> #info bugs will be looked over and triaged one final time
18:05:50 <jwb> #topic Release overview - F16
18:06:12 <jwb> who was doing f16?
18:06:12 <davej> 16 is a different story. still lots of bug activity.
18:06:21 <jforbes> so F16 (and F17) also have 3.3.7 in updates testing at the moment
18:07:13 <jforbes> At the same time we have 3.4 tracking and ready to commit once 3.3.7 has made it's way out, and once the initial mass of stable queue has been pushed
18:07:32 <jforbes> I expect the 3.4 push to happen next week
18:07:33 <jwb> #topic Release overview - F16/F17
18:07:34 <davej> 524 open bugs. 191 opened this month, 217 closed! lots of old bugs got closed out. (fallout from the i915 corruptor for eg)
18:07:52 <jwb> #info F16/F17 moving to 3.4 once 3.3.7 moves to stable updates
18:08:15 <jforbes> And we do have a small number of bugs which I know are addressed in 3.4 and we can close out once it ships.  not enough mass to make it worth backporting when we knew release was this close
18:08:56 * nirik notes from the peanut gallery that 3.4 here made iwlwifi unuseable again... expect bugs. ;)
18:09:23 <jwb> #info iwlwifi seems to have more issues.  again.  for like the 3rd kernel release
18:09:28 <davej> might be worth asking linville about that before we push a 3.4 update, to see if there's anything we need to backport
18:09:34 <davej> (or revert)
18:10:25 <jforbes> I will, nirik do you have any details anywhere?
18:10:38 <nirik> perhaps someone could get the developers some hardware to test with. ;)
18:10:45 <jwb> #action jforbes to discuss 3.4 iwlwifi issues with linville before rebase
18:10:50 <nirik> jforbes: no, but if you want I can retry it and gather info...
18:11:00 <nirik> it would just stop working after a few minutes.
18:11:10 <jforbes> nirik: I would appreciate it
18:11:12 <nirik> reloading the module made it work again for a few minutes.
18:11:20 <jwb> nirik, 802.11{a,b,g,n}?
18:12:04 <davej> I wonder if it's yet another case of intel moving to the latest shiny chipsets and breaking older ones they no longer test.
18:12:11 <jwb> i think it's somewhat known that N has issues.  i have iwlwifi here and it's worked fine on a G only network
18:12:20 <nirik> n
18:12:47 <nirik> but it works fine with 3.3.7 here (what I am on now)
18:13:02 <jwb> could koji bisect it ;)
18:13:29 <jforbes> so a regression specifically in n.  I put it on my wife's laptop last night, but we have a G only network here as well
18:14:06 <davej> I have N here, not noticed anything unusual, but I've not been using it as much lately
18:14:22 <nirik> I can try and gather more info on it.
18:14:32 <jforbes> nirik: Thanks
18:14:53 <jwb> anything else on F16/F17?  i kinda lumped them together
18:14:59 <jwb> F17 releases tuesday.  woot
18:15:20 <davej> I suspect we'll get a bunch of shiny new bugs when that gets into peoples grubby hands
18:15:34 <jwb> #info F17 Gold.  Yay.  0-day kernel updates will be pending for all
18:15:47 <davej> 81 open f17 bugs right now. quite a few I think are fixed in 3.4
18:16:32 <jforbes> Yup, 3.4 will let us close a good number of bugs, let's hope it does't open just as many.  It has been stable here for a while though
18:17:08 <jwb> #info 3.4 rebase (iwlwifi issues aside) should close a number of f17 bugs
18:17:21 <jwb> anything else?
18:17:35 <davej> rawhide ?
18:17:41 <jwb> #topic Release overview - rawhide
18:17:44 <jwb> so
18:17:52 <jwb> the 3.4 final release in rawhide was a non-event
18:17:55 <davej> rawhide feels kinda virtually untested these days.
18:17:59 <jwb> exactly
18:18:10 <jwb> i've rebased it to 3.5 merge window kernels already
18:18:11 <davej> we had just 14 bugs opened this month against rawhide
18:18:15 <davej> lower than f15!
18:18:21 <jwb> so far, the tty lockdep issues are the biggest item found
18:18:40 <jwb> hit another issue in udev where it would make USB devices act funny.  that needs a udev patch
18:18:52 <jwb> mjg59 provided that already this morning
18:19:04 <jwb> aside from those two things, it's been fairly boring on my hardware
18:19:21 <davej> I think things have been this way since fedora started doing branched releases. I suspect once 17 is out, we'll get a bunch of rawhide users, up until we branch again.
18:19:38 <jwb> here's hoping
18:20:04 <jwb> oh
18:20:08 <jforbes> Well, it's good timeing, we should get more rawhide users as 3.5 gets closer to release
18:20:12 <jwb> uprobes is merged and enabled now
18:20:21 <jwb> #info rawhide rebased to 3.5 merge window
18:20:26 <jwb> #info uprobes merged and enabled
18:20:28 <brunowolff> I am using rawhide on my home desktop with the nodebug builds and things have been working pretty smoothly.
18:21:02 <brunowolff> I fall a little behind because I only use one (the nodebug) build per RC.
18:21:37 <jwb> brunowolff, cool.  good to know :)
18:21:48 <jwb> ok, anything else on rawhide?
18:22:13 <jwb> #topic Open Floor
18:22:40 <brunowolff> I s 3.6 likely to make it into F18 at release?
18:22:40 <jforbes> just a note that the regression test framework is on fedorahosted http://git.fedorahosted.org/git/?p=kernel-tests.git
18:23:05 <jwb> #info kernel-test regression test framework on fedorahosted now
18:23:11 <davej> brunowolff: probably
18:23:15 <jwb> #link http://git.fedorahosted.org/git/?p=kernel-tests.git
18:23:22 <jforbes> This is just the framework, I am cleaning up some tests which will be pushed probably over the next couple of days.
18:23:45 <jforbes> Also, the docs have been updated on the wiki to reflect what is in git. https://fedoraproject.org/wiki/KernelRegressionTestGuidelines
18:23:59 <jwb> cool
18:24:31 <jforbes> I will get a more detailed email out to the kernel list shortly, and once we get a good number tests in the tree I will get emails out to devel-list and see if we can get people actively running it
18:24:57 <jforbes> Also, patches welcome, encouraged, appreciated... kernel list would be the best place to send them
18:26:26 <jwb> nice
18:26:40 <jwb> anyone have an other topics or questions?
18:27:31 <davej> jforbes: probably want to add an empty logs/ dir in the topdir (or mkdir it in the script if it doesn't exist)
18:29:01 <jforbes> davej: Doh. I have one, but I guess git didn't add the empty dir.  Will fix
18:29:29 <jwb> i think we're starting to lag
18:29:37 <jwb> meeting seems done :)
18:29:45 <davej> yeah, ending early wfm
18:29:56 <jwb> ok, 30 seconds...
18:30:11 <jwb> #endmeeting