cloud_sig
LOGS
19:00:40 <rbergeron> #startmeeting Cloud SIG
19:00:40 <zodbot> Meeting started Fri May 11 19:00:40 2012 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:44 <agrimm> hi
19:00:44 <rbergeron> #meetingname Cloud SIG
19:00:44 <zodbot> The meeting name has been set to 'cloud_sig'
19:00:47 <rbergeron> HI!
19:00:49 <gholms> Hello, mah cloudies!
19:00:56 <sdake> yo
19:00:57 <rbergeron> #topic HULLO, MAH CLOUDIES
19:00:58 <gregdek> sup
19:00:58 * jsmith is here and lurking
19:01:01 <rbergeron> who's here?
19:01:05 <rbergeron> oh look, an sdake
19:01:10 * rackerhacker waves
19:01:13 <tdawson> Greetings.
19:01:18 <rbergeron> heya guys. :)
19:01:26 <rbergeron> I think we have fun topics for today.
19:01:35 * jsmith even did his duty and gave a keynote address at the Utah Open Source Conference on cloudy stuff
19:01:36 <rbergeron> #info present: rbergeron agrimm gholms sdake gregdek jsmith rackerhacker tdawson
19:01:57 <rbergeron> jsmith: excellent
19:02:11 <mestery> howdy all!
19:02:23 <rbergeron> well, we have some stacks and opens and stuff. I think we can start. :)
19:02:27 <rbergeron> mestery: heya! :)
19:02:41 <rbergeron> #topic OpenShift Origin
19:02:57 <rbergeron> I'm going to pick on tdawson first, because I think we are approaching awesome news.
19:03:07 <rbergeron> #chair gholms
19:03:07 <zodbot> Current chairs: gholms rbergeron
19:03:21 <rbergeron> tdawson: So! I hear we have some wiki pages and stuff.
19:03:32 <tdawson> Yes, both a wiki and a Features page.
19:03:42 <ayoung> \O/
19:03:43 <tdawson> https://fedoraproject.org/wiki/OpenShift_Origin
19:03:51 <tdawson> https://fedoraproject.org/wiki/Features/OpenShift_Origin
19:04:08 <rbergeron> #info We have a wiki page *AND* a feature page for F18 for OpenShift Origin.
19:04:15 <tdawson> For those that are curious, the opensource version of OpenShift is OpenShift Origin.
19:04:23 <tdawson> too many opens in that sentance.
19:04:41 <rbergeron> tdawson: as I said before in #fedora-cloud... I think it's probably ready, if you want to submit it to thefeature wrangler.
19:04:48 <rbergeron> She can put it in the queue and stuff. :)
19:04:57 <tdawson> OK, I'll do that.
19:05:19 <rbergeron> tdawson: are there going to be any plans to try and get OSO running on top of $cloudstuffinFedora - OpenStack, Euca, CS, etc? :)
19:05:19 <tdawson> I think we're progressing well, our only scary part is the rubygem-passenger dependancy
19:05:39 <rbergeron> tdawson: well, passenger has been scary for, oh, i dunno, 4 years, and it's actually in progress mode now, I think.
19:06:13 <rbergeron> or so it seems. :)
19:06:15 <tdawson> I know there are people who want to try getting it working on all the cloudy stuff, my first goal is getting it in though.
19:06:24 <rbergeron> tdawson: excellent point.
19:06:40 <rbergeron> I think there will be plenty of people willing to help test it out, fo sho.
19:06:49 <tdawson> We want it working on single instance, then progress from there.
19:07:37 <tdawson> A single instance is pretty boring ... but no one says that instance can't be in the cloud somewhere.
19:07:47 <rbergeron> tdawson: is there any way that people can just... grab a package and start packaging?
19:08:10 <rbergeron> I know sometimes people will list the bz and stuff, but it looks like there's only one in here going thus far.
19:08:19 <tdawson> Well, everything is in github, including the rpm specs, so it's possible for people to grab a package or two.
19:08:44 <rbergeron> #info Lots of packages - everything is in github, including rpm specs, so it is possible for people to grab a package if they'd like.
19:08:53 <rbergeron> Coolio.
19:09:17 <rbergeron> Alrighty. ANytihng else?
19:09:17 <tdawson> One of the people on our team is already going through the specs and cleaning them up, so hopefully it won't be as painful for people to pick a package.
19:09:18 <sdake> if someone is not a packager, I can sponsor you  to become a packager if you take on some openshift packaging work
19:09:40 * tdawson raises his hand.  "Oh, me ... sponsor me. :)"
19:09:44 <rbergeron> LOL
19:09:52 <rbergeron> yes, sponsor him!
19:09:54 <sdake> contact me via email sdake@redhat.com
19:10:01 <tdawson> Will do.
19:10:01 <mgoldmann> tdawson: where can I find the AS7 cartridge?
19:10:57 <tdawson> mgoldmann, That's on brew
19:10:57 <mgoldmann> we need to make sure that this will work nicely with the AS7 effort we have ongoing
19:11:27 <mgoldmann> ok, is there a plan to put this in github?
19:11:36 <tdawson> mgoldmann, I believe they were wanting to switch over to the efforts going into Fedora.
19:12:05 <rbergeron> #action sdake to help out tdawson with sponsorship, tdawson to mail sdake
19:12:22 <mgoldmann> cool, contact me if you need any changes in the AS7 RPM to meet your needs then
19:12:54 <tdawson> mgoldmann, OK, I will.  But I think we are planning on changing the rpm to meet your packages.
19:13:35 <mgoldmann> that's cool too :)
19:14:07 <tdawson> mgoldmann, I know high on their list to test is if you have everything they need in the F17 jboss release.
19:14:30 <tdawson> Thus far, nobody has complained.  I don't know if it's because everything is in there, or nobody has tested.
19:15:12 <mgoldmann> well, AS7 is not packaged fully, yet
19:15:25 <mgoldmann> but I'm working on it! :)
19:15:35 <sdake> monumental task
19:15:47 <mgoldmann> we'll make sure it'll play nicely with openshift
19:16:02 <rbergeron> mgoldmann: it's really close though :)
19:16:10 <mgoldmann> sdake: (117 packages alredy submitted)
19:16:21 <tdawson> mgoldmann, Thank you.
19:16:32 <mgoldmann> nope, 119 :)
19:16:39 <sdake> mgoldmann been busy ;)
19:16:44 <mgoldmann> aye
19:16:49 <rbergeron> just a bit :)
19:16:53 <rbergeron> Okay, moving on? :)
19:17:02 <mgoldmann> but without the community help - it would be nothing
19:17:04 <rbergeron> mgoldmann: lincolnthree gave a nice interview about it too
19:17:14 <rbergeron> since he knew what it was and was at opencloudconf
19:17:25 <mgoldmann> cool!
19:17:46 <rbergeron> Okay! NEXT UP
19:18:05 * rbergeron sticks her nose up in the air and detects a fresh scent
19:18:07 <rbergeron> #topic Eucalyptus
19:18:14 <rbergeron> agrimm, gholms, gregdek: HI GUYS.
19:18:17 <agrimm> hi
19:18:18 <gregdek> wuzzat?
19:18:28 <rbergeron> I have the damndest time trying to spell Euca somedays. Jesus.
19:18:38 <gregdek> You should stop at Euca. We do.
19:18:39 <rbergeron> Anyway: so you guys are looking at 3.1 in like, mid-june?
19:18:49 <gregdek> Yep. Beta sooner.
19:18:57 <gregdek> As in, imminent.
19:18:58 <agrimm> yup.  gholms has been working hard on internal build system and euca packaging
19:19:13 <agrimm> code release on github coming soon
19:19:27 <rbergeron> but you guys are waiting until GA to pckage stuff and get it in, correct?
19:19:29 <agrimm> and then we'll start charging toward F18
19:19:39 <rbergeron> will you put it into F17 as well?
19:19:53 <agrimm> that depends on how gwt work goes
19:20:02 <agrimm> are the oVirt guys working on that?
19:20:34 * rbergeron isn't sure. /me wonders if mestery knows anything there by chance, otherwise I can check into it
19:20:40 <agrimm> management wasn't to keen on my "let's just put it in F17 without the web UI" idea
19:20:56 * agrimm can't really blame them
19:21:20 <rbergeron> so ovirt has the same dependency?
19:22:09 <agrimm> AFAIK
19:22:20 <rbergeron> https://fedoraproject.org/wiki/OVirtPackaging
19:22:29 <rbergeron> Okay, well, I'm happy to throw a rock in that direction.
19:22:34 <agrimm> oh, right, they do have a tracking page
19:22:54 <rbergeron> #action rbergeron to check in with ovirt folks on gwt packaging
19:23:02 <gholms> Thanks!
19:23:12 <rbergeron> so basically: F17 is a no go (or f18 even) w/out GWT?
19:23:36 <agrimm> yup
19:24:15 <rbergeron> okay.
19:24:16 <agrimm> we'll still have packages in a repo that we host... just can't get into Fedora proper without figuring out how to make that beast build
19:24:17 * ke4qqq shows up late
19:24:20 <rbergeron> oh look!
19:24:23 <rbergeron> #topic CloudStack
19:24:27 * rbergeron coughs
19:24:40 <gholms> Heh
19:24:42 <rbergeron> can I harass you about cloudstack yet? :)
19:24:47 <ke4qqq> you can
19:25:09 <ke4qqq> but i have nothing new to share
19:25:26 <rbergeron> so, you guys are like, moving into apacheland, and.... well, that's about where I don't know anything else.
19:25:39 <rbergeron> are you blocked on time or are you blocked on actual problems that are enormous?
19:25:49 <ke4qqq> blocked on time
19:26:14 * rbergeron wonders if mdomsch might be willing to help out?
19:26:34 <rbergeron> ...and he's not around anywhere at the moment
19:26:42 <rbergeron> well, i suspect that may be an option.
19:27:25 <rbergeron> ke4qqq: is the page relatively up to date - https://fedoraproject.org/wiki/Cloudstack
19:27:28 <rbergeron> or not so much
19:27:36 <ke4qqq> yes
19:28:05 <rbergeron> okay. I'll stop harassing you now. :)
19:28:15 <rbergeron> #topic OpenStack
19:28:26 <rbergeron> #info Here a stack, there a stack, there an open, mooooooooooo
19:28:43 * rbergeron saw ayoung, saw mestery drop in, not sure who else i saw
19:28:47 <rbergeron> rackerhacker :)
19:29:05 <ayoung> Yeah,  I'm here....
19:29:09 <mestery> me too
19:29:19 * mestery has been in and out actually, but here now.
19:29:34 <rbergeron> mestery: this will be the most exciting meeting all week long. i promise
19:29:36 <rbergeron> ;)
19:29:57 <ayoung> ONe thing I am working on that might interest other CLoud folks/projects is the use of PKI for off line authorization checking
19:29:58 <rbergeron> mestery: i think you got an answer or two on your devstack q.
19:30:15 <rbergeron> ayoung: is that an openstacky thing or just a cloudy thing?
19:30:34 <ayoung> well, the first impl will be openstack based,  but the approach should work for all cloud impls
19:30:36 <ayoung> I'll post a link
19:30:43 <ayoung> http://wiki.openstack.org/PKI
19:30:49 <ayoung> the tl;dr version:
19:31:06 <ayoung> take the roles for a user and package them up in a document,  then sign the document
19:31:34 <ayoung> include that document with requests, and remote services can verify that a user has the roles that they need
19:32:07 <rbergeron> interesting
19:32:22 <ayoung> typically,  distributed systems have had one mechanism for a user to prove their identity (user id password or some certificate)
19:32:26 * rbergeron nods
19:32:34 <ayoung> and then the system does something like an LDAP lookup to confirm
19:32:46 <ayoung> that the user has the roles they need to do what they are asking to do
19:32:52 <mestery> ayoung: very cool indeed
19:33:09 <ayoung> but there is not reason that can't be bundled up,  especially if we are using some sort of short term ticket...
19:33:40 <ayoung> so the identity server has a key pair
19:33:48 <ayoung> they sign the document with the private key
19:33:57 <ayoung> but the rest of the services have the public key
19:34:21 <ayoung> If they don't it is only one network call to get it
19:35:15 <ayoung> Eventually,  we'd like to push that information into the X509 used for setting up the SSL connection, but baby steps for now.
19:35:53 <ayoung> Let me see if anyone else in Fedora land has anything more pertant re OPenstack
19:35:56 <rbergeron> interesting
19:36:13 <ayoung> The Ireland folks are probably getting a little Sandy Eyed...
19:36:26 <rbergeron> probably, though mgoldmann is here, lol
19:36:33 <rbergeron> I know he loves hanging out with us on friday nights :)
19:37:15 * mgoldmann is actually enjoying now some food :)
19:37:20 <rbergeron> LOL
19:37:23 <ayoung> I'm pretty sure pixelbeat works round the clock, too
19:37:30 <rbergeron> ayoung: indeed. you all do :)
19:38:43 <rackerhacker> ayoung: PKI idea is sweet (sorry, i disappeared for a few minuteS)
19:39:03 <rbergeron> rackerhacker: how's your xen bug coming along? i haven't looked in teh past 8 hours
19:39:10 <ayoung> rackerhacker, thanks.  I have to finish packagin noVNC and they aI go back to working on the Proofof concept for it
19:39:16 <ayoung> I'll report when I have it working
19:39:27 <rackerhacker> rbergeron: solved -- konrad@oracle and law@redhat hammered out the problem
19:39:36 <rackerhacker> just this afternoon, actually
19:40:09 <rackerhacker> i'm staring at a fully functional F17 install under XS6 right now
19:40:12 <rbergeron> awesome, indeed
19:40:18 <rbergeron> rackerhacker: nice.
19:40:25 <rackerhacker> rbergeron: the beef. it flows.
19:40:34 <rbergeron> well, i'm glad that one got resolved. I know it was bugging you for a while.
19:40:38 <rbergeron> no bad pun intended.
19:40:44 <rackerhacker> hah
19:40:46 <rbergeron> bugging/blocking :)
19:42:28 <rbergeron> okay! well
19:42:35 * rbergeron plays the jeopardy theme
19:42:39 <rbergeron> #topic Open Floor
19:42:49 * rackerhacker dances on the open floor
19:42:52 <jdarcy> We changed the licenses on GlusterFS.
19:43:20 <rackerhacker> jdarcy: what's the tl;dr on that? i saw your post but didn't get time to read it fully
19:43:21 <rbergeron> to?
19:43:27 <rbergeron> #chair jdarcy
19:43:27 <zodbot> Current chairs: gholms jdarcy rbergeron
19:43:53 <jdarcy> rbergeron: LGPLv3+ or GPLv2.  The idea is to facilitate people writing translators, which they're actually starting to do.
19:44:06 <jdarcy> It's been in the works for a long time.  Kaleb is the one who actually did the work.
19:44:36 <rbergeron> Or?
19:45:07 <jdarcy> Yeah, the license allows you to choose which one.  Seems weird to me, but legal recommended it.
19:46:22 * rbergeron sometimes wonders what happened to keep it simple stupid but... hey. :)
19:46:25 <rbergeron> whatever works.
19:46:25 <jdarcy> It seems like someone could choose one, then distribute with only that one stripping the other out.  In theory.
19:47:49 * rbergeron nods
19:47:55 <rbergeron> okay!
19:48:04 <rbergeron> well. congratulations on that. I know that is a pain in the ass.
19:48:11 <rbergeron> if nothing else.
19:48:25 <sdake> few devs are working on a project called heat - AWS CloudForm analog - tldr version is we take a template and turn it into a running cloud application on openstack environments
19:48:35 <rbergeron> #info glusterFS license has changed! now LGPLv3+ or GPLv2.  The idea is to facilitate people writing translators, which they're actually starting to do.
19:48:47 <rbergeron> sdake: is there a website for that?
19:48:52 <sdake> www.heat-api.org
19:48:58 * rbergeron hates asking stupid question sshe knows the answer to
19:49:00 <sdake> lots o links there
19:49:25 <sdake> irc channel #heat on freenode - if you want to join in ;)
19:49:29 <rbergeron> #info Heat project - AWS Cloudformation analog - tldr version is we take a template and turn it into a running cloud application on openstack environments
19:49:40 <rbergeron> #link http://www.heat-api.org
19:49:44 <rbergeron> #info in #heat on freenode
19:50:14 <rbergeron> sdake: thanks
19:50:31 <rbergeron> anyone else? projects? martinis? going once, going twice? :)
19:50:44 <sdake> 2 too many martinis last night
19:51:08 <rbergeron> never.
19:51:22 <gholms> I don't think rbergeron knows what that phrase means.
19:51:49 <gholms> Too many martinis?
19:51:52 <gholms> </joke>
19:52:22 <rbergeron> gholms: you're going to be an excellent board member. I can tell already. :)
19:52:34 <rbergeron> #info Garrett is now on the Fedora Board, because he is excellent. :)
19:52:39 <gholms> Heh
19:53:39 <rbergeron> Okay. I'm closing out!
19:53:45 <rbergeron> You guys get 7 minutes until your next meeting.
19:53:48 <rbergeron> MUHAHAHAHA.
19:53:53 <rbergeron> Have an excellent weekend, all.
19:54:03 <rbergeron> Remember to get your mothers and girlfriends and wives stuff for mother's day.
19:54:07 * rbergeron eyes sdake
19:54:12 <rbergeron> :)
19:54:12 <gholms> Heh
19:54:15 <rbergeron> Bye all.
19:54:17 <rbergeron> #endmeeting