cloud_sig
LOGS
19:01:08 <rbergeron> #startmeeting Cloud SIG
19:01:08 <zodbot> Meeting started Fri May  4 19:01:08 2012 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:13 <rbergeron> #meetingname Cloud SIG
19:01:13 <zodbot> The meeting name has been set to 'cloud_sig'
19:01:17 <rbergeron> #topic Who's here?
19:01:23 <rbergeron> #chair gholms|fail
19:01:23 <zodbot> Current chairs: gholms|fail rbergeron
19:01:50 * mdomsch 
19:01:56 * tdawson bows gracefully.
19:02:04 * gholms|fail lurks
19:02:19 <ayoung> already?
19:02:25 <rbergeron> I know.
19:02:34 <spstarr_work> rbergeron: here
19:02:56 <rbergeron> #topic Light Agenda for today
19:03:23 <rbergeron> #info We can cover stuff for whoever is around - I suspect opennebula, openstack, maybe euca, maybe cloudstack?
19:03:32 <rbergeron> #info Perhaps we can cover OpenShift as well now. :)
19:03:47 <tdawson> Whoo Hooo ... go OpenShift. :)
19:04:06 <spstarr_work> :)
19:05:14 <rbergeron> ;)
19:05:19 <rbergeron> Okay, well, shall we dance? :)
19:05:28 <rbergeron> #topic OpenNebula
19:05:32 <rbergeron> spstarr_work: go for it
19:05:43 <spstarr_work> we have the package ready for review
19:05:50 <spstarr_work> but im still waiting for someone to review :)
19:05:58 <rbergeron> #info opennebula package is ready for review, but needs to have someone review it
19:06:03 <rbergeron> spstarr_work: do you have the bz handy?
19:06:26 <spstarr_work> 815001
19:06:35 <spstarr_work> Review Request: opennebula - Cloud computing tool to manage a distributed virtual data center to build private, public and hybrid IaaS clouds
19:06:45 <rbergeron> https://bugzilla.redhat.com/show_bug.cgi?id=815001
19:07:01 * rbergeron wonders if anyone is willing :)
19:07:33 <spstarr_work> there's some issues that need to be discussed on that review such as ssh key generation done in %post etc
19:07:46 <mdomsch> _evil_
19:07:57 <rbergeron> mdomsch: how do you really feel :)
19:08:22 <ayoung> mdomsch, when should it be done?
19:08:30 <mdomsch> ayoung: service startup the first time
19:08:48 <mdomsch> when there's a halfway decent chance of there being some entropy around
19:08:55 <ayoung> mdomsch, so like postgres creats a database upon first startup?
19:09:08 <mdomsch> yes; or openssh-server
19:09:13 <ayoung> mdomsch, +1
19:09:26 <ayoung> spstarr_work, does that work for you?
19:09:47 <spstarr_work> we'd need a self-distructive script then
19:09:53 <spstarr_work> it cant be done in systemd
19:10:13 <spstarr_work> unless a self-destructing unit file?
19:10:19 <ayoung> spstarr_work, it wouldn't
19:10:28 <mdomsch> nah
19:10:34 <mdomsch> look at openssh.spec
19:10:45 <mdomsch> that bit runs only if the keyfiles don't exist already
19:10:58 <spstarr_work> good point on openssh for server keys..
19:11:04 <spstarr_work> the only catch is
19:11:17 <spstarr_work> OpenNebula is best run with a shared $HOME directory
19:11:32 <spstarr_work> you *can* run it without NFS but then you must copy the key to each hypervisor
19:11:54 <mdomsch> oh, these are user keys?
19:12:29 <mdomsch> then don't do it in the package install. repeat after me.  Package Install is barely more than copy files.
19:12:53 <mdomsch> you'll undoubtedly have some database stuff to initialize too; some form of "first deploy" script. Put it there.
19:13:45 <spstarr_work> we use sqlite
19:13:48 <spstarr_work> no need :)
19:14:06 <spstarr_work> on startup it generates whats needed in .db file (unless you use MySQL but thats not default config)
19:14:26 <mdomsch> ok, then there, look for keys, and if not present, create them
19:14:29 <rbergeron> spstarr_work: so basically you need a review and ... that's about it?
19:14:31 <spstarr_work> OpenNebula doesnt provide any first deploy scripts upstream
19:14:39 <rbergeron> or is this convo helping out a little bit there
19:14:39 <spstarr_work> rbergeron: then comps.xml addition and we're done.
19:14:57 <spstarr_work> the review still can happen in parallel to the ssh key part
19:15:12 <rbergeron> spstarr_work: okay. final change deadline is monday so ... it may be realllllly tight
19:15:46 <rbergeron> #info Final change deadline is monday - would really like to get this feature in, anyone willing to review the package?
19:15:52 <gholms|fail> If not impossible.  Don't forget that your three days don't start until a testing push.
19:16:02 <rbergeron> yeah
19:16:04 <rbergeron> #undo
19:16:04 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x2e541c10>
19:16:13 <gholms|fail> :(
19:16:15 <rbergeron> #info Final change deadline is monday - would really like to get this feature in, anyone willing to review the bz?
19:16:23 <rbergeron> Hey, we can aim high :)
19:16:30 <gholms|fail> :)
19:16:39 <rbergeron> i just worded incorrectly
19:16:55 <rbergeron> okay, looks like I'm moving onwards?
19:16:58 <tflink> gholms|fail: it can be pushed straight to stable if it gets enough karma
19:17:05 * rbergeron spins the wheel of fate
19:17:08 <rbergeron> #topic OpenStack
19:17:16 <gholms|fail> Touché
19:17:32 <rbergeron> ayoung, dprince: about?
19:17:48 <ayoung> novnp?
19:17:52 <ayoung> novnc rather
19:18:06 <ayoung> what other projects are interested in it?
19:18:12 <ayoung> we know openstack.
19:18:14 <rbergeron> novnc?
19:18:19 <rbergeron> anyone else?
19:18:24 <ayoung> rbergeron, HTTP based vnc client
19:18:32 <ayoung> talk websockets back to the server.
19:18:47 <ayoung> had some indication that oVirt was interested
19:18:53 <rbergeron> ovirt
19:19:06 <tflink> qa could be interested at some point
19:19:07 <rbergeron> yeah, they use it, i don't think anyone here comes from there - they all hang out on oftc.net though
19:19:15 <tflink> I;ve been playing with guacamole more, though
19:19:28 * gregdek lurks
19:19:38 <rbergeron> gregdek: i hear you're on the red hat board! CONGRATULATIONS
19:19:45 * rbergeron falls over laughing, again
19:20:11 <gregdek> :)
19:20:16 <gholms|fail> Heh
19:20:16 <rbergeron> gregdek, gholms|fail: i assume you guys aren't looking at novnc?
19:20:23 * rbergeron looks at ke4qqq as well
19:20:26 <gholms|fail> rbergeron: Not at this point
19:21:07 <ayoung> tflink, is Guacamole Java?
19:21:20 <tflink> ayoung: yeah, it's java
19:21:29 <ayoung> openstack is Javaphobic
19:21:37 <rbergeron> lol
19:21:48 <mdomsch> cloudstack has its own ajax-based VNC
19:21:51 <tflink> I'm not a huge fan, either but it offers more features than novnc
19:22:36 <mdomsch> (and fwiw, there are several proprietary apps just like it out there...)
19:22:40 <rbergeron> mdomsch: you're so educated now :)
19:22:56 <tflink> if only one of them supported spice
19:23:24 <rbergeron> ayoung: i guess the question is - why do you ask? :)
19:23:29 <rbergeron> are you looking for feedback, alternatives, ?
19:24:06 <ayoung> feedback.  I am working on restructuring the files in the packages to get them more Fedora acceptable
19:24:35 <ayoung> but also to make people aware that we are working on it, to avoid duplication of effort...synergy if you will
19:24:49 <rbergeron> #info ayoung currently working on restructure the files in novnc packages to make them more fedora-acceptable; looking for feedback, avoidance of duplication, synergy :)
19:25:03 <ayoung> upstream is already going with novnc,  so we are going with it
19:25:10 * rbergeron nods
19:25:18 * ayoung always looking from smiles.
19:25:21 <ayoung> for
19:25:29 <vaneldik> ayoung: is there a BZ for this?
19:25:38 <ayoung> yeah, let me dig
19:25:56 <vaneldik> would love to give karma :)
19:27:27 <rbergeron> ayoung: anything else openstackky to discuss today, beyond wrangling up a bz?
19:28:19 <ayoung> rbergeron, we're good for now....packages are in EPEL....
19:28:39 <mdomsch> what's the upgrade methodology for openstack in EPEL?
19:28:41 * rbergeron nods
19:28:55 <mdomsch> e.g. for folks running diablo, now that essex packages are in
19:29:52 <spstarr_work> rbergeron: im concerned about the dadline yes... i will discuss offline in other channel.
19:30:00 <ayoung> mdomsch, hmmm....I'll ask.  But I think the answer is a bunch of migration scripts...various databases need to be upgraded.
19:30:00 <spstarr_work> deadline
19:30:35 <rbergeron> mdomsch: are you thinking higher-level-view than that?
19:30:39 <rbergeron> as far as your question?
19:31:07 * rbergeron would suspect it may be more along the lines of "how long will diablo be supported in epel"
19:31:07 <mdomsch> rbergeron: having not seen said scripts, I don't know.
19:31:15 <rbergeron> but i could be wrong
19:31:30 <mdomsch> no, that much is pretty clear - diablo is unsupported (and removed from the repos) as soon as essex is out
19:31:51 <mdomsch> which, for a service provider, is a nonstarter, but is good enough to get someone started and familiar with it
19:32:32 <rbergeron> right
19:32:40 <rbergeron> okay
19:32:46 <rbergeron> faiiiiiir 'nuff
19:33:16 <mdomsch> fwiw, same is true for any cloud mgmt stack we're putting into EPEL
19:33:34 * rbergeron nods
19:34:07 <rbergeron> okeedokee then. :)
19:34:09 <mdomsch> moving on
19:34:12 <rbergeron> shal we move on?
19:34:18 * mdomsch has a copule minutes of cloudstack stuff
19:34:20 <rbergeron> ayoung: can you post the bz when you find it?
19:34:24 <rbergeron> mdomsch: i figured :)
19:34:26 <ayoung> will do
19:34:29 <rbergeron> #topic CloudStack
19:34:47 <rbergeron> mdomsch: hi!
19:34:52 <rbergeron> :)
19:34:58 <mdomsch> A few of us attended the CloudStack Developer Onramp event in Santa Clara this week.  rbergeron, john mark, eno, and myself
19:35:30 <mdomsch> idea was to introduce folks to CS, how to become a developer or integrator, and begin the Apache-model governance process
19:35:33 <rbergeron> I think ke4qqq was there too :)
19:35:39 <mdomsch> indeed!!!
19:35:44 * rbergeron grins
19:35:53 * mdomsch thinks ke4qqq is probably still sleeping
19:36:04 <rbergeron> mdomsch: not according to the mailing list
19:36:27 <rbergeron> #info Several folks attended the CloudStack Dev onramp this week in santa clara
19:36:28 <mdomsch> anyhow - it was a great couple of days.  CS in an Apache Incubator project, so it needs outside contributors to join before it can graduate to a top-level project
19:36:35 <rbergeron> #info At the amazingly beautiful citrix facility
19:36:50 <mdomsch> there's lots of work to be done in terms of setting up governance, but the tech is quite solid
19:37:03 <ayoung> rbergeron, looks like I only opened something in launchpad https://bugs.launchpad.net/nova/+bug/993352  I'll open BZ as well.
19:37:09 <rbergeron> #info CS is an apache incubator project, needs some outside contributors before it can graduate to a top level project
19:37:39 <rbergeron> mdomsch: so I know that ke4qqq is still chasing down packaging and stuff for Fedora.
19:38:11 <mdomsch> yep
19:38:27 <mdomsch> ok, gotta go now, thanks
19:38:33 <rbergeron> mdomsch: thanks for the report in :)
19:38:40 <rbergeron> #topic OpenShift
19:39:08 <tdawson> Howdy Ho ... We finally opensourced OpenShift this week.
19:39:18 <ayoung> well done
19:39:24 <rbergeron> Okay! So for those of you who missed it, OpenShift is now out in communityland for downloading and contributing, iirc it is called OpenShift Origin, which I will never remember to say.
19:39:33 <rbergeron> Perhaps I will abbreviate it as OSO :)
19:39:49 <tdawson> Oh.  I like that abbreviation
19:39:53 <rbergeron> I do too :)
19:40:06 <rbergeron> I was saying OO for a while but that's sort of like openoffie
19:40:08 <rbergeron> office
19:40:09 <rbergeron> anyway.
19:40:16 <rbergeron> tdawson: so, what's the plan, man?
19:40:50 <tdawson> We're still stabalizing alot of things, so our main packages we don't have ready to start moving into Fedora and EPEL
19:41:19 * rbergeron nods
19:41:20 <tdawson> But alot of the side rubygem dependancies are moving forward.
19:41:31 <rbergeron> is there a wiki page with packaging plans / needs / etc?
19:41:36 <tdawson> But they were in motion even before we opensourced everything.
19:42:01 <tdawson> rbergeron: Not yet.  I am expecting to have that for next weeks meeting.
19:42:22 <rbergeron> tdawson: cool :)
19:43:07 <tdawson> For right now you can find all the rpm's that we currently expect to move to Fedora at the download area http://mirror.openshift.com/pub/
19:43:08 <rbergeron> #action tdawson expecting to have a wiki page with packaging plans / needs for next week's meeting for OSO
19:43:27 <tdawson> http://mirror.openshift.com/pub/crankcase/
19:43:36 <rbergeron> #info all rpms from OSO that are expected to move to fedora are in the download area: http://mirror.openshift.com/pub/
19:43:41 <rbergeron> http://mirror.openshift.com/pub/crankcase/
19:43:50 * rbergeron isn't sure if one of those was wrong
19:44:21 <tdawson> crankcase has all the rpm's, but you'll find the LiveCD download also at the /pub/ area.
19:44:27 * rbergeron nods
19:44:29 <rbergeron> oh, right
19:44:35 <rbergeron> I just got it on a USB key.
19:44:48 <rbergeron> That is also a church key. Now that I know my terminology.
19:45:03 <rbergeron> :)
19:45:27 <rbergeron> Well. I got lots of demos of it this week. Nice stuff.
19:45:34 <rbergeron> Hope to see it in fedora-land soon :)
19:45:39 <rbergeron> anything else on that front? :)
19:45:53 <rbergeron> tdawson: i owe you a hook-up with a sponsor.
19:45:56 <rbergeron> And I have one for you.
19:46:00 <tdawson> I think that's about it.  Hopefully next week I'll have the wiki up and some more of a roadmap.
19:46:35 <rbergeron> :) cool.
19:46:44 <tdawson> I would appreciate a sponsor.  I don't know if rubygem-mongo is worthy of being sponsored for, but if anyone else has a package, I could pick it up.
19:47:04 * rbergeron nods
19:47:27 <rbergeron> Okay! Movvvvvving on
19:47:36 <rbergeron> #topic Other things
19:47:43 <rbergeron> mgoldmann: hi! I saw you wander in.
19:47:50 <mgoldmann> :)
19:47:51 <rbergeron> I learned all about AS7 this week from lincolnthree.
19:48:04 <mgoldmann> good! I learn all the time :)
19:48:18 <mgoldmann> do, 7.1.1.FInal is un updatest-testing!
19:48:25 <mgoldmann> blah
19:48:35 <rbergeron> mgoldmann: try again :)
19:48:42 <mgoldmann> I'm on a shitty connection, some delays while typing
19:48:49 <mgoldmann> so
19:49:09 <mgoldmann> JBoss AS 7.1.1.Final is available in updates-testing repo now
19:49:27 <rbergeron> #info JBoss AS 7.1.1.Final is available in updates-testing repo now
19:49:54 <mgoldmann> and I'm working on adding new modules
19:50:12 <mgoldmann> I think we have 3-4 more that we had in initial push to Fedora
19:50:22 <mgoldmann> another 3 are done locally
19:50:30 <mgoldmann> so, expect a new update pretty soon
19:50:51 <rbergeron> #info Working on adding new modules; have a few new updates fairly soon
19:50:52 <mgoldmann> https://admin.fedoraproject.org/updates/FEDORA-2012-7180/jboss-as-7.1.1-2.fc17
19:50:54 <rbergeron> cool.
19:51:21 <mgoldmann> other than this - I have now a full time help on AS7
19:51:31 <mgoldmann> another guy joined the effort
19:52:03 <mgoldmann> and again- test and report bugs :)
19:52:17 <rbergeron> NICE!
19:52:24 <rbergeron> does this mean more boxgrinder for you?
19:52:52 <mgoldmann> I haven't touched BG since a few months :)
19:53:01 <rbergeron> well, more than zero :)
19:53:01 <mgoldmann> so, maybe?
19:53:07 <rbergeron> I hope so :)
19:53:14 <mgoldmann> yah, me too
19:53:31 <mgoldmann> the development of BG is pretty slow now
19:53:44 <mgoldmann> yes, I know this :)
19:54:27 * rbergeron hugs
19:54:30 <rbergeron> okay, anyone else?
19:54:37 <mgoldmann> :)
19:55:21 <rbergeron> going once, going twice...
19:56:27 <rbergeron> Okay, folks, see y'all next week.
19:56:28 <rbergeron> :)
19:56:30 <rbergeron> #endmeeting