i18n
LOGS
05:02:01 <tagoh> #startmeeting i18n
05:02:01 <zodbot> Meeting started Thu Mar 29 05:02:01 2012 UTC.  The chair is tagoh. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:02:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
05:02:03 <tagoh> #meetingname i18n
05:02:03 <zodbot> The meeting name has been set to 'i18n'
05:02:09 <tagoh> #topic agenda and roll call
05:02:18 <tagoh> https://fedoraproject.org/wiki/I18N/Meetings/2012-03-29
05:02:37 <tagoh> hi guys, time to have i18n meeting
05:02:57 <pravins> hi
05:03:06 <anish_> hi
05:03:08 <fujiwarat> hi
05:03:26 <dueno> hi
05:05:07 <paragan> hi
05:05:12 <epico_laptop> hi
05:05:24 <tagoh> if there are any additional topics to discuss in this meeting, please update wiki.
05:05:34 <tagoh> okay, let's get started.
05:05:38 <tagoh> #topic F17
05:06:11 <tagoh> beta rc2 is now available. has anyone tried it yet?
05:06:42 <tagoh> would be good to catch up if there are any issues.
05:08:10 <tagoh> the status in the report won't be changed until beta is out though, just wanted to make sure if the packages having the build deps issue has been built in bodhi.
05:08:53 <tagoh> if I'm missing something, we need to rebuild ibus-fep, ibus-gucharmap, ibus-panel-extensions, ibus-unikey and mozc.
05:09:02 <dingyichen> hi
05:09:06 <tagoh> can anyone update the status for them?
05:10:21 <tagoh> mozc is waiting for stable now btw.
05:10:41 <tagoh> .whoowns ibus-fep
05:10:41 <zodbot> tagoh: ueno
05:10:48 <tagoh> .whoowns ibus-gucharmap
05:10:48 <zodbot> tagoh: ueno
05:10:56 <tagoh> .whoowns ibus-panel-extensions
05:11:00 <zodbot> tagoh: ueno
05:11:07 <tagoh> .whoowns ibus-unikey
05:11:07 <zodbot> tagoh: tuanta
05:11:26 <dueno> tagoh, those 3 are also waiting for stable
05:11:30 <tagoh> cool
05:11:52 <tagoh> there are same issue in devel for ibus-unikey though
05:13:30 <tagoh> guess better filing a bug for ibus-unikey or can anyone rebuild it?
05:15:27 <tagoh> hm, okay, will file a bug then.
05:15:38 <tagoh> #action tagoh to file a bug to ibus-unikey
05:15:47 <tagoh> any other concerns or updates for f17?
05:16:11 <pravins> tagoh: thanks for fontconfig update
05:16:27 <tagoh> pravins: any chance to test it? :)
05:16:54 <pravins> yes, tested it. working fine :)
05:17:13 <pravins> i will give karma to it, now
05:17:20 <tagoh> great!
05:17:44 <pravins> tagoh: just, noticed we do not have font for ks_IN now, need to add some characters to existing Arabic script font
05:17:55 <pravins> will ping some upstream for it
05:18:30 <tagoh> aha
05:18:30 <pravins> i think we can now move feature to 100% complete https://fedoraproject.org/wiki/Features/Additional_Indic_Langs
05:18:40 <tagoh> okay
05:19:26 <pravins> tagoh: but we are facing one issue, https://bugzilla.gnome.org/show_bug.cgi?id=672677
05:19:37 <tagoh> pravins: lohit devanagari font doesn't have enough coverage for ks_IN?
05:19:55 <pravins> ks_IN@devanagari is supported by Devanagari
05:20:01 <pravins> ks_IN is Arabic script locale
05:20:43 <tagoh> hmm, so do we need to update ks.orth perhaps?
05:21:05 <pravins> tagoh: no, need to update fonts. ks.orth is now perfect
05:21:18 <tagoh> okay
05:21:45 <pravins> we need some translation for each new language, to get it listed in language selection menu of control center
05:22:33 <pravins> just talking with paragan will add few strings for new language in iok, that is looks like easy solution for now
05:23:58 <paragan> tagoh, .bug 806328
05:24:10 <paragan> .bug 806328
05:24:12 <zodbot> paragan: Bug 806328 missing /usr/share/locale/brx - https://bugzilla.redhat.com/show_bug.cgi?id=806328
05:25:33 <tagoh> pravins: for ks_IN, once you get a font, please remove lohit-devanagari-fonts from comps then. it's now marked as mandatory for ks
05:26:33 <pravins> tagoh: hmm, valid point, ks (kashmiri) language is written in 2 scripts, devanagari and arabic
05:26:47 <pravins> we do not have group for ka_IN@devanagari, so i listed it there
05:27:08 <tagoh> aha
05:28:18 <pravins> so once user says groupinstall kashmiri-support, he can get fonts for Devanagari as well for Arabic script
05:29:07 <tagoh> sure
05:31:08 <tagoh> okay, anything more for f17?
05:31:15 <pravins> done from my side
05:33:15 <tagoh> pravins: for g-c-c region thing, I tend to agree with them... you could change the locale with accounts settings I suppose.
05:34:34 <pravins> tagoh: i am still not, but will now proceed with available things, paragan will help to add translations file in iok
05:35:14 <paragan> sure
05:36:29 <tagoh> that's good then. okay, anything more?
05:36:45 <tagoh> if not, let's move on.
05:37:15 <tagoh> #topic Input Methods
05:37:40 <tagoh> any updates or concerns specially for IM?
05:38:47 <fujiwarat> ibus-1.4.99.20120317-2.fc17 is under the updates-testing.
05:40:43 <tagoh> aha. what's new in the update?
05:41:47 <fujiwarat> It fixes a segv in the latest gnome-shell with an up-compatibility.
05:42:09 <tagoh> cool
05:43:51 <tagoh> anything more? we have 64 bugs open for IM so far, but anyway.
05:45:50 <tagoh> guess it may be better adding fcitx to regexp too
05:48:23 <tagoh> okay, better move on then.
05:48:28 <tagoh> #topic Fonts and Rendering
05:48:48 <tagoh> any udpates or concerns for fonts and rendering?
05:49:07 <pravins> yesterday raise package-review request for lohit-marathi and lohit-nepali fonts
05:49:20 <pravins> this is re-review request
05:49:47 <tagoh> good
05:50:30 <tagoh> .bug 807623
05:50:32 <tagoh> .bug 807625
05:50:32 <zodbot> tagoh: Bug 807623 lohit-marathi-fonts - Open Type Font for Marathi Language - https://bugzilla.redhat.com/show_bug.cgi?id=807623
05:50:36 <zodbot> tagoh: Bug 807625 Review Request: lohit-nepali-fonts - Open Type Font for Nepali Language - https://bugzilla.redhat.com/show_bug.cgi?id=807625
05:51:40 <paragan> I can help with those reviews :)
05:52:23 <pravins> paragan: thanks, you did the earlier reviews as well
05:52:46 <tagoh> paragan: thanks
05:53:01 <tagoh> anything more for fonts and rendering?
05:54:51 <tagoh> okay, move on then.
05:54:59 <tagoh> #topic Open Floor
05:55:25 <dingyichen> Open Floor?
05:55:52 <tagoh> I forgot to add an topic to the agenda... there are another test day next Thursday
05:56:16 <tagoh> https://fedoraproject.org/wiki/Test_Day:2012-04-05_L10n_I18n_Installation
05:57:16 <tagoh> may be good to join to catch up any i18n related issues if you have time.
05:57:45 <tagoh> anything else topics we are missing in the agenda?
05:59:20 <tagoh> if not, let's close the meeting shortly.
05:59:21 <dingyichen> BTW, my zanata-util is under review request with paragan.
05:59:30 <tagoh> aha
05:59:55 <dingyichen> That should help to address the locale map-from problem for the package maintainer.
06:00:16 <tagoh> oh, that's good to hear :)
06:02:04 <tagoh> dingyichen: thanks for letting us know. I'm really looking forward to see it in repo
06:02:28 <dingyichen> I'll do my best.
06:03:39 <tagoh> okay, stop here today. thanks everyone for the meeting!
06:03:45 <tagoh> #endmeeting