fedora-meeting
LOGS
14:04:28 <jjmcd> #startmeeting Weekly Docs Meeting
14:04:28 <zodbot> Meeting started Mon Mar 26 14:04:28 2012 UTC.  The chair is jjmcd. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:28 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:04:37 <jjmcd> #topic Roll Call
14:04:48 * Capesteve waves
14:05:05 * pkovar is here
14:05:42 <suehle> oh hey you did it. Rock on :)
14:05:47 <suehle> and here
14:05:52 <jjmcd> ;-)
14:05:53 * fnadge is sort of there or here, depending on the context
14:06:03 <jjmcd> Looks like a short list
14:06:25 <jjmcd> #topic Follow up on last week's action items
14:06:55 <jjmcd> The only thing from last week is Ben checking on guide owners, and it looks like maybe he didn't
14:07:14 <jjmcd> #action bcotton to check on guide owners for F17
14:07:27 <jjmcd> ANything else on left over action items?
14:07:27 <fnadge> Well, I got a mail but need to reply yet
14:07:41 <jjmcd> Oh good, so at least its started
14:08:00 <pkovar> yes, i got one too
14:08:04 <jjmcd> #info Appears this has been started
14:08:53 <jjmcd> moving on then
14:08:57 <jjmcd> #topic Release Notes
14:09:21 <jjmcd> OK, the beta RNs went out but I would like to see an update in the repo when it goes live
14:09:38 <jjmcd> I've taken care of what I know of, but could use help in 2 places:
14:09:39 <shaiton> ?
14:09:49 <jjmcd> Proofreading and index entries
14:09:52 <fnadge> ?
14:10:02 <jjmcd> #link http://fedorapeople.org/groups/docs/release-notes/en-US/
14:10:07 <fnadge> Right, can help with proofreading
14:10:10 <jjmcd> has the latest build
14:10:20 <jjmcd> If you can picka beat
14:10:29 <jjmcd> #link https://fedoraproject.org/wiki/Documentation_Beats
14:10:57 <jjmcd> Proofread, correct and mark the beat page, that would be great
14:11:43 <jjmcd> If anyone wants to help with index entries, I'm starting at the bottom, and Amateur_Radio.xml is done and can be used as an example.
14:12:29 <fnadge> sure, no prob
14:12:30 <jjmcd> I think it is better to be generous with index entries so the reader has a better shot at finding things he cares about
14:12:56 <jjmcd> #info Release notes index entries and proofreading needed
14:12:58 <jjmcd> Also
14:13:17 <jjmcd> Better to commit often, only one xml at a time, to avoid collisions with others
14:13:34 <jjmcd> But we can also sync up on channel
14:13:43 <Capesteve> I can proofread the Networking section
14:13:59 <jjmcd> #info Will probably be looking for karma in a couple of days
14:14:04 <jjmcd> Capesteve, excellent
14:15:00 <jjmcd> Anything else on release notes?  Questions or anything?
14:15:04 <shaiton> What about RN translations (freeze, availability…)? Should we ask rbergeron to update the schedule?
14:15:53 <jjmcd> I would like to get that going pretty quick here
14:15:54 <rbergeron> wut?
14:16:08 <jjmcd> Not even sure where we stand, except behind!
14:16:09 <Capesteve> I could proofread Circuit Design
14:16:23 <Capesteve> Robotics, Ham Radio
14:16:31 <rbergeron> fortunately, we all have great behinds.
14:16:43 <Capesteve> I have some experience in those fields
14:17:10 <jjmcd> hmmmm ... that's why rbergeron spends so much time standing around at conferences
14:17:41 <claneys> hum too late
14:17:58 <rbergeron> shaiton: what updating are we looking at
14:18:06 <jjmcd> Great Capesteve, I'll do Embedded, then skip up to Development
14:18:14 <jjmcd> Robotics is empty
14:18:59 <jjmcd> rbergeron, we aren't real sure where we are on translation.  Haven't even provided POTs yet so we know we're behind... not sure how far tho
14:19:22 <shaiton> rbergeron: at http://rbergero.fedorapeople.org/schedules/f-17/f-17-trans-tasks.html
14:19:24 <jjmcd> I think shaiton is looking for reconciling the L10n sked with reality
14:20:05 <rbergeron> shaiton: i know where, just wondering... what:) jjmcd: can we figure out how far in the next day or two?
14:20:08 <shaiton> we still have time, but we should let them know as soon as they are ready (i.e. proofread)
14:20:51 <jjmcd> shaiton, I agree with that.  The index entries are going to be a bigger change, but I would hope to have them done in the next day or two then we can branch
14:21:12 <shaiton> great thanks
14:21:17 <jjmcd> (Remember RNs different than guides cuz a branch is a whole new thing for L10n)
14:21:47 <jjmcd> #action Anyone who can proofread and index
14:22:24 <jjmcd> rbergeron, I think we should be able to count on getting them something reasonable by Wed/Thu
14:23:24 <jjmcd> We had hoped to have translations for beta this release, but that just wasn't going to happen.  We barely squeaked the en-US into beta.
14:23:50 <rbergeron> okay
14:23:55 <rbergeron> yeah you did :)
14:23:59 <rbergeron> (NTH ftw)
14:24:37 * jjmcd seemed to be asleep at the switch this release
14:24:52 <jjmcd> OK, anything else on Release Notes?
14:25:45 <jjmcd> #topic Guide Status
14:25:49 <jjmcd> *
14:25:50 <jjmcd> o #link http://rbergero.fedorapeople.org/schedules/f-17/f-17-docs-tree-tasks.html
14:26:05 <jjmcd> #link http://rbergero.fedorapeople.org/schedules/f-17/f-17-docs-tree-tasks.html
14:26:11 <jjmcd> #link http://rbergero.fedorapeople.org/schedules/f-17/f-17-docs-tree-tasks.html
14:26:14 <jjmcd> THERE!
14:26:24 <jjmcd> OK, so where are we on guides?
14:27:08 <jjmcd> Not a lot of owners here - fnadge - User's Guide?
14:28:55 <jjmcd> perhaps he got called away
14:29:00 <jjmcd> pkovar, RPM guide?
14:29:41 <pkovar> jjmcd: RPM Guide is dead, more or less
14:29:52 * fnadge is here, sorry just
14:29:56 <pkovar> i now focus on the Packager's guide
14:30:01 <fnadge> worked on something
14:30:05 <jjmcd> Ahhhhh
14:30:37 <jjmcd> fnadge, is there any prayer of having that for F17?  I know the GNOME 3 thing is a huge amount of work
14:30:44 <pkovar> hopefully, it will be ready by the f17 release
14:30:49 <fnadge> The user's guide is in progress
14:30:59 <jjmcd> pkovar, very cool
14:31:09 <jjmcd> #info Users Guide in progress
14:31:23 <jjmcd> #info Packagers Guide targeted for F17
14:31:29 <pkovar> Packager's Guide: will keep the group updated, also re community feedback
14:31:47 <jjmcd> pkovar, that is a tough one
14:32:30 <jjmcd> I think there is a fair shot at getting the ARG updated for F17
14:33:06 <jjmcd> I guess I should update the table since it is updated for F16 and the table says F14
14:33:07 <pkovar> the packager's guide will not cover everything, but the basic procedures on creating and building RPMs should be there
14:33:17 <Capesteve> jjmcd: I see "Wireless Guide " F14 at the bottom of the table. Should that not be deleted as its part of Deployment Guide?
14:33:32 <Capesteve> on this page: http://fedoraproject.org/wiki/Docs_Project_meetings
14:33:57 <jjmcd> Capesteve, seems like it, tho I wonder if people looking to make WiFi work would consider the Deployment Guide
14:34:39 <jjmcd> Deployment Guide sounds like something for people with huge server farms
14:34:56 <Capesteve> I suppose you could make an extract, or just put a note "Currently incorporated in DG, see Chapter x"
14:34:56 <jhradilek> Capesteve: FYI, the NetworkManager chapter in the System Administrator's Guide is currently commented out, as there was nobody to update it for Fedora 16.
14:35:14 <jhradilek> jjmcd: Yeah, that's why we renamed it. :)
14:35:16 <Capesteve> jhradilek: That is a shame
14:35:33 <jjmcd> pkovar, on the subject of deleting, should the RPM Guide be blown away?
14:35:34 <jhradilek> Capesteve: Do I here a volunteer? :P
14:35:38 <jhradilek> *hear
14:36:05 <jjmcd> hmmmm, sounds like something that might be done well in Brno
14:36:07 <Capesteve> jhradilek: You can show me later how to clone the repo and I will check it
14:36:18 <pkovar> jjmcd:  i wouldn't oppose that, but need to discuss with bcotton first
14:36:23 <jhradilek> Capesteve: Cool. :)
14:36:37 <jjmcd> pkovar, Oh, I agree, also on the others
14:36:43 * Capesteve has been drinking more coffee since he met jhradilek
14:37:01 <jhradilek> :-D
14:37:03 <jjmcd> #info Consider removing RPM Guide
14:37:25 <pkovar> lots of various pages link the RPM guide, so we need to consider this
14:37:34 <pkovar> before removing it
14:37:46 <jjmcd> #info Capesteve will work with jhradilek to review NetworkManager chapter in SA Guide
14:38:10 <jjmcd> Capesteve, jhradilek can have that effect
14:38:24 <Capesteve> yes
14:38:32 <jjmcd> #info Many links exist to RPM Guide
14:38:37 <claneys> I work on User's Guide a little on local repo. I put my modification asap
14:38:46 * claneys late but here
14:38:57 <jjmcd> #info claneys will work on User's Guide
14:39:12 <jhradilek> jjmcd: Now I feel like a dictator. :-S
14:39:23 <jjmcd> claneys, consider committing and pushing often.  You can always roll back
14:39:56 <claneys> Ok.
14:40:05 <jjmcd> Wow, lotsa good stuff on guides
14:40:13 <jjmcd> Anything else on guides?
14:40:48 <pkovar> big thanks to those willing to contribute :-)
14:40:58 <jjmcd> Absolutely
14:41:58 <jjmcd> #topic Outstanding BZ Tickets
14:42:19 <jjmcd> OK, the number seems to be fairly satble, but there are an awful lot of NEW bugs
14:42:43 <jjmcd> Please look at the bugs for your guide and at least assign them so the reporter has some feedback
14:43:00 <jjmcd> Pretty sad when a bug sits there with no apparent action
14:43:54 <jjmcd> Does anyone need any help with bugs?
14:44:17 <jmtaylor> if they do I would like to help
14:44:34 <jjmcd> Thanks jmtaylor
14:44:51 <jjmcd> #info jmtaylor willing to help with bugs
14:46:11 <jjmcd> OK, anything else on bugs?
14:46:59 <jjmcd> #topic Open floor discussion
14:47:13 <jjmcd> So, who has anything for this august body?
14:47:20 <randomuser> I do!
14:47:25 <jjmcd> randomuser, go
14:47:50 * rbergeron asked bcotton to come to the readiness meeting on Thursday, doesn't know if he's actually available but if he's not would love a substitute :)
14:48:09 <randomuser> I think there is an excessive amount of includes in the install guide, and probably others. Are we doing this for any technical reason?
14:48:24 <randomuser> byproduct of wiki conversion?
14:48:36 <jjmcd> randomuser, usually to make it more manageable
14:48:48 <jjmcd> If you have a lot of files, it is easier for multiple people
14:49:04 <jjmcd> If we both edit the same file, git can be messy to reconcile
14:49:20 <jjmcd> But if we are in different files, a git pull to update is no issue
14:49:48 <randomuser> that makes sense
14:50:07 <jjmcd> That's why on index entries I suggested folks commit every xml they touch as soon as possible
14:50:42 <jhradilek> randomuser: In case of the Installation Guide, the reasoning behind it is that a lot of the content is the same for different architectures. This allows you to re-use certain portions of text without having to copy it all the time.
14:51:24 <jjmcd> jhradilek, and when you can re-use, a change doesn't have to happen in a dozen different places
14:51:35 <jhradilek> jjmcd: Yup.
14:51:54 <randomuser> i still think it's excessive, but as there are sound reasons, I wont start combining
14:52:15 <jjmcd> Yeah, re-use=good, duplication=bad
14:52:20 <jhradilek> randomuser: Are you in contact with jreed? He maintains the Installation Guide.
14:52:41 <randomuser> I haven't spoken to him, no.
14:53:23 <jjmcd> Smaller files also make it easier to find stuff when you edit, assuming, of course, you are familiar with the structure
14:53:41 <jhradilek> He's based in Brisbane, so I would just email him and let him know that you are working on it.
14:53:53 <randomuser> i'll get over it, but I'm finding it difficult to become familiar with the structure
14:53:54 <jhradilek> *if I were you
14:54:02 <randomuser> jhradilek, will do
14:54:11 <jjmcd> randomuser, yeah, that can be an issue
14:54:35 <jhradilek> randomuser: Another reason why it looks like this is that jreed maintains a similar guide for Red Hat Enterprise Linux, which supports much more architectures.
14:54:47 <jjmcd> The ARG has multiple levels of nesting - makes for lots of files, but the file names follow a pattern that helps
14:55:25 <jhradilek> randomuser: So changing the structure might make it much more difficult to keep both versions in sync.
14:55:45 <randomuser> jhradilek, we cover x86, x86_64 at this point; not much need for a distinction there IMO past "which do I choose"
14:55:45 <jjmcd> And as long as we commit early and often, multiple editors can be pretty reckless with low odds of collision
14:56:08 <jjmcd> Well, yeah, but ARM is coming soon, and probably others
14:56:29 <jjmcd> And ARM will probably have quite a few differences
14:56:34 <jhradilek> randomuser: Yeah, but jreed keeps both versions in sync.
14:56:55 <randomuser> jhradilek, ok, it makes a lot more sense if that's the case
14:57:07 <jjmcd> OK, we're running short on time .... anything else?
14:57:54 <jhradilek> jjmcd: Nope. :)
14:58:11 <jjmcd> Well, thanks everyone.  This has been a really good meeting.
14:58:21 <jjmcd> Helps when everyone gets engaged!
14:58:33 <jhradilek> jjmcd: Thank you. :)
14:58:35 <jjmcd> Thank you all for the hard work
14:58:41 <jjmcd> #endmeeting