i18n
LOGS
05:02:52 <tagoh> #startmeeting i18n
05:02:52 <zodbot> Meeting started Thu Mar 22 05:02:52 2012 UTC.  The chair is tagoh. Information about MeetBot at http://wiki.debian.org/MeetBot.
05:02:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
05:02:55 <tagoh> #meetingname i18n
05:02:55 <zodbot> The meeting name has been set to 'i18n'
05:03:00 <tagoh> #topic agenda and roll call
05:03:10 <tagoh> https://fedoraproject.org/wiki/I18N/Meetings/2012-03-22
05:03:28 <tagoh> hi guys, time for i18n meeting!
05:05:12 <paragan> hi
05:05:22 <epico_laptop> hi
05:06:05 <fujiwarat> hi
05:06:54 <juhp> hi
05:06:57 <tagoh> let's get started.
05:07:04 <tagoh> #topic F17
05:09:13 <tagoh> for schedule reminder, the beta change deadline was two days ago, beta will be available April 3 if no issues.
05:09:43 <anish_> hi
05:09:46 <jni> hi
05:09:56 <pravins> hi
05:10:13 <tagoh> guess you are hardly testing f17, is there any concerns to share so far?
05:10:33 <tagoh> for i18n related stuff
05:11:04 <juhp> I just saw that TC2 anaconda backtraces for japanese, hmm
05:11:15 <juhp> just filed as
05:11:16 <tagoh> aha. is it a known issue?
05:11:24 <juhp> .bug 805771
05:11:26 <zodbot> juhp: Bug 805771 UnicodeEncodeError: 'ascii' codec can't encode characters in position 3-9: ordinal not in range(128) - https://bugzilla.redhat.com/show_bug.cgi?id=805771
05:11:42 <tagoh> thanks
05:12:19 <anish_> for ,Bug 803646 - Password is visible on gnome-terminal with English-typing-booster enabled
05:12:23 <juhp> also disappointed (though not shocked:-/) not to see any i18n improvements in new gdm
05:12:24 <tagoh> no problems on other langs?
05:12:45 <juhp> .bug 803646
05:12:47 <anish_> had sent an email to devel list
05:12:47 <zodbot> juhp: Bug 803646 Password is visible on gnome-terminal with English-typing-booster enabled - https://bugzilla.redhat.com/show_bug.cgi?id=803646
05:13:02 <juhp> anish_, any response?
05:13:36 <anish_> got one
05:13:45 <anish_> but that did not solve our problem
05:15:01 <tagoh> guess need to patch out in vte maybe?
05:15:08 <juhp> wonder if other IME are unaffected?
05:16:53 <tagoh> no IMEs typing ascii with the candidate window?
05:17:32 <juhp> hm
05:18:42 <epico_laptop> maybe also ibus-pinyin, english input mode.
05:18:51 <adamw> the anaconda team was talking about those unicodeencode / unicodedecode errors earlier
05:19:00 <adamw> i think the thought was that noloader means the environment has changed somewhat
05:19:17 <tagoh> epico_laptop: does it use the preedit say? if not, guess it may be no problem.
05:19:52 <epico_laptop> tagoh: it doesn't use preedit.
05:20:47 <juhp> adamw, aha
05:20:49 <tagoh> maybe need to update vte to stop echo back in preedit?
05:21:16 <juhp> epico_laptop, could you test it?
05:21:33 <epico_laptop> juhp: okay
05:22:16 <juhp> but yeah could be related to preedit
05:22:19 <tagoh> #action epico_laptop to test ibus-pinyin for #803646
05:22:58 <juhp> anish_, probably good if you could test some our IMEs too
05:23:05 <juhp> some other
05:23:16 <anish_> sure thanks
05:23:56 <juhp> anish_, maybe same for ibus-hunspell-table I could imagine anyway?
05:24:17 <tagoh> juhp: it wasn't raised since no one wasn't going to input something through IM for password because of no needs...
05:24:55 <juhp> tagoh: ah so it is actually an old issue?
05:25:21 <juhp> that sounds right actually
05:25:29 <anish_> i think passwd do not work other than  english/ascii chars
05:25:33 <anish_> not sure though
05:27:28 <tagoh> anish_: true. but what characters is acceptable for password doesn't matter. because no changes in how IM works. this just means IM and input password isn't well integrated.
05:28:16 <anish_> yeah , i tried for anthy and password is visible
05:28:43 <tagoh> and it's just being brought up by english-typing-booster.
05:28:46 <juhp> anish_, actually it does - at least in some "places"
05:28:51 <pravins> dunno how web browsers handling it
05:29:02 <juhp> right
05:29:34 <juhp> I can set passwd to japanese characters and authenticate with su
05:29:38 <anish_> what i was tying to say is  does not matter for other IME as users are not going to try it
05:30:01 <anish_> juhp, is it?
05:30:11 <juhp> they might but not necessarily a good idea indeed
05:30:15 <tagoh> as gtk has some trick to disable IM on the password box, it may be a good idea to change some behavior on vte for that perhaps.
05:30:23 <juhp> tagoh: right
05:30:59 <tagoh> and konsole too maybe?
05:31:45 <juhp> anish_, so I think as tagoh suggests good to reassign to vte3 - it is certainly not specific to your IME
05:32:01 <juhp> I dunno if there is anything that could be done from ibus side
05:32:06 <juhp> fujiwarat, any ideas?
05:32:22 <anish_> juhp, thanks
05:33:48 <fujiwarat> hmm
05:33:57 <juhp> perhaps vte3 could disable preedit temporarily while waiting for passwd input
05:34:25 <tagoh> for Additional_Indic_Langs, I've taken over the fontconfig maintainership in Fedora though, it may be too late to push it for f17? as it's a critical path package, not having enough testing in beta is a concern.
05:35:09 <tagoh> any thoughts?
05:35:25 <pravins> tagoh: at least we should push ortho updates, those are important for new language feature
05:37:42 <tagoh> pravins: there are same concerns on even it - can we have enough time for testing for that feature too?
05:38:39 <pravins> asa: has done testing during i18n test day
05:39:03 <tagoh> the due date for the feature completion has been already passed away.
05:39:12 <pravins> ohh
05:40:47 <pravins> only remaining thing is fontconfig update else we have done with it.
05:42:01 <pravins> tagoh: so what do you suggest now
05:42:47 <tagoh> I'm tend to think that may be better postponing to f18.
05:43:50 <tagoh> anyway, 2.9.0 is available on f18 now.
05:45:26 <pravins> hmm, should ask to fesco once, since we are 95% complete mode
05:46:10 <tagoh> I can't say it's safe to push because there are too many changes in 2.9.0 as it hadn't been released for a while.
05:47:13 <pravins> tagoh: yes agree with you, that is why was asking if possible can only go with ortho patches.
05:47:14 <juhp> is it possible to do a backport update later perhaps?
05:48:06 <tagoh> juhp: maybe. dunno I'm new for critpath package anyway.
05:49:01 <paragan> I have pushed iso-codes after GA which was a CRTIPATH update
05:49:23 <juhp> sure critical path packages can be updated :)
05:49:38 <tagoh> paragan: the case is a bit different - the change was obvious in that case.
05:50:27 <paragan> tagoh, I know about fontconfig-2.9.0 change that is why I am silent here on updating it to F17
05:50:55 <paragan> but just updating required ortho files should not be risky
05:52:03 <tagoh> right. backporting orth files only somewhat sounds realistic to me.
05:52:21 <juhp> how many ortho files are we talking about btw?
05:52:52 <paragan> 4 I guess
05:53:00 <tagoh> right. 4
05:53:13 <juhp> perhaps there is still sufficient time to test 4 before GA freeze?
05:53:34 <pravins> and minor updates to ur.ortho as well
05:53:43 <paragan> juhp, https://fedoraproject.org/wiki/Features/Additional_Indic_Langs#Documentation
05:53:51 <tagoh> paravins: 4 including ur.orth
05:54:10 <paragan> total 5 then
05:54:14 <tagoh> for bugs we have in bugzilla at least.
05:54:38 <tagoh> ks, brx ur and ne
05:55:02 <tagoh> .bug 790471
05:55:05 <zodbot> tagoh: Bug 790471 Need update in ks.orth file - https://bugzilla.redhat.com/show_bug.cgi?id=790471
05:55:07 <tagoh> .bug 790460
05:55:10 <zodbot> tagoh: Bug 790460 Ortho file not present for Bodo (brx_In) locale - https://bugzilla.redhat.com/show_bug.cgi?id=790460
05:55:12 <tagoh> .bug 757985
05:55:14 <zodbot> tagoh: Bug 757985 need corrections in ur.orth file - https://bugzilla.redhat.com/show_bug.cgi?id=757985
05:55:19 <tagoh> .bug 586763
05:55:21 <zodbot> tagoh: Bug 586763 wrong ne.orth - https://bugzilla.redhat.com/show_bug.cgi?id=586763
05:55:28 <paragan> so we left then doi, mni and sat
05:56:02 <pravins> tagoh: yeah, not reported all bugs in fedora, paragan might be we should clone them
05:57:02 <paragan> thought development happens in upstream so we have not all reported in redhat bugzilla
05:57:35 <tagoh> has anyone already tested them on the updated fontconfig?
05:58:02 <paragan> not yet
05:58:04 <tagoh> and confirm if no affects on other langs too?
05:59:02 <tagoh> so does anyone have any answer for juhp's question then?
05:59:43 <pravins> tagoh: yes surely, i can test these changes on higher priority, can take help from asa  as well
05:59:54 <paragan> yes definitely we can test them all before GA freeze -> 2012-04-23
05:59:55 <pravins> paragan:  too :)
05:59:56 <tagoh> that could be done in beta. but we missed that opportunity.
06:00:56 <tagoh> testing 7 langs (and more for regression) sounds too many.
06:02:28 <pravins> for new ortho i.e. doi, sat, mni and brx it is not much problem
06:03:40 <tagoh> anyway, we could just push the updates though, need to wait for certain result on testing.
06:04:59 <tagoh> anything else for f17?
06:06:58 <tagoh> we spent too much time here. guess it may be better skip next two topics if there are no important topics there.
06:07:16 <tagoh> #topic Open Floor
06:07:35 <tagoh> does anyone have anything before closing the meeting?
06:08:18 <fujiwarat> Probably I put ibus-1.4.99.20120317-1.fc17 into stable in this week.
06:09:00 <tagoh> fujiwarat: sure - just realized mozc isn't yet pushed to f17 for new ibus and rebuilt this mornihg ;)
06:09:09 <tagoh> morning
06:09:37 <fujiwarat> tagoh: Ah, I asked you to git merge master as emacs had a build failure.
06:09:52 <fujiwarat> s/asked/forgot to ask/
06:11:09 <tagoh> I presumed you'll try it later, but anyway - we can test it and give it a karma. that would speed up to push it to avoid any problems.
06:11:23 <fujiwarat> good
06:11:38 <tagoh> anything else?
06:12:42 <tagoh> if not, let's stop here then.
06:13:12 <tagoh> thanks everyone for the meeting!
06:13:16 <tagoh> #endmeeting