kde-sig
LOGS
15:03:54 <jreznik> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2012-02-28
15:03:54 <zodbot> Meeting started Tue Feb 28 15:03:54 2012 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:54 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:04:09 <jreznik> #meetingname kde-sig
15:04:09 <zodbot> The meeting name has been set to 'kde-sig'
15:04:23 <jreznik> #topic Roll Call
15:04:34 <jreznik> Hi, who's here today? :)
15:04:39 * rdieter raises coffee mug
15:04:51 * jsmith lurks, as usual
15:04:53 * rnovacek is here
15:05:39 <Kevin_Kofler> Present.
15:06:56 <jreznik> #info rdieter raises coffee mug, rnovacek Kevin_Kofler jreznik present, ltinkl joined recently, jsmith lurking as usual
15:07:11 <jreznik> #chair rdieter rnovacek Kevin_Kofler ltinkl
15:07:11 <zodbot> Current chairs: Kevin_Kofler jreznik ltinkl rdieter rnovacek
15:07:20 * than is here
15:07:31 <jreznik> #info than is present too
15:07:41 <jreznik> #chair Kevin_Kofler jreznik ltinkl rdieter rnovacek than
15:07:41 <zodbot> Current chairs: Kevin_Kofler jreznik ltinkl rdieter rnovacek than
15:07:48 <jreznik> #topic Agenda
15:10:13 * jreznik added the kdm systemd interaction bug
15:10:28 <jreznik> touch interfaces from last meeting
15:11:54 <jreznik> anything else?
15:12:08 <jreznik> maybe post alpha review
15:14:17 * shaiton won't stay around to wait for Open Floor. Wanted to remind you about https://fedorahosted.org/fedora-websites/ticket/74
15:14:25 <Kevin_Kofler> jreznik: Let's start with those topics…
15:15:05 <jreznik> shaiton: ok, it's really f14
15:15:32 <jreznik> I have a few screenshots for f16 originally for mizmo, I'll update it
15:15:36 <shaiton> jreznik, some have been updated, no all
15:15:39 <shaiton> thanks
15:16:03 <jreznik> ok
15:16:14 <jreznik> #topic Fedora 17 Alpha post-mortem
15:16:45 <Kevin_Kofler> Post-mortem? Hopefully the Alpha is not dead yet! ^^
15:17:14 <Kevin_Kofler> "post-partum" (after birth) would make more sense IMHO. :-)
15:17:25 <jsmith> Kevin_Kofler: It's just "mostly dead" (to quote The Princess Bride)
15:17:42 <jreznik> Kevin_Kofler: :) I just used some old rh pm terminology :)
15:18:44 <jreznik> but let's skip the topic name discussion - what's the state - now, post alpha
15:19:20 * jreznik can't install alpha at all on my new hw, running in vm
15:19:21 <Kevin_Kofler> Looks like things are mostly well, except for that KDM shutdown/restart issue which will be one of the next topics.
15:19:35 <Kevin_Kofler> Oh, well ouch, that's not good. :-(
15:19:42 <jreznik> yep, the issue were/are mostly with kdm...
15:20:05 <jreznik> Kevin_Kofler: bootloader did not install... f16 works, so for now... reported to anaconda guys
15:20:24 <Kevin_Kofler> For non-KDM users, we still need systemd shutdown/restart support (instead of ConsoleKit). I'll try to have a look (as the one who wrote the ConsoleKit code).
15:20:52 <Kevin_Kofler> As for Anaconda being broken, that's not our fault. ;-)
15:21:03 <jreznik> Kevin_Kofler: would be great, I planned to take a look today but...
15:21:21 <rdieter> probably can't fully evaluate who well the -alpha did until it gets into the wild, and we start getting more feedback.
15:21:29 <rdieter> s/who/how/  hee
15:21:33 <Kevin_Kofler> jreznik: No time? No problem, I should have time this week.
15:21:48 <Kevin_Kofler> I'll look into it today or tomorrow.
15:22:14 <rdieter> that said, we should be in good shape, unless we discover any other f17-specific gotchas (like the systemd/kdm one)
15:22:27 <jreznik> #info KDM shutdown/restart issue present in Fedora 17 alpha, we are waiting for more feedback after f17 spread enough
15:22:41 <jreznik> Kevin_Kofler: ok, let me know, I can help you tomorrow
15:24:22 <jreznik> #action Kevin_Kofler to take a look on systemd support as original author of CK code, jreznik to help with
15:25:16 <jreznik> anything else for f17? and guys, great job!
15:25:43 <Kevin_Kofler> FYI, I won't be working on native systemd integration for KDM because the systemd developers claim it's not needed (PAM should be sufficient, they say).
15:26:20 <Kevin_Kofler> If we need KDM to tell systemd directly after all, we'll find out from bug reports. ;-) Right now I trust the systemd folks to know what they're talking about. :-p
15:26:40 <jreznik> Kevin_Kofler: but what about all other functionality provided by systemd?
15:26:53 <G__81> hi everyone
15:27:21 <Kevin_Kofler> What functionality? Managing session services? That's be something for ksmserver and/or kded4 to use, but I don't think that's going to happen any time soon.
15:27:35 <Kevin_Kofler> It'd need upstream support in any case, it's not something I'd want to work on as a distro patch.
15:28:21 <jreznik> Kevin_Kofler: it makes sense to do it upstream but it's more like our job to help as it's coming from fedora...
15:28:35 <jreznik> the multi seat support I think
15:29:31 <Kevin_Kofler> Multi-seat probably needs KDM support, that's something that makes sense to work on and get upstreamed, but it's not really on my list of priorities.
15:29:44 <Kevin_Kofler> Any volunteer welcome. :-)
15:30:15 <jreznik> ok, I'll try to take a look (not to implement) but what's needed
15:30:34 <G__81> i am interested in being part of this team
15:30:38 <G__81> this is my first team
15:30:39 <Kevin_Kofler> There's a thread on the systemd mailing list about display managers and systemd.
15:31:07 <jreznik> also we can consider lightdm with kde greeter - but not sure it's in better state at all (and no systemd support too)
15:31:09 <rdieter> G__81: hi, feel free to poke us more in #fedora-kde after the meeting
15:31:37 <G__81> hi rdieter yeah sure thanks
15:31:38 <rdieter> lightdm at least has the initial requisite of running in it's own non-root session
15:31:41 <G__81> just wanted to be part of the team
15:32:02 <rdieter> G__81: no problem, looking forward to it.
15:32:02 <Kevin_Kofler> AFAIK, KDM also supports it these days.
15:32:22 <Kevin_Kofler> But we aren't setting that up yet, we should.
15:32:25 <rdieter> Kevin_Kofler: oh?  maybe we can work to implement it then
15:32:36 <Kevin_Kofler> Well, at least it can run as a non-root user.
15:32:38 <rdieter> I didn't know it supported that at all
15:32:46 <Kevin_Kofler> Does it register a PAM session? I don't know.
15:32:58 <Kevin_Kofler> It's new. We'll have to check whether it actually works though.
15:33:12 <Kevin_Kofler> Of course the backend always runs as root, only the greeter would run as non-root.
15:33:18 <jreznik> #info KDM also supports non-root session
15:33:40 <jreznik> #info for greeter
15:33:55 <jreznik> #action to check the possibility of setting it up
15:34:26 <Kevin_Kofler> It's not like GDM where AFAIK everything is non-root and the stuff that needs root is all delegated to systemd (previously to ConsoleKit) and PAM.
15:36:39 <Kevin_Kofler> Next topic please?
15:37:36 <jreznik> Kevin_Kofler: yep, I think we already did the bug topic so...
15:37:48 <Kevin_Kofler> Well, we didn't exactly…
15:38:05 <jreznik> Kevin_Kofler: so continue with it? it's more urgent...
15:38:07 <Kevin_Kofler> But there's not much to say there, we have a fix for the bug, I still think systemd shouldn't go and kill processes.
15:38:22 <jreznik> so? :)
15:38:30 <Kevin_Kofler> But at least with the patch KDM shutdown/restart works. :-)
15:38:46 <than> Kevin_Kofler: yes, it's a workaround temporary
15:39:38 <rdieter> .bug 796969
15:39:40 <rdieter> for reference
15:39:41 <zodbot> rdieter: Bug 796969 f17 kde reboot does not work, leads back to kdm - https://bugzilla.redhat.com/show_bug.cgi?id=796969
15:39:54 <jreznik> #topic f17 kde reboot does not work, leads back to kdm
15:40:21 <jreznik> #link https://bugzilla.redhat.com/show_bug.cgi?id=796969
15:40:39 <rdieter> kudos to Michal Schmidt, hero of the day and beating us to figuring it out.
15:40:57 <rdieter> patched build queue'd for updates-testing
15:41:08 <G__81> rdieter, yeah sure
15:41:13 <rdieter> https://admin.fedoraproject.org/updates/kde-workspace-4.8.0-12.fc17
15:41:41 <rdieter> I'll be testing it out myself after meeting (both on f16 for regressions, and on f17 to fix the original bug)
15:42:25 <jreznik> #info kudos to Michal Schmidt for figuring it out
15:44:06 <jreznik> #info update to be tested https://admin.fedoraproject.org/updates/kde-workspace-4.8.0-12.fc17
15:44:22 <jreznik> anything else for now? before having the proper fix?
15:44:39 <Kevin_Kofler> Nothing else for now.
15:45:06 <jreznik> #topic touch interfaces, Fedora Active
15:45:19 <jreznik> topic from last meeting, we haven't managed to go through
15:46:37 * jreznik is not sure we have too much to talk about right now...
15:47:00 <jreznik> rnovacek managed to get plasma active working, he has a kickstart ready (really first try)
15:47:21 <rdieter> woo
15:47:30 <jreznik> and now it's more about selecting what do we want to have there, comps and configuration stuff
15:47:40 <jreznik> also we hit one file conflict etc.
15:48:00 <rnovacek> jreznik: I've already fixed that
15:48:09 <Kevin_Kofler> So for the touch interfaces, we should put them into subpackages.
15:48:09 <jreznik> rnovacek: I know, it's just an example
15:48:17 <rdieter> reminds me, we'll want calligra-mobile built, which means we want calligra-l10n review finished ... hint hint. :)
15:48:21 <Kevin_Kofler> (where applicable)
15:48:29 <Kevin_Kofler> (e.g. for kdepim-mobile.)
15:48:34 * jreznik adds l10n to to todo
15:48:47 <jreznik> yep, calligra mobile, kdepim-mobile
15:49:07 <jreznik> for bangarang new desktop file subpackaged in -mobile should work too
15:49:14 <Kevin_Kofler> We also need the separate kde-settings profile set up.
15:49:27 <jreznik> Kevin_Kofler: yep, that's one todo
15:49:46 <jreznik> #info first try kickstart for Fedora Active
15:50:16 <jreznik> #info we will need package splits for touch interfaces (-mobile subpackages, kdepim, calligra...)
15:50:37 <jreznik> #info we need the separate kde-settings profile set up
15:50:56 <rdieter> jreznik, rnovacek : can you review if some of the active-related patches in kde-workspace (and others?) are still needed?
15:51:21 <rdieter> kde-workspace-4.7.80-wac-html-widgets.patch, kwin-check-opengl.diff  in particular
15:51:26 <rnovacek> ok, I'll check that later
15:51:34 <rdieter> thx
15:52:25 <jreznik> #action to check if the plasma-mobile patches are still needed
15:52:57 <jreznik> anything else today?
15:54:07 <Kevin_Kofler> 4.8.1? But I think we can't say much about that yet.
15:54:40 <Kevin_Kofler> Oh, one more thing, there are some kio_tar fixes going into 4.8.1, I'd like to backport them to F15's 4.6.5, is that OK?
15:54:40 <jreznik> Kevin_Kofler: tagging is in two days... so now
15:54:52 <rdieter> I'll prep a f17-kde koji target/tag
15:55:01 <jreznik> Kevin_Kofler: ok
15:55:05 <jreznik> for me
15:55:08 <jreznik> rdieter: great
15:55:26 <Kevin_Kofler> They fix browsing tarballs from git archive, which now includes some KDE SC tarballs.
15:55:38 <jreznik> when dirk uploads 4.8.1 I'll start working on it
15:55:42 <Kevin_Kofler> (git archive uses some strange tar features.)
15:55:49 <jreznik> #topic 4.8.1
15:56:05 <jreznik> #action rdieter to prepare f17-kde koji target/tag
15:56:52 <jreznik> #action jreznik to start updates when tarballs hits packagers ftp
15:57:09 <jreznik> rdieter: than, others - what about Kevin_Kofler's proposal?
15:57:21 <jreznik> to backport kio_tar
15:57:32 <rdieter> ok with me
15:57:54 <ltinkl> ok with me as well
15:57:55 <than> fine with me
15:57:56 <rdieter> backporting bugfixes should be safe(ish)
15:58:57 <jreznik> #agreed to backport kio_tar to f16
15:59:01 <jreznik> sorry f15
15:59:08 <jreznik> #undo
15:59:08 <zodbot> Removing item from minutes: <MeetBot.items.Agreed object at 0x2702c450>
15:59:25 <jreznik> #agreed to backport kio_tar bugfix to f15
15:59:35 <jreznik> #action Kevin_Kofler to take care about backport
15:59:48 * jreznik thinks it's all for today...
16:00:11 * Kevin_Kofler thinks so too. :-)
16:01:38 <jreznik> thanks guys!
16:01:41 <jreznik> #endmeeting