infrastructure
LOGS
21:00:01 <nirik> #startmeeting Infrastructure (2012-02-23)
21:00:01 <zodbot> Meeting started Thu Feb 23 21:00:01 2012 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:01 <nirik> #meetingname infrastructure
21:00:01 <nirik> #topic Robot Roll Call
21:00:01 <nirik> #chair smooge skvidal Codeblock ricky nirik abadger1999 lmacken dgilmore mdomsch
21:00:01 <zodbot> The meeting name has been set to 'infrastructure'
21:00:01 <zodbot> Current chairs: Codeblock abadger1999 dgilmore lmacken mdomsch nirik ricky skvidal smooge
21:00:06 <nirik> hey look, another meeting. ;)
21:00:09 * skvidal is here
21:00:10 <smooge> here
21:00:15 <dgilmore> buenos
21:00:15 <rbergeron> SHINY
21:00:15 <mdomsch> whee
21:00:30 <StarBeast> here
21:00:32 <nirik> we are keeping the #fedora-meeting channel rocking today. ;)
21:00:44 <mdomsch> what time is the meeting moving to next week?
21:00:46 * ctria here
21:00:49 <mdomsch> earlier or later?
21:00:56 * ianweller here
21:00:56 * abadger1999 here
21:00:56 * lmacken here
21:01:18 <nirik> one hour earlier.
21:01:29 <rbergeron> nirik: it's pretty awesome
21:01:41 <nirik> yeah.
21:01:46 <nirik> ok, lets go ahead and dive in...
21:01:49 <nirik> #topic New folks introductions and apprentice tasks/feedback
21:02:00 <nirik> any new folks or apprentices care to discuss anything or say hi?
21:02:04 * CodeBlock here
21:02:10 <ctria> hi i'm a new folk :)
21:02:22 <smooge> hi new folks
21:02:24 <adrianhannah> Hello! I'm new
21:02:32 <smooge> we have a couple others who are 12 hours off.
21:02:35 <rbergeron> ooh! new folks galore :)
21:02:44 <nirik> welcome ctria and adrianhannah.  Care to give a quick bio and what you might be interested in working on?
21:03:14 <ctria> ok, i'm sysadmin in a Greek university
21:03:35 <adrianhannah> 13 year sys admin in different industries - I like tool development
21:03:45 <ctria> with responsibilities off administering 2 grid clusters plus security office duties
21:04:15 <ctria> i'm also in developing/scripting
21:04:21 * adrianhannah is on his phone so forgive the typing lag
21:04:24 <nirik> great! if you guys can see me after the meeting we can look at pointing you to things to work on or look around at.
21:04:31 <adrianhannah> Cool
21:04:37 <ctria> sure
21:05:01 <nirik> any other new folks want to give a quick bio and what they might like to work on?
21:05:14 * amitphukan_ new here
21:05:34 <nirik> welcome amitphukan_
21:05:41 <amitphukan_> nirik : thanks.
21:06:18 <nirik> amitphukan_: any intro or kind of things you might like to work on ?
21:06:31 <amitphukan_> i have exposure to very basic system administration stuff and i am here to learn and develop my skills
21:07:10 <amitphukan_> i am interested in scripting and automation, though i have very little experience on both
21:07:21 <nirik> excellent.
21:07:34 <nirik> do see me after the meeting over in #fedora-admin and we can get you started.
21:07:46 <amitphukan_> nirik : sure
21:07:53 * nirik will move on in a minute if no more new folks appear.
21:08:30 <nirik> #topic two factor auth status
21:08:44 <nirik> No new news on this I know of... can try and move it along
21:08:56 <nirik> #topic Staging re-work status
21:09:07 <nirik> this is waiting until after our current freeze... but should pick up then.
21:09:24 <nirik> #topic Alpha Release Tickets
21:09:42 <nirik> we should be able to knock out these in the next few days.
21:09:51 <nirik> .ticket 3136
21:09:52 <zodbot> nirik: #3136 (Fedora17 Alpha - new website) – Fedora Infrastructure - https://fedorahosted.org/fedora-infrastructure/ticket/3136
21:09:53 <nirik> .ticket 3137
21:09:55 <zodbot> nirik: #3137 (Fedora17 Alpha - Verify mirror space) – Fedora Infrastructure - https://fedorahosted.org/fedora-infrastructure/ticket/3137
21:09:59 <nirik> .ticket 3138
21:10:00 <zodbot> nirik: #3138 (Fedora17 Alpha - release day ticket) – Fedora Infrastructure - https://fedorahosted.org/fedora-infrastructure/ticket/3138
21:10:01 <nirik> .ticket 3139
21:10:04 <zodbot> nirik: #3139 (Fedora17 Alpha - verify permissions on content) – Fedora Infrastructure - https://fedorahosted.org/fedora-infrastructure/ticket/3139
21:10:35 <smooge> was there a ticket to deal with maps and such
21:10:59 <nirik> there wasn't... perhaps we should add that to the sop?
21:11:32 <dgilmore> are the maps back up?
21:11:39 <mdomsch> #3137 - currelty 770G on the master mirror
21:11:52 <mdomsch> releases/13 can be nuked as it's in archive now
21:11:56 <nirik> dgilmore: not yet.
21:12:08 <dgilmore> 14 should be moved and nuked also
21:12:11 <dgilmore> nirik: ok
21:12:13 <smooge> nirik, I thought it was.. sorry I will correct and add
21:12:27 <nirik> smooge: cool. Thanks.
21:12:27 <mdomsch> dgilmore: ok
21:12:38 <nirik> #action smooge to update fedora-release sop with maps info.
21:12:42 <smooge> I can whack 13/14 after 2 +1's. also
21:12:42 <mdomsch> I think smooge was working on that, but wanted me around when he nuked it to be sure MM picks up the move
21:12:56 <nirik> #action smooge to archive/remove f13/f14 content.
21:13:02 <smooge> they should be archived
21:13:14 <smooge> its just remove and then figure out what didn't take :)
21:13:20 <nirik> cool.
21:13:24 <nirik> would be good to get that done.
21:13:32 <dgilmore> yep
21:13:50 <nirik> ok, anything more on alpha release?
21:14:25 <nirik> moving along...
21:14:36 <nirik> #topic Applications status / discussion
21:14:52 * mdomsch has a new application - s3-mirror
21:14:58 <nirik> lmacken / threebean / abadger1999 / pingou / mdomsch: any application news, issues or things of note?
21:15:10 <mdomsch> it needs some love
21:15:16 <nirik> mdomsch: cool. is that just a script? or more to it?
21:15:16 <mdomsch> https://fedoraproject.org/wiki/Infrastructure/Mirroring/Amazon
21:15:25 <mdomsch> it's just a script really
21:15:45 <mdomsch> but the s3cmd program is crapping out somewhere
21:15:47 <nirik> cool. Is it already working? or ?
21:15:50 <nirik> ;(
21:15:54 <mdomsch> so the initial sync is done
21:16:00 <mdomsch> but subsequent update syncs are failing
21:16:28 <mdomsch> I need someone who can follow the API calls/returns to figure out why it's dying receiving an empty XML document
21:16:31 <mdomsch> e.g. ''
21:16:49 <nirik> #info help needed on s3 sync script. See mdomsch.
21:17:29 <pingou> http://ambre.pingoured.fr/public/easyfix2.html now includes bugzilla's easyfix
21:18:25 <nirik> mdomsch: might be worth filing a easyfix ticket about the problem and seeing if anyone can look into it.
21:18:36 <lmacken> pingou: awesome.
21:18:41 <nirik> (see what I did there... tying those together :)
21:18:41 <mdomsch> nirik: I doubt it's easyfix material
21:18:54 <mdomsch> at least, it wouldn't be easyfix for me...
21:18:57 <nirik> ok. I was just hoping it was a command option or something...
21:19:07 <nirik> but I suppose you already checked all that
21:19:09 <pingou> lmacken: nirik was wondering how/if it could be included into packages
21:19:22 <mdomsch> it's in the bowels
21:19:47 <skvidal> mdomsch: can't promise anything - but could you point me at what you're seeing?
21:20:17 <nirik> lmacken: not sure it makes sense in there, but packages has a lot of the same info already... ie, bugs, etc.
21:20:47 <mdomsch> skvidal: sure. bapp01, ~mdomsch, s3sync-3rdpass.log or somesuch.  It feels like it's not getting back from S3 something it thinks it should via API call
21:20:55 <lmacken> pingou: I think it would fit better under a new Bugs Dashboard... the code could easily live in the fedoracommunity.git if we wanted too
21:21:02 <dgilmore> nirik: thats been my thought about packages since i first saw it, that it duplicates alot of things that exist already
21:21:53 <pingou> lmacken: I was actually thinking about a dedicated part at the top of the bug tab or something like this
21:22:05 <nirik> dgilmore: yeah, there's overlap between several other things (most notably pkgdb), but packager does things in a pretty nice way and is fast, so I think we should look at moving those duplicate things over to it...
21:22:22 <lmacken> pingou: cool, we'll talk about it more in #fedora-apps :)
21:22:37 <nirik> any other application news or info?
21:22:56 <pingou> lmacken: nirik but that would work easily for bugzilla's easyfix, might be more tricky for fedorahosted one
21:22:56 <nirik> lmacken: any progress on puppeting packages/tagger for production ? or would you like me to look at that?
21:23:23 <dgilmore> nirik: having it all be unified from a user standpoint is great
21:23:31 <lmacken> nirik: sorry, I haven't had any cycles to poke at it :\ If you wanna take a look, it would be much appreciated.
21:23:42 <dgilmore> nirik: but it does mean that package actually needs to do a lot more than it does today
21:23:47 <nirik> sure, I can try and whip something up. should just be some renaming and copying from whats in stg.
21:23:54 <lmacken> nirik: yep
21:24:26 <nirik> yeah, would be good to identify the overlaps and come up with a plan for them at some point.
21:25:11 <nirik> ok, moving along then?
21:25:25 <nirik> #topic Upcoming Tasks/Items
21:25:34 <nirik> #info 2012-02-14 to 2012-02-28 - F17 Alpha Freeze
21:25:34 <nirik> #info 2012-02-28 - F17alpha release day
21:25:34 <nirik> #info 2012-03-01 - nag fi-apprentices.
21:25:34 <nirik> #info 2012-03-10 - drop inactive fi-apprentices
21:25:34 <nirik> #info 2012-03-20 to 2012-04-03 - F17 Beta Freeze
21:25:47 <nirik> any other upcoming items folks would like to note/schedule/shout out?
21:26:02 * nirik adds into there:
21:26:07 <nirik> #info 2012-03-07 to 2012-03-14 - Pycon
21:26:47 <nirik> after the freeze I want to see if I can move bapp01 and as many apps as possible over to rhel6
21:27:15 <nirik> also ideally we would get our staging rework done before beta freeze, but we will see.
21:28:35 <nirik> #topic Open Floor
21:28:42 <nirik> anyone have any items for open floor?
21:29:14 <smooge> I am working on mailman chanbges
21:29:21 <skvidal> ?
21:29:24 <smooge> for the current stuff.
21:29:31 <skvidal> oh
21:29:34 <smooge> stuff that skvidal outlined a while ago
21:29:38 <skvidal> gotcha
21:29:41 <smooge> 1) Remove password generation template
21:29:42 <nirik> oh cool.
21:29:52 <smooge> 2) Set everyone's password to some random string.
21:30:00 <smooge> 3) Never talk about it again
21:30:46 <nirik> ok. I expect some of that will need to be 'hotfixes'...
21:30:48 <smooge> should be ready sometime after freeze
21:30:56 <nirik> but I could be wrong, perhaps it can be done in config.
21:31:01 <mdomsch> smooge: mailman auth == FAS auth then?
21:31:06 <smooge> noooooooo
21:31:14 <mdomsch> haha
21:31:17 <smooge> mailman only knows about cleartext
21:31:23 * abadger1999 is thnking no as well
21:31:25 <smooge> and too many passwrods are the other way
21:31:39 <nirik> mdomsch: basically remove the ability of people to pick a password, they get a random one instead of one that could well be used by them elsewhere.
21:32:10 <smooge> and if they use the random one else where.. life sucks.
21:32:19 <CodeBlock> hah
21:32:19 <ctria> :)
21:32:23 <nirik> and remove the password from the reminder emails it sends out monthy
21:32:30 <smooge> though I think setting everyone to Qwerty123456 has its appeal
21:32:39 <nirik> if someone forgets their pass they can just use the reset pass and get a new random one. ;)
21:32:48 <CodeBlock> nirik: We could modify the dpsearch crawler. If it comes across a login form, quickly run down the list of random passwords and try them.
21:32:49 * CodeBlock hides
21:32:51 <CodeBlock> smooge: *
21:32:55 <nirik> ha.
21:33:04 <CodeBlock> ;)
21:33:08 <skvidal> nim-nim: they won't actually get a new random one on resetpass
21:33:14 <skvidal> err s/nim-nim/nirik/
21:33:25 <skvidal> nirik: they will get the same one :)
21:33:38 <skvidal> there is no 'reset pass' it is 'remind'
21:33:44 <smooge> your random password is 3.
21:34:04 <CodeBlock> http://xkcd.com/221/
21:34:05 <CodeBlock> :)
21:34:06 <skvidal> we used a fair 20sided die
21:34:14 <nirik> right. yeah
21:34:50 * skvidal rolls 20s, everytime
21:35:19 <nirik> ok, anyone have anything else?
21:35:23 <nirik> or shall we call it a meeting?
21:35:38 * CodeBlock has nothing... will have an update next week about search stuff
21:36:11 <nirik> cool.
21:36:15 <nirik> thanks for coming everyone!
21:36:18 <nirik> #endmeeting