fesco
LOGS
18:00:30 <limburgher> #startmeeting FESCO (2012-01-09)
18:00:30 <zodbot> Meeting started Mon Jan  9 18:00:30 2012 UTC.  The chair is limburgher. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:30 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:36 <limburgher> #meetingname fesco
18:00:36 <zodbot> The meeting name has been set to 'fesco'
18:00:37 <sgallagh> Present and accounted for.
18:00:44 <limburgher> #chair notting nirik mjg59 mmaslano t8m pjones sgallagh mitr limburgher
18:00:44 <zodbot> Current chairs: limburgher mitr mjg59 mmaslano nirik notting pjones sgallagh t8m
18:00:51 <limburgher> #topic init process
18:00:57 * nirik is here.
18:01:00 * sgallagh salutes
18:01:01 <mitr> Hello all
18:01:04 * limburgher here
18:01:42 <limburgher> Quorum'd, shall we give in a minute for others or dig in?
18:01:54 <sgallagh> limburgher: Let's wait a few minutes.
18:01:59 <sgallagh> The queue is getting pretty long.
18:02:40 <pjones> hello.
18:02:43 <mmaslano> hi
18:03:06 <limburgher> It is.
18:03:44 * notting is here
18:05:09 <limburgher> mjg59, t8m: ping?
18:05:27 <pjones> mjg59 was around just a few minutes ago, so I expect he should be back soon.
18:05:32 <limburgher> <nods>
18:05:43 <mmaslano> t8m should come
18:05:57 <t8m> Hi
18:07:16 <limburgher> Ok, let's see. . .
18:07:22 <limburgher> #topic #720 kay - provenpackager for /usr move
18:07:46 <pjones> sure, +1
18:07:58 <nirik> .fesco 720
18:07:59 <zodbot> nirik: #720 (kay - provenpackager for /usr move) – FESCo - https://fedorahosted.org/fesco/ticket/720
18:08:12 <limburgher> nirik: Thanks. :)
18:08:23 <notting> this got referred to fesco as it didn't have enough feedback on the list. there wasn't any negative feedback, though.
18:08:44 <sgallagh> Seems sensible to grant provenpackager if we're going to have this done by feature freeze
18:08:48 <nirik> I'm +1. Would be good to have another person working on usermove, as it's going to be a fair bit of work.
18:08:51 <limburgher> I have no objection, I just didn't vote in the first round as I'm not acquainted.
18:08:54 <limburgher> +1
18:08:58 <mitr> I have counted 4 commits in owned packages total, so...
18:08:58 <sgallagh> +1
18:09:21 * fenrus02 fails to see any positive gain by doing so
18:09:24 <mmaslano> other people didn't get provenpackager even if it was needed, so..
18:09:38 <sgallagh> mmaslano: That sounds like a process failure to me.
18:09:55 <mmaslano> so, it's 0 from me, same rules for everyone
18:09:56 <t8m> Just for a note he is not a maintainer of any package, just co-maintainer of 4 packages.
18:09:59 <sgallagh> I'm inclined to say "grant it, and if he screws up, remove it later"
18:10:07 <pjones> sgallagh: yeah
18:10:11 <t8m> sgallagh, fine with me
18:10:12 <pjones> it's kay, he's fairly competent.
18:10:36 <limburgher> Who's his sponsor?
18:10:39 * nb didn't vote on the sponsors list because i wasn't acquainted with them
18:10:41 <fenrus02> (erg, that could be misconstrued.  the feature is not a positive gain; nothing against kay)
18:10:56 * pingou similar to nb
18:11:01 <limburgher> fenrus02: Right there with you. :)
18:11:22 <sgallagh> fenrus02: I agreed with you, but was outvoted. So since we're doing this thing, let's at least see it done properly
18:11:38 <nirik> right.
18:11:43 <fenrus02> sgallagh, fair
18:11:52 <pingou> "nirik:Would be good to have another person working on usermove" > is there no-one else than him?
18:12:08 <nb> limburgher, i'll look
18:12:09 <nirik> I don't know them well, but they have a good grasp of changes needed, so I am fine with pp for them.
18:12:28 <nirik> pingou: yes, a few others...
18:12:43 <pingou> who have provenpackager ?
18:13:03 <mmaslano> usually are for provepackager needed some packaging skills, I can't say if he has some or not based on record in Fedora.
18:13:08 <nb> limburgher, kay's sponsor is notting
18:13:29 <mmaslano> pingou: harald was granted as provenpackager
18:13:35 <pingou> that's 2
18:13:36 <nirik> pingou: harald is the other feature owner, he has pp which was granted just recently as well.
18:14:06 <limburgher> Right, the tickets were filed together, but more people are familiar with harald, AFAICT.
18:14:21 <mitr> Sorry, I have lost logs.  How does the vote stand?
18:14:26 * nirik nods.
18:14:39 <nirik> it's +4 I think
18:14:45 <mjg59> Argh, hi, sorry
18:14:57 <pjones> so far +4: me, nirik, limburgher, sgallagh.  mmaslano abstaining.
18:15:06 <mjg59> +1
18:15:27 <notting> i don't have any real reason to vote *against* it, so +1 from me
18:16:05 <mitr> That settles it then... I'd still like the http://fedoraproject.org/wiki/Provenpackager_policy to be opened up to reflect reality, but let's leave that to another meeting
18:16:06 <sgallagh> notting: I would have assumed sponsoring him was an implicit +!
18:16:38 <limburgher> #agreed #topic #720 kay - provenpackager for /usr move
18:16:45 <nb> mitr, just wondering, how does it not reflect reality?
18:17:13 <nirik> sgallagh: well, you can sponsor someone as a packager, but not think they are ready to be a provenpackager. ;)
18:17:15 <mitr> nb: "experienced in a wide variety of package types" - I don't mind softening the criterion and opening provenpackager more
18:17:26 <nb> yeah true
18:17:46 <limburgher> Ok. . .
18:17:48 <limburgher> #topic #739 GCC-4.7 rebuild
18:17:53 <limburgher> .fesco 739
18:17:55 <zodbot> limburgher: #739 (GCC-4.7 rebuild) – FESCo - https://fedorahosted.org/fesco/ticket/739
18:18:12 <sgallagh> nirik: I think I misread the above conversation
18:18:19 <sgallagh> It sounded like notting had proposed him for pp
18:18:22 <nirik> I'll all for the rebuild, but we need to fix file first at least. ;)
18:18:23 <limburgher> Nothing to do here, correct?
18:18:51 <mmaslano> I need rpm fix a bug first
18:18:56 <mmaslano> sooner than we start
18:18:56 <nirik> yeah, it passed, so on to rel-eng to work it. ;)
18:19:02 <limburgher> Right.
18:19:11 <limburgher> #topic #740 Security updates should consult affected packages' maintainers to prevent breakages.
18:19:16 <limburgher> .fesco 740
18:19:17 <zodbot> limburgher: #740 (Security updates should consult affected packages' maintainers to prevent breakages.) – FESCo - https://fedorahosted.org/fesco/ticket/740
18:20:06 <sgallagh> Proposal: Autokarma pushes should be disabled if a package receives any negkarma (critpath or all packages: discuss)
18:20:21 <notting> i thought it was that way already, tbh
18:20:30 <sgallagh> This also ties into the complaint I was going to make in the open floor about https://admin.fedoraproject.org/updates/FEDORA-2011-16663
18:20:46 <limburgher> sgallagh: maybe just critpath, but certainly critpath.
18:20:59 <mitr> We don't have a way to detect API/ABI changes, and most packages miss a test suite.  It would be nice to change all this :)
18:21:16 <pjones> mitr: huh... we had something to detect ABI changes before...
18:21:26 <pjones> mitr: as part of rhts, so probably fedora doesn't have it :/
18:21:44 <mitr> pjones: Some software is being talked about on fedora-devel right now, sounds promising
18:21:44 <t8m> sgallagh, +1 to the proposal (for all packages) - note this is just proposal for disabling of autopush not a manual push
18:21:48 <sgallagh> mitr: That may be true, but I think it's reasonable to require that someone actually looks at the karma replies before it gets pushed, if some of them are negative
18:21:59 <mitr> sgallagh: sure
18:21:59 <sgallagh> Correct. Manual pushes can override.
18:22:14 <limburgher> Right, the manual push may be for a good reason and should be able to be done if needed.
18:22:30 <sgallagh> However, I think we need to educate people on when to do a manual push (see https://admin.fedoraproject.org/updates/FEDORA-2011-16663 as mentioned above, where the advisory was pushed with ONLY negative karma replies...)
18:22:37 <nirik> yeah, it doesn't seem to be the case currently...
18:22:59 * sgallagh is just bitter because he got bit by that Eclipse update.
18:23:07 <nirik> I don't know that it solves this issue, but does at least let us blame whoever pushes it. ;)
18:23:28 <limburgher> nirik: WHich is also a good way to direct users to someone who can explain the issue.
18:23:35 <mitr> Eclipse is large enough that introducing a few bugs may be inevitable...
18:23:49 <mitr> Anyway, +1 to the proposal - for everything (primarily to minimize the coding work)
18:23:52 <sgallagh> nirik: Well, I think the NSS update in question would probably have been held back for a bit if not for Firefox advocates pushing it through autokarma
18:23:56 <nirik> nss updates are buggy enough that I fear they will often cause issues too. ;(
18:24:30 <sgallagh> mitr: In that particular case it was "breaks anyone who had used eclipse prior to the upgrade"
18:24:31 <nirik> yeah, I am +1 to the proposal. I'd be ok if it was all packages honestly.
18:24:32 <limburgher> mitr: My only concern with moving beyond critpath is that some my cry "red tape", but generally I agree.
18:24:38 <limburgher> +1
18:24:42 <sgallagh> +1 all packages
18:25:13 <notting> +1 from me
18:25:15 <mmaslano> +1
18:25:27 <sgallagh> limburgher: It may be red tape, but I'd at least like to be able to strangle someone with it if they push something despite known major issues :)
18:25:41 <limburgher> sgallagh: Bingo. :)
18:26:14 <nirik> who wants to file the bodhi ticket and work on pushing the change through?
18:26:19 <pjones> yeah, I'm +1 for it as well.
18:26:38 <sgallagh> nirik: I'll file the bodhi ticket. Not sure what's involved in pushing the change through
18:26:43 <limburgher> #agreed #topic #740 Security updates should consult affected packages' maintainers to prevent breakages. (+:8,-:0,0:0)
18:26:49 <sgallagh> Is that "harass lmacken" or "write a patch"?
18:26:57 <nirik> sgallagh: any of the above. ;)
18:27:08 <limburgher> #topic #725 F17 Feature: Erlang R15 - http://fedoraproject.org/wiki/Features/Erlang_R15
18:27:09 <sgallagh> Understood
18:27:10 <nirik> also, do we wish any other action on this ticket? or does that close it?
18:27:16 <limburgher> .fesco .725
18:27:16 <zodbot> limburgher: An error has occurred and has been logged. Please contact this bot's administrator for more information.
18:27:31 <limburgher> .fesco 725
18:27:32 <zodbot> limburgher: #725 (F17 Feature: Erlang R15 - http://fedoraproject.org/wiki/Features/Erlang_R15) – FESCo - https://fedorahosted.org/fesco/ticket/725
18:27:39 <mmaslano> +1
18:27:45 <mjg59> +1
18:28:06 <limburgher> +1
18:28:06 <sgallagh> nirik: I think that's as much as we can do (RE: 740). We can't force communication,
18:28:14 <sgallagh> +1 rubber-stamp
18:28:14 <mitr> nirik: close i think
18:28:18 <limburgher> sgallagh, nirik: Or reading.
18:28:18 <nirik> +1 on erlang.
18:28:27 <notting> +1
18:28:28 <pjones> yeah, +1
18:28:32 <t8m> +1 with feature process disclaimer
18:28:34 <mitr> +1 to Erlang (although concerned about the 0% status)
18:28:43 <sgallagh> limburgher: Well, the passed proposal *does* force reading negkarma reports at least
18:28:51 <mmaslano> mitr: yes,but there is no rule for non 0
18:29:09 <sgallagh> Not until Feb 7 anyway
18:29:11 <limburgher> #agreed #topic #725 F17 Feature: Erlang R15 - http://fedoraproject.org/wiki/Features/Erlang_R15  (+:8,-:0,0:0)
18:29:15 <limburgher> sgallagh:  It's a start.
18:29:27 <mitr> mmaslano: Right, there's plenty of time
18:29:28 <limburgher> #topic #726 F17 Feature: GCC 4.7 - http://fedoraproject.org/wiki/Features/GCC47
18:29:33 <sgallagh> The journey of a thousand miles begins with filling the gas tank
18:29:33 <limburgher> .fesco 726
18:29:35 <zodbot> limburgher: #726 (F17 Feature: GCC 4.7 - http://fedoraproject.org/wiki/Features/GCC47) – FESCo - https://fedorahosted.org/fesco/ticket/726
18:29:50 <nirik> sure, time marches on. +1
18:29:51 <sgallagh> Again, rubber-stamp
18:29:52 <mjg59> +1
18:29:57 <limburgher> Horse, barn door, etc.
18:29:58 <limburgher> +1
18:29:59 <mitr> +1
18:29:59 <mmaslano> +1
18:29:59 <sgallagh> Especially since we already approved a mass-rebuild
18:29:59 <t8m> limburgher, please use something descriptive for the #agreed
18:30:26 <limburgher> t8m: Sure, sorry, first chairing of anything.  Suggestions welcome.
18:30:26 <notting> +1
18:30:30 <t8m> limburgher, in the #740 it was not clear what proposal we agreed upon
18:30:54 <limburgher> t8m: I'll comment on the ticket.
18:31:00 <t8m> +1
18:31:04 <t8m> limburgher, thanks
18:31:19 <limburgher> t8m: I understood 740 to be passed for all packages.
18:31:19 <sgallagh> limburgher: Please edit the minutes when you send them out too, so it's clear that we're changing bodhi process
18:31:32 <limburgher> sgalllagh:  Will do.
18:31:33 <sgallagh> Also, there should have been a #action for me to handle bodhi
18:31:59 <limburgher> Ok.
18:33:27 <limburgher> #agreed F17 GCC 4.7 Feature is passed, (+:8,-:0,0:0)
18:33:47 <limburgher> #topic #727 F17 Feature: GHC 7.4 - https://fedoraproject.org/wiki/Features/GHC74
18:33:52 <limburgher> .fesco 727
18:33:53 <zodbot> limburgher: #727 (F17 Feature: GHC 7.4 - https://fedoraproject.org/wiki/Features/GHC74) – FESCo - https://fedorahosted.org/fesco/ticket/727
18:33:58 <t8m> +1 with feature process disclaimer
18:33:59 <nirik> +1
18:34:13 <mjg59> +1
18:34:19 <mitr> +1
18:34:19 <limburgher> +1
18:34:25 <mmaslano> +1
18:34:44 <notting> +1
18:34:59 <sgallagh> +1
18:35:30 <limburgher> This appears to be for F18, correct?
18:35:49 <pjones> limburgher: no...
18:35:52 <pjones> (also I'm +1)
18:35:59 <notting> well, that's what the feature page says. oops
18:36:05 <limburgher> # Targeted release: Fedora 18
18:36:12 <nirik> hum, ok... thats early. ;)
18:36:39 <limburgher> I assume they'll correct that then?
18:36:54 <pjones> oh, well, then either that or it being on our list is a mistake.
18:37:07 <mmaslano> I assume something if prepared for F-17, but that's strange
18:37:16 <limburgher> Based on the dates I'd guess F17.
18:37:17 <drago01> might be a typo
18:37:21 <mitr> Anyway, we're probably happy to have it in either
18:37:36 <limburgher> Scope says 17 so I say run with it.
18:38:15 <limburgher> #agreed F17 GHC 7.4 Feature is passed (+:9,-:0,0:0)
18:38:23 <limburgher> #topic #728 F17 Feature: GIMP 2.8 - https://fedoraproject.org/wiki/Features/GIMP_2.8
18:38:29 <limburgher> .fesco 728
18:38:30 <zodbot> limburgher: #728 (F17 Feature: GIMP 2.8 - https://fedoraproject.org/wiki/Features/GIMP_2.8) – FESCo - https://fedorahosted.org/fesco/ticket/728
18:38:34 <mmaslano> +1
18:38:37 <t8m> +1
18:38:46 <mitr> +1
18:38:53 <nirik> +1 here as well.
18:38:54 <limburgher> +1
18:39:01 <mjg59> +1
18:39:05 <sgallagh> +1
18:39:09 <pjones> +1
18:40:15 <limburgher> #agreed F17 GIMP 2.8 Feature is passed  (+:8,-:0,0:0)
18:40:24 <limburgher> #topic #729 F17 Feature: GNOME 3.4 - https://fedoraproject.org/wiki/Features/Gnome3.4
18:40:28 <limburgher> .fesco 729
18:40:29 <zodbot> limburgher: #729 (F17 Feature: GNOME 3.4 - https://fedoraproject.org/wiki/Features/Gnome3.4) – FESCo - https://fedorahosted.org/fesco/ticket/729
18:40:39 * pjones is +1 here as well
18:41:00 * sgallagh wonders what would happen if I said -1
18:41:01 <notting> +1
18:41:07 <mitr> +1, echoing sgallagh
18:41:07 <notting> sgallagh: you'd get outvoted?
18:41:09 <sgallagh> +1 in all serious
18:41:20 <limburgher> +1
18:41:20 <mjg59> +1
18:41:21 <nirik> +1
18:41:25 <t8m> +1
18:41:30 <mmaslano> +1
18:42:36 <limburgher> pjones: ?
18:42:52 <mjg59> 18:40  * pjones is +1 here as well
18:43:24 <limburgher> I thought that was re: GIMP.
18:43:43 <sgallagh> limburgher: He +1ed there as well
18:43:57 <limburgher> So he did.  (cleans glasses)
18:44:05 <limburgher> #agreed F17 GNOME 3.4 Feature is passed  (+:9,-:0,0:0)
18:44:12 <limburgher> #topic #730 F17 Feature: Lohit Unicode 6.0 support - https://fedoraproject.org/wiki/Features/IndicUnicode6
18:44:15 <limburgher> .fesco 730
18:44:16 <zodbot> limburgher: #730 (F17 Feature: Lohit Unicode 6.0 support - https://fedoraproject.org/wiki/Features/IndicUnicode6) – FESCo - https://fedorahosted.org/fesco/ticket/730
18:44:23 <mmaslano> +1
18:44:28 <mitr> +1
18:44:33 <limburgher> +1
18:44:41 <nirik> sure, +1
18:44:56 <t8m> +1
18:44:57 <notting> +1
18:44:58 <mjg59> +1
18:45:05 <sgallagh> +1
18:45:11 <sgallagh> Though I'm wary of the completion state
18:45:19 <limburgher> I was thinking I
18:45:27 <limburgher> 'd seen some of these go in.
18:45:31 <mitr> AFAICS this is a single-package feature, only necessary for the single-line release note... we should really think of something better long-term.
18:46:27 <nirik> well, to the group of folks that would need/want those it would be a important feature.
18:46:47 <limburgher> #agreed F17 Lohit Unicode 6.0 support Feature is passed  (+:8,-:0,0:0)
18:46:57 <limburgher> #topic #731 F17 Feature: Kernel Target - https://fedoraproject.org/wiki/Features/KernelTarget
18:47:00 <limburgher> .fesco 731
18:47:01 <zodbot> limburgher: #731 (F17 Feature: Kernel Target - https://fedoraproject.org/wiki/Features/KernelTarget) – FESCo - https://fedorahosted.org/fesco/ticket/731
18:47:09 <mjg59> +1
18:47:11 <mmaslano> +1
18:47:23 <notting> +1
18:47:27 <t8m> +1
18:47:30 <limburgher> +1
18:47:32 <mitr> Would like the status of the old solution clarified, but +1
18:47:52 <nirik> +1
18:47:56 <sgallagh> +1
18:48:19 <nirik> I'm assuming the kernel folks are ok with enabling it since it's already in
18:48:23 <pjones> the old solution was a pain in the ass, so +1
18:49:14 <limburgher> #agreed F17 Kernel Target Feature is passed  (+:9,-:0,0:0)
18:49:21 <limburgher> #topic #732 F17 Feature: OpenStack using libguestfs - https://fedoraproject.org/wiki/Features/OpenStack_using_libguestfs
18:49:24 <limburgher> .fesco 732
18:49:25 <zodbot> limburgher: #732 (F17 Feature: OpenStack using libguestfs - https://fedoraproject.org/wiki/Features/OpenStack_using_libguestfs) – FESCo - https://fedorahosted.org/fesco/ticket/732
18:49:31 <mitr> +1
18:49:48 <t8m> +1
18:49:52 <limburgher> +1
18:49:55 <mmaslano> +1
18:50:02 <nirik> sure, +1
18:50:04 <notting> +1
18:50:22 <sgallagh> +1 looks to be finished already
18:50:29 <limburgher> Indeed.
18:50:35 <mmaslano> +1
18:50:39 <mjg59> +1
18:50:48 <limburgher> #agreed F17 OpenStack using libguestfs Feature is passed  (+:9,-:0,0:0)
18:50:56 <limburgher> #topic #733 F17 Feature: Package Service Presets - https://fedoraproject.org/wiki/Features/PackagePresets
18:51:00 <limburgher> .fesco 733
18:51:04 <zodbot> limburgher: #733 (F17 Feature: Package Service Presets - https://fedoraproject.org/wiki/Features/PackagePresets) – FESCo - https://fedorahosted.org/fesco/ticket/733
18:51:41 <mitr> systemd seems to have that functionality in F16 already.
18:51:49 <nirik> +1 here. I like it. We might want to look at aligning this with spins and such to actually use it.
18:51:50 <mjg59> I think this makes sense
18:52:01 <limburgher> +1
18:52:01 <mjg59> But yeah, communicating it to the spins would be great
18:52:02 <sgallagh> nirik: I think that's the point of this feature
18:52:03 <mjg59> +1
18:52:12 <sgallagh> To coordinate this feature with the assorted spins
18:52:13 <sgallagh> +1
18:52:13 <mitr> I'm -1 to the feature, annoucing presets when only few packages support it doesn't really make sense
18:52:14 <nirik> also, FPC might have to look at changes to snippets
18:52:18 <mmaslano> I like it, but it should be added into guidelines
18:52:43 <mmaslano> and RPM developers have similar idea with group post scripts..
18:52:57 <t8m> mitr, yeah we need at least the core packages changed
18:52:59 <mitr> ... which is unfortunately not ready for F17
18:53:33 <mitr> Also, I'm really not thrilled about centralizing the default state - it means additional manpower to maintain the centralized information.
18:53:38 <limburgher> So I see +4 and -1.
18:53:57 <notting> mitr: doesn't appear as if it would be hard to fix remaining packages
18:53:58 <sgallagh> Hmm, these are good points.
18:54:07 <sgallagh> I'm revising my vote to -1, try for F18
18:54:11 <t8m> mitr, yeah that's a valid point too
18:54:16 <mmaslano> -1
18:54:21 <notting> i think centralizing it makes more sense than distributing it to each individual package
18:55:03 <limburgher> So we're at +3, -3.
18:55:19 <sgallagh> Who's the tie breaker?
18:55:24 <mitr> notting: Well, it's ~360 packages.  If people would commit to doing the work (a la usrmove), I'd feel happier about it... although waiting for the shared scripts still seems sensible to me
18:55:26 * nirik looks futher, so can you override presets?
18:55:45 <notting> enable/disable overrides preset
18:55:49 <sgallagh> nirik: No, presets override platform defaults I think
18:55:53 <sgallagh> Well, that too
18:56:04 <nirik> ah, it's a ordering thing.
18:56:23 <nirik> fedora has a default, spins could override that, local user/admin could override that
18:56:25 <mmaslano> is there any example?
18:56:42 <t8m> I think this should be discussed further on fedora-devel
18:56:57 <limburgher> t8m:  Agreed, revising to -1.
18:57:01 <mitr> nirik: That would probably require seting up a sysv-stile PRIORITYname system or something
18:57:05 <limburgher> +2, -4.
18:57:33 <nirik> it's alpha ordering...
18:57:36 <t8m> I am -1 for now as well
18:57:42 <limburgher> +1, -5.
18:58:02 <notting> mitr: huh? that's already covered
18:58:10 <nirik> well, I agree it needs more discussion and we should perhaps not advertise it until we are actually using it...
18:58:11 <limburgher> What should our comments for f18 be?
18:58:16 <notting> i'm +1 to it, would be willing to help convert packages
18:58:26 <nirik> but can we not do it in f17?
18:58:29 <mitr> notting: which "that"?
18:58:39 <limburgher> +2, -5
18:58:43 <notting> mitr: the feature
18:58:56 <notting> mitr: ordering of distro vs. spin defaults
18:59:05 <nirik> proposal: ask FPC to look at changes here and see what guidelines need updating and ask spins if they could update to using this system?
18:59:21 <t8m> nirik, +1
18:59:39 <mitr> notting: "files are read in alphabetical order"
19:00:11 <nirik> so if you have: 00-local, 01-security-lab, fedora-default it would read them in that order.
19:00:22 <mitr> nirik: that's what I was thinking
19:01:01 * nirik wonders how much it would change per spin tho.
19:01:20 <mitr> What do spins currently do to enable/disable services?  Is this noticeably better?
19:01:36 <nirik> they use %post in their kickstart file
19:01:55 <notting> they call systemctl and chkconfig a bunch in their kickstart's %post
19:01:59 <nirik> things like: 'systemctl --no-reload disable mdmonitor.service 2> /dev/null || :'
19:02:13 <notting> and just sort of assume nothing is changing out from under them
19:03:36 <nirik> so, where are we here? just rejecting this? getting more info and revisiting next week?
19:03:56 <mmaslano> ask to fpc about it?
19:04:10 <t8m> and discuss at fedora-devel?
19:04:16 <mmaslano> yes
19:04:27 <mitr> FPC needs to approve the scriptlet guideline update in any case
19:04:45 <mitr> but do we particularly care that it is before the feature is approved?
19:05:02 <limburgher> Looks like +3, -5?
19:05:18 <pandaconstantin> Hi everyone
19:05:29 <limburgher> #agreed F17 Package Service Presets Feature is not passed  (+:3,-:5,0:0)
19:05:39 <limburgher> #topic #734 F17 Feature: PHP 5.4 - https://fedoraproject.org/wiki/Features/Php54
19:05:43 <limburgher> .fesco 734
19:05:44 * RemiFedora is here if any question
19:05:44 <zodbot> limburgher: #734 (F17 Feature: PHP 5.4 - https://fedoraproject.org/wiki/Features/Php54) – FESCo - https://fedorahosted.org/fesco/ticket/734
19:05:52 <mmaslano> +1
19:05:54 <limburgher> +1
19:06:02 <mitr> +1, great work preparing all of those patches
19:06:07 <mjg59> +1
19:06:28 <nirik> RemiFedora: will the gcc mass rebuild take care of the rebuild of these?
19:06:30 <notting> sure, +1
19:06:31 <nirik> or it's too soon?
19:06:33 <t8m> +1
19:06:34 <sgallagh> RemiFedora: Any backwards-compatibility gotchas to look out for?
19:06:35 <nirik> +1 in any case.
19:06:49 <pjones> sure, +1
19:07:22 <RemiFedora> nirik, yes if php 5.4 in the repo "before" mass rebuild
19:07:41 <RemiFedora> but some package need some works...
19:07:46 <nirik> RemiFedora: ok.
19:08:18 <limburgher> #agreed F17 PHP 5.4 Feature is passed  (+:8,-:0,0:0)
19:08:24 <limburgher> #topic #735 F17 Feature: Riak - https://fedoraproject.org/wiki/Features/Riak
19:08:27 <limburgher> .fesco 735
19:08:28 <zodbot> limburgher: #735 (F17 Feature: Riak - https://fedoraproject.org/wiki/Features/Riak) – FESCo - https://fedorahosted.org/fesco/ticket/735
19:08:44 <mitr> +1
19:08:48 <mmaslano> +1
19:08:56 <sgallagh> +1
19:08:58 <notting> sure, +1
19:09:07 <pjones> sure, +1
19:09:14 <limburgher> +1, does interact with or depend on R15?
19:09:33 <mjg59> +1
19:09:41 <nirik> +1
19:10:41 <limburgher> #agreed F17 Riak Feature is passed  (+:8,-:0,0:0)
19:10:47 <limburgher> #topic #736 F17 Feature: libpinyin - https://fedoraproject.org/wiki/Features/libpinyin
19:10:50 <limburgher> .fesco 736
19:10:54 <zodbot> limburgher: #736 (F17 Feature: libpinyin - https://fedoraproject.org/wiki/Features/libpinyin) – FESCo - https://fedorahosted.org/fesco/ticket/736
19:11:13 <t8m> +1
19:11:14 <pjones> sure.
19:11:16 <pjones> +1
19:11:24 <mmaslano> +1
19:11:31 <mitr> +1
19:11:35 <limburgher> +1
19:11:36 <notting> +1
19:11:45 <nirik> +1
19:11:47 <sgallagh> +1
19:11:59 <limburgher> #agreed F17 libpinyin is passed  (+:8,-:0,0:0)
19:12:06 <limburgher> #topic #737 F17 Feature: oVirt - https://fedoraproject.org/wiki/Features/oVirt
19:12:10 <limburgher> .fesco 737
19:12:11 <zodbot> limburgher: #737 (F17 Feature: oVirt - https://fedoraproject.org/wiki/Features/oVirt) – FESCo - https://fedorahosted.org/fesco/ticket/737
19:12:17 * sgallagh feels like we've seen this before
19:12:40 <notting> this is new and improved ovirt
19:12:43 <mjg59> +1
19:12:44 <mitr> +1
19:12:50 <nirik> sure, +1
19:12:54 <notting> +1
19:12:55 <limburgher> +1
19:12:57 <mmaslano> +1
19:13:04 <sgallagh> Completion status is missing
19:13:06 <pjones> +1
19:13:14 <t8m> +1
19:13:42 <sgallagh> Sure +1
19:13:57 <limburgher> Review looks like it's moving along.
19:14:13 <limburgher> #agreed F17 oVirt is passed  (+:9,-:0,0:0)
19:14:30 <pjones> though depending on sysvinit is a bit weird at this point.
19:14:45 <limburgher> pjones: One would hope that would be fixed in the review.
19:15:04 <limburgher> That looks like it for this week.
19:15:10 <limburgher> #topic Next week's chair
19:15:44 <limburgher> Any takers?
19:15:45 <mitr> I can do that.
19:15:58 <pjones> I'm not sure I'll be back from fudcon at this point next week... not entirely sure.
19:16:03 <sgallagh> We decided to skip the feature pages that rbergeron submitted this morning, then?
19:16:09 <pjones> sgallagh: yes.
19:16:11 <sgallagh> ok
19:16:14 <pjones> sgallagh: that's our policy ;)
19:16:30 * nirik is happy to address them if folks would like, or do them next week.
19:16:49 <mitr> Same here ... or vote in the tickets
19:16:59 <pjones> I'd rather stick with the "if they don't make it in time for the agenda, they don't make it" policy.
19:17:03 <t8m> I'd say skip them, we had too many +1 already today :D
19:17:04 <mmaslano> we could acked features, which are new packages...
19:17:11 <pjones> It's the only way to actually be reasonably prepared for the meeting IMO.
19:17:13 <limburgher> t8m: agreed.
19:17:25 <sgallagh> I'm +1 to being lazy :)
19:17:31 <nirik> we skipped several meetings for the holidays and feature freeze is coming up. ;)
19:17:44 <nirik> so we should try and meet next week if possible, IMHO
19:18:02 <t8m> nirik, sure
19:18:05 <limburgher> I can.  I'm OK with voting in tickets if folks need to miss next weel.
19:18:08 <limburgher> week.
19:18:16 <mitr> pjones: right, we shouldn't encourage late-breaking agenda items... but then the feature authors are innocent
19:18:36 <pjones> Well, maybe if I'm stuck as a passenger on I95 I'll see what FESCo-via-sprint is like.
19:18:36 <t8m> I see just pjones that doubts that he will be able to attend, anybody else?
19:18:38 <nirik> so, if you can't make next week, do go vote in tickets I would say. ;)
19:18:54 <limburgher> #info mitr will chair 2012-01-16 meeting
19:19:26 * limburgher will be here, most likely.
19:19:38 <limburgher> #topic Open Floor
19:19:49 <pjones> nirik: yeah, I'll try to vote on everything /at/ fudcon.
19:19:56 <limburgher> Nothing from me, I'll end in 5 if noone has anything.
19:20:09 <sgallagh> Just wanted to mention that Eclipse bug
19:20:22 <sgallagh> It's far from the first time that a stable update has broken eclipse
19:20:36 <sgallagh> The "workaround" is to manually remove ~/.eclipse
19:20:47 <sgallagh> But that's not an acceptable answer for the average user
19:21:03 <sgallagh> (Especially if they had existing custom settings that are now demolished)
19:21:26 <sgallagh> I think it was unacceptable for the maintainer to force-push an update with only negkarma knowing that it would break users.
19:21:49 <limburgher> Yeah, it really should be rawhide-only and release-noted, unless there was a compelling security rationale.
19:22:30 <nirik> sgallagh: which update was this exactly?
19:22:56 <sgallagh> https://admin.fedoraproject.org/updates/FEDORA-2011-16663
19:23:38 <nirik> yeah, that looks non ideal for sure.
19:24:14 <number80> hullo
19:24:29 <RemiFedora> <sgallagh> RemiFedora: Any backwards-compatibility gotchas to look out for?  => only some new warnings, compatibility for web app seems very good, and the only removed extension is not in fedora
19:24:41 <sgallagh> RemiFedora: Thanks :)
19:25:37 <limburgher> Anything else?
19:25:40 <mitr> Yes
19:25:55 <nirik> sgallagh: so, we could formally chastise the maintainer and ask them not to do this again?
19:26:05 <mitr> Our meeting in 2 weeks time is Jan 23, the feature submission deadline is Jan 24 - are we OK with that?
19:26:37 <t8m> mitr, that's submission deadline and not approval deadline
19:26:44 <nirik> so, the last meeting with features would be the next meeting after that?
19:26:45 <limburgher> If we cover what's in trac next week (or cover it in trac over the next week) and that's the bulk, yes.
19:26:59 <sgallagh> nirik: I suppose that's the best we can do.
19:27:06 <sgallagh> (RE: eclipse)
19:28:21 <limburgher> nirik:  Do we do anything WRT that other than this discussion?
19:28:33 * rbergeron wonders if there will actually *be* a meeting next week...
19:28:47 <nirik> perhaps one of us ( sgallagh ?) would mail them our concerns?
19:28:59 * nirik should be available to meet next week.
19:29:00 <t8m> rbergeron, we hope it will
19:29:01 * rbergeron reads upwards
19:29:02 <notting> rbergeron: only one person claimed out so far
19:29:03 <pjones> rbergeron: so far, sounds like yes...
19:30:54 <limburgher> Ok.  See most of you next week then.  Thanks!
19:30:57 <limburgher> #endmeeting