fedora_kernel
LOGS
18:00:02 <jwb> #startmeeting
18:00:02 <zodbot> Meeting started Fri Jan  6 18:00:02 2012 UTC.  The chair is jwb. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:12 <jwb> #meetingname Fedora Kernel
18:00:12 <zodbot> The meeting name has been set to 'fedora_kernel'
18:00:20 <jwb> davej, ready?
18:00:43 <jwb> #meetingtopic Fedora kernel
18:00:53 <davej> oops, yeah, gimme a sec.
18:00:57 <jwb> k
18:01:40 <davej> ok
18:01:51 <jwb> first up?
18:02:06 <davej> before we do the usual run-through,.. fudcon
18:02:15 <jwb> #topic fudcon
18:02:59 <davej> we usually do a 'state of the kernel' talk which goes over well, so I suspect we'll do that again
18:03:09 <davej> do we have any additional talks we want to give ?
18:03:36 <jwb> it'd be nice to get something on debugging/triaging kernel bugs, but i'm not sure exactly what we'd pitch
18:03:38 <davej> if I can pull my thoughts together, I might do one on some ideas I have for automating kernel qa
18:03:47 <jwb> or that, yeah
18:04:16 <jwb> i'm sure there will be general triage and qa meetings, so we might be able to piggy back on those a bit if we don't have enough for our own session
18:04:35 <davej> I had thought of a 'how to help us triage' session, but I can't imagine it would be particualrly thrilling to watch us looking through bugzilla.
18:04:46 <jwb> right, same probably i had
18:04:51 <jwb> er, s/probably/problem
18:05:21 <davej> ok, we'll just roll with it on the day. see how things go
18:05:22 <jwb> so since this is a community meeting, if anyone in the community has suggestions or questions, chime in
18:05:36 <davej> perhaps we'll touch on it in the state-of.. talk
18:05:42 <jwb> k
18:05:58 <jwb> f15/f16?
18:06:02 <davej> yeah, lets move on
18:06:09 <jwb> #topic Fedora 15/16
18:06:32 <davej> I wouldn't be surprised if we see 3.2.1 around the time of fudcon
18:06:44 <davej> so we'll probably have to start thinking about a rebase pretty soon
18:06:52 <jwb> would be nice.  3.1.x was fairly stable until we hit that resume regression
18:06:53 <davej> not expecting it to be too painful
18:07:08 <jwb> hopefully 3.2.x proves to be similarly stable
18:07:18 <davej> yeah
18:07:30 <jwb> btw... that has the fixes that should help the "hangs on I/O to slow media" problem, right?
18:07:48 <davej> I think it's more band-aid type stuff for now, with the real fixes coming in 3.3
18:08:19 <jwb> ok.  i know we had one reporter say they are going to try 3.2.  maybe that will be a good guinea pig type report
18:08:31 <jwb> i don't think they'd get much worse :\
18:09:08 <davej> I've been running self-built ones on 16 for a few weeks, it's held up pretty well
18:09:17 <jwb> the other thing we've hit lately is the oopses in the f16 compat-wireless stuff
18:09:22 <davej> hopefully .1 will fix up the odd bits that were missed
18:10:28 <jwb> unless 3.2.1 fixes those, we'll still see them in a rebase
18:10:40 <davej> I'm hoping that compat-wireless will start shaping up soon, it's been a bit of a horror show so far.
18:11:12 <davej> it might be worth keeping track of for eg, just how many wireless / suspend etc bugs we get each month.
18:11:32 <jwb> in the whiteboard?
18:11:36 <davej> yeah
18:11:47 <jwb> the problem we have with that is remembering to add it
18:12:40 <davej> oh, we could just do a bz search for /builddir/compat-wireless ;)
18:12:48 <jwb> heh, yeah
18:13:09 <jwb> maybe something could be coded up with python-bugzilla to make search and whiteboard additions easier
18:13:29 <davej> feel free to add it to the project list
18:13:38 <jwb> yep
18:13:47 <davej> so something that's been bugging me for a while..
18:13:51 <davej> those sch_generic bugs
18:14:35 <davej> I think once we have 3.2 out, if we still keep getting those, I'm going to bug upstream about them again, because they don't seem to be anything we can do anything about
18:14:48 <jwb> yes.  i know the atl1c driver seemed to get some general improvements when one user tested mjg59's driver-specific ASPM patch
18:15:01 <jwb> but those patches aren't in 3.2.  i think more rework is needed
18:15:20 <jwb> the main ASPM change was backported to f16 though
18:15:32 <jwb> of course, i'm kinda guessing that is related.
18:15:52 <davej> yeah, I think it's a bigger problem tbh
18:16:00 <davej> possibly even hardware related in some cases
18:16:38 <jwb> atl1c seems to be the most frequent by far.  the past couple of e1000e that i've seen seem to be in virt guests
18:16:55 <jwb> beyond that, i haven't noticed any trends
18:17:59 <davej> yeah, that's about it really. ~750 f15/f16 bugs right now. Hopefully we knock another bunch out with the rebase.
18:18:17 <jwb> #info Revisit sched_generic bugs with upstream if 3.2 still shows frequent occurances
18:19:03 <jwb> #info f15/f16 rebase to 3.2.x around FUDCon timeframe
18:19:47 <jwb> so one thing i don't think the rebase will help is the hibernate things...
18:20:02 <jwb> where stuff seems randomly broken on resume.  like unlock_new_inode
18:20:07 <davej> that bug is a nightmare
18:21:00 <davej> we're still no closer to really understanding that one. until one of us can reproduce it so we can bisect it, I'm not optimistic.
18:21:24 <jwb> i'll try harder.  i can't remember the last time i even wanted to hibernate
18:21:29 * jwb is non-mobile
18:22:33 <jwb> move on?
18:22:35 <davej> yep
18:22:44 <jwb> you had one more thing for f15/f16 didn't you?
18:22:51 <davej> oh yeah
18:22:57 <davej> I think it's a no-brainer though
18:23:19 <davej> things like UAS which aren't ready for mass consumption, but we want to give them a try in rawhide.. I thought about adding them to 'make release/debug'
18:23:45 <jwb> yeah, nice idea
18:24:02 <jwb> some kind of comment or separate section for them so they're noticable?
18:24:04 <davej> that's the only one that came to mind initially, but there might be more
18:24:12 <davej> yeah, needs a comment too
18:24:30 <davej> a lot of the decisions we've made in the config options really could use commenting tbh
18:24:42 <davej> I forget myself sometimes why we set something a certain way.
18:24:57 <jwb> yeah.  i'm afraid to go turn stuff off or change it because i have no idea why any of them are set the way they are
18:25:15 <jwb> i cleaned up powerpc recently, but stopped there
18:26:06 <jwb> #agreed Put various config options we want to try in rawhide but aren't ready for a stable release in 'make release/debug'
18:26:31 <davej> so, rawhide ?
18:26:37 <jwb> sure
18:26:43 <jwb> #topic f17 (rawhide)
18:26:57 <davej> 3.2 seemed to drag out a little
18:27:08 <davej> but I feel optimistic we can still squeeze 3.3 into 17
18:27:32 <jwb> hopefully.  should we hold off on a rebase until we see how -rc1/rc2 look?
18:27:48 <davej> we'll be in -rc by alpha
18:28:05 <davej> assuming the schedule on the wiki is current
18:29:04 <jwb> right
18:29:52 <jwb> too bad it won't be released before we branch.  having to do bodhi updates for 3.3 -rcs will be a bit slower
18:30:17 <davej> ugh, yeah, I dislike that process
18:31:36 <davej> so I had an item for modules-extra discussion, but I think we really need to see how that is accepted post alpha to really know whether it's a good idea or not
18:31:52 <jwb> i'm still very undecided about it myself
18:32:09 * nirik has a quick question.
18:32:18 <jwb> shoot
18:32:37 <nirik> whats the status/plans for debug options? always on in rawhide, on in branched until X? or was it going to get split into a kernel-debug ?
18:32:55 <jwb> ah, right.
18:33:04 <davej> I think the only thing we really decided so far was to do one non-debug build per -rc
18:33:26 <nirik> might be good to document somewhere...
18:33:31 <jwb> i think we should stick with that for a kernel cycle and see how much benefit it has
18:33:44 <jwb> before we go implementing kernel-debug/kernel-nodebug
18:34:03 <nirik> so you can find the non debug one via changelog?
18:34:07 <davej> yep
18:34:15 <jwb> nirik, yep.  i'll look at writing it up on the kernel wiki page too
18:34:22 <nirik> cool.
18:34:31 <davej> as of a few days ago, it's going to be the same commit msg every time too
18:34:35 <nirik> so that same plan will hold for f17 once it's branched?
18:34:44 <nirik> or undecided yet?
18:34:48 <jwb> #info rawhide will have kernels built with debug options disabled once per -rc
18:34:59 <davej> should be
18:36:32 <davej> this sort of ties into some of the ideas I have for automated benchmarking of rawhide kernels too. (which is one of the things I might talk about at fudcon)
18:37:13 * nirik updates his rawhide vm to the non debug build. ;)
18:37:59 <jwb> any other questions?
18:38:48 <jwb> davej, so i saw josh stone will be at fudcon.  maybe we can corner him on utrace/uprobes...
18:38:52 <jwb> ;)
18:38:59 <davej> maybe he plans on cornering us about same :)
18:39:13 <jwb> a double trap...
18:39:18 <davej> we'll just have to decide who plays good/bad cop beforehand.
18:39:54 <davej> from the fedora side, that has gone awfully quiet.
18:40:30 <jwb> yeah.  the patch for 3.2 was identical to 3.1 except some line number changes in the patch itself
18:40:41 <jwb> minor enough that the 3.1 patch still applied
18:41:58 <jwb> anything else?
18:42:01 <davej> I'm all out of things I had.
18:42:18 * nirik has nothing more
18:42:40 <jwb> i'm sure knurd_afk will have some questions for us on the list ;)
18:43:40 <jwb> ok, if there is nothing else, let's wrap up
18:43:43 <davej> word
18:43:51 <davej> same bat-channel 2 weeks time.
18:44:15 <jwb> #info Remember to post questions and suggestions to the fedora kernel list
18:44:19 <jwb> #endmeeting