infrastructure
LOGS
19:00:01 <nirik> #startmeeting Infrastructure (2012-01-05)
19:00:01 <zodbot> Meeting started Thu Jan  5 19:00:01 2012 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:01 <nirik> #meetingname infrastructure
19:00:01 <zodbot> The meeting name has been set to 'infrastructure'
19:00:01 <nirik> #topic Robot Roll Call
19:00:01 <nirik> #chair smooge skvidal Codeblock ricky nirik abadger1999 lmacken dgilmore mdomsch
19:00:01 <zodbot> Current chairs: Codeblock abadger1999 dgilmore lmacken mdomsch nirik ricky skvidal smooge
19:00:09 * skvidal is here
19:00:11 * lmacken 
19:00:12 <dgilmore> gday
19:00:18 <icole> hello
19:00:24 <nirik> hey everyone.
19:00:45 * abadger1999 here
19:01:00 * pingou here
19:01:09 * jsmith is here but heads-down on a couple of projects
19:01:28 <p3ll0n_> Here.
19:01:32 <nirik> ok, lets go ahead and dive on in then...
19:01:36 <nirik> #topic New folks introductions and apprentice tasks/feedback
19:01:53 * wsterling here
19:02:04 <nirik> Any new folks care to give a introduction? any apprentices care to talk about tickets or general feedback?
19:02:17 <icole> hi everyone, i just joined the apprentice group on Sunday
19:02:24 <pingou> congrats :)
19:02:34 <nirik> welcome icole.
19:02:43 <p3ll0n_> New apprentice here as well.
19:02:48 <securegates> new here as well :)
19:02:50 * thesharp is late a bit. hello everyone.
19:02:57 <icole> so I have poked around a little bit in the group, tickets etc but haven't had much of a chance to dig in to anything yet
19:03:00 <nirik> icole: you were interested in programming tasks?
19:03:11 <nirik> welcome everyone. ;)
19:03:14 <icole> i was told abadger1999 might be able to point me in the direction on some coding tickets i could look at
19:03:20 <icole> nirik, yup
19:03:27 <abadger1999> icole: I sure can.
19:03:37 <abadger1999> icole: are you familiar with python?
19:03:40 <p3ll0n_> I was looking at tackling (#2762) - adding logic to fasClient to write keys only necessary as a good starter ticket
19:03:49 <nirik> securegates: were you more interested in the coding side of things? or sysadmin ?
19:04:01 <abadger1999> p3ll0n_: I can help get you started on that as well.
19:04:02 <securegates> i prefer sysadmin work
19:04:12 <icole> abadger1999, i have used it a bit, but i have mostly used java and now ruby
19:04:13 <nirik> p3ll0n_: excellent.
19:04:16 <securegates> but i can work with php python etc..
19:04:18 <abadger1999> <nod>
19:04:34 <p3ll0n_> abadger1999: Thanks, I would appreciate that.
19:04:44 <icole> abadger1999, interested in getting more python chops though
19:04:54 <nirik> securegates: see me after the meeting over in #fedora-admin and I can see about getting you in the apprentice group to look around.
19:05:10 <abadger1999> icole: Sounds good.
19:05:10 <nirik> thesharp: welcome. ;) it's late your time I think...
19:05:17 <securegates> ok! thanks!
19:05:29 <thesharp> nirik: not so. and i just had a lovely dinner. :)
19:05:40 <abadger1999> icole, p3ll0n_: If you want to talk to me in #fedora-admin after the meeting we'll see about getting you everything you need to get started.
19:06:02 <icole> abadger1999, sounds awesome thanks
19:06:30 <nirik> nice to see lots of new nicks. ;)
19:06:35 <pingou> +1
19:06:41 <p3ll0n_> abadger1999: sounds great!
19:06:43 <nirik> any other questions or feedback from new folks before we move on?
19:07:18 * nirik moved on then...
19:07:22 <nirik> #topic Ibiblio01 status
19:07:32 <nirik> Just a quick note on ibiblio01.
19:07:42 <nirik> we need to get torrent01 moved off it and then we can reinstall it. ;)
19:07:51 <nirik> hopefully that will happen in the next few weeks.
19:08:14 <nirik> #topic Upcoming Tasks/Items
19:08:15 <skvidal> nirik: I was hoping to harass herlo about the seed
19:08:26 <skvidal> nirik: but other things intruded yesterday
19:08:32 <nirik> yeah. Thats how it goes. ;(
19:09:03 * dgilmore has travel to phx booked
19:09:06 <nirik> if nothing else we can harrass herlo at fudcon. ;)
19:09:15 <nirik> #info 2012-01-10 - drop inactive maintainers from pkgdb acls.
19:09:15 <nirik> #info 2012-01-10 - drop inactive fi-apprentice folks
19:09:15 <nirik> #info 2012-01-13 to 2012-01-15 - FUDCON blacksberg
19:09:15 <nirik> #info 2012-02-31 - fas 0.8.11 final release.
19:09:15 <nirik> #info 2012-02-14 to 2012-02-28 - F17 Alpha Freeze
19:09:15 <nirik> #info 2011-04-03 - gitweb-cache removal day.
19:09:25 <nirik> dgilmore: cool. :) Whats the schedule like?
19:10:11 <dgilmore> nirik: i get in at 1:00pm jan 31 and will be there till friday late
19:10:12 <pingou> nirik: should we announce item #1 ?
19:10:21 <pingou> it's in 5 days
19:10:28 <dgilmore> nirik: im going to drive to tucson friday night and visit a friend
19:10:32 <nirik> pingou: yeah, was about to ask that. Also, we might want to generate a list before hand.
19:10:48 <dgilmore> nirik: so i have a little extra flexibility
19:10:56 <pingou> nirik: +1
19:11:20 <nirik> abadger1999: could you generate a list of inactive matainers and packages that wll loose owners?
19:11:35 <abadger1999> nirik: yep.
19:12:30 <abadger1999> nirik: Do you know the ticket # for that?  (I'll attach results there)
19:12:48 <nirik> dgilmore: how should we generate a list of things needing done for you? ;) just email? or should we do a ticket to keep track?
19:13:04 <nirik> .ticket 3046
19:13:05 <zodbot> nirik: #3046 (Password and ssh key reset) – Fedora Infrastructure - https://fedorahosted.org/fedora-infrastructure/ticket/3046
19:13:27 <dgilmore> nirik: i guess a trac ticket
19:13:40 <nirik> dgilmore: ok. Can whip one up with the items I know of.
19:14:19 <nirik> any other upcoming tasks folks would like to talk about or schedule?
19:14:30 <nirik> Oh, I am going to look at re-installing bodhost01 later today.
19:14:39 <nirik> and then telia01 tomorrow or monday.
19:15:19 <smooge> I am going to reinstall xen03 as a temp box
19:15:43 <nirik> ok.
19:16:02 <nirik> that leaves the list of rhel5 boxes diminishing. ;)
19:16:31 <nirik> next block of them after this would be bxen04 and it's guests in rel-eng land.
19:17:11 <smooge> xen04 is the interesting one
19:17:26 <nirik> and yeah, xen04 is left on the non rel-eng side.
19:17:34 <nirik> I think we will look at that after fudcon.
19:17:40 <smooge> it has bapp01 and app01 which are fun
19:17:53 <nirik> yeah...
19:18:11 <nirik> ok, moving along...
19:18:14 <nirik> #topic Meeting next week?
19:18:24 <nirik> I'm going to be traveling to fudcon next thursday...
19:18:27 <skvidal> next week I will likely be travelling
19:18:28 <skvidal> yah
19:18:40 <nirik> if someone else wants to run a meeting they could... or we could just skip.
19:18:41 <skvidal> I suspect a lot of folks in here will
19:19:05 <albutler_> see ya when you come back
19:19:10 <smooge> I will be travelling on thursday
19:19:42 * abadger1999 will hopefully have arrived but may not have internet then.
19:20:27 <nirik> ok, so lets just cancel?
19:20:36 <abadger1999> yeah
19:20:50 <pingou> there s always -admin for questions
19:20:55 * nirik nods.
19:21:10 <nirik> #agreed no meeting next week.
19:21:18 <nirik> #topic Fudcon plans
19:21:35 <nirik> so, shall we discuss fudcon plans?
19:21:45 <nirik> I signed up to do 3 workshops.
19:22:01 <pingou> \ó/
19:22:16 <nirik> well, 2 hackfests and 1 workshop... if it makes a difference.
19:22:19 <nirik> Fedora Infrastructure: Revamping our staging server setup, then implemeting it
19:22:28 <nirik> Fedora Infrastructure: 2 factor authentication brainstorming
19:22:34 <nirik> Fedora Infrastructure: Getting started/apprentices/Getting involved
19:23:07 <nirik> abadger1999 had 3 as well.
19:23:11 <pingou> nirik: are there plan to share this on irc at the same time ?
19:23:11 <abadger1999> Yeah.
19:23:18 <nirik> Any other ones we really want to work on?
19:23:26 <nirik> pingou: hopefully yeah.
19:23:37 <nirik> it's sometimes difficult to transcribe in real time tho
19:23:38 <pingou> nirik: cool :)
19:23:50 <abadger1999> I may cancel the python one -- I need to keep an EasyFix around long enough to have a coding problem to work on ;-)
19:24:10 <nirik> another thing I thought I would mention...
19:24:23 <nirik> last years fudcon, we made: https://fedoraproject.org/wiki/Infrastructure_Cleanup_Tasks_2011
19:24:34 <pingou> abadger1999: oh I break something if you need :)
19:24:35 <nirik> some of which we did do, some of which we didn't get to.
19:24:40 <abadger1999> :-)
19:24:50 <skvidal> nirik: indeed
19:24:56 <nirik> I'd like to make a similar page for 2012... perhaps make it Infrastructure_Goals_2012
19:24:56 <pingou> "Write automated tests using TG2's test framework"!
19:25:17 <nirik> and we can work on that in a hallway track. ;)
19:25:49 <pingou> nirik: what might be nice it to 'check' those which have been done
19:26:05 <nirik> pingou: done ones should be on the bottom section...
19:26:23 <pingou> ah, there was quite some ambitions :)
19:26:25 <skvidal> pingou: see 'Done items'
19:26:37 <skvidal> some of the stuff was deemed 'not really workable'
19:26:39 <skvidal> but never removed
19:26:48 <skvidal> the items related to glusterfs, for example
19:27:16 <nirik> yeah.
19:27:19 <skvidal> all the cloud stuff has met payment issues
19:27:26 <abadger1999> :-(
19:27:50 <nirik> so, any other fudcon planning we should do?
19:28:34 <nirik> I think we should be conservative on any changes we make next wed and thursday... since so many of us will be traveling. ;)
19:28:37 <skvidal> nirik: do you want to breing a bunch of yubikeys?
19:28:59 <nirik> yeah, I was planning on bringing a pile, and at least give a spare to all the mainers...
19:29:13 <nirik> and possibly if we can work out 2fa with them give them to other sysadmin* folks.
19:29:22 <nirik> I think I have around 30ish.
19:29:55 <pingou> that's a good number
19:30:24 <nirik> and hopefully we will pick up some more this year, so we could possibly cover sysadmin folks that have sudo or something. we will see.
19:31:09 <nirik> in any case I will bring them and we can decide how to distribute. ;)
19:31:21 <nirik> anything else on fudcon? or shall we move on?
19:31:47 <nirik> #topic Open Floor
19:31:57 <nirik> anyone have items for open floor? questions? ideas?
19:33:19 * nirik listens to crickets chirp
19:33:19 <skvidal> nothing leaps to my mind
19:33:40 <nirik> ok, thanks for coming everyone. See (some) of you folks next week. ;)
19:33:43 <nirik> #endmeeting