cloud_sig
LOGS
19:01:01 <rbergeron> #startmeeting Cloud SIG
19:01:01 <zodbot> Meeting started Fri Dec 16 19:01:01 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:08 <smooge> already?
19:01:17 <rbergeron> #meetingname Cloud SIG
19:01:17 <zodbot> The meeting name has been set to 'cloud_sig'
19:01:27 <rbergeron> #topic Who's Cloudy?
19:01:32 <rbergeron> #chair gholms
19:01:32 <zodbot> Current chairs: gholms rbergeron
19:01:34 <rbergeron> HI SMOOGE
19:02:21 * jforbes is here
19:02:23 * spstarr is here
19:02:25 <mgoldmann_> lalala
19:02:31 * kkeithley is here
19:02:34 <rbergeron> hey mgoldmann_ :)
19:02:39 * rbergeron didn't realize you were still about today
19:02:47 * mgoldmann_ is here with his new laptop
19:02:53 <rbergeron> mgoldmann_: ooh, what did you wind up getting
19:03:09 <mgoldmann_> drinking beer, configuring fedora, usual evening
19:03:41 <rbergeron> excellent
19:03:51 <rbergeron> :)
19:03:57 <rbergeron> #topic OpenNebula
19:04:04 <rbergeron> spstarr: take it away, sir :)
19:04:29 <spstarr> rbergeron: I'd like to see who can help out with Rubygem stuff for OpenNebula
19:04:41 <spstarr> and other items the main developers are in Spain (not on right now)
19:05:16 <rbergeron> yarghhh. as in making gems or just reviewing?
19:05:16 <spstarr> We have a wiki page for what needs to get done. I have all the rubygems packaged but they need to be converted to RSpec 2 support for Fedora 17 will be using Ruby 1.9.3 it seems.
19:05:37 <rbergeron> spstarr: can you link the pages into the meeting notes real quicklike?
19:05:37 <spstarr> reviewing and porting there's a lot of them but I've done the packaging already so it's tweaking
19:05:40 <rbergeron> #chair spstarr
19:05:40 <zodbot> Current chairs: gholms rbergeron spstarr
19:06:04 <spstarr> https://fedoraproject.org/wiki/Features/OpenNebula
19:06:25 <spstarr> we touched on this previously in
19:06:27 <spstarr> http://meetbot.fedoraproject.org/fedora-meeting/2011-09-02/cloud_sig,_where_the_mustard_indicates_awesome.2011-09-02-18.59.html
19:06:53 <spstarr> rbergeron: there was an action item for you to ask the RubySIG folks to update the packaging guidelines so we'll know what they want
19:07:31 <dgilmore> hola rbergeron
19:07:40 <rbergeron> heya dgilmore.
19:07:42 <spstarr> I will be updating the wiki now that I'm on vacation and will be focusing on all efforts with the OpenNebula team on getting the required changes in for Fedora 17
19:07:50 <rbergeron> spstarr: well, i forget things
19:07:53 <spstarr> ;)
19:08:24 <spstarr> they developers have a channel on freenode in #opennebula as well
19:08:28 <rbergeron> spstarr: i mean, i'm not exactly ruby friendly - it might be easier to actually have you ask them to update things since ... you know what you're looking for, and i would pretty much be just on a witch hunt, since i'm not actually capable of doing those fancy technical things
19:08:28 <spstarr> sorry, the
19:08:42 <rbergeron> i'm not sure what all needs to be updated?
19:09:04 <spstarr> I will ask Vit to publish the changes to the Ruby Packaging guidelines then
19:09:05 * rbergeron wonders if anyone here is also from rubysigland
19:09:58 * mgoldmann_ just lurks at the SIG, but he doesn't consider himself as part of it :)
19:10:01 * rbergeron isn't sure if the ruby folks can just update packaging guidelines either or if they need to go through the packaging committee (/me looks at maybe spot or toshio for guidance here)
19:10:22 <abadger1999> through the packaging committee
19:10:34 <abadger1999> what needs changing?
19:10:38 <spstarr> can we have an action for that?
19:10:54 <rbergeron> spstarr: what needs changing?
19:11:03 <rbergeron> i'm not clear on what needs changing or updating
19:11:35 <spstarr> they are removing the ruby-rubygem sub package, RSPec 2.x testing standards and im not sure what else, but there is probably some more changes I think.
19:11:59 <spstarr> Vít Ondruch is the Ruby SIG lead
19:12:15 <spstarr> here's a recent email thread
19:12:17 <spstarr> "I have uploaded updated version of Ruby 1.9.3 packages into my testing
19:12:17 <spstarr> repository. They are probably very close to the shape of Ruby I'd like
19:12:17 <spstarr> to see in future Fedoras. The main changes are"
19:12:35 <abadger1999> ah -- is this needed as part of the upgrade to ruby-1.9?
19:12:38 <spstarr> .. they are preparing to move to a new version and this is going to to effect all rubygems
19:12:39 <spstarr> yes
19:12:50 <rbergeron> so we need them to decide if they are committing to a new version
19:12:52 <abadger1999> They'll need to get whatever changes they need to the fpc
19:12:53 <rbergeron> before you move forward?
19:13:00 <abadger1999> but they haven't done anything yet.
19:13:20 <spstarr> rbergeron: yes more or less, because my packages as they are now would be 'ok'
19:13:29 <abadger1999> But they haven't talked to us yet.
19:13:31 <spstarr> aside from any additional reviews needed
19:14:26 <rbergeron> well, and if it affects all rubygems, I'd expect that they would be filing a feature for it as well
19:14:40 <spstarr> I have 2 rubygems that have recently been approved by Vit and others rubygem-addressable and rubygem-idn which will be pushed into git this weekend
19:15:01 <spstarr> those are dependencies for other Fedora feature
19:15:38 * rbergeron can't believe we have nobody else here from rubysigland
19:16:39 <spstarr> here is a list of them all: opennebula, rubygem-addressable, rubygem-data_mapper, rubygem-data_objects, rubygem-dm-aggregates, rubygem-dm-constraints, rubygem-dm-core, rubygem-dm-do-adapter, rubygem-dm-migrations, rubygem-dm-mysql-adapter, rubygem-dm-serializer, rubygem-dm-sqlite-adapter, rubygem-dm-timestamps, rubygem-dm-transactions
19:16:50 <abadger1999> https://fedoraproject.org/wiki/Features/Ruby_1.9.3#Scope  "Drafts of new packaging guidelines will have to be proposed to FPSCo. No such drafts currently exist. "  :-(
19:16:51 <rbergeron> spstarr: so i guess if you really want to wait on the ruby sig deciding to *do something* before you push packages, that's your call.
19:17:07 <spstarr> rubygem-dm-types, rubygem-dm-validations, rubygem-do_mysql, rubygem-do_sqlite3, rubygem-extlib - 3rd party being done by someone else
19:17:19 <abadger1999> I think you probably want to go ahead and submit and review packages as if we aren't going to update to 1.9.x
19:17:29 <spstarr> rubygem-idn, rubygem-stringex, rubygem-xmlparser
19:17:33 <spstarr> that's all of them
19:17:34 <rbergeron> bear in mind that if it's affecting all rubygems, it's probably going to need to be a feature, in addition to going through FPC
19:17:45 <rbergeron> abadger1999: that's kind of my thinking
19:17:46 <abadger1999> what gets approved now can always be updated to the new guidelines later.
19:18:03 <spstarr> abadger1999: i can do that a lot of these are sub packages of rubygem-dm and rubygem-dm-do
19:18:04 <rbergeron> spstarr: since we're pretty much nearly at holiday break here, which means nothing will be getting done for basically a few weeks.
19:18:17 <rbergeron> if you're going to wait on them, you'll be hosing yourself.
19:18:24 <abadger1999> <nod>
19:19:05 <spstarr> then I will begin to push these into package review
19:19:07 <rbergeron> spstarr: I'd gently poke them asking wtf, though, but I would just go ahead and package as though they're not going to update.
19:19:18 <rbergeron> because it's entirely possible that they may not. :)
19:19:38 <rbergeron> spstarr: sound good? anything else?
19:19:46 <spstarr> see: https://bugzilla.redhat.com/show_bug.cgi?id=728088 and https://bugzilla.redhat.com/show_bug.cgi?id=588428 for comments in bugs on rubygem packaging
19:19:50 <spstarr> thats all.
19:20:11 <rbergeron> spstarr: thanks :)
19:20:16 <spstarr> :)
19:20:20 <rbergeron> #topic EC2
19:20:38 <rbergeron> gholms: you were mentioning a still-open-occasionally-bothering-people-bug earlier, want to run that by everyone real quicklike?
19:20:48 <rbergeron> i know you're double-tag-teaming meetings with gregdek and obino :)
19:20:49 <jforbes> So, I went to delist the F14 EC2 images as we had agreed
19:20:58 <rbergeron> jforbes: yes
19:21:13 <jforbes> It seems that they have been deleted, I am guessing dgilmore did it when he was adding the recent F16 images for the new zone
19:21:22 <obino> :)
19:21:26 <rbergeron> deleted or delisted, or are those the same meaning
19:21:31 <obino> is the RNG problem?
19:21:33 <jforbes> Deleted, and not the same meaning
19:21:39 <rbergeron> dgilmore: pingy
19:21:48 <rbergeron> jforbes: what does that do for people currently using them
19:21:50 * gregdek looks up.
19:21:51 <rbergeron> anything?
19:21:56 <jforbes> rbergeron: they are gone
19:21:59 <gregdek> Ah.
19:22:04 <dgilmore> rbergeron: pongy amiga
19:22:12 * rbergeron puts a santa hat on gregdek
19:22:23 <dgilmore> rbergeron: i deregisted the f14 amis
19:22:30 <rbergeron> dgilmore: read up to jforbes' comment re: deleting ec2 images for F14?
19:22:31 <jforbes> rbergeron: currently booted images will continue to function, if they are rebooted they wont come back.  that said, delisting them would have the same effect, just a bit harder to undo
19:22:51 <jforbes> dgilmore: we had agreed to not deregister them, only to make them private
19:23:03 <dgilmore> jforbes: wasnt communicated to me
19:23:30 <jforbes> dgilmore: I was supposed to do it, but it was discussed in this meeting a couple of weeks ago
19:23:31 * rbergeron notes that maybe we should just make a policy for the process and write it down somewhere so we know for the future
19:23:55 <jforbes> not a huge deal.  It just means if we had to back track, they would have other IDs now, which means there is no point at all really
19:24:22 <dgilmore> jforbes: there is no point in letting people launch new amis based on a eol release ever
19:24:32 <dgilmore> since the os is no longer supported
19:24:36 <jforbes> rbergeron: this will only have to be done again in this way for F15 and F16, policy will change for F17 since we will have a warning mechanism
19:25:29 <mgoldmann_> dgilmore: I'm not sure I agree with this statement
19:25:41 <jforbes> dgilmore: We agreed, but since there was no major communication over that when the images went out, and we have no way of notifying those who are not involved in fedora (casual EC2 users who chose the Fedora image on a whim), we decided that we would make sure we could undo the shutdown and give a migration period if people complained
19:25:48 <dgilmore> mgoldmann_: feel free to not agree, but its true
19:25:52 <rbergeron> dgilmore: it's not necessarily launching new ones, isn't it also if they have to reboot them as well?
19:26:10 <dgilmore> rbergeron: no
19:26:26 <dgilmore> rbergeron: if the reboot thier existing instance is still there
19:26:34 <jforbes> dgilmore: It is even worse for F14 because those images were S3 only, so people using them just can't anymore.  At least with F15 and F16 they have EBS volumes and can use them until they migrate away
19:26:39 <dgilmore> if they shut it down completely and dont save it its gone
19:27:13 <jforbes> dgilmore: there were no EBS images for F15
19:27:16 <jforbes> err F14
19:27:29 <johnmark> dgilmore: yikes. if that happened to me and nobody told me, I'd be *pissed*
19:27:59 <dgilmore> johnmark: if you shut a instance down and dont save it its gone
19:28:03 <dgilmore> johnmark: thats how ec2 works
19:28:07 <jforbes> For F17 we are going to add a piece to cloud init that checks current supported versions and gives a warning when the image is no longer in a supported state with a reference to the supported images
19:28:36 <dgilmore> jforbes: hows that supposed to be communicated to the user?
19:28:53 <johnmark> dgilmore: right, but when I use an AMI, I sort of assume I can always go back to it later. Bad assumption, I know
19:29:23 <jforbes> dgilmore: still working that out, there are a number of options there
19:29:54 <rbergeron> okay, so, is there anything we can do *today* or need to do? including:
19:30:04 <rbergeron> *update any pages saying F14 is byebye
19:30:11 <rbergeron> have we killed off F8? or not really
19:30:36 <dgilmore> rbergeron: the fc6 f8 etc images are put up by amazon
19:30:38 <jforbes> rbergeron: there is nothing we can do today, F14 is no longer on the supported ami list
19:30:42 <dgilmore> and ive asked them to remove them
19:30:50 <rbergeron> oh right
19:31:05 <rbergeron> dgilmore: i forgot about that detail
19:31:09 <rbergeron> jforbes: okay
19:31:19 <rbergeron> i mean can we document it anywhere or that's just htat
19:31:25 <jforbes> rbergeron: this is exactly what it would have looked like had we done it the other way, the only difference is right now we can't backtrack if there is public outcry, we just end up with people with a grudge against Fedora
19:31:44 <rbergeron> jforbes: right
19:31:45 <rbergeron> okay
19:31:47 <rbergeron> so
19:32:03 <rbergeron> can we document how we'd like to do this next time, and who and when, so we all know :)
19:32:21 * rbergeron uses the royal we and hates being that guy, since she's not the one doing it
19:32:32 <jforbes> rbergeron: sure, though that was the point of the meeting when we discussed it, it was in the notes
19:33:25 <rbergeron> alrighty, well, i can go sift through the notes and add it to rel-eng process somewhere I guess?
19:33:37 <rbergeron> or dgilmore can if he's more comfortable noting it himself?
19:33:49 <jforbes> process will change for F17 and later
19:33:55 <rbergeron> yup
19:33:59 <dgilmore> rbergeron: well im not comfortable doing anything but de-registering unsupported bits
19:34:41 <jforbes> dgilmore: if you make them non public it has the same effect, except that you can undo it if necessary.  Keep them registered and private for a period of time
19:34:58 <dgilmore> jforbes: but im not comfortable undoing it
19:35:18 <dgilmore> there is a reason i am only ok with removing whats not supported
19:35:18 <jforbes> dgilmore: I thought you were in on that discussion, I know jsmith and rbergeron were, as well as a few others
19:35:25 <dgilmore> jforbes: i was not
19:35:30 <jforbes> dgilmore: well, releng had nothing to do with F14 or F15 images anyway
19:36:12 <dgilmore> jforbes: then i guess i should take down f15 also, so that the only thing from the official fedora account is the official fedora bits
19:37:07 <jforbes> dgilmore: they were approved as official fedora bits when releng couldnt get them done, I can forward you the minutes from the Fedora board meeting on the F15 images
19:37:26 <dgilmore> jforbes: approved by whom?
19:37:33 <jforbes> dgilmore: The fedora board
19:37:45 <dgilmore> jforbes: id like to see that email
19:38:00 <jforbes> dgilmore: you were in the meeting, but I will be happy to forward it to you
19:38:30 <dgilmore> jforbes: anyways im not trying to be difficult. but we shouldnt be allowing people to run things with potential secuity flaws
19:38:46 <mgoldmann_> dgilmore: isn't their choice?
19:39:06 <rbergeron> dgilmore: the point was not to enable them to do that, the point was that we have no way to inform them on these older AMIs
19:39:16 <rbergeron> and we wanted to at least have a failsafe in case 200 thousand people came screaming at us
19:39:18 <dgilmore> mgoldmann_: it is, but we need to do everything to not allow it
19:39:19 <mgoldmann_> we're not forcing them to do this, we say: there you have never version which is supportes and should be used
19:39:21 <rbergeron> so we could avoid drama.
19:39:31 <rbergeron> that's all
19:39:42 <rbergeron> not trying to extend it for them, just... basically a CYA for us
19:39:42 <jforbes> dgilmore: in the end, we agree to that point, the issue was, since we have users who are in no other way involved with Fedora, we wanted an option to be able to back out with severe warning if necessary
19:39:52 <jforbes> dgilmore: it was a fail safe is all, an
19:39:55 <rbergeron> because the last thing we want is some horrible public spectacle
19:40:08 <mgoldmann_> I was not part of any meeting talking about this but I would be against removing/making private
19:40:20 <mgoldmann_> it's like: let's remove all ISOs from mirrors
19:40:38 <mgoldmann_> not all - old Fedora versions of course :)
19:40:50 <jforbes> dgilmore: and with other installations, people are more than welcome to continue running after EOL (I still have an F14 box here I haven't upgraded yet, I will do so when I get a chance)
19:41:05 <mgoldmann_> but hey, I'm just a small guy without vote :)
19:41:27 <dgilmore> jforbes: people can continue to run existing installations
19:41:41 <rbergeron> but they can't reboot them?
19:41:43 <jforbes> dgilmore: these are not EBS images, so not really
19:41:45 <gholms> A data point: Ubuntu images inform the user of outdatedness with /etc/motd messages.
19:41:59 <mgoldmann_> rbergeron: EC2 is specific, you can reboot
19:42:10 <jforbes> gholms: that was the plan with my changes to cloud init
19:42:58 * rbergeron sighs and moves to round up this topic
19:43:07 <rbergeron> I think we're about done here, are we not?
19:43:26 <rbergeron> on this topic anyway
19:43:30 * rbergeron shakes her jingle bells
19:43:50 * johnmark looks up
19:44:09 <rbergeron> going once, going twice.....
19:44:18 <smooge> done
19:44:19 <rbergeron> #topic Gluster-land
19:44:28 * rbergeron looks at johnmark, jdarcy, kkeithley, not necessarily in that order
19:44:30 <johnmark> ugh
19:44:33 <kkeithley> yes
19:44:34 <johnmark> I got nothin'
19:44:37 <rbergeron> :)
19:44:38 <mgoldmann_> rbergeron: https://bugzilla.redhat.com/show_bug.cgi?id=747692
19:44:40 <rbergeron> kkeithley: HI
19:44:47 <mgoldmann_> this is the link to the EC2 issue
19:45:03 <rbergeron> mgoldmann_: i'll come back to it :)
19:45:03 * gholms clicks
19:45:08 <rbergeron> gholms: you've seen it
19:45:14 <gholms> Ah, yes.  That bug.
19:46:05 <rbergeron> kkeithley: nothin? :)
19:46:12 <kkeithley> just EPEL6 builds of gluster and heka are in the fedora updates pipeline
19:46:41 <gholms> Yay!
19:46:43 <kkeithley> if anyone wants to give them some karma love, but not required
19:46:56 <johnmark> kkeithley: ooooh... cool
19:47:08 <rbergeron> #info EPEL6 builds of gluster and hekafs are in the fedora updates pipeline, karma is welcomed but not required :)
19:48:14 <rbergeron> kkeithley: thank you, sir :)
19:48:19 <rbergeron> #topic Back to this EC2 Bug
19:48:22 <kkeithley> de nada
19:48:27 <rbergeron> #link https://bugzilla.redhat.com/show_bug.cgi?id=747692
19:48:44 <rbergeron> So this is a bug that some people have hit, others have not, nobody can figure out how to reproduce.
19:49:21 <rbergeron> I think red_alert and verdurin are the ones who hvae.
19:49:24 <mgoldmann_> sounds like a fun
19:49:31 <rbergeron> mgoldmann_: yes, i have party hats
19:49:38 <gholms> If anyone encounters this bug the system and cloud-init logs would be useful.
19:49:38 <mgoldmann_> I personally haven't seen it
19:49:48 <gholms> So far everyone has posted only console output, which isn't very helpful.
19:50:04 <rbergeron> #info if anyone hits this bug the system and cloud-init logs would be useful, so far we only have console output
19:50:26 <mgoldmann_> if this is random, and the source (AMI) is the same I would thing that it relates to the hypervisor somehow
19:50:31 <mgoldmann_> think even!
19:51:03 <gholms> See the commentary in the bug.  If you need help getting the logs off your instance either read the EC2 primer or ask in #fedora-cloud.
19:51:50 <rbergeron> #info see bug commentary, if you need help getting logs off your instance either read the EC2 primer or ask in #fedora-cloud
19:52:02 <rbergeron> :) thanks gholms, mgoldmann_ ;)
19:52:07 <rbergeron> #topic Aeolus
19:52:13 * mgoldmann_ was just rambling
19:52:15 * rbergeron thought she saw an mmorsi wander in here
19:52:30 <mmorsi> rbergeron: howdy
19:52:46 <mmorsi> came to lurk but lets see
19:52:51 <rbergeron> mmorsi: how's aeolus-land going? :)
19:52:57 <mmorsi> aeolus is completely in fedora thats one biggie
19:52:59 <mmorsi> pretty good
19:52:59 * rbergeron wonders if you know anything about impending ruby-land-changes
19:53:19 <mmorsi> more features coming soon, include a much much simpler usage / installation scenario
19:53:29 <mmorsi> ah ruby-land
19:53:41 <mmorsi> well we're pushing towards ruby 1.9
19:53:49 <mmorsi> so be prepared (but hopefully not scared!)
19:54:07 <mmorsi> vit has been doing alot of work updating packages to comply w/ that and rspec 2
19:54:07 * gholms crosses his fingers
19:54:18 <mmorsi> tho if you maintain a package you might want to try it out against his testing repo
19:54:22 <mmorsi> one sec i'll get u a link
19:55:14 <rbergeron> mmorsi: there was some discussion earlier about if anyone was going to file changes with the packaging sig and/or file a feature since apparently it's going to require changes in all rubygems?
19:55:27 <mmorsi> here ya go http://lists.fedoraproject.org/pipermail/ruby-sig/2011-November/000693.html
19:55:29 * rbergeron wasn't sure if you were regularly attending rubysig meetings
19:55:54 <gholms> Is this like another mass-rebuild?  I'm not sure how stuff works in ruby-land.
19:55:59 <mmorsi> hrm not sure, i can ping vit re his thoughts on that and get back to you
19:56:01 <rbergeron> gholms: exactly, i'm not sure
19:56:12 <rbergeron> mmorsi: spstarr was kind of wondering for packaging opennebla
19:56:21 <mmorsi> i'm hoping it won't be too bad, as vit is doing alot of work w/ individual packages
19:56:24 <rbergeron> and was expecting packaging changes
19:56:30 <rbergeron> and guideline changes perhaps
19:56:31 <mmorsi> he's been pinging alot of maintainers individually
19:57:39 <mmorsi> ya put an action item down for me for that and i'll get back to you at the next cloud-sig mtg
19:57:55 <mmorsi> hrm what else
19:58:21 <rbergeron> #action mmorsi to investigate with ruby-sig/vit about (a) changes to packaging guidelines (b) feature filing (c) extent to which rubygems need repackaging/rebuilding/mass rebuilding?
19:58:27 <rbergeron> :)
19:58:29 <mmorsi> oh of course! how could i forget about snap! which is now in fedora https://admin.fedoraproject.org/pkgdb/acls/name/snap
19:58:39 <rbergeron> #info more features coming to aeolus soon, including a simpler usage/installation scenario
19:58:43 <mmorsi> so you can yum install snap
19:58:51 <mmorsi> and take snapshots of fedora systems on the cloud
19:58:54 <rbergeron> #info snap! is now in fedora http://lists.fedoraproject.org/pipermail/ruby-sig/2011-November/000693.html
19:59:01 <rbergeron> #info can take snapshots of fedora systems on the cloud
19:59:03 <mmorsi> and use those snapshots to migrate those instances to other cloud providers
19:59:05 <rbergeron> snapshots as in configuration?
19:59:09 <rbergeron> or... ahh
19:59:11 <mmorsi> rbergeron: well the idea is
19:59:24 <mmorsi> snapshot contains repos + packages + files outside the package system + service data
19:59:41 <mmorsi> only files track'd outside the package system are stored so snapshots are lightweight
19:59:47 <rbergeron> mmorsi: so... sort of like.. puppet manifest???? am i right there?
19:59:50 <mmorsi> and service data is collected using native tooling
20:00:06 <mmorsi> sorta, but puppet and chef are used to orchestrate systems from scratch
20:00:13 <mmorsi> snap is used to take a snapshot of an existing system
20:00:15 <gholms> Kernel?  Running state?
20:00:21 <mmorsi> so you have an instance running on the cloud
20:00:25 <mmorsi> you take a snapshot of it
20:00:30 <mmorsi> move that snapshot to another cloud
20:00:37 <mmorsi> no pre-orchestration needed
20:00:44 <mmorsi> gholms: it uses all the native tooling
20:00:52 <mmorsi> and has a very simple / pluggable interface
20:01:04 <mmorsi> so right now there are plugin for yum and apt-get repos and packages
20:01:14 <mmorsi> as well as services such as postgres, mysql, httpd, iis
20:01:19 <gholms> "The native tooling" is quite a broad term.  I will look at the code.  :)
20:01:20 <mmorsi> oh and windows support as well
20:01:25 <rbergeron> #info snapshots contain repos + packages + files outside the package system + service data
20:01:28 <mmorsi> https://github.com/movitto/snap
20:01:33 <rbergeron> mmorsi: is there a separate ... ah, yes
20:01:38 <rbergeron> #link https://github.com/movitto/snap
20:01:46 <rbergeron> mmorsi: sounds interesting, thanks for the update :)
20:01:53 <mmorsi> gholms: yes i made it as extesnible as possible
20:01:57 <mmorsi> no problem
20:02:09 <mmorsi> if there are any questions or anything along those lines just ping
20:02:11 <mgoldmann_> I like the idea :)
20:02:14 <mmorsi> i've been adding lots of features
20:02:27 <mmorsi> working on the ability to migrate snapshots between os's
20:02:34 <mmorsi> so you can take a snapshot of an ubuntu instance
20:02:43 <mmorsi> and convert it to a snapshot of a fedora instance
20:03:02 <rbergeron> YES
20:03:02 <mmorsi> (that feature is still being worked on tho, still has a ways togo)
20:03:07 <rbergeron> oh wait, did i say that out loud
20:03:09 <rbergeron> ;) lol
20:03:13 <mmorsi> but i have a proof of concept locally
20:03:16 * mmorsi needs to blog about it
20:03:19 <rbergeron> cool :) yes
20:03:19 <mmorsi> but oh the time
20:03:25 <mmorsi> i have two hackfests for fudcon
20:03:26 <rbergeron> you should make it an F17 feature too IMO
20:03:34 <mmorsi> one is going to be aeolus, and one is going to be snap
20:03:35 <gholms> Ah, I thought it was talking to the clouds directly.  Good idea to not worry about that.
20:03:44 <mmorsi> btw really looking forward to meeting alot of you there
20:03:54 <rbergeron> mmorsi: indeed :) do you have your room booked yet? :)
20:03:59 <mmorsi> gholms: nope this is a general system snapshotter
20:04:01 <mmorsi> rbergeron: ah shoot
20:04:05 <mmorsi> so many things going on
20:04:07 <mmorsi> forgot about that
20:04:11 <rbergeron> mmorsi: get it before it closes off :)
20:04:12 * mmorsi hopes they are not all booked
20:04:14 <mmorsi> k
20:04:16 <mmorsi> will do today
20:04:30 <mmorsi> well
20:04:37 <rbergeron> cool :)
20:04:42 <rbergeron> #topic Open Floor
20:04:45 <rbergeron> not to move along or anything
20:04:52 <rbergeron> but I have to eat and other things
20:04:52 <mmorsi> haha no worries
20:05:04 <mmorsi> mmm food
20:05:13 <rbergeron> yeah, nourishment
20:05:41 <mgoldmann_> I'm hungry, no food in fridge, beer just run out
20:05:53 <mgoldmann_> disaster
20:05:57 <rbergeron> yikes
20:06:04 <rbergeron> If nobody else has anything, i'll close out in a few
20:06:23 * rbergeron notes she is refraining from harassing cloudstack and eucalyptus friends today, in the spirit of the holidays and stuff
20:06:28 <gholms> mgoldmann_: Time to go out and grab a pizza?
20:07:01 <mgoldmann_> gholms: I haven't had a pizza since a long time, sounds good :)
20:07:08 <gholms> :D
20:07:21 <gholms> Thanks, everyone!
20:08:16 <rbergeron> PIZZA
20:08:17 <rbergeron> mmm
20:08:21 <rbergeron> thanks guys.
20:08:24 <rbergeron> I think we'll be off next week.
20:08:40 <rbergeron> Unless you want to join me for Drunken Cloud SIG Holiday Party online
20:08:51 <mgoldmann_> Dunk Kitchen?
20:08:55 <rbergeron> Right.
20:08:55 <mgoldmann_> Drunk*
20:08:57 <rbergeron> EXACTLY
20:09:02 <rbergeron> i love that girl
20:09:04 <mgoldmann_> yep
20:09:15 <rbergeron> #info No meeting next week; Online Cloud SIG Party optional :)
20:09:22 <rbergeron> Thanks, folks :)
20:09:24 <rbergeron> #endmeeting