fesco
LOGS
18:01:03 <ajax> #startmeeting FESCO (2011-12-05)
18:01:03 <zodbot> Meeting started Mon Dec  5 18:01:03 2011 UTC.  The chair is ajax. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:01:11 <ajax> #meetingname fesco
18:01:11 <zodbot> The meeting name has been set to 'fesco'
18:01:11 <ajax> #chair notting nirik ajax cwickert mjg59 mmaslano t8m pjones sgallagh
18:01:11 <zodbot> Current chairs: ajax cwickert mjg59 mmaslano nirik notting pjones sgallagh t8m
18:01:11 <ajax> #topic init process
18:01:16 * notting is here
18:01:19 <mjg59> Here
18:01:19 * sgallagh is here
18:01:22 <mmaslano> hi
18:01:24 <t8m> Hello
18:01:28 * pjones is here
18:01:36 * nirik is here
18:01:37 * cwickert is here
18:01:55 <ajax> hey, that's all of us!
18:01:59 <cwickert> is this the last meeting of this FESCo?
18:02:16 <ajax> i believe so.  the current elections end today.
18:02:21 <nirik> yep.
18:02:52 <sgallagh> So... last chance to make bad decisions that the new guys have to deal with :)
18:03:13 <notting> all in favor of switching to netbsd?
18:03:26 <pjones> sgallagh: we have a(n un)fortunate amount of continuity to avoid that happening
18:03:31 <ajax> notting: no way, man.  plan9 is the future.
18:03:39 <ajax> let's dive in then
18:03:40 <ajax> #topic #689 Consider including bash-completion package by default (base,
18:03:40 <ajax> not core)
18:03:40 <ajax> .fesco 689
18:03:41 <zodbot> ajax: #689 (Consider including bash-completion package by default (base, not core)) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/689
18:04:14 <nirik> we already decided this, and It seems it was in fact already done before then.
18:04:27 <nirik> proposal: close?
18:04:28 <ajax> yeah, this looks like it's just a bugzilla issue at this point.
18:04:36 <sgallagh> +1 to close
18:04:36 <t8m> yeah
18:04:41 <t8m> +1 to close
18:04:49 <notting> please do close.
18:04:53 <mmaslano> +1
18:05:08 <cwickert> t+1
18:05:14 <ajax> #action No action needed on bash-completion ticket, follow up in bugzilla with any remaining issues.
18:05:18 <ajax> er
18:05:27 <ajax> what's the undo verb?
18:05:32 <nirik> #undo
18:05:32 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x2bb74a10>
18:05:38 <ajax> thx
18:05:43 <ajax> #agreed No action needed on bash-completion ticket, follow up in bugzilla with any remaining issues.
18:06:08 <ajax> #topic #699 Proposal to remove the package "tzdata" from Critical Path
18:06:08 <ajax> .fesco 699
18:06:10 <zodbot> ajax: #699 (Proposal to remove the package "tzdata" from Critical Path) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/699
18:06:18 <pjones> ajax: inferno surely
18:06:29 <ajax> notting: still on you?
18:06:40 <notting> yup. not enough round tuits last week, should get to it this week
18:07:18 <ajax> notting: can you close out the ticket when you do so>
18:07:40 <notting> sure
18:08:08 <ajax> #action notting to follow up on pkgdb changes
18:08:11 <ajax> thanks
18:08:43 <ajax> i'm going to remove the 'meeting' keyword from #699; please re-add it if it needs to come up in the meeting again
18:08:53 <ajax> new business!
18:09:02 <ajax> #topic #711 F17 Feature: virtio-scsi - http://fedoraproject.org/wiki/Features/virtio-scsi
18:09:06 <ajax> .fesco 711
18:09:07 <zodbot> ajax: #711 (F17 Feature: virtio-scsi - http://fedoraproject.org/wiki/Features/virtio-scsi) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/711
18:09:14 <mjg59> +1
18:09:29 <nirik> cool. +1
18:09:36 <t8m> +1
18:09:38 <mmaslano> +1
18:09:42 <ajax> +1
18:09:52 <sgallagh> +1
18:09:58 <ajax> #agreed virtio-scsi feature is approved
18:10:12 <notting> sure, +1
18:10:18 <ajax> #topic #712 need update kBuild on F15
18:10:19 <ajax> .fesco 712
18:10:20 <zodbot> ajax: #712 (need update kBuild on F15) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/712
18:10:30 <mjg59> No response from the maintainer on this?
18:10:35 <nirik> so, this looks like a maintainer thats non responsive...
18:10:51 <notting> oh, actual kBuild package, not the kernel system
18:11:24 <nirik> so, we could try and ping the maintainer some more, and failing that have some interested provenpackager fix this particular issue?
18:11:33 <pjones> (+1 for previous.  you look away for a second and things fly by...)
18:11:48 <notting> who build the update for f16?
18:12:29 <ajax> notting: lkundrak.  back in september though.
18:13:49 <notting> nothing requires kbuild in fedora that i can see
18:13:57 <notting> so, i'd be fine with a pp pushing the update through
18:14:09 <notting> but someone should try and contact lkundrak some more first
18:14:15 <t8m> notting, +1
18:14:19 * nirik nods
18:14:21 <mjg59> Yeah, I'd like to see some more prodding of the maintainer
18:14:26 <mmaslano> notting: he was on list of people who didn't update FAS ;-)
18:14:27 <ajax> he tends to fall off the map from time to time iirc
18:14:38 <mjg59> The bug title's not very compelling in itself
18:14:44 <mjg59> So I can imagine it falling down someone's list
18:15:24 <notting> well, if its only use is to build vbox
18:15:29 <notting> and it's not building vbox
18:15:33 <mjg59> notting: It could be used by other out of tree stuff
18:15:45 <notting> mjg59: just going by the description in the spec file
18:16:28 <mjg59> Yeah, it's not a huge risk
18:16:40 <ajax> so, proposal anyone?
18:17:00 <t8m> I've added lkundrak to cc on the ticket
18:17:27 <notting> proposal: add lkundrak to ticket, ping him there. next week if no response, have a provenpackager do it
18:17:35 <mjg59> +1
18:17:36 <ajax> +1
18:17:42 <nirik> sure.
18:17:56 <pingou> http://fpaste.org/F0wh/ lkundrak recent activity
18:18:24 <sgallagh> +1
18:18:32 <pjones> sure, +1
18:18:33 <mmaslano> +1
18:18:38 <ajax> #agreed attempt to follow up with lkundrak on the ticket; if no response by next week have a provenpackager do it
18:19:05 <ajax> #topic #713 F17 Feature: KDE Plasma Dependency Generation and PackageKit Integration - http://fedoraproject.org/wiki/Features/Plasma_PackageKit_Integration
18:19:07 <ajax> .fesco 713
18:19:09 <zodbot> ajax: #713 (F17 Feature: KDE Plasma Dependency Generation and PackageKit Integration - http://fedoraproject.org/wiki/Features/Plasma_PackageKit_Integration) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/713
18:19:28 <mjg59> +1
18:19:35 <sgallagh> +1
18:19:42 <ajax> +1
18:19:50 <mmaslano> +1
18:19:50 <notting> +1
18:19:54 <t8m> +1
18:20:00 <ajax> #agreed plasma packagekit integration feature is approved
18:20:08 <nirik> sure, +1, sorry
18:20:22 <ajax> #topic FES tickets
18:20:23 <ajax> #topic #713 F17 Feature: KDE Plasma Dependency Generation and PackageKit Integration - http://fedoraproject.org/wiki/Features/Plasma_PackageKit_Integration
18:20:28 <ajax> argh, misfire
18:20:36 <ajax> #topic FES tickets
18:20:40 <nirik> nothing new on FES.
18:20:47 <ajax> https://fedorahosted.org/fedora-engineering-services/report/6
18:21:24 <ajax> same as last week then.
18:21:28 <mmaslano> I had a request on this one https://fedorahosted.org/fedora-infrastructure/ticket/2246
18:21:42 <mmaslano> could we do something for progress on it?
18:22:41 <nirik> abadger1999: ^ would we be able to get that into the next fas release?
18:22:44 <notting> looks like it's being wored
18:22:46 <notting> worked
18:23:21 <ajax> #topic open floor
18:23:27 <ajax> (since we're transitioning into that anyway)
18:23:49 * cwickert wonders if he is still connected
18:23:52 * abadger1999 reads ticket
18:23:59 <mjg59> cwickert: You just reconnected
18:24:32 <cwickert> too bad, I nearly missed most of my last FESCo meeting :(
18:24:46 <pingou> abadger1999: audio captcha
18:24:52 <abadger1999> mmaslano, nirik: Yeah, pingou has code that I'm willing to ship.  It uses a separate process to generate the audio file but hopefully this won't be so used that it causes an issue for the server.
18:25:04 <mmaslano> abadger1999: great
18:25:20 <abadger1999> mmaslano, nirik: This weekend I was tentatively thinking of making the next fas release in mid january.
18:25:28 <mmaslano> abadger1999: thank you
18:25:29 <nirik> ok
18:25:47 <ajax> i have one technical item for open floor
18:26:10 <ajax> as i just noted on devel@ there's still a fair pile of packages built against old libpng
18:26:19 * nirik would like to say thanks for everyone who served this cycle. Been a pleasure working with you all.
18:26:25 <notting> abadga er1999:  is it sufficiently behind a signup form that it can't be remotely DoSed?
18:26:29 * cwickert looks
18:26:37 * sgallagh seconds nirik's thank-you.
18:26:45 * notting thirds nirik and sgallagh
18:26:49 <ajax> i'm planning to fire a mass rebuild for them unless anyone has a compelling reason why i shouldn't
18:26:54 <pjones> ajax: do it.
18:26:59 <t8m> ajax, please do
18:27:00 <nirik> ajax: yeah, I'd be fine with a targeted mass rebuild on those... or perhaps we should see if there is going to be a mass rebuild down the road of everything?
18:27:13 <cwickert> ajax: what about the overlinking? afaik it's caused by libtool reordering the flags
18:27:33 <ajax> cwickert: it's not, really.
18:27:53 <ajax> that libtool reorders linker flags means you can't say -Wl,--as-needed
18:27:54 <cwickert> so all these packages really need to link against libpng?
18:28:03 <ajax> i didn't say that
18:28:12 <pjones> they at least /do/ link against libpng.
18:28:34 <abadger1999> notting: it's part of the signup process so it could be DOS'd.
18:28:56 <ajax> mostly it's a function of the .pc files for a given package, putting Requires: png in when not strictly needed
18:28:59 <abadger1999> otoh, any audio captcha is going to suffer from that to some extent.
18:29:01 <pjones> abadger1999: so it's worth making it a configurable thing so that we can turn it off in a hurry if we need to?
18:29:45 <ajax> i actually came up with a reasonable way of guessing whether a package is linked against libpng needlessly just from rpm metadata
18:29:54 <abadger1999> pjones: sure -- we can turn it off multiple other ways as well, though :-)
18:29:55 <ajax> i'll follow up with that after the rebuild
18:30:01 <ajax> #action ajax to mass-rebuild for libpng
18:30:11 <cwickert> +1
18:30:27 <ajax> anyone else?
18:30:40 <mmaslano> +1
18:30:55 <nirik> sure, go ahead
18:31:08 <cwickert> I'd like to thank all of you. It was a pleasure serving with you in FESCo.
18:31:30 <ajax> likewise.  thanks for making my last meeting short!
18:32:12 <ajax> i'll end the meeting in a minute if there's nothing else.
18:32:18 <mmaslano> ajax: thanks for chairing
18:32:24 <ajax> oh, wait
18:32:31 <t8m> Next week chair will be determined on next week?
18:32:32 <ajax> #topic next meeting's chair
18:32:34 <t8m> heh
18:32:42 <ajax> who'll be around still?
18:32:55 <notting> i'll do it
18:32:55 * cwickert not
18:33:07 <ajax> #action notting to chair next week's meeting
18:33:11 <ajax> notting: thanks
18:33:19 <ajax> resume your 60 second countdown
18:34:43 <ajax> #endmeeting