fesco
LOGS
17:00:21 <sgallagh> #startmeeting FESCO (2011-10-31)
17:00:21 <zodbot> Meeting started Mon Oct 31 17:00:21 2011 UTC.  The chair is sgallagh. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:21 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:28 <t8m> hello
17:00:31 <sgallagh> #meetingname fesco
17:00:31 <zodbot> The meeting name has been set to 'fesco'
17:00:41 <sgallagh> #chair notting nirik ajax cwickert mjg59 mmaslano t8m pjones sgallagh
17:00:41 <zodbot> Current chairs: ajax cwickert mjg59 mmaslano nirik notting pjones sgallagh t8m
17:00:41 <sgallagh> #topic init process
17:01:01 * notting is here
17:01:02 * nirik is here
17:01:04 <mjg59> Here
17:01:19 <mmaslano> hi
17:01:27 <pjones> likewise.
17:02:23 <sgallagh> I'd just like to give a birthday nod to Red Hat Linux 1.0, progenitor of the Fedora Project
17:03:12 <cra> how is is he?
17:03:14 <sgallagh> Ok, we appear to have quorum
17:03:22 <cra> old
17:03:32 <sgallagh> #topic #683 - Zif as default PackageKit backend for desktop users - http://fedoraproject.org/wiki/Features/ZifByDefaultForDesktop
17:03:40 <sgallagh> .fesco 683 - Zif as default PackageKit backend for desktop users - http://fedoraproject.org/wiki/Features/ZifByDefaultForDesktop
17:03:40 <zodbot> sgallagh: Error: '683 - Zif as default PackageKit backend for desktop users - http://fedoraproject.org/wiki/Features/ZifByDefaultForDesktop' is not a valid integer.
17:03:44 <nb> Red Hat Linux 1.0 was released on November 3, 1994
17:03:45 * nirik looks it up. nov 3rd, 1994 was its release. ;)
17:03:47 <sgallagh> .fesco 683
17:03:51 <zodbot> sgallagh: #683 (F17 Feature: Zif as default PackageKit backend for desktop users - http://fedoraproject.org/wiki/Features/ZifByDefaultForDesktop) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/683
17:04:10 <sgallagh> nirik: They called it the Halloween release. This seemed close enough to me :)
17:04:25 <mjg59> I'm pretty sure that this is still stalled on the depsolver not being the same as yum?
17:04:36 * nirik is -1 on this at the current time for the same reasons as previously discussed.
17:04:47 <pjones> yeah, I don't know why this would have changed any
17:04:52 * t8m is -1 as well
17:05:03 <mjg59> Is the feature owner here?
17:05:10 <sgallagh> Yeah, I don't like the depsolvers disagreeing either. -1
17:05:10 <ajax> maybe if i ask twice i'll get a different answer!
17:05:21 <mjg59> ajax: Well, the feature owner doesn't seem to be hughsie
17:05:22 * notting is -1 per the earlier ticket about depsolvers (which likely was a result of this feature getting submitted for f17 ...)
17:05:23 <sgallagh> ajax: Are you familiar with the definition of insanity? :)
17:05:44 <mjg59> So I've no real idea what's going on here
17:05:51 <mjg59> Anyway, -1 until the depsolver issue is sorted out
17:06:06 <sgallagh> That's five -1 votes by my count.
17:06:14 <pjones> what the hell then, +1, just to be different ;)
17:06:30 <pjones> (ha ha not serious.)
17:06:33 <mjg59> pjones: Troll
17:06:47 <mjg59> Well, uh, that seems to have been surprisingly painless
17:07:32 <sgallagh> #agreed ZifByDefaultForDesktop is refused as a Feature for Fedora 17
17:07:39 <sgallagh> Shall we move on?
17:07:52 * nirik nods
17:08:04 <sgallagh> Ah, I also realized I skipped Follow-up business.
17:08:06 * sgallagh backtracks
17:08:12 <sgallagh> #topic #667 - Request to fix CRITPATH update process
17:08:19 <sgallagh> .fesco 667
17:08:21 <zodbot> sgallagh: #667 (Request to fix CRITPATH update process) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/667
17:08:33 <mjg59> Ok, so I dug through Luke's figures
17:08:55 <mjg59> Firstly, at most around 2.5% of critpath updates have had cases where a proventester has -1ed an update that otherwise had positive karma
17:09:01 <mjg59> I've looked at each of them
17:09:29 <mjg59> In several cases there was already a +1 from a proventester, so the -1 was only significant for overall karma
17:09:47 <mjg59> In another couple of cases the -1 only came after the update had already been pushed
17:10:02 <mjg59> And some more are just from the overall glibc updates where one update has several packages attached
17:10:20 <mjg59> There's basically close to 0 cases where the proventester requirement actually made a difference
17:10:31 <mjg59> And based on that, I'd recommend dropping the requirement for proventester on critpath
17:10:52 <t8m> so basically dropping the proventester concept altogether?
17:10:54 <nirik> interesting.
17:11:20 <mjg59> However I would appreciate someone else going over the data as well
17:11:31 <ajax> hooray for facts.
17:11:38 <sgallagh> mjg59: As opposed to the earlier proposal of only requiring proventester to override non-proventester -1?
17:11:46 <mjg59> sgallagh: Yeah
17:12:21 <nirik> so, how about we propose dropping proventester requirements, and wait a week for comment from QA and developers?
17:12:33 <t8m> nirik, +1
17:12:38 <sgallagh> I've never been a fan of process for process' sake. I'm not terribly fond of proventester to begin with.
17:12:40 <mmaslano> nirik: sounds good +1
17:12:47 * nirik is willing to try it
17:12:50 <sgallagh> +1 to nirik's proposal
17:13:01 <ajax> +1
17:13:03 <pjones> +1
17:13:09 <notting> +1
17:13:10 <mjg59> At most I think there's 2 critpath updates ever where proventester has made a significant difference to the outcome
17:13:19 <mjg59> So, +1
17:13:50 <sgallagh> So #proposal: Drop proventester requirements for critpath, waiting one week for QA/developer discussion
17:13:51 <nirik> does someone want to start a thread on this on devel ? (I can if no one else wants to, but mjg59 might be best with the data)
17:13:54 <sgallagh> Yes?
17:13:57 <mjg59> I'll do it
17:14:24 <sgallagh> #agreed Drop proventester requirements for critpath, waiting one week for QA/developer discussion
17:14:48 <sgallagh> #action mjg59 will start a discussion thread on the development list about dropping the proventester requirement
17:14:58 <sgallagh> Anything further to discuss here for now?
17:15:26 <sgallagh> Actually, I'd like to make one suggestion
17:15:26 * nirik has nothing
17:15:42 <nirik> although I suppose I could stop doing proventesters meetings if we drop that group. :)
17:15:42 <nb> yeah, since really proventester doesn't require much to join anyway
17:15:44 <sgallagh> Let's not drop the CRITPATH concept altogether. I think it's reasonable to leave a minimum karma requirement on CRITPATH
17:15:50 <sgallagh> Without requiring special testers
17:15:58 <mjg59> Yes, I wasn't suggesting droping the distinction
17:16:01 <mjg59> Merely the proventester component
17:16:05 <pjones> I don't think anybody had suggested dropping critpath
17:16:09 <nirik> yeah, I was proposing: "s/proventester/logged in account holder/g'
17:16:14 <sgallagh> mjg59: I wasn't sure. That's why I'm looking for clarification
17:17:02 <sgallagh> Ok, so no argument there?
17:17:09 <t8m> nirik, what about having just regular people interested in testing meetings?
17:17:26 <sgallagh> t8m: Isn't that what bugzappers and QA meetings are for?
17:17:33 <nirik> t8m: sure, could do that, but not many people have showed up and all of them have been proventesters. ;(
17:17:55 <pjones> sgallagh: yes, and we already have far too many different kinds.
17:17:59 <t8m> nirik, then probably dropping it is fine
17:18:46 <sgallagh> Ok, shall we move on?
17:18:46 <nirik> yeah.
17:18:48 <mmaslano> there was suggestions for lower number of packages in critpath, but I'm not sure how that ends...
17:19:09 <sgallagh> mmaslano: I think it probably becomes less of an issue if we drop the proventester requirement
17:19:25 <sgallagh> I propose to wait and see if that's still a problem.
17:19:26 <mmaslano> ok
17:20:12 <sgallagh> Moving on
17:20:26 <sgallagh> #topic #663 - Late F16 Feature Java7
17:20:26 <sgallagh> .fesco 663
17:20:27 <zodbot> sgallagh: #663 (Late F16 Feature Java7) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/663
17:20:56 * dbhole is here for any issues about that one
17:20:58 <sgallagh> According to the ticket, there is an update pending to finish this
17:21:00 <nirik> all has been rebuilt... I'd say close this now.
17:21:08 <pjones> end it
17:21:14 <dbhole> so everything is now resolved, all Java packages are now built with 1.6
17:21:14 <sgallagh> dbhole: Did you open a bug and propose blocker status?
17:21:23 <dbhole> +1 from me
17:21:29 <sgallagh> I want to be sure that nothing ships on the DVD that's built with J7
17:21:45 <nirik> I think it's too late for that.
17:21:51 <dbhole> sgallagh: No. I don't think we need one though. Of the 4 remaining, libgda is the only one on the DVD, and the one on the dvd is built with 1.6
17:22:01 <dbhole> everything else is online only, so -day should be okay for that
17:22:11 <sgallagh> dbhole: Ok, good enough for me, then
17:22:12 <sgallagh> +1
17:22:25 <sgallagh> (For closing it)
17:22:31 <dbhole> +1 from me too
17:22:33 <nirik> yeah, close++
17:22:54 <mjg59> +1
17:22:58 <sgallagh> dbhole: Do please open a Feature Page for F17, if one is not already there
17:23:05 <mmaslano> +1, close it
17:23:05 <sgallagh> I think we probably want to get this in shape early on
17:23:26 <dbhole> sgallagh: Yes, I will as soon as we start the 1.7 rebuilds
17:23:29 <sgallagh> I count 5 FESCo votes to close it
17:23:35 * dbhole hopes to start within a couple of weeks
17:23:53 <sgallagh> #action dbhole to create Fedora 17 Feature Page for Java 7
17:24:22 <sgallagh> #agreed Close Late F16 Feature Java 7 ticket. Rebuilds down to 1.6 have been resolved.
17:24:43 <sgallagh> Back to new business...
17:24:53 <sgallagh> #topic #683 - Zif as default PackageKit backend for desktop users - http://fedoraproject.org/wiki/Features/ZifByDefaultForDesktop
17:24:54 <sgallagh> .fesco 683
17:24:55 <zodbot> sgallagh: #683 (F17 Feature: Zif as default PackageKit backend for desktop users - http://fedoraproject.org/wiki/Features/ZifByDefaultForDesktop) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/683
17:25:04 <nirik> we did that one. ;)
17:25:06 <sgallagh> Whoops did that one already
17:25:17 <sgallagh> #topic #684 - F17 Feature: ns-3 Network Simulator - https://fedoraproject.org/wiki/Features/Ns3
17:25:17 <sgallagh> .fesco 684
17:25:21 <zodbot> sgallagh: #684 (F17 Feature: ns-3 Network Simulator - https://fedoraproject.org/wiki/Features/Ns3) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/684
17:26:12 <mjg59> This is the bit where we complain about the feature process and then +1 it, right?
17:26:24 <mmaslano> yes
17:26:25 <nirik> yeah
17:26:27 <pjones> mjg59: correct.
17:26:29 <sgallagh> No complaints from me.
17:26:35 <mmaslano> so +1 to ns-3
17:26:37 <mjg59> Blah blah feature process. +1.
17:26:37 <t8m> hmm, shouldn't we fix the process now?
17:26:40 <ajax> yawn.  +1.
17:26:41 <sgallagh> +1 for the feature. No risk to Fedora if it's incomplete
17:26:42 <nirik> +1, good luck, do package early.
17:26:45 <notting> sure, why not. +1
17:26:45 <pjones> t8m: it's not our process.
17:26:51 <pjones> t8m: half the problem.
17:27:21 <sgallagh> #agreed ns-3 is accepted as a Feature for Fedora 17
17:27:24 <pjones> well, if that's +5, then I'll abstain in protest over the process.
17:27:32 <t8m> But we were talking about doing some proposals how to fix it?
17:27:40 <abadger1999> pjones: I think fesco could be the body to fix it... but it is a shared process.
17:28:09 <sgallagh> Shall we save that for Open Floor?
17:28:11 * nirik would love to see it fixed, but I think it would take a FAD or several folks working on a good proposal...
17:28:20 <abadger1999> t8m: maybe start by pinging rbergeron -- I bet she has more work than she knows what to do with and would be glad for someone in fesco to take the reigns of fixing this.
17:28:25 <nirik> I don't think it's something we can just fix in a meeting like this one.
17:28:40 <pjones> nirik: yeah
17:28:42 <abadger1999> nirik: +1
17:29:03 <mmaslano> abadger1999: we already commented process on her wiki page
17:29:13 <mmaslano> we might start again
17:29:55 <abadger1999> mmaslano: Yes, definitely take the existing work... but someone needs to be the driver.  organize the meetings/FADs/ propose strawmen, organize the alternatives into coherent strategies, etc.
17:30:18 <mmaslano> rbergeron: ^ ?
17:30:55 <rbergeron> yeah, a fad, and I need to get past the next week.
17:30:57 * rbergeron sighs
17:30:58 <rbergeron> sorry.
17:31:40 <mjg59> Yeah this doesn't seem like the best timing for it
17:31:51 <mjg59> I think letting people get a release out is a reasonable priority right now
17:32:07 <t8m> of course
17:33:12 <rbergeron> i can only drive so many cars at once :\
17:34:16 <sgallagh> rbergeron: switch to motorcycles. It's easier to jump between them
17:34:24 <rbergeron> sgallagh: just call me trinity
17:34:57 * abadger1999 proposes moving on and discussing this outside of meeting
17:35:03 <sgallagh> +1
17:35:09 <t8m> fine
17:35:44 <sgallagh> #topic Engineering Services Tickets
17:35:59 <sgallagh> abadger1999: Anything happening here?
17:36:09 <nirik> nothing much currently.
17:36:17 <nirik> please see me if you want to help out with them
17:36:39 <sgallagh> Ok, then...
17:36:41 <sgallagh> #topic Next week's chair
17:36:59 <abadger1999> nirik: Are you leading that now or does it need someone else to lead/co-lead as well?
17:37:01 <sgallagh> Who wants the conch shell next week?
17:37:17 <mmaslano> ok, I can take the next one
17:37:26 <nirik> abadger1999: well, it needs a driving force for sure. I'm happy to help, but I don't currently have the time to nag people, etc...
17:37:33 <abadger1999> <nod>
17:37:42 <sgallagh> #action mmaslano to chair the 2011-11-07 meeting
17:38:00 <sgallagh> #topic Open Floor
17:38:01 <abadger1999> sgallagh: Would you call that out in the fesco minutes?  (FES needs a driver)
17:38:24 <nirik> #info Fedora Engineering Services is looking for a wrangler.
17:39:19 <sgallagh> Anything to discuss at the Open Floor?
17:39:44 <mmaslano> feature process? now or later in email?
17:39:57 <sgallagh> I'm hesitant to mention UsrMove, both because tl;dr and also I'm told that the Feature hasn't been updated as they were instructed to
17:40:25 * abadger1999 added a bunch of comments/questions to UsrMove -- unanswered as well.
17:40:29 <sgallagh> mmaslano: I thought we decided above that it should be handled outside of the FESCo meeting
17:40:37 <nirik> mmaslano: I really think it's more than we can handle here, but we could discuss ideas if you want.
17:40:37 <mmaslano> ok
17:41:03 * nirik thinks usrmove is a solution in search of a problem.
17:41:43 <t8m> nirik, +1
17:41:48 <t8m> at least somewhat
17:43:57 <sgallagh> Ok, so nothing much here?
17:44:13 <sgallagh> Anything else for Open Floor? If not, I'll end the meeting in two minutes.
17:45:06 * nirik has nothing.
17:46:11 <sgallagh> #endmeeting