cloud_sig
LOGS
19:00:58 <rbergeron> #startmeeting Cloud SIG
19:00:58 <zodbot> Meeting started Fri Oct  7 19:00:58 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:58 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:01:07 <rbergeron> #meetingname Cloud SIG
19:01:07 <zodbot> The meeting name has been set to 'cloud_sig'
19:01:13 <rbergeron> #topic Who's here yo!
19:01:15 * jforbes is here
19:01:25 <rbergeron> #chair jforbes gholms
19:01:25 <zodbot> Current chairs: gholms jforbes rbergeron
19:01:32 * gholms teleports into the room
19:01:36 <rbergeron> word
19:01:43 * rbergeron transports herself to the developer lounge
19:02:32 <rbergeron> okay, anyone else?
19:02:33 <rbergeron> srsly
19:02:40 <gholms> :(
19:03:02 * kkeithley is here
19:03:07 <kkeithley> but you knew that
19:03:12 <rbergeron> yar, indeed
19:03:15 <jforbes> Heys, it's more people than last week :)
19:03:19 <rbergeron> okay, well, i'll hope we can move on
19:03:20 <rbergeron> lol
19:03:22 <rbergeron> I guess so ;)
19:03:31 <rbergeron> #topic We haz AMIs
19:03:36 <rbergeron> Okay, so very briefly:
19:03:43 <rbergeron> #info We now have Beta AMIs
19:03:53 <gholms> http://lists.fedoraproject.org/pipermail/cloud/2011-October/000861.html <- F16 beta AMI IDs
19:03:53 * jforbes cheers!
19:04:05 <rbergeron> gholms: you totally beat me to that ;)
19:04:13 <gholms> :)
19:04:15 <rbergeron> So - do we want to do an announcement of some sort?
19:04:25 <rbergeron> And do we want to do that now, or wait till monday so people actually see it?
19:04:26 * ke4qqq shows up late
19:04:33 <rbergeron> better late than never
19:04:44 <jforbes> Umm, for beta, monday is probably good, and probably only to test list and cloud list
19:04:55 <rbergeron> jforbes: agreed - maybe a blog post as well
19:04:55 <jforbes> Though I will update the page
19:05:00 <rbergeron> not necessarily needed for devel and whatnot
19:05:00 <gholms> jforbes: +1
19:05:12 <jforbes> Yeah, I will do a blog post for the planet
19:05:14 <rbergeron> #action jforbes to update wiki with ami's
19:05:17 <rbergeron> oh, sweet
19:05:22 * rbergeron meant s/devel/announce-list
19:05:25 * rbergeron can't think, sorry
19:05:51 <rbergeron> #action jforbes to bloggy-blog on monday
19:05:53 <rbergeron> thank you, sir!
19:05:56 <jforbes> NP
19:05:56 <rbergeron> ;)
19:05:59 * rbergeron apreciates that
19:06:09 <rbergeron> okay, so, i guess long-story short: if anyone sees problems, plz report, etc.
19:06:16 <rbergeron> i assume some of you have actually tried them out already?
19:06:18 * rbergeron looks around the room
19:06:37 <gholms> FYI: the beta images have one file from cloud-init patched by hand.
19:06:41 <jforbes> Why can't I find an edit button on the wiki anymore?
19:06:44 <rbergeron> ...or maybe not ;) well then
19:06:46 <gholms> So no need to get all suspicious and stuff.
19:06:56 <jforbes> rbergeron: very minimal boot check
19:07:05 <rbergeron> jforbes: need to log in perhaps?
19:07:17 <jforbes> I am logged in
19:07:18 <rbergeron> #info beta images have one file from cloud-init patched by hand
19:07:25 <rbergeron> jforbes: it's BROKEN
19:07:26 <rbergeron> ;)
19:07:34 <rbergeron> okay, anything else on this? /me wants to move on to test day goodness
19:07:37 <jforbes> Oh, have to go to "history" then click edit
19:08:03 <gholms> Oh yeah, another FYI:
19:08:06 <rbergeron> weird
19:08:07 <rbergeron> okay
19:08:15 <rbergeron> go ahead ;)
19:08:23 <gholms> Everything on those images excludes docfiles.
19:08:36 <rbergeron> #info everything on those images excludes docfiles
19:08:42 <rbergeron> (what do you mean exactly)
19:08:55 <rbergeron> (this is proably obvious but i am soooo tired right now)
19:09:09 <gholms> The image was built with --excludedocs, which means the image comes with no man pages and other documentation.
19:09:20 <gholms> This also turns out to persist to stuff that is newly installed.
19:09:26 <rbergeron> ah.
19:09:45 <gholms> To fix it you need to remove "%_excludedocs 1" from /etc/rpm/macros.imgcreate before you install things.
19:09:50 <rbergeron> #info means image was built with --excludedocs, meaning it comes with no man pages, or other documentation - this also turns out to persist to stuff that is newly installed
19:10:07 <rbergeron> #info to fix you need to remove "%_excludedocs 1" from /etc/rpm/macros.imgcreate before you install things
19:10:14 * rbergeron hands gholms the poewr of info, btw ;)
19:10:16 <gholms> dgilmore removed that from the kickstart, so next time that won't be an issue.
19:10:24 <gholms> #info This will not be an issue next time
19:10:32 <rbergeron> oh
19:10:36 <rbergeron> so this was omission and not on purpose?
19:10:44 <gholms> dgilmore: ^
19:11:01 * rbergeron was a bit puzzled as to why or if this is just normal or... what
19:11:35 <gholms> If I had to guess I would say it's to make test images smaller.
19:11:42 <rbergeron> okay, maybe dgilmore can pop in later
19:11:44 * rbergeron nods
19:11:47 <rbergeron> that seems reasonable
19:11:50 <gholms> #info Beta images also install only one language; this will also be fixed next time
19:12:01 <rbergeron> okay, i'm going to move on to testing things
19:12:05 <gholms> worksforme
19:12:09 <rbergeron> gholms: do es that seem like stuff that could be in a test matrix?
19:12:17 <rbergeron> "has docs" "has man pages" "has multiple lang support"
19:12:29 <rbergeron> or is that just... once we fix it it should be fixed forever
19:12:41 <rbergeron> #topic Test Day
19:12:52 <rbergeron> #link http://fedoraproject.org/wiki/QA/Fedora_16_test_days
19:13:04 <rbergeron> So: we have a test day coming up on 10/20
19:13:07 <gholms> Well, "has man pages" isn't a very useful test when it comes with no *reader* for man pages.
19:13:23 <rbergeron> as an FYI - we have NO wiki page set up yet, no plans, no nothing.
19:13:32 <jforbes> rbergeron: I can set up the EC2 side
19:13:32 <rbergeron> #info We need to get our collective butts together on test day.
19:13:48 <rbergeron> jforbes: excellent, thank you
19:14:01 <rbergeron> jforbes: i assume you meant that wrt test day and not something else
19:14:17 <rbergeron> #action jforbes to wrangle the notes for test day re: EC2
19:14:25 <rbergeron> so here's the scoop: we have like... 28 other cloudy features.
19:14:36 <jforbes> rbergeron: actually, I did mean something else, cloud test day :)
19:14:46 <bertux> OpenStack ?
19:14:49 <rbergeron> HekdaFS, aeolus, openstack, pacemaker-cloud (ping sdake, hai)
19:14:57 <rbergeron> s/hekdafs/hekaFS
19:15:01 <rbergeron> ugh, i can't type
19:15:01 <gholms> Heh
19:15:11 <rbergeron> Sooooooo
19:15:28 <bertux> aeolus seems more in the Fedora spirit than OpenStack
19:15:32 <rbergeron> If any of those reps from thos eare present (jdarcy, kkeithley, mdomsch, sdake, anyone, anyone, bueller)
19:15:36 <rbergeron> please pipe up
19:15:36 <jforbes> https://fedoraproject.org/wiki/Cloud_SIG/EC2_Images is edited with beta info now
19:15:41 <clalance> rbergeron: I'm here.
19:15:54 <clalance> rbergeron: I'll see if I can drum up some support for doing the test day.
19:15:58 <rbergeron> bertux: well, perhaps, but we're not going to speculate about governance drama ;)
19:16:06 <rbergeron> clalance: yeah, that would be helpful. maybe jlaska might be able to help out there
19:16:11 <clalance> (which coincides nicely with the fact that we are probably minutes away from releasing aeolus 0.4.0)
19:16:18 <clalance> rbergeron: Yeah, good idea.
19:16:21 <rbergeron> i think the main problem is getting people set up with easy instructions to even attempt to install/set up
19:16:32 <kkeithley> yup, I'm here
19:16:45 <rbergeron> #action clalance to drum up some aeolus support - perhaps talk to jlaska, since he has some experience in this area
19:16:48 <bertux> there are already instructions for OpenStack in the wiki page
19:17:03 <rbergeron> bertux: can you link that in here?
19:17:16 <rbergeron> #info we already have some instructions for openstack in the wiki page
19:17:36 <rbergeron> #info But we lack any sort of test matrix / how to test / what to test, which is what we do need from that angle
19:17:43 <clalance> Right.
19:17:49 <bertux> https://fedoraproject.org/wiki/Getting_started_with_OpenStack_Nova
19:17:52 <rbergeron> bertux: would you be interested in digging around on the openstack site, look at their QA, and see if they have a test matrix?
19:17:58 <rbergeron> or something to that effect?
19:18:16 <bertux> rbergeron: yes i can try that this weekend
19:18:20 <rbergeron> Maybe it's something we could pull bits from for oenstac and possibly also for aeolus - not just does it install, but can you do basic functional things
19:18:31 <bertux> i've plan to spend my weekend on OpenStack testing in Fedora
19:18:39 * gholms replaces rbergeron's keyboard
19:18:46 <rbergeron> #action bertux to investigate openstack QA for test matrices, etc. that we could use for test day, report back early next week
19:18:55 <rbergeron> gholms: wow, thank you, that helped ;)
19:19:07 <rbergeron> kkeithley: thoughts on testing hekaFS?
19:19:26 <kkeithley> umh, yeah, I suppose
19:19:34 <rbergeron> impossible? possible?
19:19:37 <kkeithley> client-side or server?
19:19:46 <ke4qqq> yes
19:19:57 <bertux> should i still plan to build OpenStack testing images using BoxGrinder ?
19:19:57 <kkeithley> yes, it's possible
19:20:07 <rbergeron> ke4qqq: wow, that was succinct and deep ;)
19:20:19 <ke4qqq> glad to make a contribution to the conversation :)
19:20:28 * rbergeron always appreciates your presence
19:20:36 <rbergeron> ;)
19:20:47 <rbergeron> bertux: i have no idea.
19:20:49 <kkeithley> do you want multiple 'bricks' (i.e. nodes) for a server?
19:20:59 <rbergeron> bertux: think it wouldn't hurt
19:21:05 * rbergeron notes that her internet just went straight to hell
19:21:24 <rbergeron> keithley: the alternative being?
19:21:31 <rbergeron> single-node type testing?
19:21:50 <kkeithley> right
19:21:51 <rbergeron> if we had both options available for people with different hw available - i realize that's probably stretching on time for getting ready
19:22:03 <rbergeron> not all folks have 4 zillion machines sitting around
19:22:08 <rbergeron> (i know it's hard to comprehend)
19:22:10 <kkeithley> which I might argue that single node server isn't very interesting
19:22:11 <bertux> It would be simpler to test OpenStack if the testing image is already available
19:23:20 <kkeithley> but what is the real use case? You want an EC2 client of heka/gluster? Or you want EC2 servers providing cloudy storage for clients in the wild. Both I suppose
19:23:50 <rbergeron> it doesn't have to be ec2 related at all
19:24:17 <rbergeron> i mean... unless i'm missing some enormous technical detail
19:24:19 <rbergeron> which is always possible
19:24:28 <kkeithley> sorry, brain fart, I thought we were still talking about EC2 AMIs. You're just talking about cloud test day.
19:24:31 <rbergeron> i was more thinking like... make one at home
19:24:38 <rbergeron> kkeithley: :) yes
19:24:39 <kkeithley> so yes,
19:24:54 * rbergeron was having the moment of "omfg, i know even less than i thought i did"
19:25:56 * rbergeron looks at kkeithley for the rest of the sentence
19:26:25 <kkeithley> yes, we can test multiple node server and client
19:26:41 <kkeithley> or single node server. Whatever you want
19:27:16 <rbergeron> okay. can you help make (a) instructions and (b) some sort of test matrix? :)
19:27:22 <kkeithley> yes
19:27:23 <rbergeron> or assign it to jdarcy ;)
19:27:32 <kkeithley> sure :-)
19:27:36 * rbergeron grins
19:27:50 <rbergeron> #action kkeithley to make instructions/test matrix for hekaFS
19:28:53 <rbergeron> okay.
19:28:54 <rbergeron> ummmmm
19:28:56 <rbergeron> anything else?
19:29:11 <rbergeron> #info Looking to our other features... please pipe up if ou want testing...
19:29:17 <bertux> nobody wants to try aeolus ?
19:29:31 <mdomsch> see Dell's crowbar isos for a self-deployment of openstack, albeit with centos bits and ubuntu bits
19:29:40 <clalance> bertux: Oh, I just sent mail to aeolus-devel to get some volunteers.
19:29:45 <clalance> bertux: I'll brow-beat someone into it ;).
19:29:53 <msavy> hello! just fyi that in the upcoming release of boxgrinder there'll likely be a libvirt delivery plugin which is more or less completed
19:30:01 <rbergeron> msavy: hi! :)
19:30:08 <mmorsi> ah so i'm joining late, and am sure this has been answered a million times over
19:30:09 <ke4qqq> msavy: ohhhh awesome
19:30:10 <mmorsi> and i apologize
19:30:16 <rbergeron> #info upcoming release of boxgrinder there will likely be a libvirt delivery plugin which is more or less completed
19:30:17 <mmorsi> but what would be involved in testing aeolus on this test day
19:30:25 <rbergeron> #link https://fedoraproject.org/wiki/Test_Day:2011-10-20
19:30:28 <clalance> mmorsi: Basically anything we want.
19:30:45 <rbergeron> http://fedoraproject.org/wiki/QA/SOP_Test_Day_management
19:30:48 <msavy> it is ready for testing now, but i am making some usability tweaks from feedback i've had for community members
19:30:50 <clalance> mmorsi: That is, it's best if we come up with a specific set of tests.
19:30:53 <mmorsi> so essentially people volunteer to run through the steps we give them?
19:30:54 <clalance> And have people try them out.
19:30:58 <clalance> mmorsi: Yeah, exactly.
19:31:00 <rbergeron> http://fedoraproject.org/wiki/QA/Test_Days/Template
19:31:06 <clalance> mmorsi: I just sent a mail to aeolus-devel about it.
19:31:07 <rbergeron> #info Use the test day template if you are the first person to the page
19:31:21 <msavy> ke4qqq: would you volunteer to be a guinea-pig for the libvirt plugin too :)?
19:31:27 <rbergeron> mdomsch: interesting - do you have a link offhand?
19:31:33 <rbergeron> re: crowbar isos
19:31:34 <mdomsch> I had  a good discussion with Andrey from griddynamics on getting them involved in fedora/epel.
19:31:41 <rbergeron> mdomsch: OHHHHHH
19:31:49 <mmorsi> hrm ok
19:31:51 <rbergeron> plz hook me up with infos or an intro at some point - when are you leaving?
19:31:55 <mdomsch> top of dellites.me
19:32:08 <mmorsi> so i suppose we can test launching instances against the different cloud providers, building images containing various repos and software
19:32:14 <mdomsch> leaving in 30min
19:32:22 <mmorsi> and monitoring / stopping those instances
19:32:29 <rbergeron> #info Dell Crowbar iso's are good to look at for self-deployment of opentsack (albeit with centos and ubuntu bits) - dellites.me
19:32:33 <rbergeron> mdomsch: gahhhh
19:32:35 <mmorsi> am still working on the cross-cloud migrations feature (coming soon)
19:32:38 <rbergeron> well, nice meeting you finally ;)
19:33:00 <rbergeron> mdomsch:  hook me up with his email at some point then :)
19:33:11 <mmorsi> can writeup steps to do that
19:33:18 <ke4qqq> msavy: yes
19:33:24 <mmorsi> and then do i upload those somewhere for people to pick and choose on the test day
19:33:28 <clalance> mmorsi: Well, the thing is, that won't be in F-16.
19:33:30 <mmorsi> or do we go through them syncronously
19:33:34 <mmorsi> clalance: ah ok
19:33:36 <clalance> So we should probably hold off on that until we get that in.
19:33:40 <clalance> (F-17, or whatever)
19:33:41 <mmorsi> so its just the stuff currently in fedora
19:33:46 <clalance> Yeah, exactly.
19:33:47 <rbergeron> mmorsi: exactlerly
19:33:48 <mmorsi> k
19:34:03 <clalance> (though that reminds me that I do have to build 0.4.0 final packages into F-16 before the test day)
19:34:08 * rbergeron notes she needs to leave like... now
19:34:08 <msavy> ke4qqq: thanks!, and bertux too no doubt :)
19:34:15 <mmorsi> so is it pick n' choose, or do we go 'ok we are all testing aeolus now, lets do step 1... then lets all do step 2...'
19:34:19 <rbergeron> can someone kind of... end this meeting when it's done? :)
19:34:23 <rbergeron> #chair ke4qqq
19:34:24 <zodbot> Current chairs: gholms jforbes ke4qqq rbergeron
19:34:24 <mmorsi> rbergeron: k no worries, have a good one
19:34:29 * rbergeron throws ke4qqq under the bus
19:34:34 <clalance> Heh, nice.
19:34:34 <ke4qqq> thanks for that
19:34:37 <mdomsch> rbergeron: sent
19:34:40 <clalance> mmorsi: We can choose how we want to do it.
19:34:43 <gholms> rbergeron: Internet dying?
19:34:45 <clalance> mmorsi: The more independent, the better.
19:34:51 <rbergeron> mdomsch: you are rockin' like dokken, dude
19:34:52 <mmorsi> k sure
19:34:56 <clalance> mmorsi: But if there are dependencies, that's the way it is.
19:34:58 <rbergeron> gholms: yeah, and have to go to a session
19:35:05 <mmorsi> clalance: and then assuming i'll be around to help out w/ issues?
19:35:11 <clalance> Yeah, exactly.
19:35:23 <clalance> mmorsi: Hopefully we'll get more people to help too :).
19:35:28 <mmorsi> sure
19:35:34 <mmorsi> well i can come up w/ some steps
19:35:36 <mmorsi> to run through
19:35:39 * rbergeron waves and sends hugs... i think those are the only topics i had for today but feel freeoto go on
19:35:40 <mmorsi> and upload them to the wiki
19:35:43 <clalance> mmorsi: Great, thanks.
19:35:47 <clalance> That is a big help.
19:36:07 <mmorsi> np
19:36:47 <ke4qqq> any thing else on the test day front?
19:37:46 <msavy> is boxgrinder invited? i'll have to remind mgoldmann about it.
19:37:50 <mmorsi> the date is on the 20th correct?
19:37:52 <gholms> #action mmorsi to add testing instructions to the wiki
19:37:56 <mmorsi> is there a due date for the steps?
19:37:57 <ke4qqq> boxgrinder is most def. invited.
19:38:04 <mmorsi> obviously the sooner the better
19:38:16 <clalance> mmorsi: Yeah, sooner the better, but as long as it is done before the test day.
19:38:26 <ke4qqq> it'd be cool to have a test matrix folks can go through for BG
19:38:35 <clalance> Yeah, I think so too.
19:38:41 <msavy> sounds like a good chance to find more libvirt testers
19:38:44 <mmorsi> and does it need to be 100% in fedora, eg yum installed, eg  can i write a bootstrapping script or similar?
19:38:45 * clalance might also do it for Oz.
19:38:59 <clalance> mmorsi: The idea is that people can yum install it from Fedora.
19:39:03 <mmorsi> aight
19:39:05 <ke4qqq> mmorsi: needs to be 100% in fedora
19:39:05 <mmorsi> fair enough
19:39:07 <mmorsi> k
19:39:44 <mmorsi> hrm one additional tricky thing i just thought up of
19:39:48 <mmorsi> is cloud provider credentials
19:39:55 <mmorsi> but i suppose it can be in the instructions
19:40:03 <ke4qqq> yep
19:40:03 <clalance> mmorsi: Yeah, that can be a prereq
19:40:05 <mmorsi> that you'll need to set those up independantly b4 hand
19:40:25 <mmorsi> would like to get as many clouds tested as possible
19:40:38 <mmorsi> but i imaging alot of people won't have credentials for alot of the drivers deltacloud has
19:40:47 <mmorsi> so i imagine ec2 will be extensively tested
19:40:50 <mmorsi> but it is what it is
19:41:00 <mmorsi> any way we can setup a shared account or similar for this?
19:41:07 <mmorsi> know i might be asking a bit much
19:41:15 <ke4qqq> mmorsi: wqe've agreed to reimburse folks in the past
19:41:25 <mmorsi> ah k
19:41:26 <ke4qqq> I am relatively certain we could do the same thing again
19:41:31 <mmorsi> k
19:41:36 <clalance> Yeah, we should ask about that.
19:41:46 <mmorsi> shared account might not be a bad idea going forward (active for that day only)
19:41:56 <mmorsi> then just publically share the credentials and what not
19:42:03 <mmorsi> but doesn't have to be for this one
19:42:08 <ke4qqq> #action clalance to email cloud-list to see if we can get agreement to reimburse again
19:42:21 <ke4qqq> :)
19:42:23 <mmorsi> (also inquire about the shared account if possible)
19:42:39 <mmorsi> you can have that as an action item for me if you want
19:42:42 <mmorsi> no worries either wya
19:42:43 <mmorsi> way
19:42:44 <clalance> Heh, nice delegation ;).
19:43:08 <ke4qqq> #action mmorsi to ask on cloud list about setting up temporary shared accounts for diff. providers
19:43:31 <mmorsi> k cool
19:43:34 <ke4qqq> clalance: thanks - I find it's so much easier for work to actually get done this way :)
19:44:05 <clalance> ke4qqq: Is it cloud-list@lists.fedoraproject.org ?
19:44:13 <clalance> (or somewhere else)
19:44:15 * clalance can't find it
19:44:25 <gholms> cloud@lists
19:44:42 <ke4qqq> yeah that
19:44:48 <clalance> gholms: Oh, right.
19:44:49 <clalance> Sorry :).
19:44:54 <clalance> Thanks.
19:46:07 <ke4qqq> anything else on test day?
19:46:27 <ke4qqq> hearing nothing - anything else for the meeting?
19:46:33 <mmorsi> will there be punch n' pie ;-)
19:46:39 <msavy> mmm pie!
19:46:51 <mmorsi> nothing from me
19:46:57 <gholms> [Frost gathers on the windows]
19:47:20 <ke4qqq> yeah - not seeing anything else - so will close the meeting in 60 seconds unless someone says something
19:48:41 <ke4qqq> thanks for coming folks
19:48:44 <ke4qqq> #endmeeting