fedora-meeting
LOGS
15:01:18 <tflink> #startmeeting Fedora QA Meeting
15:01:18 <zodbot> Meeting started Mon Sep 26 15:01:18 2011 UTC.  The chair is tflink. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:01:18 * pschindl is here
15:01:25 <tflink> #chair adamw
15:01:25 <zodbot> Current chairs: adamw tflink
15:01:31 <tflink> #topic roll call
15:01:35 <adamw> yo
15:01:35 * jskladan lurks from the shadows
15:01:42 <tflink> alrighty, who's around for this last-minute meeting?
15:01:56 * tflink set a reminder for the announcement for next week
15:02:12 <tflink> jskladan, pschindl: welcome
15:02:46 <tflink> adamw: did you have anything special in mind for an agenda other than followup, beta status and probably a mini-review?
15:04:30 * jsmith is here
15:04:36 <jsmith> (Lurking, mostly)
15:04:48 * nirik is also lurking in the shadows.
15:05:03 * tflink welcomes the shadows of jsmith and nirik
15:05:45 <adamw> we could look at the Xen release criterion
15:05:50 <adamw> as people keep poking me about that
15:05:56 <tflink> good idea
15:06:32 <tflink> ok, lets get started
15:06:44 <tflink> #topic previous meeting followup
15:07:01 <tflink> first up is "adamw to check in with tflink about python-yourls"
15:07:21 <tflink> which I don't think happened, but I can update status anyways :)
15:07:41 <tflink> the review is complete and code is committed, I just need to build packages and create updates
15:08:05 <tflink> #action tflink to build python-yourls for F15, F16, EL6 and create updates
15:08:29 * kparal joins in late
15:08:31 <adamw> i think i tried but you weren't on the end of whatever i pinged
15:08:31 <tflink> next up is "maxamillion to follow up with abadger1999 on the idea of linking from pkgdb to the list of package-specific test cases for a package"
15:08:41 <adamw> hi kparal
15:08:42 * kparal was buying travel adapter for fudcon, sorry
15:08:45 <tflink> maxamillion doesn't seem to be here atm
15:10:10 <adamw> i pinged him in -qa but no reply as yet
15:10:18 <adamw> abadger1999: has that been followed up on?
15:10:38 <abadger1999> nope, hasn't.
15:10:51 <tflink> so I guess we table this and add another action
15:11:04 <adamw> 'maxa to really damn well do it this week'
15:11:10 <abadger1999> If someone wants to add it as a separate page linked from the package's acl page, I'll take the patch immediately.
15:11:15 <tflink> #action maxamillion to follow up with abadger1999 on the idea of liking from pkgdb to the list of package-specific test cases
15:11:21 <abadger1999> Otherwise I'd est. a year out or so.
15:11:51 <abadger1999> I need to coordinate two pkgdb releases this year.. which means lots of coordination and bugfixing will be my priorities.
15:13:02 <abadger1999> please open a ticket if no one is working on it here, though -- I do have people who come to me looking for programming tasks and I think this is an intermediate level task so I could give it to one of them.
15:13:17 <adamw> okay. thanks
15:13:22 <tflink> #info if package-specific test case linking in pkgdb is desired, someone is going to have to write a patch for it
15:13:51 <tflink> anyone want to take an action on creating that ticket?
15:14:00 * maxamillion is here
15:14:14 <tflink> an you already have an #action :)
15:15:20 <tflink> maxamillion: would you be OK with creating the ticket to have the linking to pkg-specific test cases in pkgdb?
15:15:29 <tflink> wow, that was oddly worded
15:16:04 <tflink> ok, no volunteers so it'll be maxamillion or I
15:16:06 <maxamillion> tflink: sure, I could do that ... not entirely sure where to file the ticket though, just need to track that down
15:16:18 * maxamillion goes to the googles
15:16:45 <tflink> #action maxamillion create ticket for pkgdb to link to package-specific test cases
15:16:55 <tflink> ok, I think that's all of the followup from last week
15:16:58 <tflink> did I miss anything?
15:17:27 * tflink assumes that silence means "no"
15:17:32 <abadger1999> maxamillion: https://fedorahosted.org/packagedb/   and target it towards -- someone that I might assign it to that comes to infra looking to help.
15:17:56 <tflink> #topic Xen Release Criteria
15:18:00 <maxamillion> abadger1999: ah, rgr .. thanks :D
15:18:34 <tflink> this came up in the comments for https://bugzilla.redhat.com/show_bug.cgi?id=708267 which is currently proposed as a F16 beta blocker
15:18:43 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=708267
15:18:59 <adamw> soo...we currently have Beta release criterion which reads "The release must boot successfully as a virtual guest in a situation where the virtual host is running a supported Xen implementation"
15:19:29 <tflink> I thought that was something that came from infra
15:19:37 <adamw> afaict this criterion is sort of a vestigial tail of the criteria: it was request by jesse at the time, and so we think there was something in releng/infra back then which actually needed xen to work
15:19:39 <tflink> since they're still running Xen AFAIK
15:19:41 <adamw> that's what we think
15:20:10 <adamw> i went and asked jesse and the current releng team if they think we should still have it, and they said no
15:20:14 * nirik notes xen is still in use, but with no fedora guests. Our fedora compose box is bare hw.
15:20:17 <adamw> i haven't checked with infra (yet)
15:20:45 * tflink has F15 DomUs running, doesn't quite understand the problem
15:20:56 <adamw> so, i'm planning to propose we drop the criterion
15:21:24 <adamw> tflink: as in, the bug? let's not get off track if possible =) the question isn't whether it works right now, but whether it needs to be in the beta criteia
15:21:26 <adamw> criteria*
15:21:29 <tflink> the only objection I have to that is that Dom0 is a F16 feature
15:21:40 <maxamillion> tflink: +1
15:21:49 <adamw> feature process isn't blocker process, we already established that. =)
15:21:55 <maxamillion> ah
15:21:59 <maxamillion> crap ... rbb
15:22:00 <maxamillion> brb*
15:22:02 <tflink> it seems odd that we would advertize the ability to run Fedora as Dom0 but not support DomU
15:22:12 <nirik> so, change it for f17 to be 'must boot as a guest in a fedora dom0' ?
15:22:24 <adamw> tflink: minus ten points for using the S word!
15:22:59 <adamw> the concept of 'support' is so vague as to be unhelpful, really, and the release criteria are certainly not an exhaustive list of everything fedora could be said to 'support' in some sense
15:23:26 <adamw> the release criteria are supposed to be the stuff that absolutely needs to be working for us to consider the release, well, releasable
15:23:37 <tflink> either way, I'm not sure that Xen DomU needs to be a beta criterion
15:23:43 <adamw> do we really think we should slip the release another week if Xen support isn't working?
15:23:52 <adamw> is the essential question
15:23:54 * nirik doesn't.
15:24:08 <tflink> for beta, probably not
15:24:23 * athmane thinks that xen domu support is NTH
15:24:24 <tflink> for final, maybe
15:25:01 <adamw> okay
15:25:01 <tflink> using the same argument that we have for live images - if people are installing from DVD media, its harder to work around installation issues
15:25:22 * adamw doesn't quite follow the parallel
15:25:50 <tflink> if creating a Xen DomU from DVD media fails, how do you update to fix that?
15:26:15 <adamw> oh, i see. reasonable point.
15:26:36 <adamw> so, let's say we all agree it's not Beta material, but it's not clear whether it should be final material or not
15:26:45 <tflink> yeah, that works for me
15:26:48 <adamw> and we can discuss further on the list?
15:26:51 <maxamillion> back
15:27:00 <maxamillion> +1 for not beta
15:27:34 <athmane> also we don't have a working dom0 in fedora to test (unlike kvm)
15:27:43 <tflink> proposed #agreed - Xen DomU Beta release criterion was rejected, unclear on whether or not DomU should be a final criterion, will discuss more on list
15:27:51 <tflink> athmane: supposedly it works in F16
15:28:34 <tflink> #agreed - Xen DomU Beta release criterion was rejected, unclear on whether or not DomU should be a final criterion, will discuss more on list
15:28:52 * nirik notes that ec2 stuff is dom0 right? so that might affect that part of the compose for final?
15:29:07 <tflink> nirik: good point
15:29:34 <tflink> #action tflink to start discussion about Xen DomU for Final Release Criteria
15:29:49 <tflink> #info EC2 is Xen, DomU support may affect EC2 support
15:30:01 <maxamillion> athmane: we don't? I thought that stuff was merged upstream into the 3.0.x kernel line
15:30:10 * maxamillion hasn't tested it though ... so ... :/
15:30:32 <nirik> yeah, it's supposed to work... dunno if anyone has tested it much.
15:30:39 <maxamillion> I plan to test this week
15:30:43 * tflink hasn't heard a whole lot on the xen list
15:30:50 <tflink> fedora-xen, rather
15:31:05 <tflink> any other thoughts before we move on?
15:31:06 <maxamillion> it might be a bit late but I might post to the fedora virtualization test day wiki page but note that I tested Xen instead of KVM
15:31:10 <nirik> There was one tester a few weeks ago running into issues, but dunno if they got it working or not. ;(
15:31:36 <athmane> Xen Pvops Dom0 feature seems to be at 75%
15:32:01 <maxamillion> athmane: well, that's what the wiki page says anyways ... but I wouldn't be surprised if that was out of date
15:32:29 <tflink> the last message I'm seeing on fedora-xen sounds like it's farther along than 75%
15:33:05 <tflink> we'll see what happens
15:33:34 <tflink> #topic Beta Preparation
15:33:52 <tflink> #info Fedora 16 Beta RC2 was released last friday
15:34:50 <tflink> the install and desktop test matrices look decent, still a couple of holes
15:35:41 <tflink> 4 bugs were (re) proposed as blockers over the weekend
15:35:46 <adamw> yeah, we need some coverage, but no obvious showstoppers seem to have emerged
15:35:57 <tflink> other than nfs installs?
15:36:35 <tflink> wait, 5 bugs, I missed one
15:37:11 <tflink> well, sounds like time for a mini-review before we call this meeting over
15:37:24 <tflink> #link https://fedoraproject.org/wiki/Current_Release_Blockers
15:37:45 <tflink> #topic (741211) "save traceback to bugzilla" test doesn't work when using randomize_tb to create a new bug
15:37:52 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=741211
15:38:22 <adamw> oh, not that fucking one again.
15:38:43 <tflink> is this really distribution?
15:38:50 <tflink> I thought that we fixed this already
15:39:07 <adamw> this is https://bugzilla.redhat.com/show_bug.cgi?id=730887
15:39:19 <kparal> maybe the updates.img contains bad code?
15:39:38 <tflink> adamw: that was libreport
15:39:52 <adamw> looks like the same problem again.
15:40:05 <tflink> regression from the last libreport update?
15:40:47 <adamw> possibly.
15:40:51 <tflink> proposed #agreed - 741221 - AcceptedBlocker - The installer must be able to report failures to Bugzilla, with appropriate information included
15:40:56 <tflink> ack/nak/patch?
15:41:04 <adamw> yeah, looks ack-y.
15:41:11 <adamw> and re-assign to libreport.
15:41:25 * satellit_ in RC-2 Beta netinstall -last night-I was not able to send bug to bugzilla I could only save bug results locally. (gnome 3.1.92)
15:41:27 <tflink> proposed #agreed - 741221 - AcceptedBlocker - The installer must be able to report failures to Bugzilla, with appropriate information included. This needs to be re-assigned to libreport
15:41:38 <kparal> +1
15:42:22 <tflink> #agreed - 741221 - AcceptedBlocker - The installer must be able to report failures to Bugzilla, with appropriate information included. This needs to be re-assigned to libreport
15:42:49 <tflink> #topic (737093) [abrt] gjs-1.29.17-1.fc16: strcmp: Process /usr/bin/gjs-console was killed by signal 11 (SIGSEGV)
15:42:56 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=737093
15:43:53 <adamw> this is what happens when we take new upstreams as nth. grmph
15:44:19 <adamw> looks like they dropped all patches when bumping to 2.0.5.980 but that one got lost upstream...
15:44:35 * satellit_ https://bugzilla.redhat.com/show_bug.cgi?id=737093#c11
15:45:09 <kparal> satellit_: netinstall probably installed newer version from updates-testing
15:45:23 <satellit_> it worked
15:45:30 <tflink> what is the documents favorite?
15:45:39 <adamw> gnome-documents
15:45:40 <adamw> new app
15:45:47 <adamw> the easy fix for this is just to not have it in the Dash in beta
15:45:54 <adamw> i meant to propose this and get it fixed ahead of rc2 but forgot :(
15:45:58 * tflink doesn't see it in RC2 live
15:46:08 <adamw> anyone see it in rc2 dvd?
15:46:14 <adamw> if not, we're good...
15:46:20 <satellit_> yes but it fails
15:46:32 <tflink> nvm, it's there but just not on the favorites panel
15:46:39 <adamw> tflink: no, that matters
15:46:39 <tflink> and it crashes for me\
15:46:54 <adamw> it's only a beta blocker if it's on the Dash by default
15:47:00 <adamw> which I think is what you're calling the 'favorites'
15:47:16 <adamw> if it's only there by browsing through or searching the whole set of applications, it's a final blocker, not beta
15:47:33 <tflink> whatever the bar is that gets the apps added as "favorites" (far left in overview)
15:47:57 <adamw> right - which has, like, Firefox, install to hard disk, nautilus and whatever else as default, right?
15:48:04 <adamw> if that doesn't have Documents on it, we're good
15:48:04 * tflink realizes that he's missing a lot of terms for gnome-shell
15:48:24 <tflink> yeah, by default it has ff, evolution, rhythmbox, shotwell, files and install
15:48:50 <tflink> so -1 beta blocker, +1 final blocker for me
15:49:06 <adamw> for beta we only require 'elements of the default panel configuration' to work without crashimg
15:49:12 <drago01> the "bar" is called "dash"
15:49:16 <adamw> (i'd count the Dash in that as it basically replaces the quick launchers in an old panel)
15:49:27 <adamw> for final we require any app present on the menu system by default to at least pass a smell test
15:49:44 <drago01> whats the bug? (sorry just joined)
15:49:53 <adamw> gnome-documents insta-crashing
15:50:04 <drago01> ah ok
15:50:08 <adamw> it's a fairly well known bug, but as long as it's not in Dash by default in Beta, we're okay.
15:50:14 <tflink> proposed #agreed - 737093 - RejectedBetaBlocker, AcceptedFinalBlocker - gnome-documents isn't on the dash for Beta RC2 and therefore crashing isn't a beta blocker. However, it does hit the final criterion - "All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use. They must also have working Help and Help -> About menu items "
15:50:24 <tflink> ack/nak/patch?
15:50:28 <drago01> it should be ... (it is in the upstream default dash)
15:50:36 <jsmith> ACK
15:50:57 <kparal> ack
15:51:17 <drago01> wait
15:51:40 <drago01> it is supposed to be in the dash by default (if it isn't it is just a bug or an outdated shell build)
15:51:46 <drago01> what do we ship in the beta?
15:51:53 <adamw> drago01: 'outdated shell build', most likely
15:51:58 <adamw> beta does not have 3.1.92 and isn't going to be
15:52:00 <tflink> drago01: it isn't on the dash for the beta RC2 image I'm running
15:52:52 <tflink> running gnome-shell-3.1.91-2
15:52:53 <drago01> adamw: ok
15:53:41 <drago01> tflink: should be in 3.1.90
15:53:53 <adamw> pretty sure it wasn't.
15:54:09 <drago01> http://git.gnome.org/browse/gnome-shell/commit/?id=0133c6e174e705865adf97ed8cce11581d783c49
15:54:59 <satellit_> adamw: I do have it here on DVD RC2 Beta install to HD done last night 3.1.91
15:55:09 <adamw> satellit_: network repo enabled or not?
15:55:10 <adamw> ah.
15:55:14 <drago01> it would only not show up when 1) gnome-documents isn't installed or 2) update from previous build and same user
15:55:15 <adamw> i think we override the list in the live image
15:55:24 <satellit_> only DVD as repo
15:55:28 <adamw> but not on the DVD
15:55:36 <adamw> fedora-live-desktop.ks:favorite-apps=['mozilla-firefox.desktop', 'evolution.desktop', 'empathy.desktop', 'rhythmbox.desktop', 'shotwell.desktop', 'openoffice.org-writer.desktop', 'nautilus.desktop', 'anaconda.desktop']
15:55:50 <adamw> so if it's there in a DVD install...blocker.
15:55:50 <drago01> ah that explains it
15:56:45 <adamw> well, this is going to be funsies to fix.
15:56:52 * kparal will be back in 5
15:57:10 <tflink> I thought that the proposed fix was to just not have it on the dash for beta?
15:57:38 <adamw> tflink: yeah, but it'll be a bit tricky logistically
15:57:38 <satellit_> someone else has confirmed this ? on HD install
15:57:46 <adamw> as that will require a gnome-shell build lower than 3.1.92
15:57:55 * tflink can do an RC2 install in a bit
15:57:59 <adamw> satellit_: it sounds right: it's kinda what we'd expect
15:58:05 <satellit_> ok
15:58:20 <drago01> "remove from beta and add it later" isn't a fix imo
15:58:29 <drago01> the beta should be as close to final as possible
15:58:41 <adamw> drago01: that's not practical. it'd never be done.
15:58:47 <drago01> good
15:59:04 <adamw> as in, we would never be able to ship the beta. have you seen the delta of f16 'stable' vs. updates-testing atm>?
15:59:19 <tflink> proposed #agreed - 737093 - AcceptedBlocker - gnome-documents is on the dash by default for dvd installs and hits the beta criterion "No part of any release-blocking desktop's panel (or equivalent) configuration should crash or be entirely non-functional on boot of the installed system using default installation choices"
15:59:45 <drago01> adamw: no but I suspect it be rather large by now
16:00:14 <adamw> drago01: right. if we were trying to put all that stuff in the beta, it'd just be impossible. we have to freeze. the freeze periods have already been pared to the bone.
16:00:26 <adamw> tflink: ack
16:01:02 <drago01> adamw: my point was not "add everything from updates testing" but rather "don't pull random stuff out and add it post beta"
16:01:34 <tflink> drago01: other suggestions that don't involve pulling in a new gnome-shell et. al.?
16:02:06 <tflink> any other votes on the changed proposal?
16:02:10 <drago01> tflink: ping cosimoc / walters re gnome-documents crash and see whether it can be fixed in time or not
16:02:58 <adamw> drago01: it's not 'random stuff'. it's stuff that break the beta criteria.
16:03:10 <tflink> #info ping cosimoc / walters re gnome-documents crash and see whether it can be fixed in time or not
16:03:10 <drago01> adamw: also instead of doing hack builds ... you could just remove gnome-documents from the default install
16:03:13 <adamw> that were mostly written by the desktop team in the first place, and that dictate what's supposed to go into the release.
16:03:18 <drago01> (no conflict with updates-testing etc(
16:03:23 <adamw> drago01: yeah, that was what i just thought too.
16:03:58 <tflink> #agreed - 737093 - AcceptedBlocker - gnome-documents is on the dash by default for dvd installs and hits the beta criterion "No part of any release-blocking desktop's panel (or equivalent) configuration should crash or be entirely non-functional on boot of the installed system using default installation choices"
16:04:35 <tflink> #topic (708267) Fedora 15 cannot install as a DomU, Fails to find hard disk virtual device
16:04:42 <tflink> #link https://bugzilla.redhat.com/show_bug.cgi?id=708267
16:05:29 <tflink> since we talked about Xen earlier ...
16:06:15 <tflink> proposed #agreed - 708267 - RejectedBlocker - Xen DomU support is no longer a Beta criterion, will revisit if/when DomU support is accepted as a Final criterion
16:07:33 <adamw> ack
16:07:48 <tflink> it got quiet in here all of a sudden
16:07:56 <tflink> #agreed - 708267 - RejectedBlocker - Xen DomU support is no longer a Beta criterion, will revisit if/when DomU support is accepted as a Final criterion
16:08:11 <adamw> i think people are staging a silent protest against >1hr meetings =)
16:08:32 <maxamillion> Re: pkgdb test case action item --> https://fedorahosted.org/packagedb/ticket/223
16:09:31 * tflink proposes that we forgo discussion of the 2 re-opened blockers
16:09:40 <tflink> in the meeting, anyways
16:10:15 <tflink> maxamillion: thanks for the update
16:10:33 <adamw> tflink: fine by me
16:10:36 <adamw> actually...
16:10:42 <adamw> on the nfs ISO one, we probably need a bit more testing
16:11:03 <maxamillion> tflink: certainly, sorry for the delay ... I'm attempting to multitask and hitting a lot of context switching overhead :X
16:11:10 <tflink> maxamillion: no worries
16:11:37 <tflink> adamw: I can try that out today
16:11:52 <adamw> tflink: awesome, thanks
16:12:02 <tflink> other than that ...
16:12:03 <adamw> i'm gonna work the new acceptedblockers
16:12:10 <tflink> #topic Open Discussion
16:12:20 <tflink> adamw: are you playing secretary or am I?
16:12:36 <tflink> #info pkgdb test case action item --> https://fedorahosted.org/packagedb/ticket/223
16:12:45 <adamw> tflink: i've done a few
16:13:54 <tflink> ok, since pretty much everyone has disappeared ... fuse set for 2 minutes
16:14:44 <kparal> not disappeared, just switched to read-only mode :)
16:15:15 <tflink> kparal: will keep that in mind next time we need ack/vote :)
16:15:29 <tflink> ok, thanks for coming everyone!
16:15:34 * tflink will send out minutes shortly
16:15:37 <tflink> #endmeeting