kde-sig
LOGS
15:08:33 <jreznik> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2011-09-20
15:08:33 <zodbot> Meeting started Tue Sep 20 15:08:33 2011 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:08:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:08:38 <jreznik> #meetingname kde-sig
15:08:38 <zodbot> The meeting name has been set to 'kde-sig'
15:08:43 <jreznik> #topic roll call
15:08:50 * rnovacek is here
15:08:54 <jreznik> who's present today?
15:10:17 <Kevin_Kofler> Present.
15:10:35 <rdieter> here (1/2)
15:10:40 <jreznik> #chair jreznik rnovacek rdieter Kevin_Kofler
15:10:40 <zodbot> Current chairs: Kevin_Kofler jreznik rdieter rnovacek
15:11:04 <jreznik> #info jreznik rnovacek Kevin_Kofler present, rdieter semi-present
15:11:55 * rdieter going afk for ~10 min, though fyi, got f15/kde-4.7.1 builds ready to push to kde47 repo *real soon now*
15:13:04 <jreznik> #topic agenda
15:13:20 <jreznik> #info rdieter got f15/kde-4.7.1 builds ready to push to kde47 repo *real soon now*
15:14:02 <Kevin_Kofler> Update on the regressions on the kde-4.7 and qt-4.8 trackers.
15:15:33 <Kevin_Kofler> Showing folderview by default (putting this up again, because we still don't have another way to show liveinst on the desktop by default, it's not shown on the Alpha and Beta :-( ).
15:16:07 <rnovacek> I have tested kdepim with sqlite akonadi backend
15:16:27 <Kevin_Kofler> And, does it work properly?
15:16:33 <Kevin_Kofler> Or should we switch back to MySQL?
15:16:44 <rnovacek> I eats less ram
15:16:50 <jreznik> fedora wiki page guru meditation time again :)
15:17:18 <rnovacek> but it seems it eats more cpu on the other hand
15:17:18 <jreznik> both added to agenda
15:17:31 <jreznik> rnovacek: even more cpu??? is it possible? :)
15:18:21 <rnovacek> It seems to me, no exact testing
15:18:42 <Kevin_Kofler> Of course it does.
15:18:49 <rnovacek> just looking at stats in system activity
15:18:53 <Kevin_Kofler> Upstream warned us all the time that SQLite is slower.
15:19:01 <Kevin_Kofler> Slower also means more CPU time is needed to do the same thing.
15:19:22 <Kevin_Kofler> IMHO we should revert the default to MySQL as recommended by upstream.
15:19:56 <rnovacek> I think it usable for livecd (if noone will try to load mailbox there)
15:20:11 <rnovacek> but mysql is better for normal desktop usage
15:20:57 <jreznik> #topic akonadi mysql/sqlite backends
15:21:09 <jreznik> but we still don't have runtime selection, do we?
15:21:48 <rnovacek> jreznik: patch is here: http://rnovacek.fedorapeople.org/kdepim-runtime-4.7.0-sqlite-support.patch
15:21:49 * rdieter is still of the opinion of using the more conservative sqlite backend by default, and continue work on easier runtime selection
15:22:22 <rdieter> rnovacek: woo!
15:22:54 <Kevin_Kofler> The conservative option is using what we have used in all previous releases and what upstream recommends.
15:22:58 <Kevin_Kofler> (i.e. MySQL)
15:23:08 <rnovacek> it was easy one, just add gui option, support for sqlite is there
15:23:20 <jreznik> rnovacek: upstreamed?
15:23:26 <rnovacek> no
15:23:30 <rdieter> rnovacek: so, runtime selection works?
15:23:52 * jreznik is in favour of having virtuoso backend not to run two servers in time...
15:23:57 <rnovacek> rdieter: yes, of course it needs akonadi restart
15:24:13 <rdieter> if that patch works as advertised, I am a-ok with: 1.  switching back to mysql default  2.  modify live image to (still) use sqlite
15:24:35 <jreznik> rdieter: +1
15:24:40 <rnovacek> rdieter: +1
15:25:04 <rdieter> it also allows enterprises to set site-defaults too (yay)
15:26:02 <rdieter> that's an assumption my part, rnovacek ^^ , is there a akonadi*rc key to set to toggle this?
15:27:41 <rnovacek> rdieter: yes, can't recall where, but there is configuration option for that
15:28:12 <rdieter> ok, I'll test that.  that's what is sorely needed (@ my site anyway)
15:29:29 <rdieter> rnovacek: can you apply that patch to our kdebase-runtime builds for testing?
15:29:54 <rnovacek> rdieter: sure, f16 and rawhide?
15:30:02 <rdieter> yes
15:30:34 <rdieter> once we have it in, I'd like to test it out a bit.  If all checks out, I'll revert the akonadi backend default back to mysql
15:32:28 <jreznik> makes sense
15:35:42 <jreznik> ok, let's move on - we can talk about default once we know how it behaves
15:35:54 <rnovacek> rdieter: In ~/.config/akonadi/akonadiserverrc, section [eneral], key Driver, values QSQLITE or QMYSQL
15:36:24 <jreznik> #info rnovacek prepared patch for runtime db backend selection
15:36:44 <jreznik> #info proposal: 1.  switching back to mysql default  2.  modify live image to (still) use sqlite
15:36:45 <rdieter> rnovacek: sure, I'll test setting that globally, and see if that properly affects all new user setups
15:37:21 <jreznik> #info it's possible to set defaults in akonadiserverrc ( section [eneral], key Driver, values QSQLITE or QMYSQL)
15:37:48 <rdieter> [%General]
15:38:08 <rdieter> (careful of irc/konversation escaping the %)
15:38:18 <jreznik> ah
15:38:21 <jreznik> sorry
15:38:59 <jreznik> #topic Update on the regressions on the kde-4.7 and qt-4.8 trackers
15:42:12 <jreznik> any news on topic? sorry, I was busy with a different stuff
15:42:48 <jreznik> I'm aware of QXL driver issue, should ping the Spice guys internally
15:43:34 <rdieter> Kevin_Kofler triaged the 'kwrite/kate' settings thing to Qt, seems to be some font/harfbuzz thing
15:44:10 <Kevin_Kofler> Right.
15:44:16 <Kevin_Kofler> I linked to the upstream QTBUG.
15:44:22 <Kevin_Kofler> I also closed stuff which is already fixed.
15:44:45 <Kevin_Kofler> There are no known KDE 4.7 regressions left.
15:44:50 <Kevin_Kofler> On the Qt 4.8 tracker, we have:
15:45:03 <Kevin_Kofler> * the aforementioned Kate settings crash
15:45:28 <Kevin_Kofler> * the virtualization issue, where we still don't know whether Qt has anything to do with it or whether it's just a driver regression
15:45:47 <Kevin_Kofler> * a Qt Mobility FTBFS, already fixed in upstream git, I linked to the commits
15:46:12 * rdieter will try to include the qt-mobility fix(es) today (or soon at least)
15:48:51 * jreznik will try to ping Spice guys (already tried but not driver devels, just on-site QA guys for opinion...)
15:50:05 <jreznik> anything else?
15:50:20 * jreznik still believes in qt 4.8 rc soon...
15:51:15 <jreznik> anything else?
15:51:34 <jreznik> #info there are no known KDE 4.7 regressions left.
15:51:47 <Kevin_Kofler> For the fonts, in the upstream bug, there seems to be some hint at how it could be fixed.
15:51:54 <rnovacek> what about that folderview default?
15:51:55 <Kevin_Kofler> I'll have to see if it's enough to produce a patch.
15:52:08 <jreznik> #info qt 4.8:  Kate settings crash, the virtualization issue and qt-mobility FTBFS
15:52:14 <Kevin_Kofler> rnovacek: That's the next topic.
15:52:31 <rnovacek> ah, sorry
15:52:39 <jreznik> #action rdieter to try to include the qt-mobility fix(es) today (or soon at least)
15:53:07 <jreznik> #action jreznik to  try to ping Spice guys for virt. issue
15:53:18 <jreznik> #topic folderview by default
15:54:07 <Kevin_Kofler> So our live images still don't show a liveinst by default.
15:54:13 <Kevin_Kofler> (on the desktop)
15:54:14 <Kevin_Kofler> This sucks.
15:54:33 <rdieter> why not?  are we missing something?  a bug/failure in the kickstart?
15:54:35 <Kevin_Kofler> IMHO, we should really reenable the folderview by default for F16, the necessary change is already in kde-settings SVN.
15:54:48 * rdieter thought we already agreed to do that
15:54:52 <Kevin_Kofler> rdieter: Because there's no plasmoid to display it.
15:55:10 <rdieter> sorry, I thought we'd already agreed to reenable folderview.
15:55:15 <Kevin_Kofler> We can revisit the issue for F17 if people really like the blank desktop.
15:55:20 <rdieter> so, it's just a matter of it not getting done yet?
15:55:36 <Kevin_Kofler> It's a matter of some folks having said they'd rather the desktop stayed blank by default.
15:55:45 <Kevin_Kofler> The problem is that that hides liveinst, too.
15:55:57 <rdieter> didn't we already have this discussion?
15:56:48 <jreznik> folderview for f16
15:57:01 <rdieter> I could be misremembering, but adding the single folderview is mostly harmless, imo.  not having it is problematic (as seen here, for various reasons)
15:57:48 * Kevin_Kofler will push a kde-settings with the folder view by default and with the settings part of the KDM system users fix.
15:57:57 * rdieter doesn't hear any dissenters... :) so, looks like we have 2 additions to make to kde-settings now:  kdm min UID, +folderview (already in svn)
15:58:03 <Kevin_Kofler> It's too late for the Beta, I guess, but at least for the Final it'll be fixed.
15:58:29 <rdieter> we could try to push for beta, but it'd be a hard-sell
15:58:35 <rdieter> so yeah
15:59:26 <Kevin_Kofler> Speaking of stuff fixed post-beta, I fixed #723987, system-config-printer-kde should work again in the 4.7.1 builds.
15:59:48 <Kevin_Kofler> (That was one of the kde-4.7 regressions, it's closed now.)
16:00:26 <rdieter> Kevin_Kofler: yay!
16:02:54 <Kevin_Kofler> Auth is still broken, so it's still root-only.
16:03:03 <Kevin_Kofler> But in 4.7, there's at least a placeholder for auth.
16:03:08 <Kevin_Kofler> But the actual authentication is disabled.
16:03:23 <rdieter> oh. :(
16:03:24 <Kevin_Kofler> And I'm not sure why the cups-pk-helper authentication is disabled, we'll have to see what happens if we enable it.
16:03:42 <Kevin_Kofler> Authentication is also missing where the GTK+ version pops up a dialog (which is in 2 places).
16:03:53 * rdieter still argues not shipping something known-broken
16:03:59 <Kevin_Kofler> The dialogs need porting, but cups-pk-helper should just work, so I'm not sure why it got commented out.
16:04:09 <Kevin_Kofler> Well, it's not broken with the root-only patch.
16:04:18 <Kevin_Kofler> It just requires running the whole thing as root, which is not so nice.
16:05:34 <Kevin_Kofler> That said, we really need to have another look at the printer manager (and applet) in C++, see whether it's shippable, and if not, what is missing.
16:06:20 * rdieter still thinks it more than a little sad that fedora ships a fine, working system-config-printer, well-maintained *in house*
16:06:43 <rdieter> while we stick with something that only half-works
16:11:24 <Kevin_Kofler> Anything else?
16:11:28 <rdieter> yes, we've had this discussion before here and without other tools.  things eventually brightened for other things like kpackagekit, knetworkmanager ... but, the future of system-config-printer-kde is not so bright, and it's days are numbered. and  kde upstream isn't supporting it all that well anyway.
16:11:30 <Kevin_Kofler> We're already over time.
16:11:37 <rdieter> oh, rats
16:11:45 <nucleo> is there progress on disabling Nepomuk on LiveCD?
16:11:50 <Kevin_Kofler> rdieter: IMHO, the C++ one is the way to go.
16:11:52 <rdieter> we'd better end asap. have another meeting to go to.
16:11:54 <nucleo> and warnings
16:12:17 <rdieter> nucleo: didn't we already decide on a course of action?  (or no?)
16:12:21 <Kevin_Kofler> We really need to check what's missing in it and fix it ourselves, or get other distro folks to fix it.
16:12:39 * jreznik should end the meeting here... as he's now leading board meeting...
16:12:48 <Kevin_Kofler> dannti (who wrote it) is already swamped with Apper, unfortunately. :-(
16:12:49 <rdieter> jreznik: i'll be there in a sec
16:13:34 <Kevin_Kofler> Re Nepomuk, we kinda agreed, but nobody is actually implementing it.
16:13:37 <jreznik> please move discussion to #fedora-kde, I'm going to end it here...
16:14:03 <rnovacek> nucleo: I have a patch for disabling that warning, but it seems to don't work
16:14:06 <Kevin_Kofler> Yeah, let's close the meeting here, time's up…
16:15:07 <jreznik> thanks guys
16:15:11 <jreznik> #endmeeting