fesco
LOGS
16:59:43 <nirik> #startmeeting FESCO (2011-08-22)
16:59:43 <zodbot> Meeting started Mon Aug 22 16:59:43 2011 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:43 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:59:43 <nirik> #meetingname fesco
16:59:43 <zodbot> The meeting name has been set to 'fesco'
16:59:43 <nirik> #chair notting nirik ajax cwickert mjg59 mmaslano t8m pjones sgallagh
16:59:43 <nirik> #topic init process
16:59:43 <zodbot> Current chairs: ajax cwickert mjg59 mmaslano nirik notting pjones sgallagh t8m
16:59:52 <pjones> holla
17:00:04 <nirik> morning everyone.
17:00:24 * cwickert is here
17:00:37 * notting is here
17:00:50 <pjones> mjg59 said he probably wouldn't be able to make it.
17:01:10 * sgallagh bows formally
17:01:36 <nirik> ok. I think we have enough folks to start... not too much on the agenda today, so hopefully a short meeting.
17:01:49 <nirik> #topic ticket 659 Sponsor Request: "Miroslav Suchý" <msuchy@redhat.com>
17:01:50 <nirik> .fesco 659
17:01:51 <zodbot> nirik: #659 (Sponsor Request: "Miroslav Suchý" ) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/659
17:02:04 <nirik> this was kicked back to us based on a -1 from a sponsor...
17:02:15 <sgallagh> nirik: What was the reasoning?
17:02:34 <notting> did the mail not come through?
17:02:36 <nirik> the feedback was forwarded to fesco folks... so you should be able to read it yourself. ;)
17:03:06 <nirik> basically the issue was that they had imported srpms in the past that stomped on local changes (like mass rebuild changelog entries).
17:03:12 <sgallagh> Ah sorry. Ended up in my spam folder
17:03:44 <nirik> Personally, I am +1 here, with the addition of asking them to be careful not to import over changes moving forward.
17:04:21 * pjones does not see that email
17:05:27 <sgallagh> It sounds like his packaging skills are fine (which is the primary responsibility of a sponsor)
17:06:03 * cwickert is not fully convinced
17:06:42 <pjones> I think he's effectively sponsoring people anyway, which is more than most people are doing.
17:07:01 <cwickert> ?
17:07:06 <gholms> What does that mean?
17:07:34 <pjones> in that people are going to him to get packaging help and he's giving it to them
17:07:49 <cwickert> a lot of people are doing that
17:07:57 <cwickert> no need to be a sponsor IHMO
17:08:03 <pjones> true.
17:09:18 <cwickert> what still worries me is this mass package ownership. I mean, we all agree it was a mistake and it was revoked, however people from Brno then granted him commit access for all their packages.
17:09:18 <nirik> I'll note that feedback was overall positive... just one -1.
17:09:47 <cwickert> and they did that because it was a business decision to say so
17:09:51 <nirik> hum?
17:09:59 <nirik> cwickert: I think you are confusing him with someone else.
17:10:03 <nirik> he owns 36 packages.
17:10:09 <pjones> cwickert: shared ability and shared responsibility aren't the same thing, though.  what we had before was the latter, and we didn't like it because if everybody's responsible, no one is.
17:10:11 <cwickert> erm, let me look
17:10:19 <pjones> also what nirik said ;)
17:10:27 <nirik> mostly spacewalk stuff.
17:10:51 <nirik> also, if a maintainer wishes to add a co-maintainer, I think thats great. ;)
17:11:03 <cwickert> ok, right, I confused Miroslav with petr
17:11:08 <pjones> yeah, not seeing the downside.
17:11:26 * pjones thinks he's +1 on this, though still hasn't seen the aforementioned email.
17:11:52 <cwickert> the only thing that remains is overwriting previous commits, but this was caused by his tool. I think his tool is good after all, just needs a little fix
17:11:55 <cwickert> so I am +1
17:11:56 <notting> pjones: forwarded directly
17:12:00 <sgallagh> pjones: I just forwarded it to you
17:12:03 <sgallagh> heh
17:12:18 * sgallagh is also _1
17:12:21 <sgallagh> err +1
17:13:16 <pjones> yeah, I'm not seeing that -1 as a showstopper.  It'd be nice if they fixed it in their tool, but... meh.
17:13:52 <notting> i am +1 too
17:13:53 * nirik sees +4 so far.
17:14:00 <nirik> ok, +5. :)
17:14:11 <nirik> #agreed The sponsorship request is approved.
17:14:22 <nirik> #topic Open Floor
17:14:28 <nirik> any items for open floor?
17:15:18 <sgallagh> nirik: Should we discuss the systemd auto-start features?
17:15:27 <sgallagh> I notice that it's been up for discussion on the list
17:15:35 * nirik would like to thank everyone who worked hard on getting Alpha out.
17:15:58 <nirik> sgallagh: well, we could, but do we want to just have a general discussion? or wait until there are more specific things to address?
17:16:28 <nirik> or perhaps someone could cull out what we need to clarify/decide from the list?
17:16:32 <sgallagh> nirik: Well, it sounds like the current policy of "do not use socket activation" is not sitting well with some folks
17:16:43 <sgallagh> I think the specific example was CUPS
17:16:57 <nirik> well, it's not that tho. It's do not use socket activation unless your service is allowed to start by default, right?
17:17:18 <nirik> #topic Systemd discussion
17:17:51 * sgallagh probably needs to reread.
17:18:12 <nirik> https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd#Socket_activation
17:18:22 * notting was out friday and in meetings this morning, and needs to catch up on the thread
17:18:54 <sgallagh> Yeah, I admittedly only skimmed it (I was at a conference most of last week)
17:19:04 <kalev> I think the problem is that some folks understand the paragraph as 'do not use socket activation unless your service is allowed to start by default', and others (the ones that were complaining) as 'do not use socket activation without FESCo's explicit permission'
17:19:14 <nirik> so, perhaps we could get someone to cull the thread and summarize issues to be addressed?
17:19:53 <nirik> kalev: well, they amount to the same thing in the end as fesco adjusts the list of what can start by default. ;)
17:20:39 <sgallagh> nirik: Ok, I guess that should be my job, since I brought this up.
17:21:07 <sgallagh> I will read through it all and raise any concerns for the next meeting
17:21:19 <nirik> sgallagh: that would be great if you have time. ;) Perhaps file a ticket for issues/ideas we could use to adjust things...
17:21:57 <sgallagh> nirik: I'll see what I can do
17:22:25 <nirik> #action sgallagh to look at summarizing/collecting ideas from the devel thread.
17:23:04 <nirik> sgallagh: you are also ok with chairing on 2011-08-29?
17:23:38 <sgallagh> Yes
17:24:22 <nirik> #info sgallagh to chair on 2011-08-29 meeting.
17:24:28 <nirik> #topic Open Floor again
17:24:32 <nirik> any further open floor items?
17:24:37 * gholms raises hand
17:25:00 <nirik> gholms: fire away
17:25:21 <gholms> kkofler raised an interesting point on the devel list: stable f16 as a whole gets very little continuous testing.
17:25:55 <gholms> Since everyone has updates-testing turned on the only time stable actually gets tested is when composes are done and when we hit RC.
17:25:56 <nirik> well, it gets a lot before alpha/beta.
17:26:34 <gholms> And even then, after one installs an alpha or a beta the next yum update pulls in all of updates-testing anyway.
17:26:47 <nirik> yes, it's a balancing act...
17:27:03 <nirik> if we disable updates-testing, someone installs Alpha and gets no updates until Beta?
17:27:05 <gholms> Yeah, it just seems... odd to me that nobody really runs stable.
17:27:29 <gholms> Well, the alternative would be pulling from f16 updates but not f16 updates-testing.
17:27:45 <gholms> I'm not saying that that's necessarily the way to go, but it might be worth considering.
17:27:48 <nirik> there is no f16 updates until right near release time. ;)
17:27:57 <notting> you mean just pull from the branched repo
17:28:00 <gholms> Yeah
17:28:07 <gholms> Sorry
17:29:19 <gholms> Any thoughts?  I'm kind of just throwing this out there to see what you all think.
17:30:05 <nirik> dunno. I guess my first thought is that most everyone who installs alpha/beta/rc's/etc would just enable updates-testing anyhow... but I could be wrong.
17:30:34 <gholms> Personally, I wouldn't for an RC but I would for a beta.
17:31:41 <nirik> I guess this might be something to discuss at a 'f16 retrospective' type meeting? and see where we can adjust for f17?
17:32:13 * gholms looks around, listens to the crickets
17:32:22 <notting> yeah. i can see the benefits for  this, but it's not something we can change in midstream
17:32:50 <sgallagh> I can't really see anyone turning off updates-testing
17:33:04 <sgallagh> Except to specifically test right before a release
17:33:42 <nirik> well, I could see some less involved folks doing so to get less rate of change/etc... but should those people be using a alpha/beta release anyhow?
17:33:57 <sgallagh> Exactly
17:35:10 <sgallagh> But I agree that there's nothing to change for F16. We can talk about it when we start planning F17
17:35:39 <gholms> Works for me. Thanks.
17:36:27 <nirik> thanks for bringing it up gholms
17:36:44 <nirik> #info Will talk about disabling updates-testing for f17 cycle when we get to a f16 retrospective.
17:36:48 <nirik> ok, anything else?
17:37:02 <sgallagh> What about https://fedorahosted.org/fesco/ticket/660 ? :)
17:37:14 <gholms> Heh
17:37:38 <pjones> I dunno, that guy's kinda fishy
17:37:43 <notting> that doesn't need to come to the meeting
17:38:08 <sgallagh> notting: Ok, just asking
17:38:16 <nirik> no -votes, no need to be in the meeting. ;)
17:38:20 <sgallagh> pjones: only "kinda"? I'll get on that
17:38:29 <nirik> your bribes must have worked, everyone seems to like you? ;)
17:38:56 * nirik will close out the meeting in a minute if nothing else comes up.
17:40:07 <nirik> thanks for coming everyone!
17:40:11 <nirik> #endmeeting