kde-sig
LOGS
15:06:57 <rdieter> #startmeeting kde-sig
15:06:57 <zodbot> Meeting started Tue Aug 16 15:06:57 2011 UTC.  The chair is rdieter. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:57 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:07:04 <rdieter> #meetingname kde-sig
15:07:04 <zodbot> The meeting name has been set to 'kde-sig'
15:07:10 <rdieter> #topic roll call
15:07:18 <rdieter> hi, who's present today?
15:07:23 * rnovacek is here
15:07:31 <rdieter> Kevin_Kofler, than, ltinkl, jreznik : ping
15:07:34 * ltinkl is here
15:09:05 * than is here
15:09:07 <Kevin_Kofler> Present.
15:09:50 <rdieter> #info rdieter rnovacek ltinkl than Kevin_Kofler present
15:10:07 <rdieter> jreznik just dropped off irc, hopefully will be back soonish
15:10:17 <rdieter> #topic agenda
15:10:29 * jreznik is here, sorry, had to restart konvi
15:10:40 <rdieter> #info jreznik present now too
15:10:41 <rdieter> yay
15:11:08 <rdieter> topic 1: hopefully finalize kde47/f15 topic
15:11:18 <rdieter> any other items for today?
15:12:21 <Kevin_Kofler> Maybe we want to discuss the default widgets to show in Plasma?
15:12:21 <than> rdieter: package splits status
15:12:25 <Kevin_Kofler> Upstream's default is now blank.
15:12:44 <Kevin_Kofler> We sorta agreed to show at least a folder view, I implemented this in kde-settings SVN, but haven't built it yet.
15:13:00 <rdieter> ok
15:13:23 <rdieter> #topic package splits status
15:13:40 <jreznik> another topic - f16 image testing
15:13:44 <Kevin_Kofler> So there's kdeedu which is split upstream but still packaged monolithically.
15:14:11 <Kevin_Kofler> And kdeedu upstream actually spoke up to ask for split packaging. So the current state is quite inconsistent.
15:14:25 <Kevin_Kofler> I don't like the split packaging, but we should at least do it consistently…
15:14:32 <than> Kevin_Kofler: +1
15:14:49 <rdieter> <nod>, since we kinda already split it a little, but build monolithically, and nothing was broke (yet), I hadn't worked on that one
15:14:58 <rdieter> I can though.
15:15:24 <rdieter> unless someone else is interested to do so? :)
15:15:52 <rdieter> #info kdeedu is currently split inconsistently, especially with respect to how upstream does it now
15:16:13 <rdieter> #action rdieter to work on kdeedu packages to match upstream splits
15:16:18 <rnovacek> I started to split it but not finish http://fedoraproject.org/wiki/SIGs/KDE/KDE47Packaging
15:16:35 <rdieter> oh wow,nice!
15:17:15 <rdieter> rnovacek: thanks
15:17:40 <rnovacek> I can continue, but I'm kinda busy there days
15:17:45 <rnovacek> *these
15:18:29 <rdieter> I've had some practice, can probably whip it out pretty quick (if I find some spare time).
15:18:42 <rdieter> anything else, split-wise?
15:18:55 <than> kdebindings?
15:19:34 <than> it seems it is not complete done yet
15:19:51 <than> perl-qt/perl-kde still missing
15:20:04 <rdieter> true, another nice-to-have
15:20:19 <jreznik> than: is there any actual user using it?
15:20:33 <rdieter> though i'm not personally motivated much to work on those bindings stuff. :-/
15:20:37 <than> jreznik: good question!
15:20:54 <Kevin_Kofler> IIRC, somebody filed a bug asking for perl-qt to be packaged, it got closed when perl-qt became part of kdebindings.
15:20:59 <rdieter> I verified awhile back there are no packages using it (dependency-wise anyway)
15:21:05 <Kevin_Kofler> Hmmm, or was that php-qt, actually?
15:21:19 <Kevin_Kofler> I think php-qt was already dropped from kdebindings a while ago, wasn't it?
15:21:30 <than> Kevin_Kofler: i think so
15:21:34 <rdieter> Kevin_Kofler: yes and no.  4.6 still had it, but 4.7 dropped I think
15:21:36 <Kevin_Kofler> And now perl-* vanished, too. :-(
15:21:59 <Kevin_Kofler> Or am I mixing things up?
15:22:09 <Kevin_Kofler> With all those bindings and languages, I tend to get confused. :-(
15:22:18 <Kevin_Kofler> The names all starting with 'p' doesn't help either. ;-)
15:22:42 <jreznik> python is the must, ruby is nice to have, other bindings are far from our priority
15:22:47 <than> i don't care about perl-qt/perl-kde
15:22:54 <jreznik> but as upstream releases it, we should have packaged it
15:23:05 <Kevin_Kofler> So what bindings is upstream releasing now?
15:23:07 <than> but we should have ruby*
15:23:07 <rdieter> agreed, probably ought to do ruby, anyone working or started on that one yet?
15:23:17 <jreznik> rdieter: than started
15:23:25 <than> rdieter: i'm working on it
15:23:27 <Kevin_Kofler> Python, Ruby, C#, Perl?
15:23:38 <jreznik> I was at BDS but vondruch promised review as ruby stack maintainer
15:23:56 <jreznik> not sure about current status, my email is screwed again (searchin google for it)
15:24:01 <Kevin_Kofler> AFAIK, the C# bindings are actually well-maintained too and there's at least 1 app out there using them, though I don't know what it is.
15:24:05 <Kevin_Kofler> It's not in Fedora in any case.
15:24:49 <rdieter> cool.
15:25:04 <Kevin_Kofler> FWIW, the C# bindings can actually also be used with other Mono languages, including MonoBasic (a.k.a. VB.NET).
15:25:09 <rdieter> so we have pykde4, + ruby on the way is a good start.  anything beyond that would be nice too
15:25:21 <jreznik> .bug 727780
15:25:26 <zodbot> jreznik: Bug 727780 Review Request: qt-ruby - Ruby bindings for Qt 4 - https://bugzilla.redhat.com/show_bug.cgi?id=727780
15:25:27 <Kevin_Kofler> But since everyone (including me ;-) ) hates Mono…
15:25:35 <rdieter> jreznik: thanks
15:26:14 <rdieter> #info kdebindings splits still need some work, pykde4 done, ruby on the way (bug #727780)
15:29:16 <rdieter> move on?
15:30:11 <rdieter> #topic f16/kde47 default plasma layout/widgets
15:30:32 <rdieter> turns out upstream ships with a blank desktop now (ie, no folderview)
15:30:55 * than likes it!
15:31:04 <rdieter> Kevin_Kofler implemented shipping a default containment that is pretty much the same as before, with a default folderview at least
15:31:21 <rdieter> 1.  anyone object to restoring a folderview by default?
15:31:35 <rdieter> 2.  any other widgets we should consider changing or adding?
15:31:37 <Kevin_Kofler> It's basically the previous upstream default, except that the changes to panel setup from 4.7 are also in there.
15:32:15 <than> i always remove the folderview from desktop
15:32:22 * Kevin_Kofler still thinks we should ship a folderview as the containment, à la 3.5. :-)
15:32:23 <than> but it's just me
15:32:40 <jreznik> than: me too
15:32:42 <Kevin_Kofler> No folder view also means no installer on the desktop.
15:32:42 <rdieter> than: sure, the folderview there is where we put installer links and such on the live image
15:32:47 <jreznik> but we need it for installer
15:33:04 <rdieter> but gnome/desktop have already dealt with that in other ways, since they no longer have icons on desktop either
15:33:09 <Kevin_Kofler> Though we could ship a different setup for liveuser.
15:33:20 <jreznik> Kevin_Kofler: +1
15:33:43 <Kevin_Kofler> I still think the desktop folder ought to be shown.
15:34:01 <rnovacek> I think there should be some widgets, to make new users notice that we have something like widgets
15:34:19 <rdieter> by shipping our own default layout, we also won't get surprised by upstream changes either (but it means we ought to keep a close eye on upstream changes too)
15:35:01 <Kevin_Kofler> Now of course, if the gnomies go through with their plan to neuter xdg-user-dirs' concept of ~/Desktop, then there might actually be no desktop folder to show anymore. :-/
15:35:01 <ltinkl> I don't like the folderview on the desktop, unless it's for the live installer
15:35:58 <than> i think we just follow upstream here
15:36:00 * rnovacek don't use folderview too, but I'm +1 for not removing it
15:36:20 <rnovacek> some users just want icons on desktop
15:36:31 <than> rnovacek: +1
15:36:35 <Kevin_Kofler> My proposal is to make the folder view the default containment.
15:36:40 <rdieter> let me put it this way, for those who don't want folderview, you willing to work to fix the issues caused by it's removal? :)
15:36:52 <Kevin_Kofler> Then they have the icons directly ON the desktop.
15:36:53 <jreznik> rnovacek: so Kevin_Kofler proposal then makes sense
15:37:05 <Kevin_Kofler> But alternatively, the current solution also works.
15:37:11 <Kevin_Kofler> I think removing the icons altogether is a bad move.
15:37:22 <Kevin_Kofler> A blank desktop is just wasted space.
15:38:26 <than> Kevin_Kofler: +1
15:38:37 * rdieter has no strong feelings either way wrt to including foldeview or not.  more hesitant to change to folderview containment though
15:39:16 * jreznik has never used icons on desktop but he will accept any solution... maybe ask users first?
15:39:18 <rnovacek> Kevin_Kofler: are you suggesting have folder view layout of desktop (no widgets and icons everywhere)?
15:39:23 <jreznik> they are going to use it...
15:39:25 <rdieter> my preference is:  1.  keep folderview by default or 2. follow upstream and keep it essentially blank
15:39:38 <Kevin_Kofler> rnovacek. Yes, that's my suggestion.
15:39:51 <Kevin_Kofler> We could try to poll our users, but where?
15:40:12 <jreznik> Kevin_Kofler: fedora-kde ml
15:40:24 <jreznik> not all users but the real core users :)
15:40:42 <rnovacek> jreznik: you can try facebook poll :)
15:41:12 <rnovacek> 93 people following us on facebook
15:41:14 <jreznik> rnovacek: Kevin_Kofler would kill me :)
15:41:36 <rnovacek> so both ml and facebook?
15:43:18 <Kevin_Kofler> Now when we look at my personal use, I don't use the folder view all that much, in fact on my notebook I don't even have one because I don't have anything in there, on this desktop, I have some legacy icons I never use. ;-)
15:43:31 <Kevin_Kofler> My problem is, my desktop is always covered by maximized windows.
15:43:32 <jreznik> Kevin_Kofler: same for me
15:43:37 <Kevin_Kofler> So having icons on it is not so useful.
15:43:43 <rdieter> I'd suggest phrasing it more for some feedback about defaults, rather than as a poll per-se, and providing examples like considering a default foldeview containment...
15:44:36 <jreznik> rdieter: best solution
15:44:59 <Kevin_Kofler> Whatever we do, we should make sure liveinst is easily accessible for liveuser.
15:45:05 <rdieter> yup
15:45:08 <Kevin_Kofler> Either in a folder view or as an icon plasmoid.
15:45:28 <Kevin_Kofler> (It's possible to put it straight into a default desktop containment using the good old 4.0-era icon plasmoid.)
15:45:47 <Kevin_Kofler> It's just not really recommended, but it'd be good enough for that purpose, if it's only that 1 icon.
15:46:39 <rdieter> it's 1 icon, for 1 specialized (live) user.  that's ok for me too.
15:47:17 <rdieter> either way, who wants the job of soliciting feedback from users ?
15:48:39 * Kevin_Kofler is maily worried about all the negative "omg kde is like gnome 3 they stole my desktop icons halp!!!!!!!!!111111111!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!" press…
15:49:05 <rdieter> there's that too, but at least we/kde add easily add it back
15:49:08 * Kevin_Kofler remembers some complaints of that kind in 4.0.0 times, which lead to the rushed introduction of that icon plasmoid, and then to the folder view.
15:49:24 <rdieter> can easily add it back, rather.
15:50:15 <rdieter> #info consider soliciting feedback from users on ml and facebook about desktop defaults, providing examples like considering a default foldeview containment
15:50:25 <rdieter> moving on , getting short on time
15:50:27 <Kevin_Kofler> s/maily/mainly/ FWIW
15:50:40 <rdieter> #topic kde-4.7 for f15
15:51:04 <rdieter> a few folks were absent last week when we discussed the topic of considering an official kde47 update for f15
15:51:28 <rdieter> at the time, most were leery of doing it this time, largely due to kdepim-4.7/kmail2
15:51:31 <Kevin_Kofler> So IMHO we should do that, but without the kdepim stuff.
15:51:37 <Kevin_Kofler> (and keep kdepim 4.4.x)
15:51:46 <rdieter> turns out, it is possible to ship kde-4.7.x sans kdepim
15:51:50 <rdieter> right
15:52:00 <rdieter> would doing that change anyone's mind?
15:52:08 <Kevin_Kofler> For packaging, we can do monolithic or split. The main problem I have with split is that kdebindings is missing some pieces still…
15:52:32 <Kevin_Kofler> Now I don't know if anyone is actually using them, but they'd be stuck without an upgrade path. :-(
15:52:47 <ltinkl> I'm ok with doing an official KDE 4.7 update but certainly without kmail2... after seeing it live on jreznik's PC yesterday xD
15:53:00 <Kevin_Kofler> Otherwise, split shouldn't be a real problem if the metapackages are set up properly.
15:53:32 <jreznik> monolithic = we have to take care about two different beasts (and we don't have monolithic kdebindings for example)
15:53:44 <jreznik> split = a lot of new packages in f15
15:53:53 <rdieter> good point about the missing pieces.  we'd have to finish up the bindings' reviews first (blocker)
15:54:08 <Kevin_Kofler> We didn't have monolithic kdebindings building indeed, which is why we rushed the split package even though it's still incomplete. :-(
15:54:36 <Kevin_Kofler> My proposal is actually to try to get kdebindings to build monolithic again and to revert it to monolithic for F16.
15:54:46 <Kevin_Kofler> We can go to split when it is complete.
15:55:07 <rdieter> -1, i'd rather fix it once (for split) and be done with it, instead of twice
15:55:37 <than> we just skip kde-4.7.0
15:55:40 <jreznik> rdieter: +1
15:55:42 <than> for f15
15:56:07 <rdieter> and reverting what we have split already (esp for f16) -1 no way
15:56:27 <than> rdieter: +1
15:56:53 <Kevin_Kofler> IMHO, kdebindings split packaging shouldn't have been imported at all before all the components were packaged.
15:57:16 * Kevin_Kofler doesn't like packages just vanishing with no upgrade path. :-(
15:57:30 <rdieter> some of them vanished upstream too
15:57:41 <Kevin_Kofler> That's another problem. :-(
15:57:59 <rdieter> for the ones not vanished upstream, work to package the missing pieces if you really care that much.
15:58:07 <Kevin_Kofler> Though if it's stuff like php-qt, the old version might still work, at least against Qt 4.7 in F15.
15:58:13 <Kevin_Kofler> s/might/should/ even
15:58:19 * than doesn'z  like to push kde-4.7.x in f15, because of kdepim* and large change in package splits
15:59:06 <rdieter> there's the split packaging too, but that's not as big a deal to me personally, but it *is* a change indeed
15:59:26 <Kevin_Kofler> than: The proposal here is to keep kdepim at 4.4.x in official updates.
15:59:52 <Kevin_Kofler> The package split shouldn't be a problem if properly metapackaged, though we could probably get monolithic builds to work too, with a bit of effort.
15:59:55 <rdieter> so, Kevin_Kofler wants an update, ltinkl  is ok with it.  than seems still against
16:00:21 <Kevin_Kofler> It's just that most people here don't like the idea of spending time on monolithic builds, and I don't really want to do all the work alone either, admittedly. ;-)
16:00:29 <ltinkl> I'm ok with it but hadn't realized it would cause too much trouble due to the package splits
16:00:30 <jreznik> if someone is willing to do it, I'm not against
16:00:31 <rdieter> jreznik, rnovacek what's your opinions?
16:00:38 * rnovacek is for update
16:00:48 <rnovacek> but with splits rather
16:01:16 <jreznik> just as I noted - monolithic = 2x more maintanance work, split = big chance of regressions and mess in F15
16:01:31 <Kevin_Kofler> I don't think the splits are going to be an issue specifically for F15. They're going to be an issue for ALL updates because Bodhi is going to explode under the flood of builds.
16:01:45 <Kevin_Kofler> But that's not something specific to F15.
16:02:27 <rdieter> the splits + metapackages have been fairly well tested so far, imo, but if there are remaining bugs, they'll still hit f16, so better to get more exposure and fix remaining bugs asap.
16:03:03 <rnovacek> rdieter: +1
16:03:08 <rdieter> though, if I *had* to give a personal preference, it'd be to not to a kde47/f15 update too.  doing so will be a *lot* of work
16:03:43 <Kevin_Kofler> Speaking of the metapackage stuff, a recent mail on the ML pointed out that kdesdk has a non-empty main package. Is that normal?
16:03:58 <jreznik> rdieter: it's all about the amount of work...
16:04:01 <Kevin_Kofler> I'd expect those main packages for split packaging to all be empty metapackages.
16:04:09 <rdieter> I cheated I think, there's a very small component that I didn't make a subpkg for, iirc
16:04:35 <Kevin_Kofler> I think it should be a subpackage, otherwise installing it will drag in everything else.
16:04:41 <rdieter> will have to look again to know for sure, but whatever it is ... it's trivial
16:04:47 <rdieter> sure
16:04:56 <rdieter> we're out of time, too. :(
16:05:28 <Kevin_Kofler> So what's our position on doing 4.7 for F15?
16:05:31 * Kevin_Kofler is +1
16:05:37 <rdieter> sorry, should've left more time for this topic
16:05:51 <rdieter> folks, please do vote, so we can have a resolution today
16:06:35 <rdieter> of course, we do have the kdebindings blocker, so could continue to postpone, but having a decision now will help regardless
16:07:20 <jreznik> I'm +1 if there's a volunteer, but now the priority is cleat - f16
16:07:32 <than> -1
16:08:19 <jreznik> just I think it's quite useless - as we have kde repo... you know I'm fan of updates in older releases but it has to make sense first
16:09:30 <rnovacek> now I hesitate too
16:09:38 <rdieter> tee hee
16:09:56 <ltinkl> same here :) there are pros and cons
16:10:22 <rnovacek> the amount of work is quite big, but it seems noone has enough time..
16:11:02 * rdieter would be happy to do the work, if it's something everyone really wants
16:11:55 <Kevin_Kofler> Do we also need to get FESCo to sign off on it or did they blanket-allow KDE upgrades?
16:13:04 <jreznik> Kevin_Kofler: that's another good question
16:13:16 <rdieter> we have a blanket still, iirc, but giving notice to them is still the right thing to do
16:13:33 * rdieter hates to do it, but -1
16:14:10 <rdieter> anyone else want a vote for the record?
16:14:29 * rnovacek have to leave now
16:14:31 <rdieter> ltinkl, rnovacek  ?
16:14:51 <ltinkl> ok, -1 then
16:14:52 <rnovacek> I'm +0
16:15:05 * Kevin_Kofler guesses this means no update. :-(
16:15:06 <rnovacek> or maybe -0.1 :)
16:15:41 * Kevin_Kofler misses the Fedora 9 times where Fedora was actually an innovative distro…
16:16:07 <rdieter> not do a kde47 update for f15 (1 +1, 1 0, 3 -1)
16:16:14 <rdieter> is that tally correct ? ^^
16:16:28 <Kevin_Kofler> There were actually 2 +1 votes.
16:16:36 <Kevin_Kofler> 1 strong from me and 1 weak from jreznik.
16:16:43 <rdieter> ok
16:16:54 <Kevin_Kofler> But that's still not enough to pass, sadly.
16:16:59 <rdieter> #agreed not do a kde47 update for f15 (2 +1, 1 0, 3 -1)
16:17:04 <rdieter> ok, :(
16:17:16 <rdieter> thanks everyone
16:17:17 <rdieter> #endmeeting