fesco
LOGS
17:00:01 <t8m> #startmeeting FESCO (2011-08-15)
17:00:01 <zodbot> Meeting started Mon Aug 15 17:00:01 2011 UTC.  The chair is t8m. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:00:09 * sgallagh is here
17:00:14 * ajax waves
17:00:17 <t8m> #meetingname fesco
17:00:17 <zodbot> The meeting name has been set to 'fesco'
17:00:18 * mmaslano is here
17:00:24 <t8m> #chair notting nirik ajax cwickert mjg59 mmaslano t8m pjones sgallagh
17:00:24 <zodbot> Current chairs: ajax cwickert mjg59 mmaslano nirik notting pjones sgallagh t8m
17:00:25 * pjones is here eagerly awaiting this exciting agenda.
17:00:30 <t8m> #topic init process
17:00:44 <t8m> Hi all
17:00:48 * nirik is here.
17:00:50 * notting is here
17:01:01 * jsmith is here (lurking)
17:01:10 <t8m> So we can start I assume
17:02:17 <t8m> there are no meeting tickets so this will be really fast
17:02:26 <gholms> Seriously? Nice.
17:02:44 * nirik nods.
17:02:45 <sgallagh> Well, I have one thing to bring up in the open discussion period
17:02:45 <notting> i thought nirik was having a followup from last week about fesco members in/not in provenpackager/sponsors?
17:02:54 <t8m> (except for my extremely lousy internet connection today)
17:03:11 <nirik> Oh yeah. I looked for that, but couldn't find it in old meeting logs... ;(
17:03:28 <nirik> so, I think we will need to draft up something and this time document it. ;)
17:03:30 <t8m> notting, yes, I saw that in last week meeting log
17:04:02 * cwickert is here
17:04:06 <t8m> anyone to write the draft?
17:04:59 <nirik> I've not. What do folks think about this?
17:05:06 <sgallagh> Did we decide on the main points? Are we automatically granting provenpackager/sponsor to FESCo members?
17:05:14 <sgallagh> Do they keep it outside of their terms?
17:05:20 <sgallagh> Also, what about proventester?
17:05:25 <t8m> #topic FESCo members in/not in provenpackager/sponsors
17:05:40 <nirik> provenpackager you mean?
17:06:08 <t8m> nirik, I think he really means proventester
17:06:14 <sgallagh> nirik: No, I mean if we're going to be automatically granting provenpackager and sponsor, should we also be proventesters?
17:06:15 <t8m> as well
17:06:26 <nirik> proventester is trivial to become.
17:06:31 <cwickert> is there something I can read to get the background of this?
17:06:37 <nirik> file ticket, agree you read the page, done.
17:06:54 <nirik> cwickert: the question came up last time that some fesco members are not sponsors.
17:07:04 <nirik> so they don't see the feedback on sponsor/provenpackager requests
17:07:11 <sgallagh> Or even provenpackager (as in my case)
17:07:15 <nirik> that is sent to the sponsor alias.
17:07:28 <cwickert> and where is the problem with that?
17:08:05 <nirik> cwickert: then they have difficulty voting on sponsor requests since they didn't see the feedback emails? or at least they have less info than others.
17:08:06 <t8m> cwickert, when there is some dissenting voice and the sponsor apprentice gets for example one -1
17:08:34 <cwickert> ah, right
17:09:26 <nirik> so, we could make fesco members automatically sponsor, or we could ask for the feedback in a different way, or we could leave it the way it is.
17:10:20 <pjones> or we could put the fesco alias on the sponsor alias and be done with it? ;)
17:10:28 <cwickert> I dislike the idea of becoming a sponsor automatically
17:10:35 <pjones> I mean, the problem we're actually trying to solve is email, right?
17:10:57 <nirik> well, there's not a fesco alias, but there is a mailing list...
17:11:15 <cwickert> +1, lets fix the email problem and not change anything with proven packages or sponsors
17:11:30 <sgallagh> +1
17:11:40 <t8m> I don't really care if we resolve it one way or another
17:11:56 <t8m> so I am +1 to both possibilities.
17:11:56 <notting> i'm +1 to that if it can be done. not sure if the FAS i nternals support that
17:11:56 * nirik ponders.
17:12:15 <sgallagh> notting: If they can't, that seems like a perfectly reasonable RFE
17:12:26 <mmaslano> any solution will be good +1
17:12:44 <nirik> yeah, I don't think it's currently possible to do with fas aliases...
17:13:25 <nirik> I guess the low power answer would be to fwd the emails to the fesco list.
17:13:58 <t8m> nirik, you mean manually?
17:14:08 <nirik> yeah.
17:14:16 * pjones proposes we RFE to solve this by making the fesco mailing list get the important emails and then do so when that's an option (which may, of course, be now.)
17:14:43 <pjones> which may be the least grammatical proposal I've ever put forward.
17:14:51 <nirik> ha
17:14:59 <sgallagh> pjones: You duckspeak double-plus goodwise :)
17:15:55 <nirik> I can try and come up with a solution, but right now I think 'fwd feedback emails to the fesco list' is all I have.
17:16:28 <t8m> As for the automatic FESCo -> sponsor membership - If someone gets enough confidence to get votes for FESCo - where he can affect many things that sponsors do as well, perhaps there would be no problem with getting the sponsor status automatically?
17:16:57 <sgallagh> nirik: Perhaps in the short-term, we could go with: alert the fesco list if the sponsor list has a disagreement, with a pointer to the archive link?
17:17:31 <nirik> well, yeah, but in some cases they may not have desire or understanding to be a sponsor... they may come from some other part of the project?
17:17:40 <nirik> sgallagh: there's no archive. It's not a mailing list, it's an alias.
17:17:48 <sgallagh> oh, damn
17:18:12 <pjones> yeah, there's no real point in making, for example, me into a sponsor, since I basically don't ever do any sponsoring.
17:18:24 <sgallagh> RFE: make the sponsor "alias" into a mailing list :)
17:18:34 <pjones> sgallagh: yeah, was just going to suggest that
17:18:38 <t8m> nirik, they might not but then I understand that there is no obligation to "do more things" if you have sponsor status in the db
17:19:05 <nirik> sgallagh: problems with that approach: we would need to automatically add people somehow. Many people would just remove themselves.
17:19:12 <pjones> t8m: fair enough, I guess.  But growth for the sake of growth and all that...
17:19:16 <nirik> t8m: true
17:19:57 <sgallagh> t8m: Except that the sponsor list is public and people might just start targeting random sponsors
17:20:09 <sgallagh> It's hard to say "no" to a direct request
17:20:24 <t8m> We are discussing it for more than 15 minutes, do we want to continue?
17:20:38 <nirik> we could also just ask people to cc: fesco list on their feedback?
17:21:09 * nirik is fine with low tech here... fwd or get the feedback to fesco via whatever handy means.
17:21:23 * notting +1s pjone's proposal
17:21:24 <sgallagh> I agree with nirik
17:21:51 <sgallagh> notting: What was pjones' proposal?
17:22:02 <cwickert> fix it with an email alias
17:22:06 <sgallagh> ah, right
17:22:12 <cwickert> +1 for that
17:22:17 * sgallagh is fine with that as well
17:22:27 * nirik is unsure how it can be fixed with an alias.
17:22:30 <pjones> notting: weirdest appostriphication of my name ever.
17:22:41 <pjones> nirik: can't we just add fesco list to the sponsor alias?
17:22:55 <sgallagh> pjones: Whose, notting's or mine? :)
17:22:57 <pjones> just like we'd add any other sponsor?
17:23:02 <pjones> sgallagh: his
17:23:10 <nirik> no, because fas generates those aliases. We would need code changes in fas to add members non in a group to a group alias, which is... gross.
17:23:18 <pjones> ew, yeah.
17:23:42 <nirik> I suppose we could make a 'sponsor-feedback' alias that contains 'packager-sponsor-members fesco-list'
17:23:43 <pjones> so there's no real urgency on this, though - so we could RFE that Fesco get a Cc on these things, right?
17:23:47 <sgallagh> nirik: Can we get someone who IS on that list to just add an email filter to always send a copy to FESCo?
17:23:52 <sgallagh> (It's ugly, but...)
17:23:53 <nirik> sgallagh: sure.
17:24:04 <nirik> pjones: yeah, no urgency at all.
17:24:14 <notting> pjones: never attribute to malice what can easily be explained by an inability to type
17:25:25 <nirik> proposal: we just have someone fwd feedback emails to fesco list before the meeting where we vote on that sponsor.
17:25:41 <sgallagh> Simple, low-tech, gets the job done: +1
17:25:47 <pjones> nirik: can we do that *and* rfe getting fesco cc'd properly?
17:26:02 <pjones> a phase-out plan for that kind of hackary would be nice.
17:26:15 <sgallagh> Sure, do you mind filing the RFE?
17:26:30 <pjones> I'm not entirely sure where to file it, but okay.
17:26:35 <nirik> pjones: the only ok way I see to do that is the above alias...
17:26:41 <pjones> nirik: well, hrm.
17:26:44 <pjones> okay, whatever.
17:26:45 <nirik> make a 'sponsor-feedback' alias that contains 'packager-sponsor-members fesco-list'
17:27:06 * nirik can do that after our infrastructure freeze, but filing a ticket so we don't forget would be good.
17:27:22 <t8m> nirik, that will be fine I think
17:27:28 <sgallagh> pjones: https://fedorahosted.org/fas/
17:27:46 * nirik really dislikes the idea of adding non members to members aliases directly.
17:28:11 <t8m> #action pjones will file a ticket to create sponsor-feedback alias that will contain packager-sponsor-members and fesco-list
17:28:32 <pjones> nirik: https://fedorahosted.org/fas/ticket/142#preview
17:28:57 <pjones> #info https://fedorahosted.org/fas/ticket/142
17:29:00 <nirik> ok.
17:29:14 <pjones> I really went all-out with that one.
17:29:19 <sgallagh> :)
17:29:46 <sgallagh> So, can we get a vote on the short-term solution suggested by nirik?
17:29:54 * sgallagh remains +1
17:30:03 * pjones +1
17:30:15 <ajax> +1
17:30:17 * t8m too +1
17:30:17 <notting> +1
17:30:40 <nirik> sure.
17:30:43 <t8m> OK, who volunteers for doing the fwd?
17:30:55 <pjones> Well, I don't currently get the emails, so not I ;)
17:31:03 * sgallagh is not a sponsor at present
17:31:50 * nirik votes notting since he's sending out the feedback emails. ;)
17:32:54 <notting> ok
17:33:01 <t8m> so just adding a cc on the initial e-mail and watching that it does not get dropped would be enough?
17:33:58 <nirik> true. It will I think send people a 'your post is held for moderation since you aren't subscribed' for the fesco list.
17:34:11 <nirik> We could just not care, or open the list for non member posts.
17:34:57 <sgallagh> nirik: Why would it do that? The client rule should have it forwarded from a FESCo member
17:35:29 <nirik> sgallagh: if we added a 'CC: fesco-list' to the initial feedback email
17:35:30 <sgallagh> I wasn't talking about (the equivalent of) .forward
17:35:54 <t8m> ok, we've decided already to fwd explicitly, please ignore that
17:35:55 <sgallagh> oh, sorry. I follow now
17:35:57 <t8m> #action notting will fwd the feedback e-mails to the fesco list
17:36:07 <notting> this is only in the case of a dispute, or in all cases?
17:37:08 <nirik> only dispute I would say?
17:37:28 <t8m> notting, what would you prefer?
17:37:47 <notting> only in dispute is easier to remember
17:38:28 <t8m> I think that would be fine
17:38:39 <sgallagh> sure
17:39:20 <t8m> OK, we are discussing it for more than 30 minutes now
17:39:31 <t8m> Perhaps we should move on?
17:39:39 * nirik thinks we covered it all now.
17:39:58 <t8m> #topic Fedora Engineering Services tickets
17:40:08 <t8m> #info https://fedorahosted.org/fedora-engineering-services/report/6
17:40:48 <t8m> anything here to discuss?
17:41:37 <t8m> I suppose not
17:41:40 <nirik> nope... I tried to get a hold of the person that was going to work on it...
17:41:47 <nirik> but he was busy... will try further. ;)
17:42:03 <t8m> #topic Next week's chair
17:42:04 <sgallagh> nirik: Work on which?
17:43:10 <nirik> sgallagh: I had someone that wanted to revive and revitalize fedora engineering services.
17:43:15 <sgallagh> Oh ok
17:43:17 <sgallagh> Cool
17:43:20 <nirik> but he moved jobs and moved and had no time. ;)
17:43:45 <sgallagh> On the current topic: I will volunteer for two weeks from today, but I can't do next week (I'll be traveling right up until the meeting)
17:43:52 <t8m> Anybody wants to be the next week chair?
17:44:10 * nirik has had enough break, I can do it next week.
17:44:30 <t8m> #action sgallagh to be chair on 2011-08-29 meeting
17:44:59 <t8m> #action nirik to be chair next week - on 2011-08-22 meeting
17:45:08 <t8m> #topic Open Floor
17:45:11 <ajax> i'll be on vacation next week next week and the one following, so i won't be able to make the meetings on the 22nd or 29th
17:45:32 <sgallagh> I have two bits for Open Floor.
17:45:41 <t8m> I might not be able to make the meeting on the 22nd but unsure yet.
17:46:02 <sgallagh> First is a curiosity: Will any other members of FESCo be at LinuxCon Vancouver this week?
17:46:14 * nirik will not. Sounds like a fun one tho.
17:46:23 * mmaslano is not sure about vacation in next three weeks
17:46:44 * t8m not. Slightly too far :)
17:47:12 <ajax> not i
17:47:23 <pjones> I'm going to be in boston as usual, enjoying this fine summer weather.
17:47:59 <sgallagh> Ok, I was just curious. Would have been nice to put faces to names.
17:48:57 <sgallagh> On to my second matter: we discovered a serious bug in libtevent 0.9.10 introduced upstream that requires a rebuild of not only tevent but all of the packages that depend on it.
17:49:40 <nirik> nasty. ;(
17:49:44 <sgallagh> So this is probably going to necessitate a branch to build the fixes, as well as provenpackager and proventester support as it touches critpath and heavily-used apps :(
17:49:52 <t8m> sgallagh, how many packages depend on it?
17:50:15 <nirik> sgallagh: all branches? or rawhide/f16? or ?
17:50:20 <sgallagh> nirik: Only F15
17:50:30 <nirik> ah.
17:50:48 <sgallagh> F14 had 0.9.8 which was unaffected, and F16 had 0.9.11 (and recently 0.9.13) which contained the fix
17:50:52 <nirik> I'd suggest trying to rebuild them all and add them in one update so they all push out at once with no dep issues.
17:51:28 <sgallagh> nirik: Well, the first problem with that is that I don't own all the packages that depend on it
17:51:38 <sgallagh> (I think I may need to apply for provenpackager)
17:51:48 <nirik> yeah, might be good...
17:52:00 <sgallagh> The second problem is that, last I checked (Thursday) the buildroot overrides didn't take provenpackager into account
17:52:02 <t8m> sgallagh, now it would be handy to be a provenpackager/sponsor automatically :)
17:52:27 <sgallagh> heh
17:52:30 <ajax> afaik you can only ask for br overrides for things you're explicitly on the acl for, yeah
17:52:39 <nirik> sgallagh: they don't... yeah. it's a bug.
17:52:48 <nirik> Hopefully a fixed bodhi soon.
17:53:14 <sgallagh> BZ for reference: https://bugzilla.redhat.com/show_bug.cgi?id=730014
17:54:35 <t8m> sgallagh, what do you need from FESCo? Any proposal?
17:54:38 <sgallagh> So without that fix, I probably need to rely on the maintainers of the dependent packages to push their updates with me
17:55:09 <sgallagh> t8m: Am I mistaken that the best move here would be a "mass rebuild" branch (for very loose definition of "mass")?
17:55:15 <nirik> yeah, or a provenpackger to assist.
17:55:45 <pjones> I propose we make sgallagh a provenpackager.
17:55:46 <sgallagh> t8m: I guess my first step should be requesting provenpackager.
17:56:09 <nirik> our process calls for asking for feedback from sponsors for a week. ;)
17:56:20 * sgallagh chuckles
17:56:23 <pjones> meh ;)
17:56:35 <sgallagh> That's fine, as I'm going to be at LinuxCon, I won't have time to fix this before next Monday anyway
17:57:04 <mmaslano> sgallagh: great, so you can create provenpackagers request ;-)
17:57:19 <sgallagh> Will do
17:59:19 * nirik nods. Sounds good. Anything more?
17:59:20 <t8m> sgallagh, as for a special mass-rebuild branch - I do not think it is necessary in this case
18:00:31 <sgallagh> https://fedorahosted.org/fesco/ticket/660
18:01:16 <t8m> If there is nothing else to discuss I'll close the meeting in 2 minutes.
18:03:26 <t8m> #endmeeting