fesco
LOGS
17:01:26 <ajax> #startmeeting FESCO (2011-08-07)
17:01:26 <zodbot> Meeting started Mon Aug  8 17:01:26 2011 UTC.  The chair is ajax. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:26 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:26 <ajax> #meetingname fesco
17:01:26 <zodbot> The meeting name has been set to 'fesco'
17:01:27 <ajax> #chair ajax notting nirik cwickert mjg59 mmaslano t8m pjones sgallagh
17:01:27 <zodbot> Current chairs: ajax cwickert mjg59 mmaslano nirik notting pjones sgallagh t8m
17:01:27 <ajax> #topic init process
17:01:36 <mmaslano> hello
17:01:36 * nirik waves. Morning folks.
17:01:37 * sgallagh waves
17:02:00 <ajax> only people missing by my count are cwickert and t8m, assuming people aren't just idling
17:02:14 <mmaslano> t8m is on vacation
17:02:47 <notting> i'm here. have to leave a few minutes before 2pm, though
17:02:55 <ajax> no worries, should be quite quick today
17:03:22 <ajax> well, we've got quorum, let's dive in.
17:03:27 <ajax> #topic #563 suggested policy: all daemons must set RELRO and PIE flags
17:03:27 <ajax> .fesco 563
17:03:28 <zodbot> ajax: #563 (suggested policy: all daemons must set RELRO and PIE flags) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/563
17:03:51 <ajax> i just sent a small novel to devel@ outlining how this will all work
17:03:54 <ajax> http://lists.fedoraproject.org/pipermail/devel/2011-August/155358.html
17:04:02 * pjones is here
17:04:06 <nirik> great work ajax.
17:04:16 <nirik> clear and nice. ;) You might also send a copy to devel-announce?
17:04:31 <ajax> i got to learn far too much about two different languages, both called "spec".  i would like to forget.
17:04:36 <sgallagh> ajax: One thing just occurred to me about that. There's a lot of combined requirement between rpm, redhat-rpm-config and gcc. Might it not be wise to get them all into the same bodhi update?
17:04:53 <ajax> nirik: good idea, will do
17:05:20 <notting> any plans to backport?
17:05:34 <pjones> please no.
17:05:35 * notting is fine with 'no', just want to clarify.
17:05:46 <sgallagh> notting: From ajax's write-up, I'd say that's probably both unwise and unsafe :)
17:05:49 <nirik> ajax: also, could you add the macro info to the draft page? then I can re-ping FPC and they can get it setup as a guideline.
17:05:51 <ajax> sgallagh: think that ends up being a little tough to do since i don't own the gcc update.  but they're all pretty harmless individually for packages not using the _hardened_build macro
17:06:16 <sgallagh> ajax: Right, but it becomes difficult to know exactly when your builds are actually using it
17:06:25 <ajax> notting: to pre-f16?  i don't intend to, no.
17:06:26 <pjones> ajax: so really just make sure it's last.
17:06:40 <pjones> sgallagh: nothing is using it until it's there.
17:06:43 <sgallagh> Also, I believe any provenpackager can combine the assorted Koji builds into a single Bodhi update
17:06:48 <sgallagh> pjones: Not true.
17:07:00 <sgallagh> If redhat-rpm-config hits before gcc, there could be issues
17:07:12 <pjones> uh, reread what I said.
17:07:18 <ajax> sgallagh: both the r-r-c and rpm updates have karma automatism turned off (for this reason)
17:07:41 <ajax> nirik: yes, will update the draft page
17:07:55 <nirik> thanks.
17:07:57 <ajax> #action ajax to update the draft page for FPC to create guidelines
17:08:06 <sgallagh> ok
17:08:49 <ajax> partly because i'm doing a non-maintainer upload for rpm, so i want to give them the opportunity to say i'm a terrible person and back all my changes out if they want
17:09:04 <ajax> but in fairness...
17:09:23 <ajax> #action ajax to forward summary email to devel-announce
17:09:32 <ajax> #action ajax to email lists when all updates in place
17:09:48 <mjg59> Sorry, I'm here
17:10:24 <sgallagh> ajax: No problem. I just wanted to make sure we didn't hit any issues rolling this out.
17:10:44 <pjones> (just fwiw, we seem to have started the meeting without quorum but rectified that sense then)
17:11:10 <ajax> pjones: not 5 of 9?  my bad.
17:11:23 <ajax> sgallagh: no worries, caution is appreciated here.
17:11:33 <ajax> moving on in a moment if there's nothing else
17:11:36 <pjones> hrm, may have been.  anyway.
17:12:25 <ajax> #topic #615 Strategy for services that do not have systemd native unit
17:12:25 <ajax> .fesco 615
17:12:27 <zodbot> ajax: #615 (Strategy for services that do not have systemd native unit files) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/615
17:12:58 <ajax> any news here?
17:13:08 <Viking-Ice> depends on what you mean news
17:13:25 <pjones> the opposite of olds.
17:13:35 <pjones> something different from how it was last time we talked about it
17:13:36 <ajax> anything we need to act on that we haven't already covered in previous weeks.
17:13:40 <Viking-Ice> iscsi #714688 # maintainers wont convert from my understanding atleast for F16 ??? dnsmasq #694932 has systemd unit file  # Unresponsive maintainer this packaged should find a new maintainer or be orphaned and removed  openvpn #714710 has systemd unit file  # Stephen Pritchard the maintainer responded "I'm trying to find some time to look at those.  I'm essentially working two jobs right now, so it's rough..." wpa_supplicant #661230 has a
17:13:40 <Viking-Ice> ccepted systemd unit file dont know why Dan does not build this or did so weeks ago.
17:14:16 <sgallagh> dnsmasq can't be orphaned. WAY too many things depend on it (like libvirt)
17:14:17 <Viking-Ice> dbus and gpm got package correctly
17:14:40 * nirik is trying to parse the status. Whats the web page with that again?
17:14:48 <Viking-Ice> which only leaves avahi Lennart setting a good example there
17:15:15 <Viking-Ice> https://fedoraproject.org/wiki/User:Johannbg/Features/SysVtoSystemd
17:15:55 <nirik> thanks
17:15:56 <Viking-Ice> dnsmasq and openvpn along with wpa_supplicant are not listed there
17:16:55 <Viking-Ice> sgallagh, then some ( co)maintainer(s) need to step in
17:17:21 <sgallagh> Viking-Ice: I don't disagree. I'll take an action item to see if one of the virt guys would like to step up.
17:17:45 <ajax> #action sgallagh to talk to virt people about dnsmasq
17:17:53 <Viking-Ice> wpa_supplicant needs an proven packager?
17:18:05 <nirik> I think Dan has been out/vacationing or the like.
17:18:10 <Viking-Ice> Dan accepted that unit file weeks ago
17:18:35 <Viking-Ice> are we going to pull those service into rc2 ?
17:18:49 <Viking-Ice> as in the native unit files
17:19:04 <Viking-Ice> rc2 for alpha that is or has that mark passed?
17:19:26 <nirik> Viking-Ice: I can take on wpa_wupplicant.
17:19:35 <nirik> wpa_supplicant rather. ;)
17:19:45 <nirik> Viking-Ice: I think we are late in the game for that.
17:20:05 <Viking-Ice> which brings up the question what now?
17:20:11 <Viking-Ice> as in where to go from here
17:20:13 <notting> given that all of these are for non-default configs
17:20:56 * nirik nods. Yeah, except iscsi
17:21:39 <notting> also, the wpa_supplicant service file in the bug doesn't seem to match the upstream discussion, unless I'm missing something
17:21:59 <Viking-Ice> you are missing something I asked Dan about that
17:22:12 <Viking-Ice> if you are speaking of wpa discussion on systemd-devel
17:23:25 <nirik> and? the ones in the bug are what he would like? or ?
17:23:26 <Viking-Ice> Oh Legacy network servers might be done
17:23:33 <Viking-Ice> nirik, yes
17:23:44 <Viking-Ice> the one in the bug is approved by him to be shipped and used
17:24:03 <nirik> ok, might be worth posting that to the systemd-devel list and getting acks there too?
17:24:13 <nirik> (if only after the fact0
17:24:22 <notting> Viking-Ice: which is *not* what went upstream to wpa_supplicant
17:24:48 <nirik> somehow thats got to sync up. ;) (or should)
17:24:58 <notting> upstream wpa_supplicant applied henry's packages
17:25:01 <notting> s/packages/patches/
17:26:15 <Viking-Ice> notting, you need speak with Dan if something has changed his mind
17:26:21 <nirik> so, on iscsi can we just apply the 'use systemd in a shim that calls the sysvinit script' ?
17:26:24 <notting> huh?
17:26:27 <notting> dan's not upstream.
17:26:36 <Viking-Ice> dan owns wpa_supplicant
17:26:50 <Viking-Ice> dan knew of the thread on systemd yet sanction the wpa unit file
17:27:06 <Viking-Ice> I know nothing on what's happening upstream
17:27:12 <mjg59> Ok really not clear on what we're being asked to do here
17:27:13 <notting> ok then
17:27:29 <Viking-Ice> so nirik can package the wpa_supplicant file
17:27:31 <notting> if you know nothing on what's happening upstream, you probably shouldn't be asking provenpackagers to add something
17:27:46 <nirik> Viking-Ice: I'd like to talk to Dan... but I can at some point.
17:27:49 <ajax> we're at 15 minutes.  is this something we need to hammer on here, or can we take this to the mailing list?
17:28:14 * sgallagh is +1 for taking to the list
17:28:18 <nirik> well, I think our goal of stuff on the livecd by alpha is missing these few items...
17:28:19 <Viking-Ice> notting, I asked Fedora maintainer he should know what's happening upstream <sigh>
17:28:30 * mmaslano is also +1 for list
17:28:39 <ajax> (someplace a bit more structured)
17:28:50 <mjg59> Yeah, divergence from upstream is best handled by someone who knows upstream
17:28:57 <nirik> Viking-Ice: I think he's been on vacation since you asked him and since upstream had a discussion.
17:29:28 <Viking-Ice> anyway beta goals ?
17:29:52 <Viking-Ice> what are they and what are you willing to do to reach them?
17:29:57 <nirik> well, finish these 4 for sure...
17:30:49 <ajax> #action remaining four packages (iscsi, dnsmasq, openvpn, wpa_supplicant) targeted for conversion by beta
17:30:52 <ajax> anything else here?
17:30:59 <Viking-Ice> is that it ?
17:31:07 * nirik looks at the status page again.
17:31:10 <ajax> dude, you're the one making all the noise about this, you tell me.
17:31:38 <ajax> i personally do not care in the slightest if we're "fully converted" by f16.
17:31:46 <Viking-Ice> ok fine by
17:31:48 <sgallagh> Well, we originally stated that our intent was to have ALL SYSV scripts converted by beta
17:31:51 <Viking-Ice> let's stop then here an now
17:32:07 <sgallagh> Are we now proposing to change that?
17:32:19 <mmaslano> sgallagh: are you willing to help with that?
17:32:31 * nirik thinks it's nobel to get them converted, but it's a lot of work too.
17:32:41 <ajax> sgallagh: it sounded from the above like iscsi wasn't going to happen.  so.
17:32:47 <sgallagh> mmaslano: Sorry, the tone of my last statement sounded bad over IRC
17:32:55 <mmaslano> sgallagh: sorry :)
17:33:00 <pjones> nirik: noble, surely? ;)
17:33:06 <nirik> sorry, sure.
17:33:15 <sgallagh> I suppose I'm asking for us to make a firm decision on what we're willing to declare "success" on this particular Feature
17:33:17 <mmaslano> I think convert the basic services and havem them really working would be great
17:33:41 <nirik> so, another alternative....
17:34:21 <nirik> convert everything left to use systemd with a call to their sysvinit script. Yes, this is ugly, but it means that they can then convert in f16 timeframe anytime and not run into changing in a stable release.
17:34:33 * nirik is just tossing it out there, not sure it's a good way to go.
17:34:44 <ajax> nirik: why would that be better then leaving them as they are?
17:34:51 <notting> that sounds worse than leaving thme
17:34:55 <Viking-Ice> an good reachable goal would be to finish all service in the dvd
17:34:57 <Viking-Ice> 'as well
17:35:04 <mmaslano> nirik: imho it would be harder to debug, if admin doesn't know about it
17:35:08 <nirik> well, if we leave them, they cannot convert during f16 at all. Must wait until f17 (which may not be a bad thing)
17:35:11 <notting> especially if the conversion requires changing them to instance services, or splitting them up, or....
17:35:24 <nirik> true.
17:35:31 <notting> nirik: predictability in a released release is good
17:35:34 <nirik> Viking-Ice: how many would that leave us with?
17:35:58 <nirik> true.
17:36:18 <Viking-Ice> by groups not much to be left to convert I should mention Legacy Network Servers have been converted
17:36:43 <sgallagh> Should we consider allowing manual conversions during the F16 life? E.g., allow them to ship package-systemdunit with a manual script to convert?
17:36:48 <Viking-Ice> I had not found the time to update that package at the speed hhorak has package and shipped my submitted unit files
17:36:54 <nirik> I think trying to get the dvd ones by beta would be good. Anything after that we punt to next release.
17:37:05 <Viking-Ice> s/package/group of packages/
17:37:08 <sgallagh> So the default would be to continue with their existing scripts, but allow a more phased roll-out?
17:37:10 <ajax> sgallagh: fpc says no.
17:37:12 <nirik> sgallagh: FPC didn't want that.
17:37:28 * sgallagh withdraws the suggestion
17:37:30 <nirik> you can't tell easily if the service was enabled or not.
17:38:15 <Viking-Ice> and you kinda cant tell afters either if it is or should be ( for example components might have switched to hardware activation this no need to enable by default )
17:38:34 <ajax> we're at 25 minutes now and i don't think we've said much.
17:38:39 <ajax> (since 15 minutes)
17:38:45 <nirik> right, so we can:
17:38:49 <sgallagh> ajax: Well, we do have a proposal we should vote on
17:38:53 <nirik> a) just call this good for now, punt to next release
17:39:00 <sgallagh> Proposal: DVD-by-beta
17:39:01 <nirik> b) try and do things on dvd before beta
17:39:19 <mjg59> I don't see any problem with trying for DVD by beta
17:39:26 <mjg59> But I don't see it as an absolute disaster if we fail
17:39:31 <Viking-Ice> how much is fesco willing to back that upp
17:39:38 <Viking-Ice> the goal that is
17:39:47 <ajax> i'm not willing to hold up the release for it, if that's what you're asking.
17:39:59 <mjg59> We can't compel people to include code if they feel that it doesn't work
17:40:09 <mjg59> And I don't think (at this stage) it's worth delaying the release
17:40:20 <mjg59> A lot of excellent work has been done in this respect
17:40:36 <ajax> nor do i have any time to work on it.  but that's just speaking for me.
17:41:27 <pjones> I too would lean towards punting, but would be perfectly content seeing it fixed before beta should that be possible.
17:41:33 <ajax> i don't have a compelling argument in front of me that delaying the release would produce an appreciably better release.
17:41:42 <ajax> but i'm happy to see as much fixed before beta as possible
17:41:48 * nirik also keeps hoping to have time to help.
17:42:20 <ajax> so then.  sgallagh's proposal: try for dvd by beta.  votes?
17:42:34 * ajax +1
17:42:36 <nirik> +1 to that. (and I can try and help)
17:42:38 <pjones> sure, why not.
17:42:39 <sgallagh> +1
17:42:40 <pjones> +1
17:42:43 <Viking-Ice> the main problem here are the nonresponsive maintainers not the responsive ones
17:42:50 <mmaslano> we could try +1
17:42:59 <sgallagh> Viking-Ice: So start the non-responsive maintainer process
17:43:04 <mjg59> +1
17:43:06 <pjones> Viking-Ice: so... get some provenpackagers to just go ahead and change it.
17:43:08 <ajax> #agreed try for converting all services on the dvd by beta.
17:43:10 <notting> +1
17:43:26 <ajax> on to new business!
17:43:28 <pjones> If they're non-responsive, they won't complain ;)
17:43:32 <ajax> #topic #654 Proven packager request
17:43:33 <ajax> .fesco 654
17:43:34 <zodbot> ajax: #654 (Proven packager request) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/654
17:44:03 <notting> this is for ppisar
17:44:21 <ajax> notting: the -1 you mention on the ticket: where's that list, exactly?
17:44:22 <notting> there were 4 +1s but one -1, so here we are
17:44:36 <mmaslano> on which list? I didn't see their discussion
17:44:42 <nirik> I've not interacted with them much, but trust the other +1s, so +1 here;
17:44:42 <notting> packager-sponsors
17:44:53 <notting> which ... i don't know if it's archived. nirik?
17:44:53 <nirik> the packager-sponsors-members alias.
17:45:01 <nirik> no, it's an alias. Its not a list.
17:45:18 <ajax> no wonder i couldn't find it.
17:45:32 <nirik> I think everyone in fesco should be on it tho?
17:45:34 <notting> in any case, http://fpaste.org/L79X/
17:45:57 <pjones> I don't... think so.
17:46:06 <mmaslano> um I thought so
17:46:10 <sgallagh> nirik: I wasn't aware of it
17:46:11 <pjones> it's possible I wrote a filter for it years ago and forgot.
17:46:18 <ajax> quite sure i'm not
17:46:21 <nirik> if you are a sponsor you should be.
17:46:38 <ajax> well i ain't, so i ain't.
17:46:48 <mmaslano> in this case you should revoke my proven packager acces and we won't have new Perl next year
17:47:02 <Viking-Ice> pjones, which proven packager ( my fes ticket is still open and still unresponded too  )
17:47:10 <nirik> I think this came up a few years ago... and we agreed to promote fesco people, but I could be misremembing.
17:47:11 <sgallagh> nirik: I am not a sponsor
17:47:21 <mmaslano> me neither
17:47:24 <mjg59> Given the -1, I'm +1
17:47:35 <notting> probably just forgot to do that as a continuing process? in any case, can we discuss this *after* the provenpackager request?
17:47:45 <ajax> notting: indeed.
17:48:01 <nirik> notting: agreed.
17:48:07 <ajax> so on this request.  personally i'm still irritated that we still don't have groups.
17:48:19 <ajax> but since we don't, provenpackager is the nearest proxy for that
17:48:33 <nirik> I'll note there is a infra ticket still open on that old thing...
17:49:06 <ajax> and i am in general in favor of collective ownership, and i've no reason to dislike petr's work thus far.  so, +1.
17:49:09 <nirik> https://fedorahosted.org/fedora-infrastructure/ticket/2514 (should see if that can be closed)
17:49:21 <pjones> ajax: yeah, that's pretty reasonable, +1
17:49:37 <notting> that's 4 +1
17:49:43 <sgallagh> +1
17:49:49 <mmaslano> +1 (again)
17:50:04 <nirik> +1 (again for clarity)
17:50:19 <ajax> #agreed ppisar's provenpackager request is accepted
17:50:20 <mjg59> Looks like enough
17:50:25 <mmaslano> thank you
17:50:48 <ajax> quick detour...
17:51:06 <ajax> #topic fesco members as sponsors
17:51:25 <nirik> yeah, I think this came up, I can look in old archives if we like.
17:51:26 <ajax> anyone have a link to the background on this, or shall we follow up next meeting?
17:52:00 <notting> the alternative would be to just subcsribe fesco to the alias, but i don't know if FAS can do tht
17:52:17 <nirik> the alternatives would be:
17:52:25 <ajax> i'd be fine with either, personally i wouldn't use the sponsorship power
17:52:26 <nirik> a) fesco people use the same process as anyone else.
17:52:40 <nirik> b) when someone new joins fesco they are made sponsor/pp
17:52:49 <ajax> but if we're expected to advise, it'd be good to be in the loop.
17:53:00 <pjones> yes.
17:53:23 <notting> b) is easier, but i don't know how you'd track things on fesco changes (who was in before, vs. who was there just from fesco)
17:53:35 <pjones> nirik: it does seem an odd idea that we trust somebody to be on fesco and not pp
17:53:40 <pjones> OTOH I can think of some names.
17:53:53 <notting> sorry, have to step out now.
17:53:54 <nirik> how about I look at archives and we discuss this next week?
17:53:58 <pjones> notting: he didn't say they get unmade
17:54:03 <ajax> nirik: sounds good
17:54:17 <ajax> #action nirik to dig in archives for fesco-as-sponsor background and report next week
17:54:25 <ajax> winding down
17:54:28 <ajax> #topic Next week's chair
17:54:29 <nirik> should we file a ticket to remind us? or ?
17:54:33 <ajax> nirik: i'll file a ticket
17:54:37 <nirik> ok.
17:54:48 <ajax> my notes say t8m's on the hook for next week's chair
17:55:28 <ajax> so, uh, i guess that's it for that
17:55:34 <sgallagh> As he's not here to defend himself, sure :)
17:55:34 <nirik> cool.
17:55:48 <ajax> #topic Open Floor
17:56:27 <ajax> will close out in two minutes if nothing comes up
17:56:32 <Viking-Ice> does fesco have legion of provenpackagers at their disposal ?
17:56:48 <ajax> Viking-Ice: not as such, no.
17:56:57 <ajax> our executive power is remarkably limited.
17:57:21 <Viking-Ice> so where am I supposed to get those provenpackagers to use?
17:57:36 <pjones> send an email?
17:57:39 <mjg59> Bring it up on list
17:57:52 <Viking-Ice> did not help last time so the list is not an option
17:57:56 <sgallagh> Viking-Ice: Send an email to devel@ with the subject line "Provenpackager assistance requested for ..."
17:58:03 <nirik> might even be good for devel-announce?
17:58:16 <mjg59> Viking-Ice: Well if nobody's willing to help then nobody's willing to help
17:58:21 <mjg59> We can't force anyone to do anything
17:58:24 <nirik> there may well be people who ignore devel due to noise that would see an announcement.
17:58:54 <Viking-Ice> what's provenpackagers purpose?
17:59:14 <ajax> to have the power to fix what they care about enough to fix
17:59:24 <mjg59> To be able to modify packages as part of some wide-ranging change to the distribution or to fix bugs the maintainer isn't working on
17:59:26 * mmaslano must leave
17:59:36 <Viking-Ice> so provenpackager fail to the same extent as proventesters?
17:59:50 <ajax> that's an opinion you're free to have, but not really on-topic.
17:59:58 <mjg59> Viking-Ice: You appear to be confused about how a volunteer organisation works
18:00:02 <ajax> or anyway, not something fesco can do anything about.
18:00:26 <mjg59> Viking-Ice: There's no way that we can task people to do something unless they're already willing to do it
18:01:12 <ajax> anyway, our hour's up, and this seems well outside fesco's scope.
18:01:15 <Viking-Ice> one would think that the purpose of proven(something) is actually to be available to assist in matters such as these and others thus when one signs up for it he knows what he's getting into
18:01:30 <ajax> #endmeeting