fesco
LOGS
17:01:22 <mjg59> #startmeeting FESCO (2011-07-18)
17:01:22 <zodbot> Meeting started Mon Jul 18 17:01:22 2011 UTC.  The chair is mjg59. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:01:22 <t8m> yep
17:01:22 <gholms> Who's chairing today?
17:01:31 <mjg59> #meetingname fesco
17:01:31 <zodbot> The meeting name has been set to 'fesco'
17:01:47 <pjones> yep
17:01:54 * nirik waves.
17:01:58 * notting is here
17:02:09 * pjones hisses
17:02:19 <mjg59> sgallagh around?
17:02:22 * rbergeron lurks
17:02:23 * t8m raises hand
17:02:37 <mjg59> Well, we've got quorum in any case
17:02:42 <mjg59> #chair notting nirik ajax cwickert mjg59 mmaslano t8m pjones sgallagh
17:02:42 <zodbot> Current chairs: ajax cwickert mjg59 mmaslano nirik notting pjones sgallagh t8m
17:02:48 <ajax> howdy
17:02:52 <mjg59> #topic init process
17:02:54 <pjones> nanu nanu
17:02:57 * mmaslano here
17:03:21 <mjg59> Sorry about the agenda going out today, I ended up a friend's birthday yesterday which took up the time I was planning to send it
17:03:26 <mjg59> But anyway
17:03:40 <mjg59> Pile of F16 features today
17:03:46 <mjg59> Let's get the old stuff done
17:03:48 <pjones> monday meeting time is turning out to really suck in that regard.
17:03:53 <mjg59> #topic #608     F16Feature: Trusted Boot
17:03:54 <mjg59> .fesco 608
17:03:55 <zodbot> mjg59: #608 (F16Feature: Trusted Boot - http://fedoraproject.org/wiki/Features/Trusted_Boot) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/608
17:04:07 <mjg59> The ticket for this got updated toady
17:04:09 <mjg59> today
17:04:28 <mjg59> Sounds like there's some progress
17:04:40 <mjg59> So it seems achievable assuming that the code actually gets done
17:04:58 <mjg59> So I'd lean towards going with this as long as it reaches 100%
17:05:00 <pjones> he seems to be confused about "default package set" having anything to do with this.
17:05:04 <pjones> but aside from that, yeah
17:05:28 * nirik reads
17:05:39 <t8m> mjg59, +1
17:05:49 <dvlasenk> I tried to understand what Trusted Boot *is*, and failed.
17:06:09 <notting> re: two level multiboot, do we care about xen?
17:06:11 <ajax> dvlasenk: it's a complicated way of making your machine less likely to work.
17:06:27 <pjones> notting: I don't but apparently they do?  If he wants to spend his time making sure it works with xen, that's fine by me?
17:06:35 <dvlasenk> Should there be some understandable documentation before the package is accepted into the distro?
17:06:39 <nirik> I'm still -1 to it I think... the current issue I have is that it doesn't get us anything. Why not wait until there are UI/tools/use cases our users care about.
17:06:43 <pjones> dvlasenk: the package is already in.
17:06:45 <notting> dvlasenk: the package is already in the tree
17:07:06 <pjones> nirik: well, the idea is that this enables people to more readily work on that.
17:07:44 <pjones> nirik: note that I *don't* think we've ever agreed about anything regarding enabling this by default - the current plan (contrary to that comment) is that if the package is selected, we'll install it in the bootloader config as well.
17:07:45 <nirik> but the people working on that should know how to add a grub entry, no?
17:08:09 <nirik> ie, making it easier to enable without anything actually using it seems wrong to me.
17:08:10 <pjones> yes, but why stop them?   who else is choosing to install the package?
17:08:35 <pjones> in the past, on other subjects, we've taken the position that if you install a non-default package, it's because you intend to use it.
17:08:41 <nirik> I suppose. I just don't want to to automatically install if it sees the hardware.
17:08:46 <pjones> if they want to submit patches to that effect, why should we stop them?
17:08:53 <t8m> pjones, I don't think they mean default comps group or so but so that it is on the DVD
17:09:02 <mjg59> nirik: I don't think anyone's suggested that
17:09:19 <pjones> nirik: I'd be opposed to that as well.
17:10:42 <nirik> ok, if it only enables on selecting the package manually I guess I am ok with it. Not sure about adding it to base/core.
17:11:01 <pjones> yeah - I don't think there's been any actual proposal about comps, either.
17:11:14 <pjones> but that could be because of a lack of understanding about process or something
17:11:33 <mjg59> So should we just vote on it?
17:11:35 <t8m> it should not be in base/core set
17:11:46 <mjg59> As a feature, not as part of a default install
17:11:47 <pjones> right now, as I see it, this is about auto-enabling when the package is selected.
17:12:17 <notting> pjones: at that level, i can be +1 to that as a feature
17:12:27 <t8m> me too, +1
17:12:39 <mjg59> +1 as an (optional) feature
17:12:44 <ajax> +1 as above
17:12:44 <pjones> I guess I can +1 it, contingent on them actually getting code done
17:12:51 <t8m> of course
17:12:55 <mmaslano> +1 ^
17:13:03 <nirik> +1 as long as only enabled when manually selected.
17:13:20 <mjg59> #agreed, Trusted boot is approved as an optional F16 feature
17:13:28 <pjones> nirik: well, mechanically selected as well ;) we do have kickstart.
17:13:39 <nirik> well, sure, yeah.
17:13:42 <mjg59> Ok
17:13:48 <mjg59> #topic #563     suggested policy: all daemons must set RELRO and PIE flags
17:13:51 <mjg59> .fesco 563
17:13:52 <zodbot> mjg59: #563 (suggested policy: all daemons must set RELRO and PIE flags) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/563
17:14:00 <mjg59> Anything new on this?
17:14:09 <nirik> ok, I wanted to discuss this a bit more here before going back to fpc.
17:14:26 <nirik> I started a draft page up: https://fedoraproject.org/wiki/User:Kevin/DRAFT_When_to_use_PIE_compiler_flags
17:14:47 <nirik> but found a number of questions... it gets difficult to try and come up with a list.
17:15:04 <nirik> some data/information points:
17:15:53 <nirik> doing this on 32bit doesn't help much at all. It can be easily brute forced... slows attacks only a bit. Of course doing it only for 64bit would make things more complicated (if it's even possible)
17:16:15 <nirik> as far as I can see from docs, debian only does openssh this way.
17:16:19 <ajax> i'm not interested in varying this between 32 and 64
17:16:22 <nirik> and ubuntu has a small list.
17:16:23 <t8m> I would make the full RELRO+PIE completely conditional based on the individual package maintainer decision. They should know what they are doing and should be able to find the reasonable compromise best.
17:16:35 <nirik> (thats also odd)
17:16:47 <nirik> t8m: yeah, thats an option...
17:16:49 <mjg59> I don't think there's a strong argument against RELRO
17:17:07 <mjg59> We should just mandate that one
17:17:09 <nirik> I think relro is settled... it's PIE that we are still trying to determine.
17:17:10 <t8m> mjg59, partial RELRO hopefully will be mandated
17:17:14 <ajax> mjg59: this is an irritating bit of nomenclature some people are using
17:17:22 <ajax> where "full relro" and "partial relro" are different things
17:17:23 <t8m> nirik, full RELRO + PIE
17:17:43 <mjg59> Excellent
17:18:08 <ajax> "full" means also linking with -z now, which really isn't something we can mandate
17:18:26 <nirik> our tools maintainer is against full relro and pie for everything.
17:18:34 <mjg59> From a picky point of view, I'd make it clear that the criteria nirik lists are an "any", not an "all"
17:18:44 <mjg59> I'd also worry about the absence of, say, firefox from the list
17:18:49 <pjones> yeah
17:18:57 <pjones> and thunderbird and evolution
17:19:02 <mjg59> And libreoffice
17:19:12 * nirik notes he just threw some packages down there and relalized we have no real good critera.
17:19:14 <mjg59> Big codebases that exist purely to consume things that other people have given to you
17:19:14 <pjones> long running processes that collect exploits from the network definitely need this ;)
17:19:31 <t8m> if we make libreoffice PIE we can drop prelink altogether :D
17:19:35 <notting> ... upowerd? why would this need it?
17:20:22 * nirik sighs. Please create me a list from scratch and tell me what critera you used to do it? ;)
17:20:44 <notting> nirik: 'network-facing daemons, and user applications that process untrusted content from the internet'?
17:21:10 <mjg59> That seems reasonable
17:21:17 <nirik> ok, how do we generate the list based on that? :)
17:21:23 <pjones> manually :(
17:21:25 <mjg59> Then have fpc approve it and file bugs against appropriate packages?
17:21:41 <mjg59> Maybe just starting with the default installs
17:22:04 <ajax> i'd still prefer if we had rpm macros for this so you could just %define _hardened_build 1 and not have to worry about it
17:22:10 <ajax> (which i'm happy to write)
17:22:19 <mjg59> ajax: That does seem like a sensible implementation
17:22:21 <nirik> thats the approach debian takes.
17:22:23 <pjones> ajax: yes.
17:22:45 <t8m> ajax, +1
17:22:51 <nirik> so, does libreoffice fall under this? so it could be anything that reads a file?
17:23:12 <ajax> nirik: the case for LO is that it's too big to audit
17:23:24 <notting> "things FF would call as a file handler" would cover libreoffice, yes
17:23:39 <pjones> ajax: also it reads what should effectively be treated as hostile content.
17:23:45 <nirik> I'm fearing we will end up with a big list. ;) Also, how many things will fail to work right with this? do we block release on it?
17:24:09 <pjones> let's burn that bridge when we come to it?
17:24:16 <mjg59> Maybe everything will be fine
17:24:16 <notting> i don't think it's a release blocker, no
17:24:20 <t8m> well I'd also consider setuid binaries and long running non-network facing daemons that run with uid 0
17:24:25 <mjg59> Ok
17:24:31 <pjones> t8m: really any uid
17:24:39 <t8m> or even that
17:24:42 <dvlasenk> think about it as attacker. You would attack a typical long-running process. That is, ntpd is a possible target, but not cp or mv.
17:24:46 <pjones> which is... what we said above
17:24:50 <nirik> also, PIE using packages should also do full relro?
17:24:51 <ajax> nirik: the failure cases from -z now are really easy to diagnose, at least
17:24:55 <mjg59> So we'll work on nirik's policy a litle more, revisit next week and then punt to fpc?
17:25:09 <pjones> mjg59: +1 to that
17:25:16 <mjg59> Any objections?
17:25:29 <nirik> ok. if others wish to try and come up with a better list, please do. :)
17:25:33 <ajax> wfm
17:25:34 <t8m> mjg59, +1
17:25:35 <nirik> (or edit heavily the existing one)
17:25:45 <pjones> I think notting's criteria + setuid is a pretty solid start.
17:25:49 <mjg59> #agreed Work on tuning the criteria and revisit next week
17:25:52 <mjg59> Ok
17:25:57 <mjg59> #topic #615     Strategy for services that do not have systemd native unit files
17:26:00 <mjg59> .fesco 615
17:26:01 <zodbot> mjg59: #615 (Strategy for services that do not have systemd native unit files) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/615
17:26:03 <mjg59> Anything for this?
17:26:37 <ajax> no, though i did mean to email the list about that
17:26:42 * ajax opens a composer
17:26:50 <mjg59> Ok
17:26:51 <abadger1999> [04:05:37] <Viking-Ice> abadger1999, you might want to have proven packager to take a look at these packages http://www.fpaste.org/d7xs/ which contain native systemd unit but their package does not meet the packaging guidelines
17:27:01 <abadger1999> That's all I've heard recently.
17:27:12 * abadger1999 notes he's been busy with other things this week.
17:27:38 <mjg59> Ok
17:27:54 <mjg59> Well, if nothing else, let's just leave that for now
17:27:58 <abadger1999> Need provenpackagers to help out Viking-Ice.
17:28:01 <Viking-Ice> wait I got status update
17:28:09 <Viking-Ice> https://fedoraproject.org/wiki/User:Johannbg/Features/SysVtoSystemd
17:28:32 <Viking-Ice> http://fpaste.org/ErRL/
17:28:59 <nirik> Viking-Ice: cool.
17:29:11 <Viking-Ice> of base and core things are heading as I expected things stuck on audit iscsi and nfs
17:29:12 <mjg59> Ok, so things seem to be progressing well
17:29:32 <Viking-Ice> device mapper multipath is done but not package I just finished wpa_supplicant with Dan
17:29:47 <Viking-Ice> smolt is not a daemon but a hack but has been ported
17:30:01 <Viking-Ice> openvpn is potential issue
17:30:27 <pjones> So progress is being made, then.
17:30:32 <mjg59> Is there anything fesco can do to speed things up?
17:30:42 * nirik would like to help, but has been traveling. Will try this week/next.
17:30:46 <mjg59> Because if not, I think things look under control
17:30:54 <pjones> I don't know that we need to go through the entire list individually, but anything we can do to help would be worth noting.
17:31:19 <Viking-Ice> package I suppose is the biggest issue and getting some response from maintainers et al I guess
17:31:34 <mjg59> Yeah, I don't know that we can really do anything about that
17:31:51 <Viking-Ice> simple I dont have time to package this and I could ping and point a proven packager to that component
17:32:20 <mjg59> Well, sure, but fesco can't mandate that proven packagers do things
17:33:10 <nirik> right, all we can do is use our own provenpackager powers to help. ;)
17:33:32 <ajax> next item then?
17:33:33 <mjg59> There seems to be steady progress being made, and unless there's anything that fesco's explicitly being asked to help with I think that's fine
17:33:38 <Viking-Ice> well we are faced with a difficult problem if we dont take any action the conversion process will span over multiple release cycles delaying any other legacy sysv init clean in the process
17:33:50 <Viking-Ice> s/clean/clean up
17:33:51 <mjg59> Viking-Ice: What action do you want fesco to take?
17:34:06 <mjg59> Because I don't think there's anything we can actually do to help you here
17:34:25 <ajax> why would that be a calamity?  it's taken five releases for us to delete hal, who cares.
17:34:26 <Viking-Ice> I'm blank for ideas on how to improve speed up the progress
17:34:54 <mjg59> ajax: Well, right now it's a release blocker
17:34:58 <mjg59> But I'm sure we can revisit that
17:35:02 <mjg59> Anyway
17:35:11 <mjg59> Moving on
17:35:14 <mjg59> #topic  #647 Consider 14 features in FeatureReadyForFesco despite the Submission Date passing.
17:35:18 <mjg59> .fesco 647
17:35:19 <ajax> i meant it rhetorically, yeah.
17:35:20 <zodbot> mjg59: #647 (Consider 14 features in FeatureReadyForFesco despite the Submission Date passing.) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/647
17:35:38 <abadger1999> ajax: switching from sysv to systemd service may changes whether the service starts on boot.
17:35:54 * rbergeron peeks in
17:35:55 <mjg59> I'm +1 to this
17:36:01 <abadger1999> ajax: So it's better to do it in one fell swoop than to stretch it out over multiple releases.
17:36:04 <nirik> I'm +1 for considering these. Given scheduling changes, etc.
17:36:07 <mmaslano> +1 with this
17:36:10 <pjones> yeah, +1
17:36:14 <ajax> do it, +1
17:36:25 <mjg59> #agreed Fesco will consider these features
17:36:29 <rbergeron> thanks. :)
17:36:30 <t8m> +1
17:36:31 <mjg59> Well that makes things easier
17:36:35 <mjg59> #topic #634     F16Feature: EclipseIndigo
17:36:35 <mjg59> .fesco 634
17:36:36 <zodbot> mjg59: #634 (F16Feature: EclipseIndigo - https://fedoraproject.org/wiki/Features/EclipseIndigo) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/634
17:36:58 <mjg59> +1
17:36:58 <notting> sure, why not +1
17:37:01 <t8m> +1
17:37:03 <pjones> +1
17:37:10 <nirik> sure, +1
17:37:15 <t8m> The release notes should be filled in
17:37:29 <ajax> they say "33 million lines of code" as if it were a good thing.
17:37:32 <mjg59> #agreed Eclipse Indigo is approved as an F16 feature
17:37:37 <mjg59> #topic #635     F16Feature: 1000 System Accounts
17:37:37 <mjg59> .fesco 635
17:37:38 <zodbot> mjg59: #635 (F16Feature: 1000 System Accounts - http://fedoraproject.org/wiki/Features/1000SystemAccounts) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/635
17:38:12 <pjones> depressing that we'd need this, but +1
17:38:16 <t8m> +1
17:38:21 <mjg59> +1
17:38:26 <ajax> +1, entirely sensible
17:38:29 <mmaslano> +1
17:38:37 <notting> +1
17:38:38 <nirik> +1, seems more like a release notes thing, but I guess it could affect people more, so a feature is worth while.
17:38:43 <mjg59> #agreed 1000 System Accounts is approved as a Fedora feature
17:38:47 <mjg59> #topic #636     F16Feature: Chrony default NTP client
17:38:48 <mjg59> .fesco 636
17:38:50 <zodbot> mjg59: #636 (F16Feature: Chrony default NTP client - https://fedoraproject.org/wiki/Features/ChronyDefaultNTP) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/636
17:38:51 <t8m> there will be some code changes needed
17:38:58 <pjones> enthusiastic +1
17:39:03 <t8m> that was for the 1000 sys accounts
17:39:20 <mjg59> +1 to this
17:39:23 <mmaslano> +1
17:39:26 <t8m> +1 to chrony
17:39:34 <nirik> +1, yes please.
17:39:50 <notting> i'm somewhat leery of switching something that has been a standard app forever
17:39:51 <mjg59> #agreed Chrony approved as the default NTP client
17:39:58 <ajax> +1; does this need anaconda or firstboot skinning?
17:40:00 <pjones> notting: but it's always been crappy
17:40:11 <mjg59> notting: Like init? :p
17:40:24 <notting> mjg59: bah, once you do that once, you can do it all the time!
17:40:50 <mjg59> #topic #637     F16Feature: Condor Cloud
17:40:50 <mjg59> .fesco 637
17:40:52 <zodbot> mjg59: #637 (F16Feature: Condor Cloud - https://fedoraproject.org/wiki/Features/Condor_Cloud) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/637
17:41:32 <ajax> more clouds!
17:41:40 <Slower> I am here to answer questions FYI
17:41:42 <Slower> re condor cloud
17:41:44 <mjg59> Cloudier than a thunderstorm
17:41:49 <pjones> I guess I'm vaguely +1 to getting overrun with near-meaningless acronyms.
17:41:50 <mjg59> +1 I guses
17:41:53 * nirik is +1 for this.
17:41:55 <notting> mjg59: needs more meatballs
17:41:59 <t8m> +1
17:41:59 <mmaslano> +1
17:42:03 <mjg59> No impact on anything else really, so...
17:42:04 <pjones> NMAaaS, as it were.
17:42:18 <mjg59> #agreed Condor Cloud is approved as an F16 feature
17:42:22 <ajax> we have kind of a lot of "cloud" features in f16
17:42:22 <notting> +1
17:42:31 <mjg59> #topic #638     F16Feature: Unified Problem Reporting UI
17:42:31 <mjg59> .fesco 638
17:42:32 <zodbot> mjg59: #638 (F16Feature: Unified Problem Reporting UI - https://fedoraproject.org/wiki/Features/Unified_Problem_Reporting_UI) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/638
17:42:35 <pjones> ajax: and not enough meatballs?
17:42:40 <ajax> it would be pleasant if someone would write an overview of them explaining why they're a) different b) desirable
17:42:49 <Slower> I think it's a new space and eventually the best will prevail
17:42:55 <pjones> not sure why this is really a feature, but what the hell, I'm feeling generous: +1
17:42:59 <nirik> Slower: yeah...
17:43:14 <t8m> +1 from me definitely
17:43:22 <mmaslano> +1
17:43:23 * nirik thinks using the same code to do the same thing instead of duplicating is a good idea. +1.
17:43:25 <mjg59> +1
17:43:37 <notting> +1
17:43:54 <mjg59> #agreed Unified Problem Reporting UI is approved as an F16 feature
17:43:58 <ajax> +1 i guess, though not including abrt in the list is weird
17:44:04 <ajax> or just not in scope yet
17:44:13 <nirik> arbt already uses it I thought.
17:44:18 <mjg59> ajax: abrt is mentioned
17:44:19 <nirik> abrt rather
17:44:53 <mjg59> Ok
17:44:55 <mjg59> #topic #639     F16Feature: GCC Python Plugins
17:44:55 <mjg59> .fesco 639
17:44:56 <zodbot> mjg59: #639 (F16Feature: GCC Python Plugins - https://fedoraproject.org/wiki/Features/GccPythonPlugin) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/639
17:45:13 <pjones> definitely +1
17:45:16 <ajax> <3 <3 <3
17:45:17 <mjg59> +1
17:45:21 <mjg59> This looks kind of amazing
17:45:24 <nirik> I suspect not too many people will use this or care about it, but it's cool and the people who do/will will find it of note, +1
17:45:27 <ajax> +1 and buy that man a beer
17:45:30 <pjones> mjg59: the next feature is more ninja from dmalcolm.
17:45:35 <notting> +1
17:45:39 <mmaslano> +1
17:45:58 <mjg59> #agreed GCC Python Plugins are an approved F16 feature
17:46:08 <mjg59> #topic #639     F16Feature: GCC Python Plugins
17:46:09 <mjg59> .fesco 639
17:46:10 <zodbot> mjg59: #639 (F16Feature: GCC Python Plugins - https://fedoraproject.org/wiki/Features/GccPythonPlugin) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/639
17:46:18 <pjones> this is really fantastic: +1
17:46:30 <mjg59> Wait.
17:46:32 <nirik> hum? a bit of an echo?
17:46:33 <notting> so fantastic mjg59 submitted it twice?
17:46:37 <mjg59> #topic #640     F16Feature: Static Analysis of CPython Extensions
17:46:37 <mjg59> .fesco 640
17:46:39 <zodbot> mjg59: #640 (F16Feature: Static Analysis of CPython Extensions - https://fedoraproject.org/wiki/Features/StaticAnalysisOfCPythonExtensions) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/640
17:46:44 <nirik> I suspect not too many people will use this or care about it, but it's cool and the people who do/will will find it of note, +1
17:46:45 <ajax> please replace the handset, and try again
17:46:48 <pjones> this is the really fantastic thing to which I referred: +1
17:46:54 <mjg59> +1
17:46:55 <ajax> +1
17:46:57 <t8m> +1
17:47:06 <notting> +1
17:47:19 <mjg59> #agreed Static Analysis of CPython Extensions is an approved F16 features
17:47:32 <mjg59> #topic #641     F16Feature: GNOME Input Integration
17:47:32 <mjg59> .fesco 641
17:47:33 <zodbot> mjg59: #641 (F16Feature: GNOME Input Integration - https://fedoraproject.org/wiki/Features/GnomeInputIntegration) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/641
17:47:42 <mjg59> +1 oh yes at last
17:47:49 <pjones> for the love of god, finally, +1
17:48:00 <t8m> +1
17:48:04 <ajax> +1
17:48:10 <nirik> +1. Although, it would be nice to work on other desktops too?
17:48:36 <notting> looking at the names on it.. .upstream gnome is aware of this?
17:48:48 <ajax> notting: pretty sure, yeah
17:49:30 <ajax> given the links at the bottom, i suspect this is about implementing something gnome's already done some design on
17:49:37 <mjg59> And if they're not, it doesn't get merged and the feature doesn't get compelted
17:49:59 <mjg59> Ok
17:49:59 <ajax> also i believe i've heard mclasen talk about this during team meetings
17:50:08 <notting> ok. +1
17:50:12 <mjg59> #agreed Gnome Input Integration is an approved F16 feature
17:50:17 <mjg59> #topic #642     F16Feature: Sugar 0.94
17:50:17 <mjg59> .fesco 642
17:50:18 <zodbot> mjg59: #642 (F16Feature: Sugar 0.94 - https://fedoraproject.org/wiki/Features/Sugar_0.94) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/642
17:50:27 <pjones> +1
17:50:33 <mjg59> +1
17:50:36 <nirik> sure, +1. more sugar. NM 0.9 integration would be good to get...
17:50:52 <pjones> Also glad "sugar" and "spice" were next to each other in the list.
17:50:54 <t8m> +1
17:51:02 <mmaslano> +1
17:51:16 * nirik submits a 'everything nice' feature.
17:51:22 <notting> +1
17:51:24 <ajax> +1
17:51:30 <mjg59> #agreed Sugar 0.94 is an approved F16 feature
17:51:34 <mjg59> #topic #644     F16Feature: Spice 0.10
17:51:34 <mjg59> .fesco 644
17:51:35 <zodbot> mjg59: #644 (F16Feature: Spice 0.10 - https://fedoraproject.org/wiki/Features/F16Spice0.10) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/644
17:52:10 <ajax> +1, usb sharing is really very cool
17:52:18 <nirik> sure, +1. I still need to find time to play with the existing version, but it's pretty cool sounding.
17:52:19 <notting> +1
17:52:20 <t8m> +1
17:52:32 <mjg59> +1
17:52:34 <notting> ajax: it's 1-1, not 1-N, right?
17:52:48 <notting> can't imagine the latter would work well
17:52:53 <pjones> +1
17:52:59 <mmaslano> +1
17:53:08 <mjg59> #agreed Spice 0.10 is an approved F16 feature
17:53:16 <mjg59> #topic #645     F16Feature: New mkdumprd for for kdump
17:53:16 <mjg59> .fesco 645
17:53:17 <zodbot> mjg59: #645 (F16Feature: New mkdumprd for for kdump - https://fedoraproject.org/wiki/Features/NewMkdumprd) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/645
17:53:36 <mjg59> I guess +1? It feels like a bit of an implementation detail.
17:53:37 <pjones> +1 to undoing stupid mistakes of the past that I tried to prevent from happening in the first place.
17:53:54 <notting> mjg59: a complete rewrite is probably worth a feature page
17:54:03 <notting> so, i'm +1
17:54:13 <nirik> sure, +1, using dracut instead of their own thing is good.
17:54:47 <ajax> notting: i'm... not actually sure?  i think if you have multiple viewers each one could share a USB device with the guest
17:55:32 <ajax> +1 to the current feature i guess.  still never seen any personal benefit from kdump, but i guess someone has.
17:55:32 <pjones> N-1 then
17:55:57 <pjones> okay, that's 4 of us...
17:56:01 <mjg59> 5, I think
17:56:03 <t8m> +1
17:56:08 <mmaslano> +1
17:56:18 <mjg59> #agreed New mkdumprd for kdump is an approved F16 feature
17:56:24 <mjg59> #topic #646     F16 Feature: Use Ext4 driver for Ext3 and Ext2 filesystems
17:56:27 <mjg59> .fesco 646
17:56:29 <zodbot> mjg59: #646 (F16 Feature: Use Ext4 driver for Ext3 and Ext2 filesystems -- https://fedoraproject.org/wiki/Features/UseExt4ForExt3AndExt2) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/646
17:56:37 <pjones> If sandeen says we should, then +12
17:56:41 <pjones> er, +1
17:56:44 <nirik> this seems odd for a feature, but i guess they want more noise than a release note...
17:56:44 <mjg59> If Eric wants this, Eric can have this
17:56:45 <pjones> though more may be appropriate.
17:56:50 <notting> +1
17:56:52 <mjg59> +1
17:56:52 <mmaslano> +1
17:56:58 <t8m> ok then +1
17:56:58 <nirik> so, sure, +1
17:57:07 <nirik> less duplicated code is good.
17:57:14 <mjg59> #agreed Use Ext4 driver for Ext3 and Ext2 filesystems is an approved F16 feature
17:57:17 <mjg59> Phew.
17:57:26 <mjg59> Ok. I think that's everything we had on the schedule.
17:57:35 <mjg59> So next I just have
17:57:38 <mjg59> #topic Next week's chair
17:57:48 <notting> i'll do it
17:57:49 <mjg59> Any volunteers?
17:57:51 <mjg59> Awesome
17:57:57 <mjg59> #agreed notting to chair next week's meeting
17:57:59 * nirik cheers.
17:58:12 <mjg59> Anything about engineering tickets?
17:58:44 <abadger1999> What's the status of FES?"
17:58:55 <nirik> abadger1999: it seems kinda quiet. ;(
17:59:16 <nirik> I can ask the person who was going to work reviving it. He had to move, so was off net for a while.
17:59:32 <abadger1999> Its mission was to give fesco a way to direct labor, like mjg59 asked what fesco could do about migration to systemd.... so was w0ndering if it was dead or dormant or what.
17:59:46 <abadger1999> <nod>
18:00:40 <nirik> yeah, it's not had much activity of late, will see if we can revive it.
18:01:01 <mjg59> nirik: Awesome
18:01:03 <Viking-Ice> explains why I have not had any response on that ticket ...
18:01:13 <mjg59> Anything else on that?
18:01:37 <mjg59> Ok
18:01:38 <mjg59> #topic Open Floor
18:01:54 <adamw> nirik: do you want to mention my feature / blocker process mail?
18:01:59 <mjg59> I'll just wait a few minutes in case anyone has something they'd like to bring up
18:02:05 <nirik> adamw: sure, if you like...
18:02:31 <adamw> http://lists.fedoraproject.org/pipermail/devel/2011-July/154345.html , in case anyone didn't see it
18:03:01 * nirik thinks it sounds reasonable.
18:03:02 <t8m> adamw, that's definitely OK
18:03:17 <nirik> qa is responsible for qa things, not any other groups reasons for possibly blocking release.
18:03:29 <mmaslano> adamw: sounds fine
18:03:38 <mjg59> Yeah, fine by me
18:03:41 <adamw> awesome
18:03:42 <notting> fine with me
18:04:20 <adamw> thanks, folks, i'll drop a reply to the list to highlight the wiki changes once i've made them
18:04:33 <t8m> that will be nice
18:04:48 <mjg59> Ok, I'll close out in a minute unless anyone has anything else
18:05:22 <mjg59> Ok
18:05:25 <mjg59> #endmeeting