insight
LOGS
20:00:02 <stickster> #startmeeting Insight -- agenda: http://tinyurl.com/insight-agenda
20:00:02 <zodbot> Meeting started Tue Jun 14 20:00:02 2011 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:05 <stickster> #meetingname Insight
20:00:05 <zodbot> The meeting name has been set to 'insight'
20:00:09 <stickster> #topic Roll call
20:00:10 * stickster 
20:00:13 <asrob> re
20:02:14 <stickster> I was thinking hiemanshu, pcalarco, tatica would be here too :-)
20:02:30 * hiemanshu is around
20:02:44 <pcalarco> greetings, all!
20:02:52 <stickster> Hi pcalarco!
20:03:28 <stickster> #chair hiemanshu pcalarco asrob
20:03:28 <zodbot> Current chairs: asrob hiemanshu pcalarco stickster
20:03:36 <stickster> Anyone seen averi lately? Or is he still in exams?
20:03:56 <asrob> negative, I think he is still in exams
20:04:16 <hiemanshu> I saw he jump in and out a couple of times
20:04:19 <hiemanshu> him*
20:04:25 <tatica> o/
20:04:35 <asrob> o/
20:04:59 <stickster> OK
20:05:04 <stickster> give me 60 sec to finish one quick task
20:05:13 <hiemanshu> your time starts now
20:05:29 <stickster> OK, that's done now :-)
20:05:34 <stickster> #topic Last week's action items
20:05:46 <stickster> I'm going to re-run averi's, which is fine
20:05:54 <stickster> #action averi check and set a backup profile on the insight01.dev host
20:06:10 <stickster> #action averi Do a use case explanation for podcast announcement idea
20:06:18 <stickster> #action stickster Do an email to list on user-centric ideas for the identi.ca feed idea
20:06:23 <stickster> I have to do my other one too :-)
20:06:43 <stickster> #info Deferring all these another week... but they will get done!
20:06:55 * tatica brings design reinforcements
20:07:05 <stickster> #topic Use case reviews
20:07:58 <stickster> asrob, I posted some additional feedback on the "win" level for your use cases to the list
20:08:16 <stickster> No one responded to that, maybe that means everyone agrees with me?
20:08:30 <asrob> stickster: yeah, I saw that, +1 from me
20:08:31 <stickster> http://lists.fedoraproject.org/pipermail/logistics/2011-June/001336.html
20:08:36 <stickster> asrob, On the list please ;-)
20:08:43 <pcalarco> +1 here to, they made sense to me
20:08:58 <pcalarco> will send email now
20:09:16 * asrob too
20:09:22 <stickster> Cool -- I encourage everyone to use the list over the course of the week. I know we all get busy but that's the best way to keep things moving rather than stalling until we have another IRC meeting.
20:09:50 <stickster> I'm just as guilty of this as anyone -- last week I traveled Thu - Sun so it really took a bite out of my time to do any email or Insight work
20:11:05 <asrob> done
20:11:44 <stickster> Well, how would you guys like to spend this time? I'm curious as to how you think the meeting is best spent.
20:11:58 <stickster> Heh, that was kind of redundant there... anyway... :-)
20:12:20 <hiemanshu> the meeting should be spent on catching up things done in the past, and what should be done next week
20:12:29 <hiemanshu> which well it seems to be doing perfectly
20:12:53 <pcalarco> further prioritizing amongst the "wins" use cases?
20:13:48 <asrob> hey averi :)
20:13:55 <stickster> Hi averi
20:13:57 <stickster> #chair averi
20:13:57 <zodbot> Current chairs: asrob averi hiemanshu pcalarco stickster
20:14:06 <averi> hello, sorry for being late
20:14:40 <stickster> Well, let's take a look at what we've got now. We've spent a little time on the calendar already, which I wrote up. We got some additional use cases that need to be parsed out. Probably best if I put all that in a wiki to make it easier to discuss -- it will be all in one place then.
20:14:57 <stickster> #action stickster consolidate email thread on calendar use cases in to a wiki page that's easier to review
20:15:35 <stickster> What if we spend some time talking about asrob's podcast integration topic?
20:16:21 * stickster waits for a sign of life... ;-)
20:16:30 <asrob> :)
20:16:48 * hiemanshu moves his fingers
20:16:59 <stickster> http://lists.fedoraproject.org/pipermail/logistics/2011-June/001332.html
20:17:13 <stickster> ^^ That's asrob's use cases for the podcast integration.
20:17:22 <pcalarco> +1 to that, seems the easier of the two
20:17:48 <stickster> My first question is, Are there some other ways that some people might use a podcast attachment feature? We have a use case there for people looking for all podcast, and one for people listening to podcasts. What about people who want to post them?
20:18:31 <hiemanshu> stickster: they share the links of the podcast?
20:18:39 <pcalarco> so most folk would host these at the Internet Archive, likely; is that a good assumption?
20:18:51 <hiemanshu> pcalarco: yes
20:19:17 <stickster> pcalarco, I think that's up to us to determine, but sure, that would be one possibility
20:20:10 <stickster> So the first question would be, how does the person do such an attachment? If it's a link to Internet Archive, how do we guarantee licensing of the content?
20:20:52 <hiemanshu> stickster: the first few mins being a license disclaimer? like in any README
20:20:56 <hiemanshu> s/mins/seconds
20:21:44 <pcalarco> stickster: can license be mentioned and embedded as ogg/mp3 metadata in one of those fields? Don't know enough offhand about this
20:21:54 <stickster> So let's say I put something on the Internet Archive, and the submission page says, "By adding this content, you are confirming it is licensed CC BY-SA or CC BY."
20:22:11 <stickster> (Those being the two acceptable CC licenses for Fedora collaterial content, AFAIK)
20:22:29 <stickster> (oh, and maybe CC 0, I can't recall off the top of my head.)
20:22:56 <pcalarco> the onus is on the content submitter, but the Insight team should likely try to verify an explicit CC license, I'd think
20:23:18 <stickster> pcalarco, Yeah, precisely -- I was about to say, an editor would be responsible for checking the license before it gets published
20:23:23 <stickster> So now we have a requirement for this feature:
20:23:46 <stickster> * Needs a workflow that guarantees appropriate licensing, if we link out to some external resource
20:24:09 <pcalarco> Insight editorial team can pull off the story if someone comes along to counter that assertion
20:24:37 <stickster> I don't know the answer to this -- is there any worry that something can be taken off the Internet Archive once it's posted? (Assuming it's not evil content or something.)
20:25:36 <pcalarco> the IA as a hosting platform is responsible for pulling content down if it is deemed to be in copyright without CC rights
20:26:01 <stickster> pcalarco, OK, that makes sense. But if I upload something, could I change my mind later and remove it unilaterally?
20:26:04 <pcalarco> but it is up to the content owner to make that assertion and to provie it
20:26:23 <pcalarco> stickster: good question, not sure
20:26:32 <pcalarco> I bet spot would know
20:26:41 <pcalarco> or know who to ask
20:26:52 <stickster> Hm, http://www.archive.org/about/faqs.php <-- look at bottom -- I see a lot of delete requests in those threads that are being honored.
20:27:04 <stickster> That might argue for us to actually host the content somewhere.
20:27:26 <pcalarco> why would we want to take on that liability?
20:27:42 <stickster> pcalarco, It's not really a liability if we're checking the content as editors.
20:28:01 <stickster> pcalarco, Any more than it's a liability with the wiki, or the old video archives we have, or any number of other pieces of content.
20:29:10 <pcalarco> stickster: we've shown due diligence if we check but we could still be wrong occasionally; these don't usually end in lawsuits, in any event, more like cease and disist, and it ends there
20:29:17 <stickster> If the person uploads in agreement with our licensing, and we find there's a problem, we can deal with that on a case by case basis.
20:29:24 <pcalarco> +1
20:30:05 <stickster> One other point maybe -- I wouldn't foresee giving out the rights to all users to just upload audio. A small set of people we know who are doing this media could upload directly, and if we want to encourage other submissions the editors could simply download the media, check, and then upload.
20:30:46 <stickster> That's really a good editor role anyway, because the whole mission for the site is not to just be a dumping ground, but a well-tended set of content.
20:31:36 <stickster> So would people agree this is a reasonable way to go? We'd have to determine where to store things, but that's an implementation detail.
20:32:13 <pcalarco> do we repost media that is critical of Fedora?  I am thinking of the Linux Action Show "review" of Fedora 15
20:33:09 <stickster> pcalarco, I think our mission is not to repost other media.
20:33:31 <pcalarco> stories occasionally get posted to In The News that are thus, but there is always follow up of the misconceptions with those
20:34:02 <pcalarco> stickster: apologies, "point to" instead of repost, which I agree are different
20:34:06 <stickster> The overall mission of Fedora Insight is to offer a subset of media created by the Fedora community, which helps educate and inform people who aren't necessarily in the community
20:34:29 <asrob> hm, there are a few archive.org drupal modules, so we can use one of them
20:34:46 <stickster> So for any particular link, whether we put it on Insight is dependent on whether it meets our criteria for that mission
20:35:14 <pcalarco> stickster: great, that is a good statement of scope and purpose; this will be important for content submitters
20:35:41 <stickster> There are plenty of places where people can post their rants about {X} where {X} is Fedora, openSUSE, Ubuntu, Linux, computers, or whatever. I think our scope is to be part of the marketing outreach for Fedora itself, not to be a disinterested third party.
20:35:57 <pcalarco> agreed
20:36:18 <stickster> Is everyone #agreed on that?
20:36:32 <asrob> +1
20:36:48 <pcalarco> +1
20:37:24 <stickster> #agreed Insight accepts stuff for purposes of marketing Fedora, and the content reflects that purpose.
20:37:56 <stickster> So are we also agreed that we should store copies of the content to ensure it's available and licensed under the same terms as other Fedora content, e.g. the wiki, etc.?
20:38:36 <asrob> +1
20:39:05 <pcalarco> stickster: are we okay with storage somewhere in Fedora infrastructure somewhere for internal copies?  I know this was an issue in the past
20:40:06 <stickster> pcalarco, I think that's an implementation detail that we'll certainly need to sort out, but it should be possible to sort it out. I would foresee this being not a very big repository overall.
20:40:25 <stickster> However we store it, we'd want the storage to be backed up somehow
20:40:37 <pcalarco> +1 here then, sounds good
20:40:45 <stickster> And we can work with Infra to find out the best way to do that
20:41:46 <stickster> #agreed To do media attachments, we'll work out a way of uploading/storing things so that we can assure licensing and availability, and work with Infra to use resources appropriately.
20:44:03 * stickster got lost, not sure what was the next point he wanted to make
20:44:24 * tatica waiting a chance to jump
20:44:39 <pcalarco> so now we'll need some ears to watch for appropriate content like Rahul does for print/web/blogosphere
20:45:19 <stickster> tatica, one thing I was hoping you could help with... if you have any time... and this is off topic :-) ... is helping to fix the Blocks menu in our theme
20:45:31 <tatica> css? sure
20:45:32 <tatica> link?
20:45:45 <stickster> tatica, I will find it :-) one sec...
20:46:02 <tatica> oki
20:46:10 <asrob> tatica: log in into Insight, edit blocks and ta-da :)
20:46:17 <stickster> tatica, https://insight01.dev.fedoraproject.org/admin/build/block
20:46:40 <stickster> tatica, If that doesn't work, you can point it to any Drupal 6 at /admin/build/block as long as you're using our Insight theme
20:46:41 <tatica> asrob, any acount?
20:46:52 <stickster> tatica, It may only work if you have rights to get to that screen
20:46:54 <tatica> and if not.. I can just mail you the changes :P
20:47:05 * tatica trying to login first
20:47:25 <tatica> logon
20:48:03 <asrob> .container-12 .pull-9, .container-16 .pull-12 <--- just remove "left: -720px;" and it works
20:48:30 <tatica> ok... problem with those blocks are.. ?
20:48:31 <stickster> pcalarco, As to your question... actually... I was foreseeing not that we would go scour for these media resources, but that we would be looking to (1) the Fedora Marketing team to create them for releases, as in some of the previous releases such as F11... and (2) maybe offer this as a place for someone like Jonathan Nadeau to do an official podcast
20:48:32 <asrob> but I think this is a workaround
20:49:01 <asrob> tatica: not exactly, with first and second sidebar
20:49:14 <pcalarco> stickster: great ideas!
20:49:15 <asrob> I mean, left and right sidebar
20:49:41 <stickster> tatica, http://pfrields.fedorapeople.org/temp/blocks-weird.png
20:49:57 <tatica> dear lord! I don't see it that way!
20:50:07 <stickster> tatica, Oh my goodness... I didn't think I had a weird setup
20:50:08 <tatica> Firefox 4?
20:50:41 <stickster> tatica, Correct, using stock Firefox 4 package on F15
20:50:48 <tatica> ok
20:50:55 <stickster> tatica, I don't have any weird css plugins installed as far as I know
20:51:10 <tatica> maybe is your firefox not reading it as it should
20:51:29 <tatica> continue with the meeting and I will give it a look
20:51:37 <tatica> I don't want to interrupt guys
20:52:02 <stickster> tatica, Thank you for looking at it!
20:52:12 <stickster> pcalarco, OK, so let's go into that more on the list.
20:52:25 <stickster> #action stickster Send summary of #agreed stuff to list regarding podcast attachments
20:52:30 <stickster> #topic Open floor
20:52:34 <stickster> Anything else before we depart?
20:52:40 <tatica> if you need podcast I can send you mines too
20:52:48 <tatica> bot about fedora, but all of them recorded at fedora
20:52:53 <stickster> NEAT!
20:53:05 <stickster> I think that would be great.
20:53:16 <tatica> I'm doing like 4-5 per week
20:53:37 <stickster> We don't need to be restricted to just one podcast. We just want any podcast we put up to show something great about Fedora, and I *know* tatica does an excellent job at that :-)
20:54:00 <tatica> I will encourage more people to do podcast
20:54:07 <tatica> maybe record a video about how to do podcast can work
20:54:10 <stickster> Hopefully averi will get some time to work on exploring how the feed of podcasts would work.
20:54:32 * stickster will leave meeting open for 60 sec on other topics before we end
20:54:44 <pcalarco> stickster: agreed, thx
20:54:53 <asrob> thank you
20:54:56 <stickster> tatica, Did you want to point anyone to a URL for your podcast so we can sample your work?
20:55:07 <hiemanshu> stickster: a very very rough draft https://fedoraproject.org/wiki/Fedora_Events_System
20:55:15 <averi> stickster: good point, we'll check how to do it :)
20:55:15 <tatica> tatica.blip.tv
20:55:21 <stickster> hiemanshu, To the list please, sir! Thanks :-)
20:55:36 <tatica> stickster, I cannot reach admin
20:55:49 <tatica> asrob, point me that I might be a groups issue
20:55:52 <hiemanshu> stickster: still very rough, I'll email it once I have something better
20:56:05 <stickster> tatica, OK, it may be a permissions thing. If you install the theme on your local sandbox, select that as the default theme, and visit it, you may see it then
20:56:20 <stickster> tatica, I can put you in cmsadmin so you can access that menu
20:56:24 <tatica> oki
20:56:38 <stickster> #action stickster add tatica to cmsadmin FAS gruop
20:56:41 <pcalarco> thanks to all and see you later, gotta run!
20:56:42 <stickster> #undo
20:56:42 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x10e8a24c>
20:56:49 <stickster> #action stickster add tatica to cmsadmin FAS group so she can see theme problems more easily
20:56:54 <tatica> :D
20:56:55 <tatica> go go go!
20:56:57 <stickster> Bye pcalarco :-)
20:56:59 <stickster> OK
20:57:03 <stickster> That's it for me too!
20:57:15 <stickster> I'll send notes to the list -- thanks everyone!
20:57:16 <stickster> #endmeeting