insight
LOGS
20:00:05 <stickster> #startmeeting Fedora Insight (agenda: http://tinyurl.com/insight-agenda)
20:00:05 <zodbot> Meeting started Tue Jun  7 20:00:05 2011 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:00:09 <stickster> #meetingname Insight
20:00:09 <zodbot> The meeting name has been set to 'insight'
20:00:13 <stickster> #topic Roll call!
20:00:16 * stickster 
20:01:02 <asrob> hi
20:01:23 <stickster> hi asrob o/
20:02:09 <stickster> asrob, Do you know if averi, hiemanshu, pcalarco, anyone else might be joining us?
20:02:53 * jsmith lurks
20:02:57 * hiemanshu is around
20:03:03 <hiemanshu> finally up at this time
20:03:06 <asrob> stickster: I do not know, I talked with averi last week, but I have not seen him yet
20:03:48 <asrob> probably he is trying to pass his exams
20:04:10 <stickster> Ah yes, it's exam time for averi -- I keep forgetting.
20:04:29 <asrob> and me too :)
20:04:34 <stickster> It's now officially been two decades since I was in full-time school so I forget :-)
20:04:47 <stickster> #chair hiemanshu asrob
20:04:47 <zodbot> Current chairs: asrob hiemanshu stickster
20:04:55 <stickster> Well, let's check on last week's action items:
20:05:00 <stickster> #topic Action item followup
20:05:05 * hiemanshu is busy with exams too
20:05:12 <stickster> #info stickster did #2, still needs to do #5
20:05:29 <stickster> #action stickster Do an email to list on user-centric ideas for the identi.ca feed idea
20:05:42 <stickster> asrob, I see you did yours, thank you
20:05:45 <stickster> #info asrob did his
20:05:56 <stickster> #action averi check and set a backup profile on the insight01.dev host
20:06:06 <stickster> #action averi do the same thing for podcast announcement idea
20:06:20 <stickster> We'll cover those more in just a moment.
20:06:31 <stickster> #topic insight01.dev MySQL problems
20:06:56 <stickster> So I know that no one really worked on development stuff last week... because when I looked at the insight01.dev host on Friday it had a SQL connection problem.
20:07:44 <stickster> #info stickster found and resolved two problems: (1) too big a memory allocation for innodb storage engine; and (2) bad permissions on /var/lib/mysql that prevent a local socket connection.
20:08:42 <stickster> If the host stops working again, please let the list know! And even try troubleshooting if you're in a group that can do so.
20:10:04 <stickster> asrob, Anything else on host status? The production site appears fine, is staging working OK too?
20:10:33 <asrob> are we running the latest drupal?
20:10:59 <asrob> ah yes, we are
20:11:05 <asrob> then nothing
20:12:25 <asrob> we can start to fix the bugs, there was a problem with dev, stg and prod. is working well
20:12:35 <asrob> -is +are
20:13:00 <stickster> asrob, OK then
20:13:05 <stickster> #topic Use cases
20:14:05 <stickster> asrob, Which one would you like to talk about first? We have two on the list pending -- one is for calendar, one is for podcast feed/integration
20:14:17 * stickster doesn't want to spend the whole meeting doing all the talking :-)
20:14:26 <asrob> :)
20:14:38 <asrob> let us start the calendar idea
20:15:05 * asrob is looking for stickster's email
20:15:24 <stickster> http://lists.fedoraproject.org/pipermail/logistics/2011-May/001321.html
20:15:43 <asrob> I got it, thanks
20:16:14 <asrob> so, I like your ideas, those would be great
20:16:17 <stickster> So here's how I've been thinking about this from a user-centric perspective:
20:16:32 <stickster> We can all have lots of good ideas, but that doesn't mean we should do all of them.
20:16:59 <stickster> We need to prioritize, especially judging by how few people are actually doing the work :-)
20:17:51 <stickster> asrob, If you look at each of the ideas, I rated it also by how big a "win" it would be -- if we are able to make the "shiny ideal future" case happen, how much of a difference does that make to the user?
20:18:02 <stickster> Is it a HUGE change, or is it really just a small change?
20:18:23 <stickster> That's something I would like to see along with each of the use cases.
20:20:22 <asrob> I agree your rates
20:21:13 <stickster> So in that case, the next step is to sort of figure out in more detail how the ideas would work.
20:21:14 <asrob> the huge rates are indeed huge
20:22:30 <stickster> So let's look at breaking down what it would take to do some of these things.
20:23:08 <stickster> If a win is small but it takes a lot of work, we should probably make that a lower priority, or not do it at all. If something is a big win, and very little work, that's a no-brainer. :-)
20:23:24 <asrob> :)
20:23:33 <stickster> If it's a big win and a lot of work, we should still consider it, but realize the scope of work required to make it happen.
20:24:13 <stickster> So the first idea is about finding team meetings. Let's #topic for that and use #info as we figure out what it would take to make it happen.
20:24:20 <stickster> #topic Calendar idea - finding team meetings
20:25:17 <stickster> asrob, just start talking about how you would try to make this work. What modules would we need? How much work is required?
20:26:01 * stickster guessing that this would require at least Calendar and Date modules.
20:26:15 <asrob> yeah, you are right
20:26:33 <asrob> "Go to one-stop calendar page, choose a filter by
20:26:35 <asrob> team (Infrastructure) and type (weekly IRC meeting) -- results
20:26:37 <asrob> are automatically in my timezone. (Medium/small)"
20:26:39 <asrob> oops
20:26:44 <asrob> sorry
20:26:53 <asrob> bad copy & paste
20:27:01 <stickster> asrob, Does Calendar offer some sort of customizable Calendar View that integrates with Views?
20:27:02 <asrob> so, I am thinking about this
20:27:28 <asrob> probably yes, but we have to test it
20:27:55 <asrob> I have not done this before
20:28:00 <stickster> asrob, Maybe it's best for us not to concentrate on "which modules" here or "how" but rather... what else would we need to creat
20:28:02 <stickster> *create.
20:28:34 <stickster> #info To make this work, we need both an entry/edit form for team meetings, and a calendar view that shows the meeting schedule.
20:29:24 <stickster> #info We'd probably want to make sure that members of a team could edit/delete their team's meetings but not other teams'
20:30:30 <stickster> #info The calendar view would be best as a 2-week view, since some teams alternate weeks. AFAIK there are no monthly meetings.
20:31:01 <stickster> asrob, Feel free to #info some additional thoughts :-) I feel bad if I'm the only one running my big mouth :-D
20:31:27 <asrob> :)
20:31:28 <asrob> OK
20:33:08 <asrob> stickster: wait a sec, what about hiemanshu's gsoc project? he is building a calendar or not?
20:33:35 <hiemanshu> I am working more on a event system than calendar
20:33:52 <stickster> hiemanshu's project is for an entire event, like setting up a conference.
20:34:09 <stickster> asrob, But maybe it would make sense for us to take the above ideas, and reply to the list with thoughts for each of the calendar ideas.
20:34:21 <stickster> That way we could talk to hiemanshu about his project while he's around right now :-)
20:34:40 <asrob> ah, I see
20:34:52 <hiemanshu> yeah
20:35:02 * hiemanshu will be done with exams this week
20:35:26 <stickster> asrob, +/-1? ^^^
20:35:42 <asrob> stickster: +1
20:35:50 <stickster> #agreed Let's take next steps on the list of starting to parse out the requirements that come out of each of the use cases -- both for the calendar idea and the podcast integration idea.
20:36:07 <stickster> #topic New events system (ad hoc topic)
20:36:41 <stickster> hiemanshu, So tell me what you're doing with the COD project that a few people have mentioned previously.
20:37:06 <hiemanshu> stickster: well, COD is really basic
20:37:07 <stickster> #link http://drupal.org/project/cod <-- Drupal Conference Organizing Distribution, an events system on demand
20:37:18 <hiemanshu> I am going to add other stuff like managing events
20:37:23 <hiemanshu> the budgets
20:37:40 <hiemanshu> and other features like that, which makes it possible for us to move away from the wiki
20:37:58 <hiemanshu> and make it easier for us to organize events and manage them
20:38:11 <stickster> hiemanshu, So are you looking at building this around the framework of COD?
20:38:16 <hiemanshu> stickster: yes
20:38:18 <asrob> hiemanshu: can I ask?
20:38:22 <hiemanshu> asrob: sure
20:38:34 <hiemanshu> stickster: well cod is mainly few modules + install profile
20:38:39 <stickster> Right
20:38:42 <asrob> hiemanshu: so do you expand cod functionality?
20:38:57 <hiemanshu> asrob: yes
20:39:25 <asrob> hiemanshu: do you use features like cod?
20:39:48 <hiemanshu> asrob: sorry, I didn't get you
20:40:20 <stickster> hiemanshu, I think asrob means, are you familiar with/using the Features module as COD does
20:40:48 <hiemanshu> stickster: the main idea is to make the FUDCons easier to organize (most people put an X next to sponsorship needed but never file a ticket, and stuff like that)
20:41:02 <hiemanshu> stickster: yeah, I have been looking at it, so yeah, getting a little familiar with it
20:41:03 <asrob> stickster: you are right, thanks
20:41:32 <stickster> hiemanshu, This sounds like an *excellent* goal since we are overall trying to spread the ability for the community to put together more of FUDCon
20:41:56 <stickster> The EMEA folks started this with their FUDCons and we also did this with Tempe and Panama.
20:42:07 <stickster> Having a more reliable workflow would be a great help.
20:42:28 <stickster> hiemanshu, So after your exams end, I take it you will be working more full-time on GSoC, is that right?
20:42:37 <hiemanshu> that is the main idea behind it, and the same with non fedora organized events
20:42:39 <hiemanshu> stickster: yes
20:43:18 <stickster> hiemanshu, Yes, I love the idea that this would serve "events in general" as opposed to "just Fedora events". So integrating with the COD project is a big win-win, as they are also 100% FOSS. Are you in contact yet with the COD folks?
20:43:50 <hiemanshu> stickster: so far not yet, mostly been busy with exams, I'll be done in a couple of days and will start the talk with them
20:43:57 <hiemanshu> I have been in touch with a few drupal devs though
20:43:59 <stickster> hiemanshu, Sure, that makes total sense
20:44:46 <stickster> hiemanshu, Is there anything our team can do to assist you?
20:45:12 * hiemanshu can't think of anything right now, but would ping you if I needed any help
20:45:24 <hiemanshu> stickster: Nushio is also here now
20:45:48 <asrob> hiemanshu: ezra-g is hanging on #drupal ;)
20:45:50 <stickster> o/ Nushio
20:46:09 <Nushio> hey stickster, everyone
20:46:12 <asrob> hi
20:47:21 <hiemanshu> asrob: well not right now, once done with the meeting, I'll have to go sleep, I'll probably do it the day after
20:47:22 <stickster> asrob, So it seems to me we should be able to pursue things like the #fedora-meeting calendar items separately from what hiemanshu is doing
20:47:41 <stickster> There's not much crossover AFAICT
20:48:21 <asrob> okay
20:48:27 <Nushio> This should enhance insight, actually
20:48:48 <stickster> Nushio, yes possibly -- we are on Drupal 6 though and likely staying there for some time still
20:48:57 <Nushio> The idea behind the system it to keep track of budgets in events, as well as conferences and 'impressions' (tweets/dents from specific hashtags)
20:49:11 <stickster> Not sure what COD roadmap is and how that affects hiemanshu's FOSS event system project
20:49:14 <Nushio> stickster: and that's fine, iirc, drupal5 is still supported
20:49:19 <stickster> Nushio, Yup, hiemanshu described earlier
20:49:37 <asrob> Nushio: drupal 5 supported?
20:49:46 * Nushio takes this moment to apologize for being late / missing so many meetings, i really need to set up a reminder on my phone
20:49:48 <asrob> it is interesting :)
20:50:35 <stickster> hiemanshu, Nushio -- if you guys wanted to develop some questions or things you need to know from people who have organized FUDCon, you could always set up a meeting or interview with me, jsmith-away, rbergeron, spevack, aeperezt, red, and others who have planned FUDCons
20:51:06 <stickster> I suspect our needs are not much different from other conferences. But you could also talk to people like ke4qqq and herlo who have organized conferences independent from Fedora too
20:51:06 <Nushio> stickster: i've been planning this system for quite a while, and I did talk with rbergeron and tatica during FUDCon Tempe
20:51:12 <stickster> Nushio, AWESOME.
20:51:15 <hiemanshu> stickster: I have seen most of process (kudos to the transperancy), and for everything else I can always ping you :)
20:51:27 <stickster> Just wanted to make sure you guys know you're welcome to call on us if needed
20:51:30 * ke4qqq looks up
20:51:32 <Nushio> Thanks
20:51:58 <asrob> Nushio: where do you read that drupal 5 is supported?
20:52:13 * stickster has to go afk shortly -- asrob, can you do the #endmeeting when things wrap up in a few minutes?
20:52:20 <hiemanshu> stickster: also what version of drupal are we on? drupal6 right?
20:52:27 <hiemanshu> asrob: ^
20:52:28 <Nushio> asrob: well it was last time I checked, I admit I haven't checked drupal.org recently :P
20:52:29 <stickster> hiemanshu, Correct, D6
20:52:37 <asrob> hiemanshu: yeah, d6
20:52:42 <hiemanshu> ah thanks
20:53:24 <asrob> Nushio: ah, I see, drupal 5 is not supported
20:53:35 <stickster> ke4qqq, NBD -- just making sure the guys knew they could ask us questions about event planning if needed during hiemanshu's GSoC project.
20:53:39 <asrob> drupal 6 and drupal 7 are supported
20:54:07 <Nushio> yeah, it was before drupal 7 was out though, so I think Drupal does maintain its latest and previous version
20:54:11 <ke4qqq> stickster: ahhh ok.
20:54:18 <asrob> stickster: yes I can, but you can do it now ;)
20:54:26 <asrob> Nushio: correct
20:54:55 <stickster> OK, anything else before we close up?
20:55:01 <asrob> -
20:55:19 <stickster> hiemanshu, Nushio, feel free to look for us on #fedora-mktg anytime
20:55:49 <stickster> #endmeeting