fesco
LOGS
17:30:01 <nirik> #startmeeting FESCO (2011-05-18)
17:30:01 <zodbot> Meeting started Wed May 18 17:30:01 2011 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:30:01 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
17:30:01 <nirik> #meetingname fesco
17:30:01 <zodbot> The meeting name has been set to 'fesco'
17:30:01 <nirik> #chair mclasen notting nirik SMParrish kylem ajax cwickert mjg59 mmaslano
17:30:01 <zodbot> Current chairs: SMParrish ajax cwickert kylem mclasen mjg59 mmaslano nirik notting
17:30:01 <nirik> #topic init process
17:30:09 * notting is here
17:30:19 <mjg59> Here
17:30:57 <ajax> also here
17:31:00 <kylem> yo
17:31:19 * nirik waves and waits another minute for more folks to wander in
17:31:42 * cwickert is here
17:31:56 * mmaslano here
17:32:22 <nirik> ok, lets go ahead and dive in.
17:32:32 <nirik> #topic #515 Investigate a "features" repo for stable releases
17:32:33 <nirik> .fesco 515
17:32:34 <zodbot> nirik: #515 (Investigate a "features" repo for stable releases) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/515
17:32:37 <nirik> any news on this one?
17:32:44 <cwickert> nope, sorry
17:32:51 <cwickert> this is becoming a running gar
17:32:52 <cwickert> gag
17:33:00 <cwickert> I suggest we take it off the agenda for now
17:33:03 <nirik> no problem... lots of busyness with release coming up.
17:33:08 <nirik> ok, can do that...
17:33:13 <cwickert> I will set the meeting keyword once I have something to show
17:33:19 <nirik> sounds good.
17:33:32 <nirik> #info will remove from meeting agenda for now, will bring back up when there is progress to report.
17:33:41 <nirik> #topic #563 suggested policy: all daemons must set RELRO and PIE flags
17:33:41 <nirik> .fesco 563
17:33:42 <zodbot> nirik: #563 (suggested policy: all daemons must set RELRO and PIE flags) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/563
17:33:54 <nirik> ajax: I think someone ran into an issue with this? so we are holding off on it for now?
17:34:24 <ajax> yeah, -pie implies a semantic change to apps that we think is unintentional
17:34:51 <ajax> it's being followed up with the binutils people though
17:34:57 <nirik> cool.
17:35:25 <ajax> hopefully i'll have an update (or better, a fix) next week
17:35:30 <ajax> defer in the meantime though
17:35:35 <nirik> #info issue with pie, being followed up with binutils folks before we enable globally.
17:35:37 <nirik> sounds good.
17:35:43 <nirik> #topic #588 promote praveenp to sponsor
17:35:43 <nirik> .fesco 588
17:35:44 <zodbot> nirik: #588 (promote praveenp to sponsor) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/588
17:35:56 <nirik> This was a sponsor request that didn't get much feedback.
17:36:12 <nirik> mdomsch submitted them, as they are a active dell contributor...
17:36:20 <nirik> and they want someone to help dell folks get more involved.
17:36:23 <notting> much or any?
17:36:29 * nirik looks
17:36:50 <nirik> none.
17:36:58 <nirik> no negative, no positive.
17:37:39 <mmaslano> If mdomsh prepared him, I don't see any problem to give sponsorship to praveenp
17:38:01 * cwickert hasn't seen much of Praveen, but trusts Matt
17:38:36 <nirik> I assume there's an implicit +1 from mdomsch here. ;)
17:39:02 <mmaslano> yes
17:39:15 * notting will +1, then
17:39:21 * mdomsch is here now
17:39:38 <ajax> i trust matt's judgement, +!
17:39:42 <cwickert> Praveen does detailed changelogs, definitely one thing I like
17:39:43 <cwickert> +1
17:39:47 <mmaslano> +1
17:39:54 <mdomsch> My reasoning is that I'm sponsor to them now, but I need to work on a pile of other things, and I've been training Praveen to act as sponsor
17:40:06 * mdomsch appreciates the votes of confidence
17:40:11 <nirik> usually sponsors are more known for their work in the community, but I also trust mdomsch and am ok with promoting
17:40:33 <kylem> +1
17:40:44 <nirik> #agreed praveenp is approved for sponsor.
17:41:06 <nirik> #topic #589 Porting from sysVinit init scripts to systemd unit files
17:41:07 <nirik> .fesco 589
17:41:11 <zodbot> nirik: #589 (Porting from sysVinit init scripts to systemd unit files) - FESCo - Trac - https://fedorahosted.org/fesco/ticket/589
17:41:27 <mjg59> Having this as a FES ticket seems like a good plan
17:41:35 <mjg59> And I guess it falls under the feature process
17:42:11 <nirik> yeah, I would think a feature would be good to use to coordinate... and also to let people know that it's being done.
17:42:29 <nirik> so, feature, fes ticket, try and get it done in f16 cycle if possible?
17:42:56 <mjg59> It'd certainly be nice
17:43:09 <cwickert> +1 for a F16 feature
17:43:28 * notting is +1 to that. slightly concerned about having a feature attached to the variable resource that is FES work
17:43:48 <nirik> as to the cleanups, I would think we should ask maintainers to look at those when converting... (or whoever is doing the converting)
17:44:19 <nirik> I think the bulk will need to be done by maintainers... but there is already bugs out there for this right?
17:44:38 <mmaslano> I suppose maintainers should review these changes
17:44:40 <notting> yup, Viking-Ice filed a bunch of bugs with sample scripts
17:44:45 <mmaslano> +1 for feature
17:45:58 <nirik> so, proposal: Ask for a feature page to track and coordinate, will file a FES ticket for any interested fes folks to work on them, try and get done in f16, cleanups welcome while converting.
17:46:04 <nirik> anything else in there I missed?
17:46:41 <mjg59> Looks good
17:47:54 <cwickert> ack
17:48:22 <notting> yup
17:49:39 <nirik> ok.
17:49:50 <nirik> #agreed Ask for a feature page to track and coordinate, will file a FES ticket for any interested fes folks to work on them, try and get done in f16, cleanups welcome while converting.
17:50:05 <nirik> #topic F15 and Elections
17:50:16 <nirik> f15 is gold and ready to go out next week. ;)
17:50:22 <kylem> \o/
17:50:27 <nirik> Thanks to all folks hard work on it. ;)
17:51:10 <nirik> we also have elections coming up...
17:51:22 <nirik> please attend town halls and grill your candidates.
17:51:55 <nirik> #topic Open Floor
17:52:01 <nirik> anyone have anything for open floor?
17:52:33 * Viking-Ice just want to add in that we need to review the submitted unit files and that means all of them to see if the meet the propose guidlines
17:52:53 <mdomsch> congratulations on reaching gold!
17:52:55 <Viking-Ice> s/proposed//
17:53:17 <nirik> Viking-Ice: yeah. Have you seen much action on maintainers on those bugs? or it's pretty low volume yet?
17:54:02 <Viking-Ice> Few so far the ones I spoke with all where waiting for FPC before they made a move
17:54:11 <nirik> yeah, thats fine.
17:54:18 <nirik> as long as we get it done in f16. ;)
17:54:30 <Viking-Ice> that's should be doable
17:55:18 <nirik> cool.
17:55:22 <Viking-Ice> but before we get started we need to address the points i mentioned in the ticket along
17:55:27 <nirik> #info kudos to everyone on f15.
17:55:49 <ajax> woooo f15
17:55:52 <nirik> Viking-Ice: those are items for the guidelines? or did we need to address them?
17:55:55 <Viking-Ice> with finding a place for script snippets to stored in ( directory path )
17:56:18 <Viking-Ice> the load module stuff
17:56:49 <Viking-Ice> determine which service should be activated on demand ( write udev rules for those )
17:57:40 <nirik> yeah, but that should be in the systemd unit files guidelines, no?
17:58:27 <Viking-Ice> the directory path yes.. the whole issue if service should be loading unloading modules no along with if an service should be started on demand
17:58:40 <Viking-Ice> via udev rule
17:59:04 <Viking-Ice> and the dbus ones as well
17:59:25 <nirik> ok, shall we go over those then...
17:59:42 <nirik> #topic #589 Porting from sysVinit init scripts to systemd unit files (redux)
17:59:59 <nirik> * should systemd unit files load/unload kernel modules?
18:00:13 <Viking-Ice> yup item 1
18:00:28 <nirik> Viking-Ice: do you have a list or example of this in a package?
18:00:42 <notting> they certainly shouldn't unload
18:00:49 <Viking-Ice> iptables for ones does this
18:01:23 <mjg59> So does cpuspeed
18:01:28 <mjg59> But, oh, my eyes, cpuspeed
18:01:42 <nirik> iscsid, irda, yeah.
18:01:56 <notting> i wouldn't forbid it, but recommend against it
18:01:58 <mjg59> But isn't this really FPC's domain?
18:02:02 <notting> not everything can be autoloaded properly
18:02:21 * cwickert needs to leave now
18:02:28 <mjg59> I'm inclined to trust them not to do foolish things
18:02:31 <Viking-Ice> what does the kernel team think about this
18:02:54 <mjg59> The kernel team thinks everything should be autoloaded magically, and awaits patches from people to make that possible
18:03:05 <Viking-Ice> yes! ;)
18:03:12 <mjg59> Meanwhile, in reality...
18:03:42 * nirik gets a call.
18:05:23 <Viking-Ice> so what we allow services to load modules  ( ExecStartPre=-/sbin/modprobe -qab <module> ) and not unloading them ?
18:05:23 <nirik> yeah, so how about: try and avoid loading, but if you must, ok. Do not unload.
18:05:31 <nirik> right.
18:06:08 <Viking-Ice> so FPC needs to update the guidlines to cover that
18:06:31 <notting> ... maybe? i don't know that FPC has ever standardized what init scripts *do*
18:07:37 <nirik> I'd be ok telling them the above idea, and they could codify it as they like in guidelines?
18:08:25 <Viking-Ice> ok
18:08:37 <Viking-Ice> Item 2 Hardware activated services
18:09:05 <Viking-Ice> I'm no udev expert but something in the line of this http://lists.fedoraproject.org/pipermail/devel/2011-May/151397.html is how you do that
18:09:43 <nirik> not sure thats a good example...
18:09:51 <Viking-Ice> probably not
18:10:09 <Viking-Ice> but can be used as a bases for a good one ;)
18:10:09 <nirik> what if we have several packages that could handle the same thing...
18:10:18 <nirik> nut, gnome-power-manager, etc?
18:11:33 <nirik> so, I guess I would say if we want to identify these that would be good, then we could consider a plan for them...
18:12:05 <Viking-Ice> ok task identify packages with sysv init scripts and udev rules in them
18:12:23 * nirik isn't sure where the line is here on whats fesco and whats FPC.
18:12:54 <Viking-Ice> basically dont we want to get those to activate service on demand that can
18:13:50 <nirik> yeah, but it's not that clear cut. ;) For example, nut can run as a server and manage upses on other machines...
18:14:15 <Viking-Ice> then you would start the service manually
18:14:15 <nirik> without having a ups on that box at all.
18:14:25 <nirik> yeah.
18:14:49 <Viking-Ice> basically the udev rule example as horrible as that might be starts the service if the kernel detects hw changes
18:14:51 <nirik> so, a list of these might help figure further I guess.
18:15:12 <notting> yeah, hard to write a general example without > 1 use case
18:15:13 <Viking-Ice> for example  you would plug in a printer you would start cups
18:15:56 <Viking-Ice> if you wanted to enable it manually encase you where using network printer you would do so via the printer application or manually on the command line
18:16:07 <Viking-Ice> just an example
18:17:01 <nirik> well, if it could see if you have printers defined and start then too, that might be ok.
18:17:12 <nirik> having to manually start it every boot is not good tho.
18:17:43 <Viking-Ice> you would of course enable it at boot up
18:18:20 <Viking-Ice> if you wanted to start it at boot up
18:18:26 <notting> not sure trying to define every case in this meeting is the right way to do this?
18:18:26 <Viking-Ice> always
18:18:34 <nirik> sure, but manual steps are not fun for some people... 'why doesn't my network printer show up' 'run this systemctl command... '
18:18:35 <Viking-Ice> nope
18:18:38 <nirik> notting: no.
18:18:58 <mmaslano> Viking-Ice: you should prepare list of items for FPC, for FESCo, for maintainers in bz
18:19:11 <nirik> as to deadlines, I think beta is a good one to shoot for.
18:19:27 * nirik notes the feature page could have some outstanding questions on it too.
18:19:41 <Viking-Ice> has someone created a feature page ?
18:19:51 * mmaslano bangs 15 minutes gong
18:19:58 <nirik> Viking-Ice: not yet.
18:20:07 <nirik> but there should be one.
18:20:12 <Viking-Ice> yup
18:20:25 <mmaslano> who will be maintainer of this feature?
18:20:59 <nirik> perhaps Viking-Ice would be willing to? ;) or we could ask lennert.
18:21:02 <Viking-Ice> propably the whole converting crew + lennart and notting
18:21:33 <Viking-Ice> I'll do the feature page
18:21:41 <nirik> Viking-Ice: thanks!
18:21:52 <nirik> #topic Open Floor again
18:22:01 <nirik> anything else for open floor?
18:22:59 * nirik will close out in a minute if nothing else.
18:23:40 <nirik> Thanks for coming everyone.
18:23:43 <nirik> #endmeeting