epel
LOGS
19:30:07 <nirik> #startmeeting EPEL (2011-04-11)
19:30:07 <zodbot> Meeting started Mon Apr 11 19:30:07 2011 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:30:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:30:07 <nirik> #meetingname epel
19:30:07 <nirik> #topic init process/agenda
19:30:07 <nirik> #chair smooge tremble
19:30:07 <nirik> EPEL meeting ping abadger1999 rsc stahnma tremble dgilmore smooge nb maxamillion tremble Jeff_S
19:30:07 <zodbot> The meeting name has been set to 'epel'
19:30:07 <zodbot> Current chairs: nirik smooge tremble
19:30:14 * abadger1999 here
19:31:07 * rsc_ 's around, too
19:32:07 * nb 
19:32:33 <nirik> cool. Anyone have topics for today?
19:32:45 * dgilmore has no topics
19:32:48 <rsc_> except that I miss CentOS 6, not :)
19:32:51 <nb> clamav is in stable
19:32:58 <smooge> here
19:33:10 <nb> -12 (latest) is in el4 and el5, -11 (which only has a small bug with i forget what it was) is in el6
19:33:12 <smooge> I will be working on xfce
19:33:20 <nb> karma for -12 in el6 is welcome
19:33:39 <nirik> smooge: oh yeah? I have been poking at it as time permits, but more help would be very welcome.
19:34:22 <nirik> smooge: epel5 should have the base packages done, but is waiting on cwickert for which plugins we can ship.
19:34:30 <rsc_> nb: testing with EL-6 is still hard, because most servers still run CentOS 5, I think
19:34:33 <nirik> on epel6, I need to try and build the 4.8 stack.
19:35:01 <smooge> plugins we can ship?
19:35:05 <nb> rsc_, true
19:35:24 <rsc_> nb: can't we build CentOS as part of EPEL? :)
19:35:25 <smooge> my plan is to get my home system able to build stuff again in mock and then attack the 4.8 as a mass rebuild
19:36:05 <nirik> smooge: well, epel5 is way too old for some of the plugins... or things are missing. epel6 might have better luck...
19:36:16 <skvidal> rsc_: haha
19:36:25 <nb> rsc_, it'd be nice :)
19:36:41 <smooge> yeah. I figured 4.6 for el5 and 4.8 for el6
19:36:46 <nb> rsc_, i kinda wonder how feasible that would be
19:36:48 <smooge> or is that too far off
19:36:56 <nb> rsc_, although i doubt redhat would like it
19:36:59 * nirik nods. Exactly what I was thinking too.
19:37:17 <rsc_> nb: what's redhat? *hides* ;)
19:37:21 <nirik> well, currently EPEL doesn't replace base packages, so it's not very feasable. ;)
19:37:36 <rsc_> ah, but if we're all together...
19:38:42 <rsc_> https://bugzilla.redhat.com/show_bug.cgi?id=694673 - I've a package that is similar to postgresql vs postgresql83 or php vs php53 - does this work in EPEL, too? A /etc/postfix26 etc. causes SELinux trouble :(
19:39:19 <nirik> #topic parallel installable packages (postfix)
19:39:51 <nirik> rsc_: well, thats a tough one.
19:40:09 <nirik> we want different version packages like that to parallel install...
19:40:21 <nirik> but as you note those ones above don't in base RHEL
19:40:29 <rsc_> nirik: I am forced to postfix > 2.3 in that case. And you know, having postfix 2.3 + 2.6 doesn't make sense...
19:41:08 <nirik> can you not just go to rhel6? or you must have this on rhel5?
19:41:28 <rsc_> this must be RHEL 5, because HyperV vs RHEL 6 is unsupported for at least 1+ year :(
19:41:59 <tremble> It is?  Surprised it's taking them that long.
19:42:14 <nirik> yeah, that seems slow.
19:42:46 <rsc_> tremble: well, it works as long as you don't need paravirtualized drivers as in supported at all. And from what I got when playing with upstream stuff, it is broken. Thus RHEL 5 :/
19:42:48 <nirik> anyhow, I really don't like the idea of conflicting with base packages. ;(
19:43:36 <smooge> well lets look at it this way.
19:43:48 <nirik> even if rhel does it... I don't think we should.
19:43:49 <rsc_> nirik: I know...ideas? /etc/postfix26, postconf26, /var/spool/postfix26 etc. isn't funny too - especially it requires SELinux exceptions while it now works without any additional SELinux rule here
19:43:51 <smooge> can one do a yum install * in RHEL5/6 by default?
19:44:01 <rsc_> smooge: no, will fail anyway ;)
19:44:07 <skvidal> smooge: pretty sure 'no'
19:44:15 <nirik> I doubt it too.
19:44:20 <tremble> smooge: No
19:44:27 <smooge> so ... as long as we don't override a RHEL package and just conflict is that a problem?
19:44:44 <smooge> [loves to see all the people who have RHEL and yum as irc keywords]
19:44:57 <skvidal> hah
19:45:21 <tremble> I see no reason to ban it.
19:45:34 <smooge> basically as long as yum install postfix does not get the EPEL package is that a problem?
19:45:43 <tremble> exactly
19:45:44 <nirik> well, conflicts are nasty from a end user viewpoint... "I'd like to install postfix*' downloads, wanders off 'conflicts! you lose'
19:45:55 <smooge> and maybe we get all nice and pretty with some selinux policy or another and RH adds it into 5.8 or something
19:45:56 <nirik> but I guess it's a pretty corner case.
19:46:03 <rsc_> nirik: if you do 'yum install postfix-*' everything is fine :)
19:46:13 <nirik> sure.
19:46:25 <rsc_> but there is only postfix-pflogsumm or so anyway
19:46:28 <smooge> nirik, but wouldn't I run into that with a yum install php* with just regular stuff?
19:46:53 <smooge> argues by absurdium
19:47:01 <nirik> yep. Since they added the php53 stuff.
19:47:16 <nirik> but you wouldn't with 'yum install python*' at least.
19:47:21 <nirik> dunno about mediawiki*
19:48:57 * nirik tries.
19:49:26 <nirik> how about this: post to the list a proposed conflicts guideline, discuss on list, revisit next week?
19:51:36 <nirik> thoughts?
19:52:19 <rsc_> if I need to be the one to write that proposal, I need some help - never did that before, even I read lots of our existing guidelines
19:52:56 <nirik> rsc_: I can try and assist. Basically we need to explain why we want EPEL to behave differently from Fedora's conflict guideline...
19:55:17 <nirik> or does everyone think we should just relax the rule now?
19:55:34 <nirik> http://fedoraproject.org/wiki/Packaging:Conflicts is the Fedora guideline.
19:55:53 <rsc_> (I'm not going to answer this, because my point of view is obviously clear and not from a neutral perspective)
19:58:10 <smooge> I would say we need to look at this and then ask the FPC for input.
19:58:44 <smooge> though I expect from some it would be "GTFA"
19:59:07 <nirik> so, how about we post to the list and have a weeks discussion and revisit next week?
19:59:17 <tremble> sounds good here
20:01:18 <smooge> hahaha Requires: postfix >= 2.6; Provides: postfix >=2.6 && postfix <=2.7
20:02:17 <nirik> woah. thats pretty weird.
20:02:33 <rsc_> smooge: hu?
20:02:36 <nirik> #action will post to the list about conflicts and epel packages.
20:03:34 <smooge> I don't know if that would work.. the && part is guesswork.
20:04:20 <smooge> the provides though would make a yum install postfix use the epel package before the RHEL one so would not be good.
20:05:58 <nirik> yeah, that would be bad
20:06:42 <rsc_> smooge: shouldn't what I did in the current *.spec work?
20:06:59 <fenrus02> 'Provides: postfix26' would work, but might be an issue to maintain
20:07:36 <rsc_> smooge: at least our company-internal overlay repo wanted nowhere to install postfix26 so far - except where I did it intended
20:08:17 <smooge> rsc_, yours will work. I was reading through the fedora conflicts on how they wanted it fixed and thought that was silly.
20:10:32 <nirik> #topic Open Floor
20:10:39 <nirik> anyone have anything for open floor?
20:11:01 <smooge> not me
20:13:00 <nirik> cool. will close out in a minute if nothing else shows up.
20:14:47 <Southern_Gentlem> nothing else :)
20:15:16 <nirik> #endmeeting