cloud_sig
LOGS
19:00:32 <rbergeron> #startmeeting Cloud SIG
19:00:32 <zodbot> Meeting started Fri Apr  8 19:00:32 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:32 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:37 <rbergeron> #meetingname Cloud SIG
19:00:37 <zodbot> The meeting name has been set to 'cloud_sig'
19:00:43 <rbergeron> #chair gholms
19:00:43 <zodbot> Current chairs: gholms rbergeron
19:01:01 <rbergeron> #topic Roll call!
19:01:23 * kkeithley is here
19:01:27 <jforbes> here
19:01:46 <rbergeron> hi kkeithley ;) i see you changed your nick. :D
19:01:56 * kkeithley nods
19:02:20 <rbergeron> hey jdarcy :)
19:02:28 <jdarcy> Good morning.
19:02:35 <rbergeron> How are you?
19:02:41 <mmorsi> howdy
19:02:46 <rbergeron> hola.
19:03:00 <jdarcy> Brain is fried from doing slides too long.
19:03:09 <rbergeron> aw.
19:03:21 <rbergeron> I'll get you a drink at summit to make up for the Pain.
19:03:32 <rbergeron> ;D
19:03:40 <rbergeron> #topic EC2
19:03:58 <jdarcy> Sounds like a plan.
19:04:05 <jforbes> Not a lot new to report, I need to get with dgilmore, hoping to get beta images out in 11 days
19:04:10 <rbergeron> So: The good news is that I've moved the EC2 unspin page to the EC2 Image Process page. :)
19:04:14 <rbergeron> jforbes: very nice
19:04:19 <rbergeron> #link https://fedoraproject.org/wiki/EC2_Image_Process
19:04:28 <rbergeron> (The bad news is that there's nothing on the pgae, but I suppose it will come. )
19:04:43 <dgilmore> jforbes: :P
19:05:21 <jforbes> rbergeron: some of the headers are still not entirely relevants
19:05:41 <rbergeron> jforbes: it's a wiki, be bold (when time allows)
19:05:42 <rbergeron> :)
19:06:07 <jforbes> until next friday, time doesnt allow for much, virt test day in 6 days
19:06:12 * rbergeron nods
19:06:22 <rbergeron> I know it :)
19:06:31 <rbergeron> We also have a cloud sig test day scheduled for the 28th.
19:06:56 <rbergeron> Do we have *any* idea what we're doing there (short of getting together with marek on boxgrinder stuff) - as far as ec2-related stuff goes?
19:07:14 <jforbes> Yes, I need to get the page together
19:07:28 * rbergeron hands jforbes a time machine and a coffee and a hug
19:07:54 <rbergeron> #info EC2_Image_Process page is up and waiting for YOUR LOVE and input and bold wiki changes.
19:08:02 <jforbes> I dont need to move through time, just pause it for a bit
19:08:11 <rbergeron> #info Cloud SIG test day is coming up on 4/28 - please send your ideas to the list if you have any
19:08:15 <rbergeron> I hear that.
19:08:42 <rbergeron> jforbes: anything anyone can do to help you out?
19:09:16 * jdarcy doesn't do bold changes.  Prefers italics.
19:09:49 * rbergeron smirks at jdarcy
19:09:50 <rbergeron> ;)
19:10:31 <rbergeron> alrighty.
19:10:42 <rbergeron> Well, if there's anything anyone can assist with, you know where to find us.
19:10:53 * rbergeron spins the wheel of fate
19:10:56 * quaid sneaks in and sits in the back row
19:11:00 <rbergeron> #topic CloudFS
19:11:09 <rbergeron> jdarcy! you're up :)
19:11:17 * rbergeron waves at quaid
19:11:18 <jdarcy> Hm.  Magazine article done, Summit presentation mostly so.  Lots of pretty pictures.
19:11:28 <jforbes> rbergeron: um, the page will need review and edits when up
19:11:39 <rbergeron> jforbes: word, gotcha
19:12:16 <rbergeron> kkeithley, jdarcy: I know there was talk last week of getting some of the information up about ... iirc, testing environment? Or something to that effect?
19:12:17 <jdarcy> Climbing the openssl learning curve.  I think I know how to do all of the cert management, and the data transfer, and where it needs to fit into the socket transport code.
19:12:49 <kkeithley> I'm continuing w/ web UI for setup and config, almost have enough done to say enough and start working on meatier things. I guess I like python better than, ugh, perl.
19:12:53 <jdarcy> Yeah, those are going into the slides and we can preview most of it.
19:13:17 <jdarcy> Ben's discovered some interesting things about how to configure the systems for optimal performance under GlusterFS/CloudFS.
19:14:00 <rbergeron> Are you saving that info for summit, or sticking it on a wiki page somewhere (on fedora or ... elsewhere??) ...
19:14:01 <jdarcy> Also, sad to report that the Gluster IRC channel and mailing lists have been filled with people having 3.1.3 problems.  I've spent some time trying to figure out what seems to be a pretty severe problem with finding files on the servers.
19:14:07 <rbergeron> Yuck.
19:14:18 <kkeithley> s/enough/enough for now/
19:14:27 <jdarcy> rbergeron: I think the stuff about configuration/tuning/benchmarking can go somewhere public before Summit.
19:15:00 <kkeithley> problems like the ENODATA  one I am seeing when I try to write to a volume?
19:15:04 <rbergeron> jdarcy: are you guys thinking about having your own wiki page, or keeping it on fedora wiki for now or forever, or?
19:15:41 * rbergeron thinks it would be a fabulous idea to have some of that information up before summit, if possible, and we might be able to rustle up some wiki gardening help to get you started.
19:15:41 <jdarcy> We probably should set up a wiki or something on cloudfs.org
19:16:42 <rbergeron> jdarcy: i'm guessing you own that domain or are hosting it somewhere onyour own?
19:17:10 <jdarcy> rbergeron: Right now I own the domain and host it alongside my personal site, but I can see that changing some day.
19:17:24 <rbergeron> if your time is strained right now (which I'm guessing it might be :D) at least doing something temp on fedora's wiki might be a reasonable start than getting all that set up, and you could probably point it from cloudfs to fedora at least temporarily
19:17:38 <jdarcy> Some of the information we're generating probably belongs somewhere on Fedora or Red Hat pages too.
19:17:53 <rbergeron> jdarcy: for the record, not trying to change your mind about "who owns it" - just trying to do what's most efficient for your time at the moment. :)
19:18:17 <jdarcy> Yep.  Using the Fedora wiki might be easier.
19:18:34 * jdarcy still feels like a bit of a squatter there.
19:18:39 * rbergeron grins
19:19:00 <rbergeron> kkeithley: do you want to maybe get a page started? I know that jdarcy set up the CloudFS feature page a while back...
19:19:14 * kkeithley says sure
19:19:18 * rbergeron looks at quaid and wonders if his uberwikigardeneingskills might be of help here too.
19:19:28 <rbergeron> :D
19:20:06 <rbergeron> #action kkeithley get started on a CloudFS wiki page on fedora
19:20:21 <rbergeron> #action rbergeron to try and wrangle up some help / assistance there too. (or help herself)
19:20:40 <rbergeron> #info would be awesome to have a cloudfs page up with at least basic info / tips prior to summit
19:21:00 <rbergeron> also: jdarcy, I saw that you have a bz open for cloudfs - i think ke4qqq offered to help get you sponsored as a packager there.
19:21:12 <rbergeron> (though I haven't looked at the ticket in the past few days)
19:21:40 <jdarcy> Yep.  We'll be moving forward on that shortly.  Also GlusterFS 3.1.3 packaging.
19:22:49 <rbergeron> FUN.
19:23:12 <rbergeron> jdarcy: is there a bz yet for glusterfs packaging?
19:23:40 <jdarcy> Well, it has been a package for a while so I don't think they need a bz, but it's at 3.1.2 currently.
19:24:00 <quaid> jdarcy: any help you need with feeling like a resident insteand of a squatter, or using the wiki, you can find me here or on #fedora-docs :)
19:24:02 <rbergeron> ahhh.
19:24:13 <jdarcy> quaid: OK, thanks muchly.
19:24:26 <rbergeron> kkeithley: same for you - find quaid, he's da master ;)
19:24:35 * kkeithley nods
19:24:47 <kkeithley> okay
19:24:58 <rbergeron> sweet.
19:25:17 <rbergeron> thanks for the updates there :)
19:25:27 <rbergeron> #topic Aeolus
19:25:43 <rbergeron> mmorsi: how goes it?
19:26:20 <mmorsi> rbergeron: ah not too bad
19:26:58 <mmorsi> not a terrible lot to report on the aeolus front this week, at least not with fedora, good news on the rhel side as we've got our packages building against that
19:27:23 <rbergeron> progress is progress. :)
19:27:40 <rbergeron> as always:
19:27:42 <quaid> yay
19:27:43 <rbergeron> #link http://aeolusproject.org/page/Packages_Missing_From_Fedora
19:27:55 <mmorsi> working towards a public release and demo in the near future, but other than that mostly planning and bug fixes this week
19:28:14 <rbergeron> Will we get to have a cool demo here on IRC of sorts?
19:28:31 * rbergeron thinks that might be a fun thing to do in a meeting time (or even a non-meeting time, more like a special attention to aeolus time!)
19:28:34 <mmorsi> ah i'm sure that can be arrainged
19:28:56 <rbergeron> If nothing I'm sure we'd be a patient group to do a dry run with. :)
19:29:36 <mmorsi> ya, its actually shoring up quite a bit
19:30:04 <mmorsi> which is why there haven't been a slew of new features recently, but whats there should be working a whole lot more robustly due to recent work
19:30:12 <rbergeron> right
19:30:23 <rbergeron> and I'm guessing all of this will be on display at Summit as well :)
19:30:32 <mmorsi> yes
19:30:37 <mmorsi> thats what we are working towards
19:30:51 <mmorsi> we will have aeolus amis then as well
19:31:02 <rbergeron> very nice!
19:32:01 <mmorsi> but ya thats about it on my end
19:33:21 <rbergeron> cool.
19:33:30 <rbergeron> thanks for the update :) always nice to have you guys here.
19:33:30 <mmorsi> oh ya we've just released another version of the core deltacloud driver
19:33:35 <rbergeron> oh?
19:33:37 <mmorsi> more info here http://mail-archives.apache.org/mod_mbox/incubator-deltacloud-dev/201104.mbox/browser
19:33:50 <mmorsi> well pending release
19:33:55 <mmorsi> thats about it for real :-)
19:34:00 <mmorsi> np, our pleasure
19:34:09 <rbergeron> wait, is there a more direct mail link :)
19:34:19 <mmorsi> ah srry
19:34:21 <mmorsi> http://mail-archives.apache.org/mod_mbox/incubator-deltacloud-dev/201104.mbox/%3C1301696185.13303.8.camel@avon.watzmann.net%3E
19:34:59 <rbergeron> cool. thanks!
19:35:03 <mmorsi> np
19:35:16 <rbergeron> so once that gets voted on, will that be going back into fedora as well?
19:35:22 <mmorsi> yes
19:35:23 * gholms bursts through the door
19:35:26 <rbergeron> (iirc the core deltacloud stuff is already in)
19:35:32 <rbergeron> GHOLMS!
19:35:33 <mmorsi> since the latest upstream release needs to be there
19:35:42 * rbergeron hands you a trophy for door-bustin
19:35:46 <gholms> :D
19:36:00 <rbergeron> mmorsi: gotit.
19:36:11 * rbergeron looks around for other comments/questions on aeolus/deltacloud/etc
19:37:51 <rbergeron> #topic Any other business
19:38:00 <rbergeron> Anyone, anyone? :)
19:38:34 <mmorsi> beuller, beuller, beuller,... ;-)
19:38:45 <gholms> [Everyone stares at rbergeron]
19:38:45 <rbergeron> totally
19:39:02 <rbergeron> Jeez. you're making me self-conscious here
19:39:06 * rbergeron blushes
19:39:40 <rbergeron> ANyone heard from mgoldmann? I think this meeting time sucks for him (being friday night and all where he's at)
19:40:08 <gholms> He hasn't filed any bugs against my stuff, which is a plus in my book.
19:40:15 * rbergeron grins
19:40:26 <obino> isn't mgoldmann at a conference?
19:40:33 <rbergeron> I haz no idea.
19:40:51 <rbergeron> Well.
19:40:59 <rbergeron> If nobody else has anything, I'll close out in just a minute.
19:41:15 <gholms> Is that a real minute or a rbergeron minute?
19:41:23 <gholms> The latter tends to be much shorter.
19:41:42 * rbergeron plays the jeopardy theme song
19:41:59 <rbergeron> What, doesn't everyone live by my time scale? :)
19:42:05 * rbergeron cries, again
19:42:09 <rbergeron> :D
19:42:11 <rbergeron> #endmeeting