fedora_cloud
LOGS
19:00:09 <rbergeron> #startmeeting Fedora Cloud
19:00:09 <zodbot> Meeting started Fri Apr  1 19:00:09 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:00:09 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
19:00:11 <clalance> rbergeron: Good afternoon :).
19:00:17 <rbergeron> #meetingname Fedora Cloud
19:00:17 <zodbot> The meeting name has been set to 'fedora_cloud'
19:01:38 <rbergeron> #topic Roll call :)
19:01:42 <rbergeron> (it may be a light meeting today)
19:01:46 <rbergeron> who's about?
19:01:50 * jsmith lurks
19:01:52 * clalance here
19:02:04 * ksk1 here
19:02:25 <rbergeron> hey jsmith, ksk1
19:02:52 <ksk1> rbergeron: hm, am I still showing up as ksk1?
19:02:54 * rbergeron holds for a momento for other folks
19:03:06 <rbergeron> ksk1: indeed, why?
19:03:20 <ksk1> rbergeron: I thought I fixed it
19:03:24 <ksk1> to be kkeithley
19:03:38 <rbergeron> ah.
19:03:53 <mmorsi> howdy
19:04:04 * rbergeron notes that there is no specific standard, if that's what you're worrying about :)
19:04:27 * rbergeron took rbergeron because EVERY OTHER NICK I EVER USED IN MY LIFE WAS REGISTERED oh gosh, did i just let on about how bitter i am about that?
19:04:53 <rbergeron> anyway - i'm letting jforbes off the hook for a few minutes here at the beginning so i'm going to start with......
19:04:53 * Sparks lurks as well
19:04:59 <rbergeron> Sparks! welcome :)
19:05:03 <rbergeron> #topic Aeolus
19:05:14 <rbergeron> clalance, mmorsi: I haz a question :)
19:05:26 <clalance> rbergeron: Just one?
19:05:27 <clalance> :)
19:05:29 <mmorsi> good cause i'm all out of cheezeburgers ;-)
19:05:31 <rbergeron> lol
19:05:41 <rbergeron> clalance: well, you know, i can't totally promise that
19:05:50 <clalance> Haha.
19:05:53 <rbergeron> What parts of Aeolus are in Fedora right now, and what parts aren't?
19:05:58 <rbergeron> I realize there are a few subprojects
19:06:07 <rbergeron> (if that's how you'd like to refer to them, i'm not sure)
19:06:18 <clalance> rbergeron: Essentially, none.
19:06:21 <mmorsi> hrm not too much in fedora properly
19:06:26 <clalance> None of the sub-projects, that is.
19:06:31 <rbergeron> Or maybe the question is "what parts are you currently working on getting into fedora or are currently being packaged"
19:06:38 <clalance> rbergeron: Many of the dependencies are in process for getting into fedora.
19:06:42 <mmorsi> ya and core
19:06:57 <clalance> http://aeolusproject.org/page/Packages_Missing_From_Fedora
19:06:59 <rbergeron> for oz, conductor, .... all of them?
19:07:01 <rbergeron> or just some of them?
19:07:03 * jforbes is here
19:07:06 <rbergeron> there's that link
19:07:07 <clalance> rbergeron: All of them.
19:07:09 * rbergeron was trying to find it the other day
19:07:14 <clalance> rbergeron: All of the dependencies are being worked on.
19:07:21 <clalance> Well, not *all*.
19:07:28 <clalance> But most of the dependencies for most of the components are.
19:07:36 <clalance> That list is all of the known ones.
19:07:42 <rbergeron> Is that list *dependencies* only?
19:07:44 <clalance> (barring ones we may have inadvertently missed for now)
19:07:48 <clalance> rbergeron: Yes.
19:08:03 <clalance> But if all of those get in, then importing the sub-projects is importing 4 source rpms.
19:08:07 <mmorsi> rbergeron: the actual component packages themselves should be trivials tho
19:08:14 <clalance> What mmorsi said :).
19:08:15 <mmorsi> since we are the upstream 4 that
19:08:29 <rbergeron> So you're not even starting to track the packages for oz, image factory and image warehouse, audrey, conductor.
19:08:36 <clalance> rbergeron: Not yet, no.
19:08:46 <clalance> rbergeron: Though there is no reason that oz can't go in now.
19:08:50 <clalance> (other than lack of time on my part)
19:08:53 <rbergeron> Okay. I just wanted to make sure that I wasn't confused / missing anything.
19:08:56 * rbergeron hands clalance a time machine
19:08:58 <clalance> Image factory and warehouse could also probably go in.
19:09:11 <clalance> Audrey and conductor are the worst.
19:09:14 * rbergeron nods
19:09:15 <mmorsi> ya as things shore up they should start making their way in
19:09:43 <rbergeron> And are we thinking F16 hopefully for all that to work its way in?
19:09:45 <mmorsi> until then we'll have a public installation available at somepoint and there is always our own yum repo
19:09:51 * rbergeron nods, yup!
19:09:59 <clalance> rbergeron: Yes, I think that is the plan.
19:10:00 <mmorsi> http://repos.fedorapeople.org/repos/aeolus/packages/
19:10:04 <rbergeron> sweet.
19:10:17 <clalance> rbergeron: The biggest blockers there would be condor and/or qpid.
19:10:26 <clalance> But I think qpid is going to be updated enough for us.
19:10:27 <rbergeron> #info all the packages listed on http://aeolusproject.org/page/Packages_Missing_From_Fedora are *dependencies* needed before aeolus goes in.
19:10:30 <clalance> And I hope condor will be.
19:10:45 <clalance> rbergeron: Is that relatively clear?
19:11:08 <rbergeron> yes, much more than before. sorry that I wasn't totally on the same page, I probably should have been by now ;)
19:11:17 <clalance> No problem :).
19:11:32 <rbergeron> I was just puzzling over "which of these packages are oz, audrey, etc"
19:11:50 <clalance> rbergeron: I should make that page a little more clear.
19:11:59 <clalance> One which things are dependencies, and which are the top-level packages.
19:12:14 <rbergeron> yeah, that might be helpful for you to clarify that, particularly as you guys start adding MOAR STUFF.
19:12:20 <clalance> :)
19:12:26 <mmorsi> http://mo.morsi.org/files/dcloud/overview.png
19:12:27 <rbergeron> at least from your own community standpoint. :)
19:12:31 <mmorsi> those are the top level components
19:12:43 <mmorsi> everything else under it is a dependency
19:12:57 <mmorsi> http://mo.morsi.org/files/dcloud/overview.txt  for a textual description
19:13:00 <rbergeron> mmorsi: you may be my hero with that lovely diagram
19:13:14 <mmorsi> heh i try ;-)
19:13:30 <rbergeron> mmorsi: and that description list
19:13:42 <rbergeron> thank you!
19:13:48 <mmorsi> np
19:14:02 * ke4qqq pretends to show up
19:14:14 <rbergeron> greetings, ke4qqq :)
19:14:34 <rbergeron> clalance, mmorsi: anything else? I think we have a couple people who may be trying to help you guys out with packaging reviews and such.
19:14:43 <mmorsi> ah that'd be awesome
19:14:45 <mmorsi> the package reviews
19:14:46 <rbergeron> indeed.
19:14:51 <mmorsi> perhaps that can be an action item
19:14:55 <mmorsi> start getting that ball rolling again
19:15:01 <mmorsi> but thats it from our end
19:15:10 <mmorsi> at least mine don't want to speak for clalance :-)
19:15:15 <clalance> Yeah, pretty much.
19:15:20 <rbergeron> #info please take a look at the Aeolus packages missing from fedora link and help out with reviews if you can :)
19:15:22 <clalance> We have had some people be helpful with reviews already.
19:15:32 <clalance> But more is always appreciated!
19:15:54 * rbergeron nods. Indeed!
19:15:59 * rbergeron shall move onwards
19:16:05 <rbergeron> #topic EC2 business
19:16:13 <rbergeron> jforbes: anything fun to report or that I should be harassing you about? :)
19:16:27 <jsmith> What's our status of having Koji build EC2 images?
19:16:38 * jsmith is still hoping to have that all working by beta
19:16:41 <jforbes> I am building some new test images right now (my last attempt failed due to messed up koji command)
19:16:49 <rbergeron> #link http://fedoraproject.org/wiki/EC2_unspin
19:16:59 <jforbes> jsmith: koji has been able to build images since fudcon
19:17:01 <rbergeron> #info unspin page still needs love (I may have been on the hook to do more there)
19:17:25 <rbergeron> (though I made the page! wahoo)
19:17:35 <jsmith> jforbes: Oh? I was under the impression there were still some issues -- I'll follow up w/ rel-eng
19:17:50 <rbergeron> probably could be renamed to EC2 image process (I'll do that now, unless anyone objects)
19:17:52 <jforbes> Basically I need to test my script to convert S3 to EBS
19:18:19 <rbergeron> #info jforbes is building new test images now (last attempt didn't work out so well)
19:18:21 <jsmith> rbergeron: I have no problem w/ that :-)
19:19:23 * rbergeron nods
19:19:41 <rbergeron> #action rbergeron to redirect ec2_unspin to EC2 image process wiki page
19:20:24 <rbergeron> #action jsmith to follow up with rel-eng on koji being able to build images and resolve any miscommunication there
19:20:37 * rbergeron looks around for any other ec2 comments
19:21:11 <jforbes> none at this time
19:21:14 <Sparks> rbergeron: It might be helpful to put all the wiki pages in a "Cloud" category
19:21:24 <Sparks> so that others may find them easier
19:21:37 <rbergeron> Sparks: did you just volunteer to help out? :)
19:21:45 <Sparks> I can.
19:21:45 <rbergeron> or is that a friendly suggestion ;)
19:21:49 <Sparks> Both
19:21:50 <rbergeron> Thanks! :)
19:21:52 <rbergeron> lol
19:21:55 * rbergeron thinks that is a great idea.
19:22:02 * Sparks brings up tudu and makes notation
19:22:12 <rbergeron> #action sparks to put all the Cloud-related wiki pages i a "cloud" category
19:22:33 <rbergeron> sparks: feel free to ping me if you're hunting for stuff, too.
19:22:47 <rbergeron> thank you sir
19:22:51 <rbergeron> #topic CloudFS
19:23:24 <rbergeron> jdarcy, ksk1: how goes it?
19:23:39 <ksk1> jdarcy: ??
19:23:40 * rbergeron just likes to check in to see if there's anything we can help out with.
19:23:57 <jdarcy> Not much going on.
19:24:09 <ksk1> no, I'm migrating from working on Jeff's lab setup to my own cluster
19:24:17 <jdarcy> I've started implementation of an in-flight-encryption module.
19:24:39 <jdarcy> Also helping Kaleb and Ben (performance guy) get up to speed on GlusterFS/CloudFS>
19:25:07 <jdarcy> For the next short while, the big focus will probably getting enough numbers to make the Red Hat Summit talk interesting.
19:25:17 <rbergeron> very nice. ksk1, i bet that is fun. :)
19:25:23 * rbergeron nods
19:25:45 <jdarcy> Oh, and I put together some 3.1.3 specfiles.
19:26:06 <jdarcy> They work for me, but I need to work with daMaestro to get 3.1.3 (plus ACL changes) packaged up properly.
19:27:02 <rbergeron> jdarcy: do you have a wiki page or anything other than your Features/CloudFS page with information for people to look at? (mailing list, etc)
19:27:18 <jdarcy> I need to update that page.  Mostly I refer people to there and/or cloudfs.org
19:27:48 <ksk1> I'm writing up the steps I'm doing to set up my cluster as I migrate off Jeff's
19:27:56 <ksk1> might be useful
19:28:17 <rbergeron> ksk1: indeed :)
19:29:00 <rbergeron> You could probably make a link on the fedora wiki to those notes, or put them in your fedorapeople page temporarily, if nothing else, for other reuse in the future
19:29:04 <rbergeron> just a thought ;)
19:29:28 <rbergeron> Anything else?
19:29:31 <jdarcy> ksk1: Is fedorapeople working for you now?
19:29:35 <ksk1> rbergeron: yes, I got my own fedorapeople account sorted out earlier today, just so I can do that
19:29:41 <jdarcy> Yay.
19:29:52 <rbergeron> ksk1: good, i'm glad :)
19:30:10 * rbergeron shall move on....
19:30:25 <rbergeron> #topic OpenStack
19:30:28 * rbergeron looks for a link real quicklike
19:31:26 <rbergeron> #info ke4qqq sent a note to the list looking for someone who might be interested in nova maintenance.
19:31:30 <rbergeron> #link http://lists.fedoraproject.org/pipermail/cloud/2011-March/000589.html
19:31:49 <rbergeron> #link https://bugzilla.redhat.com/show_bug.cgi?id=649495
19:32:25 * ke4qqq notes that he has someone that will do if it notihng else, but given the rate of nova progress, that person is worried about not being able to give enough focus to it.
19:33:08 * ke4qqq would also like some maintainers for cloudstack and mass of dependencies, but need to get those on the wiki, etc.
19:33:22 <rbergeron> I guess the only other thing to note here is that if you *are* interested, it's a great place to help out, so please pipe up on the list :)
19:33:30 <rbergeron> ke4qqq: is that coming to f16? :)
19:33:43 * rbergeron revs her bus
19:34:00 <ke4qqq> no idea, we'll see
19:34:05 <rbergeron> alrighty.
19:34:23 <rbergeron> #topic Open Floor
19:34:38 <rbergeron> Comments, questions, flames, take it away. :)
19:35:31 * rbergeron will hold it open for a minute or two before ending things.
19:36:21 <rbergeron> Well then.
19:36:26 <rbergeron> Thanks for coming everyone. Have a great weekend :)
19:36:36 * rbergeron waves
19:36:56 <rbergeron> #endmeeting