fedora_cloud_sig
LOGS
21:02:18 <rbergeron> #startmeeting Cloud SIG
21:02:18 <zodbot> Meeting started Thu Jan  6 21:02:18 2011 UTC.  The chair is rbergeron. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:18 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:02:18 <goozbach> and not have this problem?
21:02:18 <ricky> -1 is empty.
21:02:22 <smooge> OK meeting -3
21:02:31 <rbergeron> #meetingname Fedora Cloud SIG
21:02:31 <zodbot> The meeting name has been set to 'fedora_cloud_sig'
21:03:09 * gholms runs off to the microwave
21:03:15 <rbergeron> gholms :)
21:03:18 <rbergeron> popcorn time?
21:03:24 <smooge> meeting is continuing in -3 for infrastructure.
21:03:24 <rbergeron> #topic Roll call!
21:03:26 <gholms> Lunch time.
21:03:27 <smooge> rbergeron, later
21:03:28 <rbergeron> who's about today?
21:03:34 * jforbes is here
21:03:34 * clalance waves
21:03:36 * mmorsi says hi
21:04:19 <rbergeron> well. alllllrighty then
21:04:30 <rbergeron> #topic EC2
21:04:38 <rbergeron> jforbes: what's the word? :)
21:05:02 <jforbes> Not much, I just got back yesterday...
21:05:25 <jforbes> I did manage to get the koji permissions and information to get things rolling, so working on that now
21:05:26 * rbergeron notes that we had a mail over the holiday break about large instances on EC2 being unresponsive
21:05:41 <dgilmore> rbergeron:
21:06:00 <rbergeron> dgilmore: yessir
21:06:16 <dgilmore> 
21:06:21 <rbergeron> jforbes: have we given more thought to doing a test day?
21:06:28 <rbergeron> Dates are still available.
21:06:28 <dgilmore> rbergeron: sorry was going to say i was here
21:06:34 <rbergeron> If we know what we're testing.
21:06:40 <dgilmore> my modem just rebooted
21:06:48 <rbergeron> dgilmore: awesome
21:07:18 <jforbes> rbergeron: I can schedule the test day, but we need test plans lined up
21:07:41 <rbergeron> jforbes: agreed.
21:07:56 <jforbes> rbergeron: so far, I think we need test plans for basic EC2 images, boxgrinder, openstack?
21:08:34 <rbergeron> I think we need to circle up with silas on where openstack is at. I'll look at it a bit later in the meeting - but, yeah, I think that's a basic list.
21:08:47 <rbergeron> jdarcy may also be interested in testing CloudFS.
21:08:53 <clalance> Maybe we can do something with deltacloud core as well.
21:08:58 <rbergeron> clalance: I don't know if you have any thoughts on deltacloud
21:09:03 <rbergeron> aha, jinx.
21:09:10 <clalance> rbergeron: The aggregator portion is just not going to be ready.
21:09:36 <clalance> There is one additional component (oz/imagefactory) that I might get in before the deadline.
21:09:40 <clalance> But I'm not certain about that.
21:09:43 <rbergeron> clalance: yeah, I figured.
21:09:59 <clalance> The core, though, is already in, so probably bears testing.
21:10:33 <rbergeron> jforbes: how about we do this: I'll shoot a mail to the list about test day ideas. Maybe you can throw sometihng in about what you'd like to do with EC2 - do you think you'd have time to write up some test plans for that, and we can see what other folks want to contribute for their respective cloudy features?
21:10:33 <clalance> rbergeron: Also, FYI; we are going to be renaming the aggregator in the very near future.
21:10:37 <clalance> To reduce confusion with the API.
21:10:47 <jforbes> rbergeron: sure
21:11:10 <rbergeron> clalance: :) any confusion-reducing is proably good there.
21:11:15 <clalance> Seriously.
21:11:31 <clalance> A website revamp will go along with that.
21:11:37 <clalance> I'll announce this in Tempe as well.
21:11:46 <clalance> (I hope to have the rename done by then)
21:12:05 <rbergeron> clalance: excellent. I'm glad you're getting to come, btw.
21:12:21 <rbergeron> #action rbergeron send an email to the list re: test days brainstorming
21:12:25 <gholms> I tried getting more Eucalyptus people to go, but that's apparently not going to happen.  :(
21:12:27 <clalance> Yeah, my first business trip in a while :).
21:12:49 <rbergeron> #info jforbes is working on getting koji permissions and information to get EC2 stuff rolling.
21:13:04 <dgilmore> rbergeron: jforbes has the koji permissions
21:13:14 <dgilmore> he just needs to get me a kickstart file
21:13:25 <dgilmore> e can do his testing of the kickstart
21:13:34 <jforbes> yup, have the permissions, just need to finish testing and get a file out
21:13:41 <dgilmore> so i can put it in spains-kickstarts with the other fedora kickstarts
21:13:52 <dgilmore> spins-kickstarts even
21:13:53 <rbergeron> #action jforbes to do some testing, get dgilmore a kickstart file.
21:14:09 <rbergeron> Awesome. You guys rock.
21:14:19 <rbergeron> Anything else ec2-ish?
21:14:40 <jforbes> none else here
21:15:24 <rbergeron> sounds good.
21:16:24 <rbergeron> mooooooving on....
21:16:28 <rbergeron> #topic CloudFS
21:16:36 <rbergeron> jdarcy: how's feature-land going?
21:16:39 <jdarcy> Hm, let's see.
21:16:58 <jdarcy> Little progress on writing code since the last meeting.
21:17:11 <jdarcy> I did get some EC2 performance results showing that the new functionality doesn't cost much.
21:17:18 <jdarcy> Generated lots of content for CloudFS.org
21:17:45 <jdarcy> We had meetings with Gluster today, some partner-relationship kindsa stuff I can't talk about but a few technical tidbits.
21:18:14 <jdarcy> They've announced their own fairly limited form of (active/passive, file-granularity) replication, which is good for DR but not much else.
21:18:37 <jdarcy> We talked about how to migrate/converge toward the kinds of replication CloudFS is targeting.
21:18:52 <rbergeron> Cool!
21:18:56 <jdarcy> Some talk about multi-tenancy and authentication (they're getting a lot stronger there, driven mostly by CIFS/AD).
21:19:15 <jdarcy> They're actively reviewing some of the CloudFS bits now.
21:19:23 <jdarcy> I think that's about it.
21:20:01 <rbergeron> Do you think you're still on-track as far as feature completion goes?
21:20:22 <rbergeron> :D
21:20:28 <jdarcy> I think so.  This week is being chewed up by other stuff, but after that I have a pretty clear shot to feature freeze.  More eyeballs would be nice, though.
21:20:45 * rbergeron nods
21:20:47 <jdarcy> And if anyone wants to volunteer to help with building/packaging kindsa stuff (about which I know zip) that would be a huge help.
21:21:09 <rbergeron> we were talking before you got here also about doing test days - I just sent a mail to the list about it.
21:21:17 <jdarcy> Excellent.
21:21:27 <rbergeron> But that's some food for thought for you as well, if you want to do some test plans and whatnot.
21:21:33 * jdarcy nods.
21:21:47 <rbergeron> I would imagine if you shot a mail to the cloud SIG list looking for some packaging help, you might find some. :)
21:21:54 <jdarcy> Will do.
21:21:58 <rbergeron> at least, it's worth a shot.
21:22:12 <rbergeron> Anything else? :)
21:22:26 <jdarcy> Not that I can think of.
21:22:33 <rbergeron> coolio.
21:22:41 <rbergeron> #topic Deltacloud
21:22:51 <rbergeron> clalance, mmorsi: anything fun going on?
21:23:13 <clalance> rbergeron: Nothing hugely new since we last spoke.
21:23:26 <mmorsi> yea alot of dev work really
21:23:27 <clalance> rbergeron: We have someone packaging up more of the dependencies to get into Fedora.
21:23:47 <clalance> Yeah, other than that, more development, but nothing hugely new.
21:23:58 <mmorsi> also a better web interface is in teh works, also a better installation and configuration tool
21:24:01 <clalance> The biggest externally visible thing will be the name change.
21:24:06 <clalance> Oh yeah, that stuff too.
21:24:42 <mmorsi> we're tightening up alot of hanging ends and what not too, tackling security over deltacloud as we speak
21:24:53 <mmorsi> all of this should be in the next release we hope
21:25:01 <rbergeron> Are you guys still planning on doing part of deltacloud as a feature in F15, and if so, is someone going to be making that feature page before the submission deadline on 1/25 :)
21:25:31 <clalance> rbergeron: I think not.
21:25:44 <mmorsi> clalance: oh? we're not adding the core at least?
21:25:49 <clalance> rbergeron: As we discussed before the break, we have a lot of dependencies.
21:25:51 <clalance> mmorsi: That is in already.
21:25:57 <mmorsi> ah aight
21:26:03 <clalance> Not sure if it needs a feature page, though maybe that will get it some additional exposure.
21:26:13 <rbergeron> clalance: that's the idea.
21:26:16 <clalance> rbergeron: What do you think about that.
21:26:19 <mmorsi> sure thing, fine w/ me either way
21:26:32 <clalance> rbergeron: OK.  Let me ping a couple of people to make the feature page for the core.
21:26:46 <clalance> rbergeron: As far as the aggregator, I think we are just going to continue to get dependencies in.
21:26:55 <rbergeron> clalance: I think it would be fabulous, both from the getting you guys some extra PR perspective, as well as getting the Cloud SIG some extra marketing love.
21:26:59 <clalance> With any luck, condor 7.6 will be ready for F-16.  And then we can do a feature for the aggregator.
21:27:03 <clalance> Yeah.
21:27:05 <rbergeron> Plus testing and so forth.
21:27:29 <clalance> You can put an action item for me for that.
21:27:35 <rbergeron> #action clalance to investigate finding someone to do a feature page for deltacloud core
21:27:43 * rbergeron was just in the process of doing so :)
21:27:44 <clalance> Oh, I guess I could just do it ;).
21:27:57 <rbergeron> actually, i think you have to be chaired, but i'm not a meetbot expert, per se.
21:28:06 <clalance> Ah.
21:28:06 <rbergeron> I just type things, and usually it all comes out in the wash.
21:28:10 <clalance> LOL
21:28:11 <clalance> Love it.
21:28:15 <mmorsi> shout out if you need help w/ that, owned the F14 feature for Ruby 1.8.7
21:28:31 <mmorsi> also the F15 feature for Rails 3 is still in the work
21:28:32 <mmorsi> works
21:28:35 <clalance> mmorsi: I'm going to make lutter or mfojtik do it ;).
21:28:46 <rbergeron> mmorsi: yes please, send that in ;)
21:28:46 <mmorsi> which we could also prolly tied into deltacloud, eg that can be one of the first major use cases
21:28:59 <mmorsi> like u said, the more exposure the better :-)
21:29:03 <mmorsi> sure thing
21:29:09 <clalance> mmorsi: Yeah, but it doesn't need to be tied.
21:29:20 <mmorsi> agreed, just a mention
21:29:23 <clalance> mmorsi: If we get rails 3 into F-15, we should mark that as its own feature.
21:29:25 <rbergeron> Yeah, I think rails 3 stands on its own :)
21:29:28 <mmorsi> agreed
21:30:20 <rbergeron> But - like I said - we're getting there pretty quickly - just 2.5 more weeks.
21:30:35 <rbergeron> #info Feature Submission deadline is 1/25
21:30:39 <mmorsi> ya hear the clock ticking :-p
21:30:53 <gholms> mmorsi: I do now.  >:(
21:31:02 <gholms> :P
21:31:05 <rbergeron> lol
21:31:08 <clalance> haha.
21:31:15 * rbergeron hears it quite a bit :)
21:31:32 <rbergeron> Anything else from deltacloud land?
21:31:41 <mmorsi> we need an irc plug that just spews out "tick-tock", keeps us on our toes :-p
21:31:53 <mmorsi> nothing from me
21:32:20 <clalance> Yeah, that's about all I have.
21:32:26 <rbergeron> Thanks for the updates, folks.
21:32:33 <rbergeron> #topic OpenStack
21:32:42 * rbergeron is going to peek in on that bz and see where it's at.
21:33:15 <rbergeron> #link http://fedoraproject.org/wiki/Cloud_SIG/OpenStack
21:33:41 <rbergeron> #link https://bugzilla.redhat.com/show_bug.cgi?id=649495
21:33:51 <rbergeron> Okay - looks like silas is still waiting on python-carrot.
21:35:24 <rbergeron> #info if someone is interested in helping out with OpenStack, there are some reviews still outstanding (python-carrot)
21:36:03 <rbergeron> #link https://bugzilla.redhat.com/show_bug.cgi?id=611054
21:36:26 * rbergeron would really like to see us be able to get this in - I'll send an email to silas and see if there is anything else he's hung up on.
21:37:15 <rbergeron> Okay. Moving along
21:37:19 <rbergeron> #topic Open Floor
21:37:26 <rbergeron> Anyone? :)
21:37:47 <clalance> rbergeron: What do we have planned for Tempe?
21:37:52 <clalance> (cloud-wise, that is)
21:37:54 * rbergeron notes that FUDCon is coming up, of course, lest you think I would let y'all go for a week without a reminder - if you'd like to do Cloud SIG stuff, i'm taking ideas.
21:38:02 <clalance> Heh ;).
21:38:03 <rbergeron> clalance: you have an uncanny way of being in my head today.
21:38:06 <clalance> Seriously.
21:38:10 * gholms steals rbergeron's '/' key
21:38:13 <mmorsi> great minds think alike :-)
21:38:29 <rbergeron> Soooo - there are a few cloud-related proposals already on the wiki.
21:38:32 * rbergeron pulls it up real quicklike.
21:38:36 <jdarcy> Hm.  Need slides.
21:38:39 <gholms> ...
21:38:47 <clalance> jdarcy: Yeah, me too.
21:39:03 <clalance> rbergeron: How does that work, by the way?  How is it chosen which sessions are given?
21:40:01 <rbergeron> zaitcev has someting on Fedora Cloud storage.... sdake has something on sheepdog.... jdarcy has something on cloudFS...clalance has something on cloud management.
21:40:06 * rbergeron looks around
21:40:11 <rbergeron> dgilmore: you still here?
21:40:26 <dgilmore> rbergeron: si
21:40:27 <rbergeron> or someone wanting to give a better explanation than I can of how the sessions get chosen / organized
21:40:54 <dgilmore> rbergeron: for fudcon?
21:41:04 <clalance> dgilmore: Yes.
21:41:11 <dgilmore> rbergeron: everyone pitcjes their session idea
21:41:13 <rbergeron> it's a little known secret that I have never been to a FUDCon. So this part is still somewhat mysterious to me, but from what I understand, it's very barcamp style - people will be pitching ideas in front of others in the morning, and we'll be doing the session grid onsite.
21:41:20 <dgilmore> then the attendees vote on them
21:41:23 <clalance> Ah, OK.
21:41:30 <clalance> dgilmore: OK, thanks.  Easy enough.
21:41:38 <dgilmore> they then get ordered so that the most people can get to what they want
21:41:41 <dgilmore> we then do them
21:41:46 <jdarcy> dgilmore: So basically the first session is used to choose the rest?
21:41:56 <dgilmore> jdarcy: yeah
21:42:03 <dgilmore> its done bar camp style
21:42:04 * jdarcy thinks about scheduling algorithms.
21:42:15 <mmorsi> yeh, most often you pitch the idea, and write it on a eice of paper, all of which are collected at the end of the first session and put up on a wall
21:42:20 <dgilmore> we have the welcome/pitching sessions session
21:42:32 <dgilmore> then its a big jungle of voting and sorting
21:42:36 <zaitcev> I was basically do a 2-parter about Hail and Swift, how Fedora can be used for it now that we have packages.
21:42:50 <dgilmore> followed by an easy to follow schedule where you are free to choose your own path
21:42:51 <mmorsi> then everyone is given a chance to vote on whichever ones by putting a tally mark on the papers they are interested in
21:43:04 <dgilmore> mmorsi: correct
21:43:07 <jdarcy> Does bribery work?
21:43:11 <rbergeron> I think we have a big enough cloud contingent that we'll all be going to each other's proposed sessions.
21:43:14 * mmorsi gave the deltacloud talk at toronto (combined w/ jforbes ec2 talk)
21:43:15 <dgilmore> jdarcy: it does not
21:43:20 <mmorsi> you can propose multiple talks too
21:43:24 <dgilmore> jdarcy: ponies have been known to work though
21:43:25 <rbergeron> dgilmore: what? bribery works for me all the time. :)
21:43:32 * rbergeron has an arsenal of cookies.
21:43:33 <dgilmore> rbergeron: your special ;)
21:43:38 <rbergeron> dgilmore: ;)
21:43:51 <jdarcy> I guess I'll just have to focus on content.  Darn.
21:44:52 <zaitcev> jdarcy: Well I have your comparison with Ceph, maybe you just read that aloud ^_^
21:45:06 <rbergeron> jdarcy: lol
21:45:13 <jdarcy> I'll re-do it as an epic poem.
21:45:20 <zaitcev> YES
21:46:18 <dgilmore> the pitching is honestly pretty fun
21:47:02 <rbergeron> Anyway, to circle back a bit, I think we have some good opportunities to talk about the individual features people are working on, but I htink we could also think about organizing something around "how this all works together"
21:47:14 <rbergeron> since, I think for most poeple, that's the big mystery of cloud things.
21:47:27 <rbergeron> How does it work together, if it even does, and if it doesn't, what can we do to get it there, etc.
21:47:44 <clalance> rbergeron: Yeah.  Some of the additional pieces we are building for aggregator fit well in there.
21:47:51 * rbergeron nods
21:47:55 <clalance> (there is a project called audrey to do configuration-like things that I would like to talk about)
21:48:07 <jdarcy> I think Chris's talk will shed some good light on that side of things.
21:48:14 <rbergeron> And I think it's probably also a good place to run it by people who are actual users of the stuff, who may have good feedback as well.
21:48:20 <clalance> Yeah, definitely.
21:48:21 <rbergeron> Or potential users. Etc.
21:48:29 <clalance> We are missing some of that.
21:48:56 <rbergeron> So if someone wants to organize or propose a session around "How does all this cloud stuff work together," Or ... well, anything else, really, I think that would be a great idea.
21:49:27 <dgilmore> rbergeron: probably a good hackfest thing also
21:50:09 <rbergeron> dgilmore: yeah. Do you think that would be best in tha tformat?
21:50:37 <dgilmore> rbergeron: could be good for both
21:50:58 <dgilmore> or maybe have a question and answer session
21:51:06 <dgilmore> where we get all kinds of dev folks
21:51:19 <dgilmore> and the viewers can ask about how things work
21:51:28 <dgilmore> you know put the devs on the spot and all
21:51:39 <rbergeron> OH. i love tha tkind of thing
21:51:46 <rbergeron> mostly because i'm not a developer ;) lol
21:52:25 <rbergeron> Maybe it's a good question to take to the mailing list.
21:52:35 <clalance> Heh, nice.
21:52:36 * clalance runs
21:52:52 <rbergeron> There is also the option of getting the cloud folks together and maybe going out for some f00d together one night.
21:52:54 <rbergeron> ;)
21:53:09 <jforbes> That works too
21:53:18 * gholms is all for an all-hands meeting
21:53:27 * rbergeron knows the secrets of getting people to show up. Food.
21:54:03 <rbergeron> #action rbergeron to send a FUDCon prodding message about "what to do!" to the cloud sig list.
21:54:11 <rbergeron> Anyone else have anything? :)
21:54:21 * dgilmore would like to sit down with jforbes and other to talk about floud and releng
21:54:26 <dgilmore> but at fudcon
21:54:33 <rbergeron> dgilmore: hackfest? :)
21:54:56 <dgilmore> rbergeron: probably more a intimate discussion
21:55:02 <dgilmore> but could be a hackfest
21:55:10 <rbergeron> hallway track? :)
21:55:18 <rbergeron> We'll figure it out.
21:55:21 <dgilmore> probaly hallway track
21:55:23 <dgilmore> or hackfest
21:55:43 <jforbes> yup. we will certainly do something there
21:55:51 <rbergeron> okay.
21:56:02 * rbergeron looks around for any other comments before closing things out
21:56:56 <rbergeron> Thanks for coming, all!
21:57:03 <rbergeron> #endmeeting