fedora-meeting
LOGS
00:00:03 <jjmcd> #startmeeting Docs project weekly meeting - agenda https://fedoraproject.org/wiki/Docs_Project_meetings
00:00:03 <zodbot> Meeting started Thu Nov 18 00:00:03 2010 UTC.  The chair is jjmcd. Information about MeetBot at http://wiki.debian.org/MeetBot.
00:00:03 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
00:00:11 <jjmcd> #topic Roll call
00:00:17 * jjmcd 
00:00:20 * jhradilek is here.
00:00:34 * rudi__ is here
00:01:12 <jjmcd> Where are all the usual suspects?
00:01:24 * nb 
00:01:46 <nb> Sparks, is afk
00:01:52 <jjmcd> I guess Gearoid is afk and I don't see too many other perps
00:02:06 <jjmcd> #topic Action Items
00:02:17 <jjmcd> Sparks to add creating and publishing links to the Docs wiki page
00:02:40 <jjmcd> I don't know whether that was done or not, so we'll add it back
00:02:47 <jjmcd> #action Sparks to add creating and publishing links to the Docs wiki page
00:02:55 <jjmcd> rudi to add "get a bugzilla component" to the "Creating a new Guide" page http://fedoraproject.org/wiki/Creating_a_new_guide
00:03:24 <rudi__> done
00:03:28 <jjmcd> super
00:03:38 <jjmcd> Sparks to bring nominations up to the Docs list to make sure everyone has a chance to volunteer
00:03:50 * nb nominates sparks
00:03:52 <jjmcd> That got done and there were no takers
00:04:06 <jjmcd> Sparks, rudi, and jjmcd (and anyone else that would like to attend) to discuss building docs for the desktop
00:04:28 <jjmcd> There was some discussion, but I had to leave before there was any resolution
00:04:43 <jjmcd> rudi__, did you and Sparks and I think others conclude anything?
00:05:04 <rudi__> jjmcd -- no, not yet
00:05:19 <rudi__> There's a patch for the bug in Publican
00:05:30 <jjmcd> OK, that comes up later, don't know how fruitful it will be
00:05:38 <jjmcd> Ohh, do you know the BZ#?
00:05:40 <rudi__> Probably not much yet
00:06:05 <rudi__> https://bugzilla.redhat.com/show_bug.cgi?id=652120
00:06:49 <jjmcd> OK, next topic is practically null
00:07:10 <jjmcd> #topic Docs Project leader elections
00:07:19 <jjmcd> #info No one stepped forward to run for the Docs Project leader position so there won't be any elections. #info No one stepped forward to run for the Docs Project leader position so there won't be any elections.
00:07:34 <jjmcd> #topic Publishing Documentation to the desktop
00:07:50 <jjmcd> rudi__, would you like to summarize the issue?
00:08:17 <rudi__> OK
00:08:32 <rudi__> So we need to work out how we'd like to publish to the desktop
00:08:49 <rudi__> And then we need to work out what we need from infra to make that happen
00:09:12 <rudi__> Options include a package that contains links to online docs
00:09:39 <rudi__> (either static, or able to consume an XML data dump on the site itself)
00:09:57 <rudi__> Or packaging for desktop installation
00:10:10 <rudi__> And if we choose packaging, how do we do it?
00:10:40 <rudi__> Publican is designed for a one-package-per-doc-per-Fedora_release-per-language
00:10:56 <rudi__> to get around nightmares that RH had with packaging docs in the past
00:11:10 <rudi__> But we could decide to do something different
00:11:51 <jjmcd> As a point of information, in Fedora, you can select a language at logon and everything shows up in your language if it is available
00:12:05 <jjmcd> With an app the bloat for multiple langs isn't bad
00:12:11 <rudi__> One key point here is that when we get automation going for publishing to the website, the desktop RPMs are automatically created as a by-product of that
00:12:44 <rudi__> So in theory, publishing desktop RPMs is as simple as putting those packages in a publically-accessible repo somewhere
00:13:05 <rudi__> And of course, the two major strategies here are not mutually exclusive
00:13:20 <jjmcd> rudi__, do you think it is possible to create a spec that somehow knows what languages you have installed, presuming more than one, so rational .desktop files could be created?
00:14:33 <rudi__> I'd be surpised if that were not possible; but I'm not an RPM guru :)
00:14:52 <jjmcd> The ways I can think of break some rules
00:14:53 <rudi__> But I'm not sure what you mean by "rational .desktop files"
00:15:22 <jjmcd> Well, if you install multiple language docs as individual packages, you get one menu entry per doc per language
00:15:46 <hicham> that would be insane
00:15:47 <jjmcd> In a perfect world, you would have one entry per doc, and if your selected language were installed it would lead to that doc
00:15:54 <rudi__> Oh OK, yeah, that's true; although the menu entries identify the language
00:15:55 <jjmcd> hicham, exactly
00:16:22 <jjmcd> hicham, that is the current publican default behavior.
00:16:25 <rudi__> It's a little more complex than that
00:16:30 <jjmcd> Fine if you only have one language
00:16:32 <hicham> jjmcd: desktop files are multilingual
00:16:39 <jjmcd> rudi__, oh yeah, it's a bear
00:16:52 <jjmcd> But what the user should see is simple
00:17:01 <jjmcd> It;s the stuff under the covers that isn't pretty
00:17:01 <hicham> jjmcd: and gnome docs follow the desktop language
00:17:07 <rudi__> It would be more like: if you click on the doc, and the doc exists in the language in which you're currently logged in, then it leads to that doc"
00:17:25 <jjmcd> hicham, yes.  Yelp takes care of it.  And we take care of it in release notes
00:17:32 <jjmcd> But we don't have a general solution
00:17:50 <rudi__> Yeah, whatever we do needs to work across desktops
00:18:08 <jjmcd> Exactly, currently yelp is pretty much a GNOME-only solution
00:18:21 <jjmcd> ANd release notes to exactly that
00:18:22 <rudi__> Or, alternatively, support KDE, and let GNOME users suffer for their poor life choice :)
00:18:34 <jjmcd> work across languages and desktops
00:18:45 <NiveusLuna> why not xfce and let the others suffer?
00:18:53 <jjmcd> But with release notes we install all languages
00:19:05 <hicham> i think a simple script can do that
00:19:15 <jjmcd> We test release notes on kde, sfce, lxde and gnome
00:19:22 <jjmcd> and presume it works on the others
00:19:32 <jjmcd> xfce sorry typing
00:19:57 <hicham> a script which would check for the current language, and then launch the help in the system browser in the system language
00:20:09 <hicham> it is not hard i think
00:20:18 <rudi__> This is not help documentation though
00:20:25 <rudi__> And I don't think it belongs there
00:20:33 <jjmcd> hicham, the problem is it works if you install all languages.  But in a perfect world, we would like to install SOME languages and have rational behavior
00:21:01 <jjmcd> For RNs it isn't too bad, but some of the guides are HUGE and installing in 50 languages would be nuts
00:21:24 <rudi__> Yeah, we waste bandwidth and waste space on people's systems installing stuff that we don't need to
00:21:34 <jjmcd> So the user should be able to choose, say, farsi, bengali and french, and get just those
00:21:54 <hicham> jjmcd: it is feasible
00:21:56 <jjmcd> That makes the script a bit of a challenge
00:22:22 <jjmcd> I think it may be.  Might be more of an app than a little js, but certainly it should be possible
00:23:04 <rudi__> heh; or the app is a specialised front-end for yum
00:23:25 <jjmcd> We could do something like publican publish, the install stuffs the data into a sqlite db and an app reads that
00:24:05 <jjmcd> The .desktop file would simply point to the app
00:24:31 <jjmcd> and the app would sort the langs available.
00:25:05 <jjmcd> Shall we try to draw more discussion on the list?
00:25:44 <rudi__> Yeah
00:25:51 <rudi__> And maybe update that wiki page
00:26:10 <jjmcd> #action jjmcd to try to draw more discussion on desktop publication on the list
00:26:27 <jjmcd> #action rudi will update wiki page on publication to desktop
00:26:30 <jjmcd> OK?
00:26:33 <rudi__> Yep
00:26:45 <jjmcd> Moving on
00:26:52 <jjmcd> #topic Release Notes
00:26:57 <jjmcd> Not much to say here
00:27:16 <jjmcd> Last batch of translations FINALLY got pushed to docs.fp.o
00:27:29 <jjmcd> And nothing more to do unless bugs come in
00:27:39 <jjmcd> or more translations
00:28:01 <jjmcd> Anyone with questions?
00:28:42 <jjmcd> #topic Guide Status
00:29:08 <jjmcd> OK, I will be pushing an updated ARG to docs.fp.o shortly now that I found the problem I was having
00:29:20 <jjmcd> Everyone ready to start thinking F15?
00:29:21 <rudi__> Pretty much the same as RN status -- everything published AFAIK
00:29:50 <rudi__> And yeah, time to start fixing bugs in "master" and getting ready for F15
00:30:16 <jjmcd> Gotta give everyone a big attaboy.  We got one heck of a collection of guides out there
00:30:41 <jjmcd> #topic Outstanding BZ Tickets
00:30:50 <jjmcd> #link http://tinyurl.com/lbrq84
00:31:09 <jjmcd> I haven't even looked to see where we are
00:31:39 <jjmcd> 104 bugs
00:32:17 <jjmcd> hmmm, Koji didn't close my catalan bug
00:32:44 <jjmcd> Anyone need any assistance with any bugs?
00:33:17 <jjmcd> Wow, we're just zooming through this agenda.  Helps to have everything done ;-)
00:33:24 <jjmcd> #topic Open floor discussion
00:33:35 <jjmcd> Does anyone have anything for the good of the order?
00:34:28 * nb does not think he does
00:34:36 * jjmcd is all geeked that his first actual application has made it to the repos
00:35:40 <jjmcd> Should we get rbergeron to work up a schedule for our publishing to the desktop project?
00:36:14 <jjmcd> Nobody else?
00:36:26 <jjmcd> 5
00:36:33 <jjmcd> 4
00:36:40 <jjmcd> 3
00:36:45 <jjmcd> 2
00:36:48 <jjmcd> 1
00:36:49 <jhradilek> *BOOM*
00:37:02 <jjmcd> Thank you everybody.  Let's all hope Sparks' wife is OK
00:37:06 <jjmcd> #endmeeting