fedora-meeting
LOGS
20:59:48 <poelcat> #startmeeting Fedora 14 Final Release Go/No-Go Meeting http://fedoraproject.org/wiki/Go_No_Go_Meeting
20:59:48 <zodbot> Meeting started Tue Oct 26 20:59:48 2010 UTC.  The chair is poelcat. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:59:48 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:00:08 * jlaska waves
21:00:09 <Oxf13> hi all
21:00:51 <poelcat> do we have a fescoite?
21:01:31 <poelcat> nirik: ?
21:01:38 <poelcat> anyone else for the record keeping?
21:01:46 <Oxf13> drumming up some folks
21:01:48 <adamw> yo
21:02:14 <poelcat> hi everyone
21:02:24 <poelcat> we'll wait 60 seconds and then jump in
21:03:08 <Oxf13> dcantrell is here for anaconda/devel folks
21:03:14 * brunowolff is here from spins SIG
21:03:40 <poelcat> #info attendees: jlaska Oxf13 adamw poelcat dcantrell (and anyone on #fedora-meeting)
21:03:51 <poelcat> #topic Why are here and what does it mean?
21:04:02 <poelcat> #link http://fedoraproject.org/wiki/Go_No_Go_Meeting
21:04:25 <poelcat> we're here to to review where we are at with Fedora 14 testing and blockerness
21:04:33 <poelcat> and to decide if the release can be declared GOLD
21:04:38 <poelcat> anything i missed?
21:05:02 <jlaska> nope, that's my understanding
21:05:10 <poelcat> #topic Testing Status
21:05:21 <poelcat> QA people, what do we know?
21:05:50 <adamw> tl;dr summary - all is lollipops
21:05:57 <poelcat> lol
21:06:01 <Oxf13> and lollipops are good
21:06:02 <jlaska> heh ... meetbot needs #tldr
21:06:04 <fenris02> and no pony.
21:06:07 <rbergeron> with unicorns?
21:06:19 <adamw> we have one open bug on the blocker tracker: https://bugzilla.redhat.com/show_bug.cgi?id=639650
21:06:30 <poelcat> so test matrices are done and look good?
21:06:34 <adamw> but note it's not an f14 bug exactly, it's an f13 bug
21:06:54 <jlaska> #link https://fedoraproject.org/wiki/Test_Results:Fedora_14_Final_RC1_Desktop
21:07:07 <jlaska> #link https://fedoraproject.org/wiki/Test_Results:Fedora_14_Final_RC1_Install
21:07:10 <adamw> we've got a slightly janky system where for issues in previous releases that affect use of the new release - stuff like preupgrade or, in this case, livecd-tools - we can mark a bug as a 'blocker' and have it mean the bug should be fixed in the previous release(s) before the new release goes ga
21:07:16 <adamw> jlaska: i was gonna go through blockers and then matrices
21:07:26 <fenris02> adamw, does that reproduce under the current rc1 iso?
21:07:35 <adamw> fenris02: getting to it :)
21:07:37 <jlaska> adamw: take it away ... I'm just feeding meetbot
21:07:52 <adamw> so even if this bug is accepted as a blocker, it doesn't mean we're slipping, it just means we'd have to fix it in f13 by f14 GA date
21:08:05 <adamw> (we should have a better system for this, i know, i'll probably go away and dream something up)
21:08:27 * jlaska points to https://fedoraproject.org/wiki/Fedora_14_QA_Retrospective
21:08:30 <adamw> anyway, the bug isn't accepted as a blocker in any case; at first we thought it may affect everyone writing f14 usb sticks from f13 but it doesn't seem to be the case
21:08:39 <adamw> several people have tried and not reproduced
21:08:54 <adamw> so it seems likely to be specific to particular hardware - probably some BIOS interaction thing that happens to be fixed in a later syslinux
21:09:20 <adamw> that being the case, i'm getting less and less worried about this one as days go by and we can probably knock it off the blocker list unless anyone else is worried
21:10:04 <Oxf13> not really a decision for this meeting.  For the sake of this meeting, it is not an accepted blocker
21:10:08 <adamw> agreed
21:10:13 <Oxf13> nor will it become an accepted blocker in the next... 10 minutes
21:10:16 <adamw> so that's teh blocker story: nice and simple
21:10:28 <poelcat> so why not just kick it off so we dont' have to revist?
21:10:29 <adamw> so, matrices - jlaska gave the links
21:10:36 <jlaska> re: nice and simple, that's rare, and a nice change :)
21:10:39 <adamw> poelcat: let's do that in -qa or something
21:11:02 <poelcat> okay, i thought we usually did that in meetings
21:11:17 <adamw> install test matrix: we have no fails on any critical test
21:11:30 <adamw> the only fail in the entire matrix is a preupgrade from f12-f14 fail, which is just an advisory test
21:11:31 <jlaska> poelcat: we don't have a great process for tracking these types of issues (packages in F-13 that may impact F-14 install/upgrade)
21:11:51 <adamw> it's not required to work, we just test it so we know if there's issues we can document
21:11:54 <jlaska> poelcat: so we keep using the blocker bugs even though they don't *block* the release
21:12:12 <poelcat> ah, okay... carry on :)
21:12:16 <adamw> so that one's nice and simple too. there's some warnings, but none of them is terribly worrying
21:12:20 <jlaska> adamw: did you get rhe's note about that failure?
21:12:22 <Oxf13> except that it's not an accepted blocker
21:12:26 <Oxf13> it's just a proposed blocker
21:12:42 <adamw> jlaska: no?
21:13:14 <jlaska> #info https://bugzilla.redhat.com/show_bug.cgi?id=646437
21:13:17 <adamw> check the footnotes if you're interested in the warnings, but they're all small beer
21:13:20 <poelcat> Oxf13: if it's proposed, lets just deal with it
21:13:29 <poelcat> we don't have any other blocker meetings scheduled
21:13:38 <poelcat> and probably don't want to :)
21:13:44 <jlaska> That's the failure reported by rhe ... I wasn't able to reproduce the failure in my testing, and rhe noted that the selinux-policy package in 'updates-testing' resolved the problem for her
21:14:00 <adamw> desktop matrix: the desktop and kde spins, which are the ones that can block the release, have no fails
21:14:20 <adamw> we have one warning in desktop which is just that you can't input non-ascii characters in passwords, which is not a blocker issue
21:14:27 <Oxf13> poelcat: this isn't the place for it.  I agree it should be dealt with, but this isn't the meeting for it.
21:14:43 <poelcat> Oxf13: we have in previous releases so i was confused
21:14:45 <adamw> and one warning in kde, which is abrt notification icon missing, also not a blocker issue (right rdieter?)
21:15:01 <Oxf13> poelcat: ah, ok.
21:15:07 <jlaska> should we let adamw finish, and then we can knock out any open items?
21:15:12 * jlaska quiets also
21:15:15 <Oxf13> I don't /really/ care, it jsut didn't seem like appropriate use of this time
21:15:38 <adamw> we decided xfce and lxde wouldn't block f14 release, but in any case both look pretty good, we have one 'fail' in each but it's a fairly minor issue (system-config-keyboard is borked)
21:16:03 <adamw> so, yeah - all lollipops and unicorns. i'm sure this means we've overlooked something horrible, as releases shouldn't be this easy. :P
21:16:07 <fenris02> adamw, is that the "cannot hit the ok button" bug?
21:16:10 <adamw> fenris02: yup
21:16:24 <poelcat> #info test matrices are clear
21:16:24 <adamw> fenris02: in case you're wondering, s-c-k is hidden in the GNOME and KDE menus in favour of their own keyboard config tools
21:16:35 <adamw> so it doesn't cause a fail for the gnome/kde spins
21:16:51 <fenris02> oh, so it's borked there too - but obscured?
21:17:02 <poelcat> any other information that should be presented before we start talking about gold?
21:17:07 <adamw> fenris02: yep. it's not in the menus, hence doesn't fail the 'all apps in the menus should work' criterion.
21:17:21 <fenris02> adamw, right.  np
21:17:22 <adamw> i can't think of anything from the qa side...jlaska?
21:17:35 <jlaska> adamw: nothing here, you covered all the bases.  Thanks!
21:17:52 <adamw> i guess just to note i've also been monitoring irc and forum chatter and haven't seen anything worrying there
21:18:02 <adamw> so there's just nothing on the radar
21:18:12 <poelcat> #topic Releng
21:18:22 <poelcat> Oxf13: anyhing on the releng side?
21:18:33 <Oxf13> releng is a go.  nothing to worry about on my end.  I've been staging a complete tree today for easy drop onto the mirrors
21:18:43 <poelcat> fantastic
21:18:52 <poelcat> #topic fesco/devel/etc
21:18:53 <Oxf13> the only thing of note is that the source DVD is 5gigs, but it was oversize last release too
21:18:57 <adamw> oh, whoops - forgot to mention, the kde update notification/installation tests haven't been done for rc1, but they were done for tc, passed, there's no open bugs related to the functions, there's no reason to believe they're broken.
21:19:27 <poelcat> #info the source DVD is 5gigs, but it was oversize last release too
21:19:50 <poelcat> any input from fesco, devel, or elsewhere before deciding gold?
21:20:13 <adamw> oh, i asked oxf13 if we could respin lxde to deal with one annoying bug
21:20:26 <adamw> it'd simply be a change of adding one package to the lxde spin, nothing else at all changes
21:20:33 <adamw> but it's not critical either way.
21:20:57 <jlaska> oh rats ... lemme add to retrospective ... we haven't been checking the source ISO's
21:21:40 <Oxf13> adamw: and I'm really not inclined to do that at this point.
21:21:48 <fenris02> poelcat, is that a concern?
21:22:02 <poelcat> fenris02: that == ?
21:22:11 <fenris02> poelcat, source dvd size i mean
21:22:22 <poelcat> apparently not, if last release it was okay :)
21:22:30 <adamw> Oxf13: fine, we'll hack around it somehow
21:22:36 <adamw> i'll see what cwickert wants to do
21:22:36 <fenris02> heh.  just wondering if it's worth cutting into two dvd's or not
21:22:54 <poelcat> Oxf13: what's the risk of oversized source DVD?
21:23:00 <adamw> you can't write it? :P
21:23:07 <adamw> well, only to DL media
21:23:16 <fenris02> adamw, sure you can.  you just a 7.5g dvd
21:23:18 <poelcat> so the only way to use it loopback?
21:23:19 <brunowolff> You can't download it to FAT32 file systems.
21:23:21 <fenris02> or usb
21:23:32 <fenris02> brunowolff, you cant anyhow, if it's over 4G
21:23:42 <poelcat> split dvd?
21:24:09 <poelcat> Oxf13: why did we decide it was okay last release, do you remember?
21:24:25 <Oxf13> poelcat: I think we decided to ship it and see if anybody cared
21:24:43 <fenris02> what percentage users actually dl the src dvd?  is it a signicant number?
21:24:47 <fenris02> 'significant'
21:24:49 <poelcat> that's one way to do a market study :)
21:25:16 <adamw> where's those torrent numbers?
21:25:45 <Oxf13> oh, I'm wrong.  F13 wasn't oversize.
21:25:47 <Oxf13> it was 4.2G
21:27:11 <poelcat> Oxf13: what are the go-forward options?
21:28:56 <Oxf13> still.  nonissue to me,  use dual layer if you have to burn it
21:29:20 <poelcat> anyone disagree?
21:29:36 <adamw> nope.
21:29:48 <brunowolff> I suggest a note somewhere that you can't save it to an FAT file system.
21:30:00 <poelcat> release note?
21:30:05 <Oxf13> ship as is with common bugs entry, or slip and find somethings to trim off the dvd
21:30:08 <brunowolff> Or common bugs.
21:30:22 <jlaska> Oxf13: in the future, do those need to be included in the ISO drops to get testing?
21:30:46 <brunowolff> For uses I can think of the image should be OK.
21:31:26 <stickster> I can't imagine there are a ton of people downloading an ISO full of SRPMS that only have a Windows box available on which to play with them
21:31:42 <jlaska> no objection to noting this issue on Common_F14_Bugs (it's not an intended behavioral change, so I think that's more appropriate than the release notes)
21:31:46 <adamw> okay, blocker list is now clear :)
21:31:59 * jlaska sees adamw swinging the blocker axe
21:32:01 <poelcat> so the issue is kind of moot because we're providing the DVD as a convenience and full source is always available in CVS, repos, etc.
21:32:05 <poelcat> ?
21:32:13 <adamw> let's be honest, i suspect no-one actually downloads the source DVD anyway.
21:32:19 <stickster> poelcat: Yes, precisely.
21:32:22 <adamw> we've probably kicked this around for five minutes too long anyway.
21:32:22 <poelcat> got it
21:32:31 <stickster> adamw: There are a few thousand torrent downloads, but that pales in comparison to the binary totals.
21:32:37 <poelcat> wow, usually it's me trying to move the meeting along :)
21:32:45 * adamw puts on his poelcat mask =)
21:32:48 <poelcat> #topic GOLD or Not?
21:33:25 <poelcat> is there anyone that believes Fedora 14 should not be declared GOLD?
21:33:28 <fenris02> i'd rather size the media for dl-dvd anyhow.  that allows more stuff to fit
21:33:32 <adamw> qa is +1 golden lollipops
21:33:49 <Oxf13> we dont need more stuff.
21:34:14 <dcantrell> I vote gold, fwiw (though I imagine my vote counts like Guam counts in a US presidential election)
21:34:27 * jlaska +1 to declaring F-14-RC1 GOLD
21:34:28 <adamw> dcantrell: i'm helping! i'm helping!
21:34:36 <stickster> dcantrell: I vote gold, but I think I'm D.C.
21:34:51 <Oxf13> capcom is go
21:34:55 <poelcat> #agreed Fedora 14 is declared GOLD
21:35:05 <adamw> is shipping RC1 some kind of record?
21:35:06 <poelcat> #action add DVD size issue to common bugs
21:35:12 <fenris02> and there was much rejoicing
21:35:16 <adamw> we can't ever have done that before
21:35:17 <Oxf13> adamw: yes
21:35:27 <adamw> shots all round
21:35:35 <dcantrell> so, F-15 Alpha next week?
21:35:41 <jlaska> dcantrell: that was last week
21:35:45 <stickster> dcantrell: BRING IT ON
21:35:49 <bcl> Now where did those minstrels go?
21:35:55 <poelcat> #topic open discussion
21:35:58 <jlaska> bcl: wandering I think
21:36:03 <stickster> HALLELUJAH
21:36:11 <stickster> Seriously, I hear angels singing.
21:36:37 * cyberpear is impressed with shipping the first "release candidate" as the actual release
21:36:38 <dcantrell> separation of church and operating system!
21:36:45 <bcl> That's just ringing in your ears from lack of sleep
21:37:05 <jlaska> Mr. Broken record would like to point out that we had another really strong community turn-out with our organized test runs for the TC and RC phase.  So many thanks to all who contributed wiki results, bugs and mailing list feedback early and often
21:37:31 <poelcat> jlaska: +1
21:37:43 * poelcat closes meeting 60 seconds
21:38:02 * jlaska needs to step away ... thanks all
21:38:13 <poelcat> jlaska: thank you!
21:38:16 <poelcat> and everyone else
21:38:28 <poelcat> great finish to the release
21:38:50 <adamw> yep awesome job everyone
21:39:06 <poelcat> #action poelcat to send GOLD email to the lists w/ reminder for release readiness meeting on Thursday
21:39:19 <poelcat> #endmeeting