fedora-meeting
MINUTES

#fedora-meeting: Java SIG -- https://fedoraproject.org/wiki/SIGs/Java

Meeting started by akurtakov_ at 17:02:30 UTC (full logs).

Meeting summary

  1. roll-call (akurtakov_, 17:03:38)
    1. akurtakov_ cspike ggraz mbooth sochotni present (sochotni, 17:04:00)
    2. akurtakov_ cspike ggraz mbooth sochotni present (akurtakov_, 17:04:25)

  2. maven 3 status (akurtakov_, 17:05:33)
    1. http://sochotni.fedorapeople.org/maven-3.0-1.fc13.src.rpm (sochotni, 17:06:37)
    2. http://sochotni.fedorapeople.org/maven-3.0-1.fc13.src.rpm maven 3 source rpm (sochotni, 17:06:45)
    3. https://fedoraproject.org/wiki/MavenUpdate#Maven_3 may be helpful, too (cspike, 17:06:58)
    4. http://sochotni.fedorapeople.org/maven-3.0-1.fc15.noarch.rpm maven 3 binary rpm (sochotni, 17:07:01)
    5. ACTION: sochotni will put maven 3 spec for review (sochotni, 17:12:25)
    6. ACTION: sochotni will create public git repo with custom resolver so others can see/review (sochotni, 17:12:56)
    7. new resolver should be basically re-implemented maven-aether-provider (sochotni, 17:14:45)

  3. Java packages monitoring (sochotni, 17:15:04)
    1. https://fedoraproject.org/wiki/SIGs/Java/Monitored_packages Wiki to collect Java packages for monitoring (sochotni, 17:15:27)
    2. https://fedorahosted.org/fedora-infrastructure/ infra ticketing system (sochotni, 17:19:26)
    3. ACTION: akurtakov_ will file infra ticket asking for java pseudo user (sochotni, 17:19:44)
    4. java-sig user will forward to java-devel mailing list (sochotni, 17:26:08)

  4. New packaging guidelines (akurtakov_, 17:26:54)
    1. https://fedoraproject.org/wiki/User:Akurtakov/JavaPackagingDraftUpdate Draft (sochotni, 17:27:15)
    2. ACTION: akurtakov_ to add javadoc:aggregate to guidelines (akurtakov_, 17:31:31)
    3. ACTION: akurtakov_ add to guidelines that ant packages that have pom files MUST install them (akurtakov_, 17:35:38)
    4. ACTION: akurtakov_ f there is no pom consider using the one from maven central addition to guidelines (akurtakov_, 17:37:40)
    5. ACTION: akurtakov_ merge parts from JPPMavenReadme and explain when usage of depmap is reasonable and when one have to patch the pom.xml file (akurtakov_, 17:43:42)
    6. http://fedoraproject.org/wiki/Fedora_meeting_channel (cspike, 17:54:56)

  5. Update Java SIG wiki (sochotni, 17:57:27)
  6. open-floor (akurtakov_, 17:58:15)
    1. http://fedoraproject.org/wiki/JakartaCommonsRename (cspike, 17:59:12)
    2. http://fedoraproject.org/wiki/How_to_remove_a_package_at_end_of_life (cspike, 18:01:11)
    3. ACTION: sochotni try to contact jmrodri and fnasser about orphaning their jakarta packages (sochotni, 18:05:32)


Meeting ended at 18:25:51 UTC (full logs).

Action items

  1. sochotni will put maven 3 spec for review
  2. sochotni will create public git repo with custom resolver so others can see/review
  3. akurtakov_ will file infra ticket asking for java pseudo user
  4. akurtakov_ to add javadoc:aggregate to guidelines
  5. akurtakov_ add to guidelines that ant packages that have pom files MUST install them
  6. akurtakov_ f there is no pom consider using the one from maven central addition to guidelines
  7. akurtakov_ merge parts from JPPMavenReadme and explain when usage of depmap is reasonable and when one have to patch the pom.xml file
  8. sochotni try to contact jmrodri and fnasser about orphaning their jakarta packages


Action items, by person

  1. akurtakov_
    1. akurtakov_ will file infra ticket asking for java pseudo user
    2. akurtakov_ to add javadoc:aggregate to guidelines
    3. akurtakov_ add to guidelines that ant packages that have pom files MUST install them
    4. akurtakov_ f there is no pom consider using the one from maven central addition to guidelines
    5. akurtakov_ merge parts from JPPMavenReadme and explain when usage of depmap is reasonable and when one have to patch the pom.xml file
  2. sochotni
    1. sochotni will put maven 3 spec for review
    2. sochotni will create public git repo with custom resolver so others can see/review
    3. sochotni try to contact jmrodri and fnasser about orphaning their jakarta packages


People present (lines said)

  1. sochotni (132)
  2. akurtakov_ (95)
  3. cspike (43)
  4. ggraz (27)
  5. mbooth (12)
  6. zodbot (3)


Generated by MeetBot 0.1.4.