spins-sig
LOGS
21:15:08 <brunowolff> #startmeeting spins SIG 2010-10-18
21:15:08 <zodbot> Meeting started Mon Oct 18 21:15:08 2010 UTC.  The chair is brunowolff. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:15:08 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:15:17 <brunowolff> #meetingname spins-sig
21:15:17 <zodbot> The meeting name has been set to 'spins-sig'
21:15:30 <brunowolff> #topic who's here?
21:15:50 * brunowolff got back a little later from my work meeting than i had hoped.
21:16:08 <brunowolff> #chair nirik
21:16:08 <zodbot> Current chairs: brunowolff nirik
21:16:38 * nirik is around...
21:16:53 <brunowolff> #topic spins status
21:17:14 <brunowolff> When I checked earlier a new compose wasn't ready yet.
21:17:25 <nirik> I synced yesterdays this morning...
21:17:36 <nirik> but they didn't have the change for the backgrounds in them.
21:17:36 <brunowolff> I am hoping that spins all get fixed, but noticed that Desktop is very close.
21:17:38 <nirik> todays should
21:18:04 <brunowolff> I hadn't noticed at first because I mixed up MiB and MB.
21:18:09 <nirik> 722632  /var/tmp/nightly-composes/desktop/desktop-x86_64-20101018.15.iso
21:18:17 <nirik> 722632  /var/tmp/nightly-composes/desktop/desktop-i386-20101018.15.iso
21:18:21 <brunowolff> The compressed images may not be enough to get it under size.
21:18:44 <brunowolff> Those are about 7MB over size.
21:18:51 <nirik> yep. ;(
21:19:05 <brunowolff> If so, we'll need to drop the animated backgrounds from that spin as well.
21:19:12 <nirik> or something else...
21:19:25 <brunowolff> Also I haven't heard anything about a comps change from desktop.
21:19:33 <nirik> can ask them what they want to do.
21:20:08 <brunowolff> Thanks. It would help to know if they want to try to do a cut if they need to save a couple of more MB.
21:20:14 <nirik> yeah, I can ask...
21:20:38 <brunowolff> The comps change will be needed for people doing installs, as best I can figure.
21:20:57 <nirik> yeah, for 'yum install @gnome-desktop'
21:21:13 <brunowolff> They probably want to add the animated image gnome package to the gnome desktop group.
21:21:45 <brunowolff> The comps file said to consult desktop for that group so I didn't want to change it myself.
21:22:14 <brunowolff> The oversize issue for a couple of the spins are supposed to turn into blocker bugs and others nice to have.
21:22:27 <nirik> yeah ok.
21:23:07 <brunowolff> I only had initial back and forth with laska. I want to make sure I am copied on the bugs once I find them.
21:23:14 <brunowolff> I'll add you as well.
21:23:28 <nirik> that would be great.
21:23:53 <brunowolff> #action nirik will contact desktop about further remediation of Desktop spin size and comps entry for animated background.
21:24:25 <brunowolff> #action brunowolff will find (or file) bugs for spin over size issues and make sure bruno and nirik are copied.
21:25:32 <brunowolff> #action brunowolff will look at spin sizes after next nightly compose and report results to interested parties.
21:25:50 <brunowolff> I think that is mostly it for the oversize issue.
21:26:01 <brunowolff> #topic Test plans
21:26:28 <brunowolff> I found some test plans in a live image category that seemed pretty reasonable.
21:26:42 <nirik> there's one issue on the xfce spin around mixers... I might just add gnome-media in for now until we have a longer term solution.
21:27:02 <brunowolff> I was think of asking owners to do all of the test plans with both i686 and x86_64 and report results to the spins list.
21:27:17 <nirik> sounds great.
21:28:08 <brunowolff> Some might be N/A for some spins. But I'll word things to indicate I just want a report with comments for any nonpass.
21:28:35 <brunowolff> Off the record, I might do the tests for spins where the owner doesn't.
21:29:04 <brunowolff> A few spins will probably get QA resources. And for those I can check those test results.
21:29:41 <brunowolff> Probably Desktop and KDE will get help from the QA team. I am not sure about XFCE and the other desktop.
21:30:28 <brunowolff> I'll send the message out to the spins list and all of the owners. The time frame is during the RC process, so it will be another
21:30:32 <brunowolff> day or two.
21:30:39 <nirik> there are some folks on the xfce list that have been testing.
21:30:59 <brunowolff> #action brunowolff will send out details of the test plans required for spin owners to execute.
21:31:31 <brunowolff> #topic meego
21:31:48 <brunowolff> In case you missed it, Meego has been withdrawn.
21:32:12 <brunowolff> Peter will probably do it as a remix after some more work gets done.
21:32:20 <nirik> yep. ;( sad.
21:32:30 <brunowolff> I think I made all of the needed wiki changes and notificfations.
21:32:53 <brunowolff> #topic f15
21:33:30 <brunowolff> So for F15, I have pretty much decided that I can't commit to staying on as both lead and wrangler though the whole process.
21:33:54 <nirik> yeah, understandable.
21:34:07 <brunowolff> Giving that with are current state, dropping out part way through would cause a lot of problems, I notified the advisory board
21:34:34 <nirik> yeah, we need to see what we want to do in the next cycle.
21:34:40 <brunowolff> that I would stop filling in in those roles shortly after the F14 release. (Some F14 spins work happens a bit after the release.)
21:34:46 <nirik> perhaps we can do a session at fudcon
21:35:17 <brunowolff> I'll send a more detailed message to the spins list to give lurkers a chance to volunteer. I also asked for a future of spins
21:35:32 <brunowolff> meeting to occur, but haven't heard a response yet.
21:36:23 <brunowolff> With our current staff, just treading water would be about the best that would happen. There is documentation that needs
21:37:09 <nirik> yeah.
21:37:13 <brunowolff> to get written. Wrangling to do. Fire fighting. And if there really was a lot of support, process improvement in several areas.
21:37:36 <nirik> it might be we could fold it back into rel-eng...
21:37:39 <brunowolff> I suspect that SIG per Spin may be the future.
21:38:30 <nirik> yeah, but still needs some overall quality/management process I fear.
21:38:37 <brunowolff> Maybe the threat of a number of minor spins getting less exposure will convince some more people to volunteer.
21:39:22 <nirik> perhaps.
21:39:31 * nirik doesn't hold his breath
21:40:08 <brunowolff> I'd like to see the board, spin owners and releng get together to talk about what is both sustainable and desirable.
21:40:44 <nirik> yep
21:40:46 <brunowolff> A more dynamic lead for the team might be able to get things going again.
21:41:47 <brunowolff> Anyway, expect something from me spelling things out on the spins list in the next day or so.
21:42:01 <nirik> sounds good, and thanks for all your work this cycle.
21:42:21 <brunowolff> We'll I didn't get as much done as I had hoped.
21:42:58 <brunowolff> I have been surprised that the board hasn't been discussing more about the future. I was hoping to have some better
21:43:11 <brunowolff> idea of the future before the F14 release.
21:43:46 <nirik> yeah, perhaps it will heat up as f14 is in the can ready for release.
21:43:53 <brunowolff> We should still have time to make a change over, but it might make things harder for f15.
21:44:43 * nirik nods.
21:44:48 <brunowolff> I'll still be around to provide history and do some work.
21:44:57 <nirik> I have to head out to an appt... do we have anything more for the meeting today?
21:45:21 <brunowolff> Were done.
21:45:24 <brunowolff> Thanks.
21:45:25 <nirik> thanks.
21:45:27 <brunowolff> #endmeeting