kde-sig
LOGS
14:05:52 <jreznik> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2010-10-05
14:05:52 <zodbot> Meeting started Tue Oct  5 14:05:52 2010 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:52 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:06:32 <jreznik> #meetingname kde-sig
14:06:33 <zodbot> The meeting name has been set to 'kde-sig'
14:06:58 * ltinkl is here
14:06:58 <jreznik> #chair than Kevin_Kofler rdieter_work SMParrish_away thomasj
14:06:58 <zodbot> Current chairs: Kevin_Kofler SMParrish_away jreznik rdieter_work than thomasj
14:07:06 <jreznik> #topic roll call
14:07:10 <jreznik> who's present?
14:07:21 <rdieter> here (for ~20 minutes at least)
14:07:21 <thomasj> 7me is present
14:07:29 <thomasj> heh, and can't type
14:07:32 <Kevin_Kofler> Present.
14:07:38 * rnovacek_ here
14:08:37 * than is present
14:09:35 <jreznik> #topic agenda
14:09:57 <jreznik> #info jreznik ltinkl thomasj rdieter Kevin_Kofler rnovacek_ than present
14:10:17 <Kevin_Kofler> Dropping "Compiz Switcher" a.k.a the "desktop-effects-kde" script from compiz-kde.
14:10:38 <Kevin_Kofler> (Rationale: This can be set up in System Settings since at least 4.1.)
14:11:23 <rdieter> review 4.5 blockers, aka http://bugzilla.redhat.com/show_bug.cgi?id=kde-4.5
14:12:42 <jreznik> anything else?
14:13:53 <rdieter> guess that's all , for now. :)
14:14:16 <jreznik> #topic dropping "Compiz Switcher"
14:14:20 <jreznik> Kevin_Kofler: your turn
14:15:10 <Kevin_Kofler> Our compiz-kde packages are still shipping a script called "desktop-effects-kde" which we wrote as a quick hack to allow using Compiz in KDE 3.
14:15:31 <Kevin_Kofler> With KDE 4, we renamed the menu entry to "Compiz Switcher" to make it clear it's not about KWin effects.
14:15:41 <Kevin_Kofler> But otherwise, it's still the same old script.
14:16:09 <Kevin_Kofler> But since 4.0 or 4.1 (not sure), KDE has a setting in System Settings for the window manager, allowing to set Compiz or anything else.
14:16:18 <Kevin_Kofler> So the script is redundant.
14:16:24 * rdieter has no preference, sure. ?
14:16:46 <Kevin_Kofler> The problem is: the script sets an environment variable which overrides whatever is set in System Settings.
14:17:16 <Kevin_Kofler> So once the script is used, the System Settings entry doesn't work unless/until you remove the offending env script from somewhere under ~/.kde
14:17:21 <rdieter> ok, slight preference, nuke it.
14:17:41 <ltinkl> nuke nuke
14:17:57 <Kevin_Kofler> This means that 1. we should IMHO get rid of the script ASAP, but 2. we should also describe in the release notes how to get rid of the offending file.
14:18:30 <rdieter> we could be evil and put something in /etc/kde/env to remove the offender too.
14:18:35 <than> Kevin_Kofler: it's better to drop it
14:18:45 <than> if it's redundant
14:19:18 <rdieter> but release notes should be sufficient, imo
14:20:32 * jreznik has never used it... but nuke it + release notes
14:20:34 <rdieter> sounds like we largely agree then, Kevin_Kofler, you want to take care of implementing the plan?
14:20:47 <Kevin_Kofler> Yes.
14:20:57 <jreznik> #agreed on dropping "compiz switcher"
14:20:57 <rdieter> go forth, and do
14:21:05 * thomasj is +1 (for posterity)
14:21:12 <Kevin_Kofler> F14 too or only F15?
14:21:30 <Kevin_Kofler> (I'm not going to touch releases, IMHO this kind of change doesn't belong in an update.)
14:22:07 <thomasj> right
14:22:13 <rdieter> f14 if possible, may be worth poking docs folks if release note additions are still possible this late
14:22:29 <than> rdieter: +1
14:22:50 <rdieter> (may require some sort of bribery, cookies and/or beer)
14:23:00 <jreznik> I'm not sure it fits NTH
14:23:03 <jreznik> for f14
14:24:10 <rdieter> jreznik:doesn't feel like nth.  it's just  removing crud.  the blocker really is if we can get a release note about it or not.
14:26:12 <ltinkl> move on? :)
14:27:32 <rdieter> think so.
14:27:38 <jreznik> so f14 if we can have release notes otherwise f15 only?
14:27:45 <rdieter> jreznik: yes
14:28:04 <jreznik> #info make change in f14 if we can have release notes otherwise f15 only
14:28:17 <jreznik> #topic review 4.5 blockers
14:28:26 <rdieter> gotta run to my other meeting, but wanted to mention the kwin/mesa thing has fixes available,   https://bugzilla.redhat.com/show_bug.cgi?id=625894
14:28:43 <rdieter> though for f14, requires an update to mesa-7.9 (rc2 or final) from our current snapshot
14:29:18 <rdieter> .bug 628433
14:29:20 <zodbot> rdieter: Bug 628433 KDE icon are blurred - https://bugzilla.redhat.com/show_bug.cgi?id=628433
14:29:34 <rdieter> and review ^^ it's impact and whether to continue to consider it a blocker.
14:29:43 <rdieter> that's the last one I think
14:29:49 <Kevin_Kofler> rdieter: Upgrading Mesa from snapshot to final should be fine.
14:30:04 <ltinkl> well I wouldn't consider blurry icons to be a blocker
14:30:23 <SMParrish_away> /me here sorry I'm late
14:30:25 <rdieter_work> ltinkl: the whole screen is munged (driver badness, most likely)
14:30:38 <rdieter_work> gory detail and screenshot in the bug
14:30:42 <rdieter_work> bye...
14:31:18 <ltinkl> rdieter_work: ah ok, I was seeing that bug only for tray icons
14:31:27 <ltinkl> but the screenshot looks interesting :)
14:31:37 <than> ltinkl: it seems critical for me
14:31:47 <ltinkl> yes, but that's definitely a driver bug
14:31:54 <than> sure
14:32:14 <ltinkl> nothing we should consider a KDe blocker
14:33:37 <jreznik> ltinkl: but then F14 blocker?
14:34:08 <than> does it only show up in kde?
14:36:17 <jreznik> ltinkl: you can reproduce it? with desktop effects or without?
14:36:23 <ltinkl> I can't
14:36:57 <ltinkl> and desktop effects don't work at all for me (with both ati and intel)
14:39:33 <ltinkl> so I'd tend to move it as a F14blocker
14:40:32 <than> i cannot reproduce this issue on f13
14:40:40 <than> with nouveau friver
14:41:04 <Kevin_Kofler> Well, such driver bugs can be dependent on the exact hardware, too.
14:41:43 <ltinkl> the bug doesn't mention whether the kwin effects are in use or not
14:41:51 <ltinkl> (or I fail to see itú
14:42:20 <than> ltinkl: you said you can reproduce it with radeon driver?
14:42:42 <ltinkl> than: yup, initially I thought so but I can't reproduce it anymore
14:43:13 <ltinkl> and it only happened to me on the systray icons
14:43:39 <than> it seems not easy to reproduce this issue. I think we should drop it from F14blocker
14:43:51 <rnovacek_> I saw it too on nouveau
14:44:01 <rnovacek_> but it is been some time
14:44:19 <than> this bug cannot fixed without usefull infos and reproducer
14:44:45 <ltinkl> it might have gotten fixed meanwhile with some mesa update
14:44:57 <than> ltinkl: yes, it could be
14:46:15 <than> move on please
14:46:21 <ltinkl> I marked the bug as NEEDINFO, let's see what the reporter has to say
14:46:23 <ltinkl> move on :)
14:48:20 <jreznik> another bugs for review? we have some time
14:48:46 <jreznik> rnovacek_: do we have bug report downstream for crashing polkit agent while logging out?
14:48:52 <ltinkl> nope, but I wanted to briefly mention the Solid sprint that took place this weekend
14:48:53 <jreznik> we have to fix it too...
14:49:44 <than> jreznik: bugzilla number?
14:50:09 <jreznik> #info Bug 628433 KDE icon are blurred marked as NEEDINFO
14:50:49 <jreznik> #link https://bugs.kde.org/show_bug.cgi?id=248636
14:50:57 <jreznik> it affects F14 too
14:51:00 <rnovacek_> jreznik: i think there is one
14:51:15 <rnovacek_> but I don't have it here
14:52:34 <than> rnovacek_: full agree with jaroslav, it should be fixed in f14
14:53:12 <rnovacek_> yes, but I can't reproduce it
14:53:36 <than> Comment #17 said, the crash can be reproduced every time
14:55:23 <than> it's tested in f15
14:55:47 <rnovacek_> than: ok, I'll try f15 tomorrow
14:55:50 <than> rnovacek_: have you tested it in rawhide
14:56:07 <than> rnovacek_: thanks, please try to test it in rawhide
14:56:18 <rnovacek_> no, only f13 and f14
14:56:43 <than> rnovacek_: it could be it only happens in rawhide
14:56:54 <than> move on please
14:57:16 <Kevin_Kofler> I think the next topic is ltinkl's report from the Solid sprint.
14:57:36 <ltinkl> ye, just briefly (I couldn't attend but anyway)
14:57:37 <Kevin_Kofler> jreznik: next topic please :-)
14:58:24 <Kevin_Kofler> #topic Solid sprint
14:58:32 <Kevin_Kofler> Let's not waste more time. ;-)
14:58:42 <Kevin_Kofler> ltinkl: Please start. :-)
14:58:43 <ltinkl> there is a nice wrap up written by ervin: http://ervin.ipsquad.net/2010/10/04/metalworkers-unite-a-solid-sprint-wrap-up/
14:58:53 <ltinkl> in short, what this means for Fedora
14:58:59 <rnovacek_> here is downstream bug for previous topic: https://bugzilla.redhat.com/show_bug.cgi?id=637064
14:59:24 <ltinkl> udisks and upower backends in kdelibs is mostly feature complete
14:59:47 <ltinkl> what needs to be done is a simple backend for PowerDevil (talking to upower)
15:00:06 <ltinkl> the general idea is to make these backends the default for KDE 4.6
15:00:13 <ltinkl> bibuy HAL
15:00:50 <than> ltinkl: is this feature backportable to 4.5?
15:00:52 <ltinkl> citing "the new set of backends for libsolid reaching feature completion for daily use (it’s now realistic to see them become default for 4.6);"
15:01:06 <ltinkl> than: I fear not
15:01:24 <Kevin_Kofler> It's too late for F14 anyway.
15:01:29 <Kevin_Kofler> F15 will have 4.6.
15:01:30 <ltinkl> the Solid API in kdelibs is not forward compatible
15:01:43 <ltinkl> yup, F15 sounds more realistic
15:02:14 <Kevin_Kofler> This kind of changes doesn't make sense post Beta.
15:02:25 <jreznik> we're out of time (sorry, I had to afk)
15:02:41 <ltinkl> did I just hear a conservative opinion from Kevin xD
15:03:00 <thomasj> The second time in this meeting!
15:03:02 <thomasj> :D
15:03:25 <jreznik> #info udisks and upower solid backends planned as default for kde 4.6
15:03:31 <jreznik> #endmeeting