kde-sig
LOGS
14:00:07 <jreznik> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2010-09-21
14:00:07 <zodbot> Meeting started Tue Sep 21 14:00:07 2010 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:07 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:03:21 <jreznik> #meetingname kde-sig
14:03:21 <zodbot> The meeting name has been set to 'kde-sig'
14:03:28 <jreznik> #chair jreznik Kevin_Kofler ltinkl than thomasj SMParrish
14:03:28 <zodbot> Current chairs: Kevin_Kofler SMParrish jreznik ltinkl than thomasj
14:03:33 <jreznik> #topic roll call
14:03:41 * thomasj here
14:03:42 <jreznik> Who's present today?
14:03:44 <Kevin_Kofler> Present.
14:03:55 * rnovacek here
14:04:04 * SMParrish here
14:04:10 <svahl> present
14:04:24 * jsmith lurks
14:04:36 * than is present
14:05:29 <thomasj> Welcome jsmith
14:05:52 <jsmith> Thanks thomasj
14:06:37 <jreznik> #info  thomasj jreznik Kevin_Kofler rnovacek SMParrish svahl thomasj present, jsmith lurks :)
14:06:45 <jreznik> #topic agenda
14:07:14 * nucleo here
14:07:31 <jreznik> #info nucleo present too
14:07:31 <thomasj> Wow, two hot topics today :)
14:08:09 <jreznik> maybe that update policy document should be added too (just to say no to the latest changes :D)
14:08:19 <thomasj> :D
14:08:27 * thomasj adds it
14:08:56 <than> jreznik:  let start the meeting
14:09:55 <jreznik> than: ok
14:10:09 <jreznik> #topic qt 4.7 released
14:10:38 <than> i'm working on qt-4.7 update
14:11:08 <thomasj> woo
14:11:24 <than> it will be build in rawhide today
14:11:30 <jreznik> than: great
14:11:39 <jreznik> we need it for f14 too...
14:11:54 <than> yes, i know
14:12:11 <than> first rawhide, than f14 ;-)
14:12:21 * jreznik understands
14:12:36 <thomasj> than, if you're short on time, i can probably help with f14 builds.
14:12:37 <jreznik> #info than is working on qt 4.7 update for rawhide
14:12:45 <Kevin_Kofler> IMHO we want it for all releases all the way down to F12.
14:12:55 <Kevin_Kofler> But we need to check the blockers.
14:14:12 <than> Kevin_Kofler: in my opinion it doesn't make sense for F12
14:14:14 <ltinkl> Kevin_Kofler: are we gonna push KDE 4.5 into F12?
14:14:22 <Kevin_Kofler> I'd like to.
14:14:25 <than> even KDE4.5 for F12
14:14:29 <Kevin_Kofler> But I might be alone there.
14:14:43 <thomasj> s/might/am/ ;p
14:14:47 <Kevin_Kofler> I think all our releases deserve the same level of update support as long as they're supported.
14:14:48 <SMParrish> qt4.7 and kde4.5 need to stay out of F12
14:14:48 <ltinkl> I think Qt 4.7 in F12 makes sense only together with KDE 4.5
14:14:49 <jreznik> thomasj: :D
14:15:00 <than> thomasj: thanks
14:15:21 <Kevin_Kofler> We all used to believe that, we've already been FESCo-ized to some extent. :-(
14:15:27 <than> ltinkl: we don't plan to do kde4.5 update for F12
14:15:34 <SMParrish> if anyone who still uses F12 wants 4.5 they can upgrade to F13.  That is what we need to encourage
14:15:39 <maxamillion> yeah, I think KDE 4.5 on F12 might be a QA nightmare, but if the group would like to make that happen then I would be willing to do as much testing as I can for it
14:15:49 <than> SMParrish: +1
14:15:52 <maxamillion> as I'm sure others would as well
14:16:03 <Kevin_Kofler> maxamillion: I think it's not going to happen anyway, I'm the only one who wants it. :-(
14:16:09 <thomasj> SMParrish, +1
14:16:12 <maxamillion> Kevin_Kofler: gotchya
14:17:17 <thomasj> maxamillion, hi :) FYI, i'm not very far with the oo.o kde integration, but working on it.
14:17:35 <jreznik> f14 is top priority now, we can talk about f13 later, f12 is out of scope
14:17:56 <maxamillion> thomasj: oooo, you're still my hero for even looking into it! :D
14:18:01 <thomasj> :D
14:18:09 <maxamillion> jreznik: +1
14:18:28 <thomasj> oh yes, jreznik +1
14:18:33 <than> jreznik: do we want kde-4.5+qt-4.7 update for f13?
14:19:06 <ltinkl> thomasj: good luck with that, you will need it :p
14:19:16 <thomasj> ltinkl, thanks, i know yeah :)
14:19:27 <strace> than: i think it would be good as then someone can easily fork the packages for RHEL6
14:19:46 <jreznik> than: it depends on update policies...
14:19:46 <SMParrish> than: that would be inline with the updates policy proposal.  Its should go into F13, F14 & rawhide
14:20:25 <than> SMParrish: great, then we will do kde-4.5+qt4.7 update for f13
14:20:39 <Kevin_Kofler> Yes, we definitely want the update for F13.
14:20:43 * thomasj want to see qt-4.7 final on his f13 with KDE 4.5 if irons out some minor glitches.
14:20:43 <jreznik> than: I'm +1, it's working very well
14:20:47 <than> so long the updates policy allows
14:20:51 <Kevin_Kofler> strace: RHEL 6 is based on F12, not F13.
14:20:51 <thomasj> *if it
14:21:09 <strace> Kevin_Kofler: IIRC i thought it used parts from F13 also
14:21:09 <jreznik> than: yes
14:21:11 <Kevin_Kofler> So that'd actually be an argument for building F12 updates. :-)
14:21:27 <maxamillion> strace: wha? why on earth are we worried about EL6?
14:21:38 <Kevin_Kofler> (But tbh, I'm not interested in supporting EL.)
14:21:53 <jreznik> #info kde 4.5 & qt 4.7 is in line with our updates policy proposal
14:21:55 <than> jreznik: please add KDE-4.5+qt-4.7 update for f13 on todo list
14:22:15 <jreznik> than: do we have any todo list at all?
14:22:20 <ltinkl> :)
14:22:23 <maxamillion> strace: if someone wants to build for EL6, they are more than welcome to but I find that out of the scope of this meeting and this SIG
14:22:34 <jreznik> maxamillion: indeed
14:22:40 <Kevin_Kofler> Well, it would be within the scope of kde-redhat.
14:22:49 <Kevin_Kofler> Anybody interested, please talk to rdieter.
14:22:50 <than> jreznik:  if not, it's time to do ;-)
14:22:56 <nucleo> there is old dbus related problem in F12, F13 that we can't solve https://bugs.kde.org/show_bug.cgi?id=250030
14:23:04 <jreznik> than: I'm thinking about it a very long time :)
14:23:09 <Kevin_Kofler> (He's currently not interested in EL6 builds himself, but he should be able to host them if somebody does the work.)
14:23:23 <Kevin_Kofler> (At least that was the news last I discussed this with him.)
14:24:02 <jreznik> ok, let's move - it's great nokia finally released qt 4.7 but next time it would be better to know real schedule
14:24:15 <than> thomasj: can you help us to work on KDE-4.5 update for F13?
14:24:19 <thomasj> nucleo, we can't fix that, as rdieter mentioned in -kde
14:24:23 <thomasj> than, sure
14:24:43 <than> thomasj: thanks, i will let you know
14:24:48 <jreznik> #action thomasj helps with kde 4.5 update for f13
14:24:55 <jreznik> #topic Fedora 14 beta rc3
14:25:01 <nucleo> thomasj: then KDE 4.5 dolphin in F13 will have this problem
14:25:08 <jreznik> 1. testing needed https://fedoraproject.org/wiki/Test_Results:Current_Desktop_Test
14:25:14 <jreznik> 2. we are still oversized
14:25:17 <Kevin_Kofler> I think we really need to get this fix into our dbus packages.
14:25:49 <thomasj> Kevin_Kofler, you might talk to rdieter about it. Even upstream thinks it's not easy to backport the fix.
14:26:01 <thomasj> Or was it nightmare ;p
14:26:07 <Kevin_Kofler> thomasj: Actually upstream and the Fedora maintainers are basically identical.
14:26:16 <maxamillion> jreznik: 1. is there a test day planned yet?
14:26:23 <Kevin_Kofler> (which is why it's not going to be an easy fight to get that fix in :-( )
14:26:31 <jreznik> maxamillion: no, it's not a test day, just that wiki page
14:26:36 <nucleo> can't swithc to console with Ctrl+Alt+F2 after logout/login on F14 RC3 LiveCD
14:26:41 <Kevin_Kofler> Re oversized, we need to fix that for the final F14, it's probably too late for the beta.
14:26:45 <Kevin_Kofler> At least it should be overburnable now.
14:27:00 <Kevin_Kofler> 708 MiB, I've overburned 712 MiB once. ;-)
14:27:17 <ltinkl> depends on the media I guess, you can't rely on that :)
14:27:19 <svahl> kdeaccessibility and some more fonts were removed, but gtk3 is still there
14:27:22 <thomasj> Have we already changed the topic? /me is confused
14:27:31 <jreznik> #info F14 KDE Plasma Desktop spin still oversized, has to be fixed by F14 final
14:27:50 <jreznik> thomasj: yes, I've changed topic
14:27:56 <Kevin_Kofler> ltinkl: I know, we need to get the size down for the final.
14:27:59 <thomasj> thanks
14:28:14 <Kevin_Kofler> svahl: gtk3 is gone from the Beta RC2 and RC3.
14:28:27 <Kevin_Kofler> They've pulled in the firstboot update which stops dragging in metacity.
14:28:32 <maxamillion> jreznik: should we look into scheduling a test day for the beta image?
14:28:37 <svahl> yes? ok, only compared the latest nightly
14:29:12 <jreznik> maxamillion: no, it's not a test day stuff... and go/no-go meeting is tomorrow afternoon (US)
14:29:17 <Kevin_Kofler> The nightlies still have metacity and deps (including the libcanberra-gtk3 and gtk3 stuff which is being dragged in by libcanberra-gtk2, that should be fixed too…).
14:29:33 <Kevin_Kofler> (but it stops being our problem now because we don't drag in metacity nor libcanberra-gtk2 anymore)
14:30:24 <jreznik> #info from beta rc2 metacity is not dragged in -> no gtk3 deps
14:30:32 * thomasj has to go afk for a couple minutes (kids).. brb..
14:31:26 <Kevin_Kofler> I've downloaded the ISOs, but I haven't had the time to burn, let alone test, them.
14:31:38 <jreznik> 100% right now
14:31:44 <Kevin_Kofler> (I downloaded both the 32-bit and 64-bit one.)
14:31:50 * jreznik fires VirtualBox
14:32:21 <rnovacek> jreznik: I think it won't work in VirtualBox (at least for me)
14:32:34 <jreznik> rnovacek: really? :(
14:32:51 <rnovacek> jreznik: I'll try to find the bug report...
14:33:06 <nucleo> just after RC3 boot switching to console works with Ctrl+Alt+F2 but after logout not works
14:33:50 <rnovacek> jreznik: https://bugzilla.redhat.com/show_bug.cgi?id=621893
14:34:30 <svahl> btw: package list of rc3 http://fpaste.org/WgE6/  proposals for removal welcome
14:34:43 <jreznik> rnovacek: hh, /me commented it too :)
14:35:08 <Kevin_Kofler> svahl: We've had some discussion tonight.
14:35:52 * thomasj back
14:36:16 <svahl> Kevin_Kofler: yes?
14:36:46 <Kevin_Kofler> rdieter removed paratype-pt-sans-fonts (Cyrillic, already covered by DejaVu) and stix-fonts (mathematical symbols, we can do without those by default), but those changes haven't been propagated to RC3.
14:36:47 <thomasj> Do we have a chance to remove kdepim from the livecd and get it installed together with the livecd on HDD?
14:36:55 <Kevin_Kofler> But they're probably not sufficient to fit.
14:37:33 <thomasj> Something like a trigger that's called after installation to HDD.
14:37:43 <Kevin_Kofler> We could save some space by omitting phonon-backend-gstreamer and gstreamer-plugins-good, but we're still having gstreamer and gstreamer-plugins-base dragged in.
14:38:16 <Kevin_Kofler> Other than that, everything we can remove probably removes some functionality. :-(
14:38:29 <svahl> Kevin_Kofler: also think so. the difference between the last two nightlies is only 3MB
14:38:42 <Kevin_Kofler> We could possibly split some stuff out of k3b-common into subpackages, e.g. translations, non-default themes, maybe also the image files for CD-I or such.
14:39:48 <maxamillion> maybe drop the koffice stuff? didn't the F13 release image not contain those?
14:40:25 <Kevin_Kofler> We haven't shipped an image without KOffice.
14:40:38 <maxamillion> oh ... really?
14:40:39 <maxamillion> my mistake
14:40:40 <Kevin_Kofler> The GNOME folks have shipped a release with no office stuff at all, but I think that's really a bad idea. :-(
14:40:48 <svahl> maxamillion: kword, kspread and kpresenter were present on all former releases
14:40:48 <maxamillion> I swore I always hat to install it after the fact
14:40:57 <maxamillion> huh ... nvm :/
14:41:00 <Kevin_Kofler> svahl: I think we actually omitted kpresenter once.
14:41:05 <nucleo> man-pages?
14:41:17 <svahl> Kevin_Kofler: ok, maybe.
14:41:31 <Kevin_Kofler> But with KOffice 2, it wouldn't save us much.
14:41:36 <jreznik> we just can't fit size and have all features...
14:41:38 <Kevin_Kofler> A lot of stuff is now in the core.
14:41:39 <than> svahl:  and perhaps kspread.
14:42:08 <than> if more space is needed
14:42:29 <Kevin_Kofler> I'd omit K3b before KOffice… You're not likely to want to burn from a live image…
14:42:43 <ltinkl> good point :)
14:42:46 <Kevin_Kofler> But we might be able to make k3b-common smaller, too.
14:42:59 <svahl> indeed, imho k3b would be the best option for removal/splitting
14:43:29 <than> Kevin_Kofler: kword stays on livecd
14:43:45 <svahl> than: sure
14:43:50 <Kevin_Kofler> It's 20 MiB and that includes translations (can be subpackaged, we don't even have kde-l10n on the live image, so why ship K3b translations?), themes (why install by default?), some relatively large (1-2 MiB) image files for formats nobody uses (CD-I) etc.
14:44:17 <rdieter> (last comment before running), +1 to dropping k3b asap, and +1 to splitting out k3b translations longer-term.
14:44:35 <rdieter> (unless there's any obvious better solution... which I don't see right now)
14:44:46 <Kevin_Kofler> We also need to talk to the Anaconda folks to see if they can't remove the tigervnc-server(-minimal) dep.
14:44:46 <jreznik> rdieter: +1
14:44:48 <svahl> rdieter: +1 (for both)
14:44:57 <Kevin_Kofler> Nobody wants to do a VNC install from a live image.
14:45:04 <jreznik> Kevin_Kofler: +1
14:45:13 <Kevin_Kofler> And it drags in the xorg-x11-fonts-misc which are huge and unneeded.
14:45:13 <nucleo> is man-pages really needed on LiveCD (4.4Mb)?
14:45:49 <Kevin_Kofler> And the bug report which is cited as justification for adding the dep is RH-only.
14:45:57 <Kevin_Kofler> (Can one of the folks @ RH please check what this is all about?)
14:46:04 <nucleo> may be konq-plugins (5.4 Mb)  will be better than man-pages
14:46:10 <rnovacek> I would rather drop k3b that man-pages
14:46:17 <Kevin_Kofler> #561498
14:46:40 <jreznik> rnovacek: no, man-pages are useful :)
14:46:47 <Kevin_Kofler> nucleo: konq-plugins have already been omitted.
14:47:06 <rnovacek> jreznik: that what I said
14:47:27 <maxamillion> man-pages are often my life line
14:47:35 <jreznik> rnovacek: sorry :)
14:47:41 <mcepl> Kevin_Kofler: number of the bug report, please? (the one with xorg-x11-fonts-misc)
14:48:05 <jreznik> Kevin_Kofler: no justification there
14:48:43 <Kevin_Kofler> mcepl: #561498
14:48:58 <Kevin_Kofler> If it just says "add the dep", let's just file a bug saying just "remove the dep". ;-)
14:49:21 <mcepl> Kevin_Kofler: it basically says, "anaconda uses it, so it should be required"
14:49:36 <mcepl> and there is no discussion about it
14:49:43 <Kevin_Kofler> It shouldn't be required because it's not needed on live images.
14:50:07 <mcepl> so it should be dealt with only via comps, right? (just to be sure I understand what you suggest)
14:50:18 <Kevin_Kofler> We really don't want tigervnc-server(-minimal) and especially not xorg-x11-fonts-misc on our live images.
14:50:35 <Kevin_Kofler> mcepl: It should be dealt with by whatever builds the Anaconda environment for the traditional installer.
14:50:37 <mcepl> Kevin_Kofler: and BTW, the question is ... why are you bothered with RHEL-6 bug?
14:51:01 <Kevin_Kofler> mcepl: Because that's used as a justification for dragging in a dependency into Anaconda, also in Fedora, which is bloating our live images.
14:51:31 <mcepl> then I would just go and file contra-Fedora-bug ... "don't do it" and we can deal with that bug.
14:51:35 <mcepl> do we have such bug
14:51:35 <mcepl> ?
14:51:44 <Kevin_Kofler> Not yet.
14:51:55 <mcepl> OK, I am going to ask about the issue
14:54:13 <Kevin_Kofler> Can we move on now? We only have 6 minutes left…
14:54:31 <jreznik> #topic dbusmenu-qt issue
14:55:13 <Kevin_Kofler> We obviously need to ship the dbusmenu-qt version with the bugfixes.
14:55:28 <Kevin_Kofler> I think there's not much more to add on the Fedora side there…
14:55:45 <ltinkl> the one from http://people.canonical.com/~agateau/dbusmenu/
14:56:29 <Kevin_Kofler> ltinkl: Isn't that upstream Canonical version?
14:56:42 <jreznik> #info we need to ship fixed dbusmenu-qt version
14:56:54 <ltinkl> Kevin_Kofler: afaik no
14:57:02 <thomasj> The fixed one is IIRC in a GIT repo
14:57:16 <jreznik> http://gitorious.org/dbusmenu/dbusmenu-qt
14:57:19 <jreznik> #link http://gitorious.org/dbusmenu/dbusmenu-qt
14:57:30 <ltinkl> ye, the page points to that gitorious repo
14:58:23 <ltinkl> shall I take care of this?
14:59:21 <Kevin_Kofler> Actually, what we're shipping comes from that repo.
14:59:37 <Kevin_Kofler> But the new tarballs on that page are going to come from Launchpad bzr.
14:59:45 <Kevin_Kofler> The project just moved to Launchpad, it seems.
14:59:51 <Kevin_Kofler> http://bazaar.launchpad.net/~agateau/libdbusmenu-qt/trunk/changes/183?start_revid=183
14:59:59 <Kevin_Kofler> And all the non-Canonical patches have been dropped.
15:00:09 <ltinkl> ye but the launchpad repo doesn't contain aseigo's and others' fixes
15:00:51 <thomasj> http://bazaar.launchpad.net/~kubuntu-members/libdbusmenu-qt/ubuntu/files/head:/debian/patches/    <== patches are here as well
15:00:56 <jreznik> ok, we're running out of time -> #fedora-kde
15:01:06 <Kevin_Kofler> ltinkl: Right, that's the whole problem.
15:01:33 <Kevin_Kofler> So future upstream tarballs from Launchpad won't have them.
15:01:35 <ltinkl> thomasj: yes but it's better to take it directly from gitorious imho
15:01:37 <jreznik> #endmeeting