kde-sig
LOGS
14:03:33 <jreznik> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2010-09-14
14:03:33 <zodbot> Meeting started Tue Sep 14 14:03:33 2010 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:33 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:03:45 <jreznik> #meetingname kde-sig
14:03:45 <zodbot> The meeting name has been set to 'kde-sig'
14:04:12 <jreznik> #chair Kevin_Kofler than rdieter thomasj svahl
14:04:12 <zodbot> Current chairs: Kevin_Kofler jreznik rdieter svahl than thomasj
14:04:18 * thomasj here
14:04:22 <Kevin_Kofler> Present.
14:04:23 <jreznik> #topic roll call
14:04:31 * rnovacek here
14:04:41 <jreznik> anyone else present today?
14:04:56 <svahl> present
14:05:57 <jreznik> ok, looks like small group today present today...
14:05:58 <jreznik> #info thomasj Kevin_Kofler rnovacek jreznik svahl present
14:06:08 <jreznik> #topic agenda
14:06:17 <Kevin_Kofler> live images
14:07:36 <Kevin_Kofler> packages orphaned by Ben Boeckel
14:07:45 <Kevin_Kofler> (mathstuf / boeckb)
14:07:53 <Kevin_Kofler> Anything else?
14:08:33 <thomasj> Not much i guess
14:08:35 <jreznik> FUDCon EMEA - who's going there? but it's more for open discussion
14:08:56 * jsmith will be there :-)
14:09:15 <jreznik> #topic oversized live cd
14:09:50 <Kevin_Kofler> #link http://alt.fedoraproject.org/pub/alt/nightly-composes/kde/
14:09:58 <Kevin_Kofler> So this is where we are.
14:10:07 <rdieter> hi, here now. :)
14:10:09 <svahl> I've looked a bit into the last nightly builds. The problem is that there are not much options for package removals.
14:10:19 <Kevin_Kofler> 734 MiB for 32 bits, 736 MiB for 64 bits.
14:10:35 <Kevin_Kofler> I've noticed some gtk3 stuff is still being dragged in even after the GNOME 3 reversion.
14:10:39 <rdieter> ouchie, wasn't than going to look at that?  wonder if he came up with anything.
14:10:40 <svahl> This is a comparison between the (already stripped down) F13 final image and the nightly spin from yesterday
14:10:43 <Kevin_Kofler> Retrieving http://infrastructure.fedoraproject.org/pub/fedora/linux/development/14/x86_64/os/Packages/gtk3-2.90.5-1.fc14.x86_64.rpm ...OK
14:10:43 <Kevin_Kofler> Retrieving http://infrastructure.fedoraproject.org/pub/fedora/linux/development/14/x86_64/os/Packages/gtk3-immodule-xim-2.90.5-1.fc14.x86_64.rpm ...OK
14:10:49 <Kevin_Kofler> Retrieving http://infrastructure.fedoraproject.org/pub/fedora/linux/development/14/x86_64/os/Packages/libcanberra-gtk3-0.25-2.fc14.x86_64.rpm ...OK
14:10:50 <Kevin_Kofler> #
14:11:01 <svahl> http://fpaste.org/3Ew5/
14:11:07 <Kevin_Kofler> Can you please figure out what's dragging these in and get them fixed?
14:11:31 <svahl> anaconda maybe
14:11:37 <Kevin_Kofler> Uh, no.
14:11:40 <Kevin_Kofler> Anaconda is PyGTK.
14:11:46 <Kevin_Kofler> That hasn't even been ported to gtk3 yet.
14:12:41 <rdieter> I can dl the iso after meeting and try it out, and see
14:13:00 <svahl> mhh. metacity -> libcanberra-gtk2 -> libcanberra-gtk3
14:13:10 <Kevin_Kofler> So libcanberra is the culprit.
14:13:20 <Kevin_Kofler> That upgrade path dependency needs to go away for F14.
14:13:32 <Kevin_Kofler> It makes sense in F15 with GNOME 3, but not in F14.
14:13:43 <rdieter> fun, what pulls in metacity anymore? (ah, firstboot)
14:14:19 <jreznik> firstboot always fun...
14:14:36 <Kevin_Kofler> Who's taking care of the libcanberra issue?
14:14:51 <Kevin_Kofler> libcanberra-gtk2 should not require libcanberra-gtk3 in F14.
14:15:21 <rdieter> Kevin_Kofler: I can
14:15:32 <kalev> I think it might be some shared files which would have otherwise conflicted
14:15:47 <kalev> so moving those shared files to libcanberra-gtk2 and reversing the dep would fix it
14:16:05 <rdieter> or having some sort of libcanbarra-common, whatever.
14:16:11 <Kevin_Kofler> #action rdieter to get libcanberra fixed so -gtk2 doesn't depend on -gtk3
14:16:28 <Kevin_Kofler> kalev: I think it's for upgrade path, so people get -gtk3 pulled in on updates.
14:16:33 <Kevin_Kofler> But we don't want that before F15.
14:17:58 * rdieter sees tcl as something worth kicking out, if possible
14:18:07 <Kevin_Kofler> Some other possible size savings: zap some more fonts (the Latin and Arabic scripts probably both have more fonts than necessary).
14:18:17 <Kevin_Kofler> And maybe use kdeutils-minimal.
14:18:22 <Kevin_Kofler> (instead of the full kdeutils)
14:18:25 <svahl> rdieter: kdeaccessibility -> speech-dispatcher -> tcl
14:18:36 <Kevin_Kofler> Oh, kick out kdeaccessibility too.
14:18:41 <Kevin_Kofler> Why are we even still shipping that?
14:18:52 <Kevin_Kofler> It drags in the whole TTS infrastructure, wastes a lot of space.
14:18:55 <Kevin_Kofler> And so far, doesn't even work.
14:19:00 <Kevin_Kofler> (though that's being slowly sorted out)
14:19:18 <rdieter> it'd be a shame, but you have a point there.
14:19:22 <Kevin_Kofler> https://bugzilla.redhat.com/show_bug.cgi?id=569531
14:19:39 <rdieter> (please, please, please, can we reconsider bigger images for f15? :) )
14:19:54 <svahl> btw: full package list of yesterday's nghtly: http://fpaste.org/RNyE/
14:19:59 <Kevin_Kofler> I think festival etc. would all go away by removing kdeaccessibility.
14:20:10 <rdieter> Kevin_Kofler: yeah
14:20:13 <rdieter> svahl: thanks!
14:20:34 <jreznik> bigger images!!!
14:20:51 <Kevin_Kofler> svahl: Can you try how much space we save by omitting kdeaccessibility (+ deps)?
14:21:00 <jreznik> Kevin_Kofler: yes, kdeaccessibility does not work and probably drags too much... it's shame it doesn't work but...
14:21:09 <svahl> Kevin_Kofler: sure, after the meeting (or this evening)
14:21:28 <Kevin_Kofler> #action svahl to try omitting kdeaccessibility (+deps) and checking the saved space
14:21:46 <svahl> if we really remove it we should explain that step in the release notes
14:22:11 <rdieter> svahl: nod, file a bug documenting the removal, and mark the release notes flag
14:22:23 <svahl> ok
14:22:37 <jreznik> #action svahl to  file a bug documenting the removal, and mark the release notes flag (kdeaccessibility)
14:23:02 <Kevin_Kofler> But only if it actually helps for the size issues (but I think it will, kdeaccessibility is dragging in a lot of stuff).
14:23:08 <svahl> sure :)
14:24:28 <thomasj> For posterity, +1 bigger images
14:25:11 <Kevin_Kofler> Bigger images are going to make some people unhappy.
14:25:18 <Kevin_Kofler> There are still folks using CD-Rs.
14:25:36 <thomasj> USB-Sticks ftw :)
14:25:37 <Kevin_Kofler> Also, folks are using 1 GiB USB sticks and want to have room left for an overlay.
14:25:58 <Kevin_Kofler> If you make the image 1 GiB, there's no room for an overlay on a 1 GiB stick.
14:25:58 <rdieter> standard reply, we can continue to provide a kickstart that fits on a cd, it just will no longer be our primary/official one
14:26:21 <thomasj> +1
14:27:23 <thomasj> The CD should be very basic anyways, just to see how fedora kde looks like. not to provide anything that you can fully work with it.
14:27:24 <jreznik> rdieter: yes, I like it
14:27:31 <Kevin_Kofler> Well, when the GNOME folks wanted to make their F13 image larger, there was a lot of backlash.
14:27:37 <Kevin_Kofler> And they ended up reverting to CD size.
14:28:00 <jreznik> CD size is important for eastern countries...
14:28:13 <Kevin_Kofler> If we want to have ANY chance to get pressed media released at ANY events, we'll need to target CD size.
14:28:13 <rdieter> we'll likely see some too, but having a barely functional official cd image isn't apppealing either.
14:28:40 <Kevin_Kofler> There was unwillingness to master even GNOME DVDs, now imagine KDE ones. :-/
14:29:10 <rdieter> shrug, we can discuss the pros/cons later I guess (unless there's nothing else for today?)
14:29:29 <Kevin_Kofler> Hand-burning media like I did for Linuxwochen Wien is also more expensive with DVDs.
14:29:52 <Kevin_Kofler> (But that's not an effective way to spread Fedora KDE anyway, to be frank.)
14:30:12 <jreznik> I'm not sure it's even possible to buy CD-R here :) (I don't use DVD-R anymore too)
14:30:34 <jreznik> ok, let's skip it - it needs consensus over the all spins
14:30:48 <jreznik> #topic packages orphaned by Ben Boeckel
14:31:27 <rnovacek> I took ownership of most of the packages
14:31:45 <rdieter> rnovacek: thanks!
14:31:58 <rnovacek> if anyone would like to comaintain, just ask
14:32:02 <Kevin_Kofler> jreznik: You can buy some CD-Rs in Vienna for sure. :-)
14:32:03 <jreznik> #link http://www.spinics.net/linux/fedora/fedora-kde/msg07946.html
14:32:22 <Kevin_Kofler> We even have the 800 MB ones in some places (but those are not very standard, so probably not a good size target).
14:33:04 * Kevin_Kofler is signing up for comaintainership for the k* packages orphaned by mathstuf.
14:33:15 <jreznik> Kevin_Kofler: yes, probably it's still possible to buy it here, all CD-R and DVD-R are quite cheap here (not like in Spain where my brother lives)
14:33:19 <Kevin_Kofler> qca2 seems already well taken care of (1 new primary maintainer, 3 comaintainers).
14:33:23 <Kevin_Kofler> And bilbo is obsolete.
14:33:48 <Kevin_Kofler> jreznik: Yeah, chances are they're cheaper in Brno than Vienna.
14:35:13 <jreznik> #info rnovacek took ownership of mathstuf's packages
14:35:32 <jreznik> anything else to the topic?
14:36:11 <Kevin_Kofler> kde-plasma-networkmanagement is now owned by rdieter (who was already comaintainer), I was also already comaintainer and still am.
14:36:47 <Kevin_Kofler> qca2 is now owned by Sven Lankes (slankes / killefiz).
14:38:16 <jreznik> #info  qca2 is now owned by Sven Lankes (slankes / killefiz).
14:38:33 <jreznik> #info kde-plasma-networkmanagement is now owned by rdieter
14:39:17 <jreznik> #topic FUDCon EMEA
14:39:58 <jreznik> FUDCon starts this Friday
14:40:07 <jreznik> in Zurich, anyone there?
14:40:16 * jsmith will be there
14:40:24 <jsmith> Anybody else?
14:40:34 <thomasj> No money, no time
14:40:37 <thomasj> :)
14:41:04 <nucleo> qca2 should be renamed to qca
14:41:06 <jreznik> ltinkl is not going as his wife is sick -> no kde talk... but maybe we prepare one tomorrow with marcela
14:41:12 <nucleo> .bug 512000
14:41:14 <zodbot> nucleo: Bug 512000 rename this package to qca2-ossl - https://bugzilla.redhat.com/show_bug.cgi?id=512000
14:41:58 <jreznik> #topic Bug 512000
14:43:47 <Kevin_Kofler> For the suggestion of retiring the Qt 3 qca, are we sure it's not used anymore?
14:44:05 <Kevin_Kofler> I'm opposed to retiring libraries which are still used by stuff.
14:46:43 <Kevin_Kofler> Uhm, do we have any plan on how to proceed?
14:46:51 <Kevin_Kofler> Or do we just close the bug as WONTFIX or something?
14:47:04 <Kevin_Kofler> (NOTABUG maybe?)
14:48:30 <jreznik> I prefer WONTFIX
14:49:13 <Kevin_Kofler> rdieter: Any comments on how to proceed here?
14:49:37 <jreznik> on the other hand it would make me sad to see a new package that depends on qt3/qca
14:49:55 <rdieter> who's maintaining it now?
14:50:14 <Kevin_Kofler> Actually I think there's no qca in the repos anymore for F13.
14:50:27 <Kevin_Kofler> At least repoquery finds nothing.
14:50:33 <nucleo> I maintaining qca2-ossl
14:50:36 <Kevin_Kofler> So all that's needed is renaming qca2 to qca.
14:50:47 <jreznik> Kevin_Kofler: really no qca?
14:50:55 <nucleo> *qca-ossl
14:50:59 <rdieter> yeah think so, the naming should be consistent
14:51:21 <Kevin_Kofler> jreznik: repoquery qca is empty and repoquery qca\* only returns qca2 stuff.
14:51:36 <Kevin_Kofler> qca-gnupg and qca-ossl are both named qca-, but the main package is qca2.
14:51:50 <Kevin_Kofler> So the main package should be renamed.
14:52:10 <jreznik> it's really confusing
14:52:16 <Kevin_Kofler> I don't think we'll want to resurrect the Qt 3 QCA at this stage, and if somebody really wants it, they should call it qca1.
14:52:22 <jreznik> once we don't have qca, rename is reasonable
14:52:33 <Kevin_Kofler> Nothing in Fedora seems to require qca 1 or we'd have broken deps already.
14:52:35 <jreznik> Kevin_Kofler: no, it's should sleep (forever)
14:52:59 <rdieter> nucleo: which way would you prefer?
14:53:47 <Kevin_Kofler> Note that if we go with qca2 naming, qca-gnupg would also need renaming.
14:54:08 <Kevin_Kofler> I think calling it just qca fits better with our naming scheme.
14:54:12 <nucleo> one way to rename qca2 to but qca second is rename qca-ossl to qca2-ossl and qca-gnupg to qca2-gnupg
14:54:21 <nucleo> may be firs way more simple
14:54:28 <rdieter> nod, I think I'd prefer qca2 -> qca at this piont
14:54:30 <rdieter> point
14:54:31 <nucleo> *first
14:54:47 <Kevin_Kofler> So we agree on renaming qca2(-devel) to qca(-devel)? Any objections?
14:55:24 <rdieter> .whoowns qca2
14:55:24 <zodbot> rdieter: slankes
14:55:44 <Kevin_Kofler> Yeah, he just picked it up from mathstuf.
14:55:53 <Kevin_Kofler> killefiz: Ping?
14:55:54 <rdieter> we should consult the maintainer too, before deciding anything, ok.
14:55:59 <jreznik> yes
14:56:30 <rdieter> I'll ask for it in the aforementioned bug
14:56:46 <Kevin_Kofler> rdieter: Sven isn't CCed to it yet.
14:58:12 <rdieter> I reassigned it to qca2
14:58:21 <Kevin_Kofler> #action rdieter to contact slankes/killefiz about renaming qca2 to qca (which appears to be the preferred solution)
14:58:27 <rdieter> .bug 512000
14:58:29 <zodbot> rdieter: Bug 512000 rename qca-ossl -> qca2-ossl (or rename qca2 -> qca) - https://bugzilla.redhat.com/show_bug.cgi?id=512000
14:58:32 <rdieter> (and adjusted summary)
14:58:46 <Kevin_Kofler> rdieter: OK, thanks.
15:00:32 <jreznik> ok, time... thanks all
15:00:38 <jreznik> #endmeeting