irc-support-sig
LOGS
16:00:05 <nirik> #startmeeting IRC Support SIG (2010-08-26)
16:00:05 <zodbot> Meeting started Thu Aug 26 16:00:05 2010 UTC.  The chair is nirik. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:05 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
16:00:05 <nirik> #meetingname irc-support-sig
16:00:05 <zodbot> The meeting name has been set to 'irc-support-sig'
16:00:05 <nirik> #topic init process
16:00:21 <nirik> who all is around for meeting?
16:00:24 <mock> me
16:00:27 * EvilBob 
16:00:37 <fenris02> #chair fenris02
16:00:38 <EvilBob> Happy Birthday Sonar_Gal
16:00:44 * fcami waves
16:00:45 <N3LRX> 
16:00:45 <fenris02> hm.  i cant grab my own chair?
16:00:48 <mharris> me sort of
16:00:49 <Sonar_Gal> thanks EvilBob
16:00:57 * pembo13 bows
16:00:59 <Sonar_Gal> 
16:01:02 <nirik> meeting agenda is at: http://lists.fedoraproject.org/pipermail/irc-support-sig/2010-August/000037.html
16:01:04 <zaniyah> we need a recliner
16:01:04 <fcami> fenris02: stand. it's good for you. :)
16:01:10 <zaniyah> it's like a chair but more laid back
16:01:18 * Sonar_Guy 
16:01:19 <mharris> nirik: does that mean when someone says "PEBCAK"  it is a problem between you and the keyboard? ;)
16:01:47 <nirik> I guess so.
16:01:56 <mharris> :)
16:02:07 <nirik> ok, we have a full docket today, so lets dive in.
16:02:15 <nirik> #topic Week in review
16:02:15 <nirik> http://fedora.theglaserfamily.org/ircstats/fedora-weekly.html
16:02:25 <thomasj> Well, i'm here as well
16:02:33 <nirik> slower than normal week I think.
16:02:57 <fcami> yeah, autopsy didn't even reach 1K
16:03:57 <fenris02> full moon too, so extra winblows questions.
16:03:59 <nirik> Also since last meeting we had no bans, and 5 kicks
16:04:26 <nirik> anything anyone would like to note from this last week? or shall we move on?
16:04:39 <fcami> I'm pretty sure there was a silent ban
16:04:40 <mharris> wow, I didn't make it into the most active, nor even "These didn't make it to the top:" lists.  Your script must be broken.
16:04:41 <mharris> :)
16:04:59 <pembo13> wow, i'm #6
16:05:01 * che joins
16:05:10 <nirik> fcami: odd. I will look at why my grep didn't see it...
16:05:23 <mharris> ohhh... that's for #fedora, that's why
16:05:26 <nirik> ok, moving along then...
16:05:26 <che> i have 30 mins before i need to leave to the airport ;)
16:05:28 <EvilBob> Yeah Anvil had one ban
16:05:30 <nirik> mharris: yes, #fedora.
16:05:38 <fcami> EvilBob: I was thinking of that one yes
16:06:10 <nirik> #topic should we add any new ops now?
16:06:24 <mharris> che: hopefully airport security doesn't screen you and take you aside and grill you for hours, snoop through liquids in your carry on, etc.
16:06:25 <nirik> This was brought up by EvilBob last week, and we didn't fully discuss it.
16:06:27 <pembo13> nirik: what does one have to do as an op?
16:06:46 <che> mharris, i am long haired and bearded and it said "Red Hat" everywhere ;)
16:06:54 <mharris> che: also, hopefully they don't do that because I said that in IRC and the government monitors IRC
16:06:56 <nirik> pembo13: http://fedoraproject.org/wiki/IRC_operators_code_of_conduct
16:06:57 <che> mharris, guess the question is answered :D
16:07:04 <pembo13> nirik: thanks
16:07:06 <fenris02> pembo13, be around for one ...
16:07:10 <mharris> che: also, I hope they don't do it because I said that too
16:07:12 <mharris> :)
16:07:21 <pembo13> fenris02: i'm aparently around a lot
16:07:26 <EvilBob> I brought this up, because we are in a growth faze and while we need more people for input I think we should hold off on adding any ops until we clear up some policy
16:08:07 <nirik> EvilBob: what policies should be set before you think we should add more ops?
16:08:11 <EvilBob> There are many items in todays agenda that I think we need policies for and more
16:08:54 <EvilBob> nirik: we don't even have a policy for how someone outside complains about a new op or even how WE discuss their progress
16:09:13 <fenris02> EvilBob, trac + ml currently.  what's missing?
16:09:53 <nirik> well, we have muddled along without in the past...
16:10:09 * nirik doesn't feel strongly either way on this. I could see holding off, or not.
16:10:16 <EvilBob> nirik: so the past makes it OK?
16:10:43 <nirik> Does the future mean it's all rosy? ;)
16:10:50 <EvilBob> "we have always done it wrong, lets keep doing that"
16:11:11 <thomasj> Does that count for any past?
16:11:22 <nirik> what specific problems have been seen in the past with adding new ops?
16:11:23 * fcami uses his "new" eyes and candidly asks what was _always wrong_ in the past.
16:11:24 <EvilBob> thomasj: I sure hope not
16:11:44 <thomasj> :)
16:11:53 <che> actually i am not against new ops
16:11:55 <EvilBob> Really it is just unfair to throw someone in to the pit at this point IMO
16:11:59 <che> the question is just... how many do we need?
16:11:59 <mharris> I agree that policies/procedures are important, but that care must also be taken to not over-legislate or over-complicate things as well.
16:12:02 <che> do we need any new?
16:12:10 <che> what time zones need to be covered?
16:12:12 <nirik> mharris: +1
16:12:13 <EvilBob> che: All of them
16:12:16 <thomasj> EvilBob, throw me in, no problem here
16:12:25 <che> and common sense should be a prerequirement for new ops
16:12:41 <pembo13> if I am needed, you can use me
16:12:46 <EvilBob> che: and for old?
16:12:57 <che> EvilBob, lost cause *jokingly*
16:12:57 <fenris02> che, which tz would i fall in?  see stats page ...
16:13:13 <mharris> If a channel is having a number of requires-op occurrances on a regular basis and no op is around, that should stand as an indication that perhaps another op would be useful, especially someone frequently or always alive in that time of day
16:13:15 <nirik> anyhow, I'm 0 on this. EvilBob is +1, any further positive or negative votes?
16:13:44 <pembo13> 0
16:13:49 <EvilBob> nirik: NOTE: I am not against us grooming ops while we work these things out a bit more
16:14:12 <che> i have no objections if more are required but we need to select them carefully
16:14:18 <mharris> That's what I informally do in some other channels..   if a few people mention to me that there are problems when nobody is around, I add another op or two, etc.
16:14:31 <mharris> ie: #fedora-qa
16:14:49 <EvilBob> nirik: We can and should have as many as we can ready in 6 weeks or so when we sort out the trac and feedback processes a little more
16:14:52 * nirik sees so far +1 on this... any other opinions?
16:15:06 <mharris> The different channels of course have slightly different needs too, and what works in one may not be a good solution in another channel.
16:15:21 <che> mharris, depends on many factors and reasoning
16:15:27 <fenris02> nirik, what's the actual query/poll ?
16:15:30 <mharris> yup
16:15:35 * Sonar_Guy +1 factoring in the comments from Warrens e-mail to the list
16:15:58 <nirik> We add no new ops at this time. Work on policies/process and then revisit opening to new ops down the road
16:16:01 <EvilBob> fenris02: should we add more ops right now before we sort things out a bit more
16:16:03 <nirik> EvilBob: is that accurate?
16:16:13 <EvilBob> nirik: yes
16:16:29 <fenris02> EvilBob, i dont see a point in waiting.  afaict, things are already sorted.
16:17:09 <EvilBob> fenris02: non-cla users and users that don't want to sign up for the list can not complain or compliment, that is OK with you?
16:17:13 <mharris> Is there a pressing need for more ops immediately?  If so, then adding one or 2 or whatever might be ok.  If not, putting it off for a week or whatever should be fine also no?
16:17:24 <che> i want to add new one comment. i think that social competency is a big factor for new ops.
16:17:27 <EvilBob> mharris: there is not a pressing need
16:17:29 <nirik> mharris: right. I don't know that the need is pressing.
16:17:33 <fenris02> EvilBob, they can complain in this meeting.
16:17:45 <fenris02> EvilBob, how is that broken?
16:17:58 <EvilBob> fenris02: that is what we have been working to prevent
16:18:01 <che> what are the channel growth statistics at this point?
16:18:07 <che> do we have something like that?
16:18:17 <nirik> che: depends on how you measure things I suppose...
16:18:19 <fenris02> EvilBob, because it's a no-gain situation.  so just move on.
16:18:31 <che> long time charts about our userbase? i have the feeling that the channel is shrinking a bit.
16:18:45 <nirik> anyhow, I see +2
16:18:45 <fenris02> EvilBob, you have no alternative solution other than the cla.  until such time as one exists, move on
16:18:45 <mharris> For #fedora specifically, I have no strong feelings either way as I don't frequent there.
16:19:15 <nirik> #agreed we will not add new ops at this time. Will work on process and revisit when we will start adding them again.
16:19:29 <nirik> #topic #topic how should new ops be nominated?
16:19:33 <nirik> oops.
16:19:35 <nirik> #undo
16:19:35 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x6dc7c90>
16:19:41 <nirik> #topic how should new ops be nominated?
16:20:11 <che> nirik, from the current base of operators or active participants in the fedora project or in other upstream projects.
16:20:23 <che> nirik, atleast 3 points to argue about in one sentence ;)
16:20:24 <nirik> My take: Anyone can nominate, even self nominate. If we get a flood of inapproprate nominations, we revisit the process or stop accepting nominations from that person.
16:20:24 <mharris> nirik: New ops should be nominated based on obtaining the top position for vulgarities posted in #fedora-social two weeks in a row, plus top mention of "bacon"
16:20:51 <EvilBob> I think anyone that that is an op should be able to approach any qualified user to see if they are interested, if so the user essentially self nominates with the existing op as a "sponsor" of sorts
16:20:53 <pembo13> mharris: i said bacon this week
16:20:59 <che> mharris, new ops shouldnt be former X maintainers because they have silly ideas ;)
16:21:04 <fenris02> nirik, i'd not say that "self nominations" would be permitted.
16:21:13 <che> mharris, hehe
16:21:16 <EvilBob> this is more or less how it has been done in the past and it has worked well
16:21:21 <fenris02> nirik, that just leads to troubles
16:21:26 <mharris> pembo13: try saying "f'ing bacon"" more.  You're just about there!
16:21:27 <nirik> EvilBob: when you say 'op', you mean #fedora op? op in any #fedora-* channel, op in #fedora or #fedora-social?
16:21:44 <che> nirik, i can tell you that id never give someone op that actively asks for it.
16:21:51 <che> nirik, thats hunger for power.
16:22:07 <EvilBob> nirik: #fedora and #fedora-social are the channels we generally deal with, so I would say an op from either of those
16:22:09 <che> nirik, and abuse is what we cannot afford and do not want to have.
16:22:11 * fenris02 points at che ... what he said
16:22:36 <mharris> I think an informal suggestion that makes its way to the ops somehow from someone, and then is considered serious enough to warrant discussion in the weekly meeting - could move to a nomination
16:22:48 <nirik> I think in some cases people nominate themselves from good motives and would be good ops.
16:22:56 <EvilBob> che: I agree that is why I said someone has to "sponsor" the nomination by bringing it to the group
16:22:59 <fenris02> nirik, i'm +1 for having a sufficient number of knowledgeable and helpful folks around for ops.
16:23:07 <nirik> would any folks like to write up a process for consideration by the group?
16:23:14 <fenris02> nirik, if they are really that good, someone else would be able to +1 them
16:23:17 <EvilBob> nirik: in that case an existing op should be willing to sponsor them
16:23:36 <mharris> I'm thinking someone thinks "hey, what about $person as an op?"   a few people discuss it informally and possibly agree, then mention it to nirik or whoever to bring up at the meeting
16:23:39 <che> nirik, id propose that self nomination works if you are an active open source contributor atleast (upstream) or an active member of the fedora project + you survived the probation period.
16:24:09 <che> nirik, or you are getting nominated from someone that is an active op in addition.
16:24:17 <mock> with great power comes great responsbility
16:24:19 <EvilBob> nirik: I can, I think we have an idea what the general consensus is
16:24:20 <fenris02> mharris, that is exactly how it has happened in the past
16:24:36 <fenris02> mharris, i fail to see a problem with that method.
16:24:37 <nirik> true... I think most of the sane self nomination cases would be covered by getting someone to nominate them...
16:24:38 <che> mharris, that is sponsoring then.
16:24:53 <mharris> Do you distinguish between "self nomination" and "volunteer" though?
16:25:03 <nirik> EvilBob: great. Possibly on the ops page on the wiki or in a trac ticket?
16:25:13 <mharris> ANyone can volunteer "I would do foo if someone would like"
16:25:14 <EvilBob> nirik: in a trac ticket
16:25:26 <mharris> which could be seen as self-nomination in a sense
16:25:27 <nirik> we should also note clearly that the person should be asked and are willing to serve.
16:25:35 <EvilBob> mharris: I will admit I did it if you do not ask what I did...
16:25:45 <EvilBob> nirik: Yes
16:26:01 <nirik> #action EvilBob to write up a proposed process in a trac ticket for feedback, review and approval.
16:26:04 <che> 6 minutes left until i have to run
16:26:07 <nirik> anything further on this topic?
16:26:08 <fenris02> so we should add two trac tickets to cover the email junk in the last week?
16:26:10 <EvilBob> if the user/helper is not willing it is pointless
16:26:13 <fenris02> che, ditto
16:26:25 <nirik> #topic we need a rule about how long an op can be inactive
16:26:40 <mharris> I agree that having a valid FAS account is a requisite to op status for #fedora*
16:26:55 <nirik> mharris: yes, that should be in there too.
16:27:09 <che> inactivity is a tough topic
16:27:15 <mharris> with the default agreements signed or whatever of course too
16:27:20 <nirik> EvilBob: care to introduce this topic?
16:27:37 <fenris02> i'm much more prone to +op someone for positive activity than -op anyone for inactivity.
16:27:39 <EvilBob> I brought this up because I thought thomasj had quit several months ago, so when he spoke up it annoyed me
16:27:52 <nirik> sorry to hear it.
16:27:56 <che> id propose 3 months of inactivity
16:27:56 <Sonar_Gal> everyone is inactive at one time or another
16:28:02 * nirik notes he just said he would step back.
16:28:02 <che> that covers all potential circumstances
16:28:13 <EvilBob> che: I was thinking 6 months
16:28:15 <Sonar_Guy> che: you would first have to define inactivity!
16:28:16 <fenris02> che, hm.  i'd say 6
16:28:16 <Southern_Gentlem> che i am more for 6 months
16:28:20 <nirik> I am against any inactivity removal
16:28:28 <che> i dont have anything against 6 months
16:28:30 <EvilBob> nirik: potential probem
16:28:34 <nirik> why?
16:28:35 <mharris> fenris02: I think being somewhat informal has its benefits as long as it works well, and then only clarify things with policies/procedures where there is confusion/conflict as problems arise, etc.
16:28:39 <nirik> what problem are we solving ?
16:28:39 <fenris02> nirik, users can remove themselves from the group if they wish, correct?
16:28:40 <che> and i also dont have anything against no removal
16:28:48 <nirik> fenris02: yes.
16:28:52 <mharris> And only then to handle the problem scenarios without overdoing it ;)
16:28:53 <fenris02> then the point is moot.
16:28:56 <che> i thought along 3 months at least.
16:29:03 <fenris02> if a +op user wants to be removed, they can do it
16:29:17 <fenris02> forcibly -op someone for inactivity is silly at this point.
16:29:17 <EvilBob> if we set a policy that a majority of all available votes be needed for a change or policy, what happens when a majority are dead weight?
16:29:18 * thomasj is still here.. Just silent
16:29:21 <che> Sonar_Guy, /msg nickserv info ;)
16:29:30 <nirik> we could I suppose mail people who haven't been around in a long time and ask them if they would like to be removed or plan on coming back...
16:29:47 <Southern_Gentlem> i+1
16:29:48 <fenris02> if their fas account expires that's a good clue they are gone :)
16:29:56 <che> fenris02, depends
16:30:01 <thomasj> nirik, +1
16:30:03 <mharris> nirik: On the topic of "how long can an op be inactive", I think "inactive" needs to be well defined if that question is going to be asked.
16:30:03 <nirik> EvilBob: well, two things there.
16:30:04 <fenris02> che, hm?  on what?
16:30:05 <Southern_Gentlem> do fas accounts expire?
16:30:09 <Sonar_Guy> che: but what is the consideration, activity in #fedora, #fedora-ops, or #fedora-social?
16:30:11 <EvilBob> Southern_Gentlem: yes
16:30:20 <fenris02> Southern_Gentlem, 1yr at a time iirc
16:30:24 <nirik> 1. I think we should avoid majority votes, and work for consensus of active participants.
16:30:25 <EvilBob> Southern_Gentlem: password changes have been required in the past
16:30:42 <nirik> 2. why are they dead weight? they may just be busy or the like... and might come back and have good  input.
16:30:43 <mharris> Personally, I think "until they die, or until they explicitly indicate they are no longer interested, or do not respond to repeated attempts to contact them"
16:31:04 <fenris02> mharris, you left out fas
16:31:18 <EvilBob> mharris: I agree with that if you add FAS disabled
16:31:20 <mharris> they must maintain an FAS account as well
16:31:23 <nirik> Southern_Gentlem: no, they do go inactive tho if they fail to reset passwords.
16:31:28 <fcami> I think the problem could be nicely solved if FAS had a "I'm away" system. I don't think it has, and other distros account systems have.
16:31:30 <che> Sonar_Guy, identifying to nickserv ;)
16:31:55 <Sonar_Guy> che: my server could do that for me, does that mean I am active?
16:31:58 <mharris> Of course, if they're not in FAS, it should be confirmed as to why, in case there is an administrative goofup or something.
16:31:59 <EvilBob> che: that does not mean they have not moved to DistroX
16:32:03 <fenris02> any user can remove themselves from the fas group and become -op effectively.  in that event, there is no conflict by removing them from the op list
16:32:03 <fcami> because, well, I definitely see myself going on an "extended vacation" that could definitely mean being offline for 3+ months.
16:32:12 <Khaytsus> I miss anything important?  Just got out of class
16:32:15 <N3LRX> fcami, there is a vacation status on FAS
16:32:24 <fcami> N3LRX: in this case, how do we handle that.
16:32:35 <nirik> Khaytsus: depends on what you consider important. ;)
16:32:35 <fcami> N3LRX: someone who's on a vacation has a legit reason to be offline.
16:32:39 <che> Sonar_Guy, technically yes. but i think no removal is fine aswell.
16:32:50 <Khaytsus> nirik: You.. eh, knoww hat I mean ;)
16:33:00 <nirik> we also have ops in #fedora that were there from the distant past and are active in the project, but not so active in #fedora
16:33:04 <mharris> I think auto-removing people's op privs simply based on time is a bad idea.
16:33:13 <mock> Khaytsus: if you were in class too long, you might get deop-ed :)
16:33:14 <che> EvilBob, if we have people leaving to other distros i am not sure if we picked the ops in a good manner
16:33:17 * nirik agrees with mharris.
16:33:21 <mharris> It is "doing something" with no concrete problem being solved.
16:33:25 <EvilBob> nirik: and if they can't be reached to solve a problem there, what is the point?
16:33:30 <Khaytsus> mock: But then I won't be classy
16:33:41 <che> mharris, is a good example... he took his time off and came back ;)
16:33:43 <mharris> and in the process, possibly creating a problem, confusion or causing discontent or misunderstanding
16:33:50 <nirik> EvilBob: but they can. Oxf13 and dgilmore are available, just not active in #fedora unless someone specifically calls them. ;)
16:33:54 <EvilBob> mharris: I don't think time alone would be a reason
16:34:01 <fcami> che: you're going to miss your flight. :P
16:34:08 <che> fcami, thanks.
16:34:11 <fcami> np.
16:34:27 <EvilBob> mharris: Time based contact attempts that are ignored would be
16:34:31 <che> thanks everyone. i will read the log later and if i have something constructive i will bring it up in the next meeting or in -ops ;)
16:34:42 <mharris> Some people are busy doing other things for long time periods.  Look at spot for example. How often does spot perform a kick/ban/etc?
16:34:47 <mock> che: don't be gone too long
16:35:02 <EvilBob> mharris: Does not matter, he is the Freenode contact
16:35:06 <nirik> safe travels che
16:35:10 <mharris> I would object to someone suggesting spot pass the baton on or lose his ops, because it brings no gain.
16:35:15 <che> thanks! bye!
16:35:32 <mharris> and if he was around and there was a problem, he'd jump in and take care of it in a second
16:35:40 <EvilBob> mharris: and he has
16:35:42 <mharris> as would many people who are not normally super visible
16:35:56 <nirik> so, where do we go from here? do we have any kind of consensus?
16:36:19 <Southern_Gentlem> nirik,  yeah to leave it alone for now
16:36:30 <mharris> For example, I own several #fedora* channels that I'm currently not even autojoining (for the time being anyway).  But if there is a problem in there and nobody is around, I occasionally get a /msg.
16:36:32 <EvilBob> nirik: lets write up some options and discuss it on the list
16:36:32 <Sonar_Guy> nirik: As I said earlier I think inactivity needs to be defined, before we can come to a consensus
16:36:40 <nirik> EvilBob: sounds reasonable.
16:36:41 <EvilBob> Sonar_Guy: +1
16:36:43 <mharris> I pop in there, take care of it, hang out for an hour/day/week/whatever.
16:37:09 <EvilBob> next?
16:37:10 <nirik> ok, anything further on this? or shall we continue discussion on list about it?
16:37:14 <mharris> Southern_Gentlem, Sonar_Guy: +1
16:37:21 <nirik> #action will discuss further on list.
16:37:26 <nirik> #topic thomasj be removed from op status because of his inactivity
16:37:35 * thomasj here
16:37:35 <nirik> I guess this is a non topic due to the last topic?
16:37:40 <Sonar_Guy> yes
16:37:41 <EvilBob> nirik: Correct
16:37:43 * nirik notes thomasj is around. ;)
16:37:49 <EvilBob> nirik: I remove my motion
16:37:57 <nirik> #action see last topic.
16:38:02 <nirik> #topic all #fedora ops be removed from op status in #fedora-social
16:38:04 <Southern_Gentlem> -1 to dropping
16:38:07 <mharris> -1 to removing thomasj unless he wants to be removed explicitly
16:38:19 <thomasj> I don't
16:38:21 <EvilBob> again see the topic above
16:38:22 <Sonar_Gal> -1 to dropping
16:38:36 <nirik> yeah, sorry, moved on quickly there. ;)
16:38:44 <nirik> anyhow, on to this one...
16:38:47 <Khaytsus> Unless thomasj has no interest in participating, -1
16:38:54 <EvilBob> the thomasj motion has been removed, no need to vote unless someone else wants to pick it up
16:39:15 <mharris> nirik: can you clarify the last topic?
16:39:25 <nirik> A bit of history/info on this topic: #fedora ops are NOT automatically ops in #fedora-social. There is a small subset.
16:39:27 <Khaytsus> I rushed out of class for this?
16:39:27 <mharris> EvilBob: roger, Roger! :)
16:39:37 <Sonar_Gal> The only issue I see with removing fedora ops from social is we would need more -social ops
16:39:42 <EvilBob> mharris: It was suggested that only #fedora ops could nominate for #fedora
16:39:47 <nirik> We added some ops when we started sending people to social for off topic from #fedora.
16:40:00 <nirik> so, I don't see what issue this is solving.
16:40:14 <Sonar_Guy> nirik: most of those were added via access to ops via fedbot
16:40:32 <EvilBob> nirik: it is a non issue now because of the earlier topic
16:40:35 <Sonar_Guy> nirik: only 2 have been given ops since the sig formed directly yourself and Sonar_Gal
16:40:35 <mharris> I think #fedora and #fedora-social are separate spaces and don't see any benefit to having any meta-bindings between them.
16:41:03 * nirik nods.
16:41:12 <nirik> ok, so should we just drop this topic and move on? or ?
16:41:20 <Khaytsus> +1 move on
16:41:20 <Sonar_Guy> +1 to drop and move on
16:41:37 <Sonar_Gal> +1 move on
16:41:38 <mharris> I'd volunteer as a spare op in #fedora-social if it were deemed beneficial/useful to have more people around for when there are problems for example, but I wouldn't volunteer for to be a general op in #fedora per se.
16:41:50 <mock> +1 move on and bacon
16:41:55 <Sonar_Gal> +1 for mharris nomination
16:42:04 <Khaytsus> I think there's no need for a #fedora op to *not be allowed* to be a -social op.
16:42:13 <Khaytsus> ie:  if a #fedora op asks, they should reasonably expect to get it.
16:42:14 <Sonar_Guy> +1 for mharris nomination
16:42:23 <EvilBob> mharris: the issue was that because I (a #-social op) nominated a op for #fedora that someone did not like they suggested I should not be allowed to
16:42:28 <Southern_Gentlem> +1 mharris
16:42:28 <mharris> It isn't often that there are problems in #fedora-social that someone isn't around though mind you either.
16:42:32 <thomasj> +1 mharris
16:42:39 <nirik> #agreed this proposal is dropped.
16:42:46 <nirik> lets stick to the current topics?
16:42:59 <nirik> #topic SIG lead be elected and have a set term
16:43:23 <nirik> I'd be happy to hand off stuff I do for the sig if people feel I am doing a poor job or they can do better...
16:43:28 <mharris> EvilBob: I suppose that the term 'nominated' is the sticky point there.
16:43:42 <nirik> I will note that no other places in Fedora has term limits.
16:43:56 <mharris> I see such as more informal... like "hey, I have this idea, what do you guys think", in which case I support anyone having any ideas to suggest to see what others think
16:43:56 <EvilBob> I think we should elect a new SIG leader with every even nummbered beta release
16:44:09 <mharris> If that informal process is called "nominating someone", then I support it.
16:44:13 <Sonar_Guy> nirik: I do not think that is the issue but I think a 1 year term would be beneficial and bring in a fresh set of eyes and new ideas
16:44:16 <EvilBob> nirik: How often is a FESCo lead in place for?
16:44:38 <EvilBob> nirik: How often is a FPL in place for?
16:44:47 <nirik> EvilBob: the chair? nominated each time new fesco is elected.
16:44:48 <mharris> One final comment about the nomination/suggestion of an op...
16:44:49 <EvilBob> s/often/long
16:44:52 <nirik> FPL, until they step down.
16:45:04 <fcami> if the SIG goes down that route, the SIG will have to solve: who gets to vote, what kind of voting system, who can be elected, etc. the SIG is not that numerous and having a few people "skip" the vote could lead to weird results.
16:45:05 <Sonar_Guy> nirik: it would also stop any apparent or perceived ideas of favoritism
16:45:06 <EvilBob> nirik: or fired?
16:45:17 <nirik> EvilBob: I suppose, sure.
16:45:42 <nirik> I'd be happy to hand off running meetings if someone would like to take that over...
16:45:50 <mharris> If someone (anyone) suggests someone else could be an op in $channel, the worst that can happen is that there isn't enough consensus between others, so it wont happen anyway.  No big deal.  Or if there is consensus, then does it really matter who suggests it first? ;)   Anyhow, no more on that... :)
16:46:30 <nirik> I'm not sure what else I do that could be handed off, but would be happy to look at doing that too if people think it's needed.
16:46:35 <EvilBob> Again I think we should elect a new SIG leader with every even numbered beta release
16:46:59 <mharris> nirik: no strong feelings either way on that one.  You seem to do a good job at it, but then if it were an elected thing, you'd be a candidate too.
16:46:59 <Sonar_Guy> EvilBob: +1 for the reasons I stated above
16:47:01 <nirik> EvilBob: so who votes? and nominates? :)
16:47:15 <EvilBob> nirik: active SIG members
16:47:15 <nirik> and also what exact duties are involved?
16:47:32 <EvilBob> nirik: Complaint head, meeting lead
16:47:44 <mharris> nirik: 1) Adding more bacon recipes, links, etc. to fedbot
16:47:52 <EvilBob> mharris: +1
16:47:55 <nirik> whats an active sig member? shows up to meeting?
16:48:16 <mharris> I'd just say "SIG member" without adjectives
16:48:24 <nirik> I would LOVE to hand off complaints... which I think we can do by having a process in place... :)
16:48:37 <EvilBob> nirik: I think in this case a "calling all members" email would be needed
16:48:56 <mock> mharris: +1
16:48:59 <nirik> so it's anyone subscribed to the list?
16:49:01 <mharris> whatever you do, dont nominate me to chair any meetings!  :)
16:49:15 <EvilBob> nirik: IRC OP SIG in FAS
16:49:21 <EvilBob> or what ever it is
16:49:21 <mharris> I'll handle all complaints though.
16:49:40 <mharris> For my special definition of "handle" of course. :)
16:49:50 <nirik> so, again, perhaps we should discuss this on list and come up with a concrete proposal?
16:50:01 * nirik also doesn't know any sigs that hold elections.
16:50:28 <mharris> lets hold electrocutions instead
16:50:44 <nirik> :)
16:50:49 <Sonar_Guy> nirik: +1 to coming up with a concrete proposal
16:50:49 <mock> mharris: that's the kinda of "handling" i'd expect from you
16:50:57 <EvilBob> nirik: +1
16:51:02 * mharris notes no offense to anyone who may have lost a loved one to electrocution...  he didn't know
16:51:20 <EvilBob> next
16:51:27 <mharris> Sonar_Guy: I have a concrete proposal
16:51:28 <nirik> #action will discuss further on list.
16:51:36 <nirik> the next 2 topics are nominations.
16:51:46 * zaniyah thought mharris said 'elocutions' and was confused about hwo anyone would know on IRC
16:51:47 <nirik> but since we decided to not accept new ops for now, shall I skip them?
16:51:47 <mharris> 2 parts concrete mix, 1 part lime, one part sand, and 1 part aggregate
16:51:49 * zaniyah sighs
16:52:16 <Sonar_Guy> zaniyah: lol
16:52:18 <EvilBob> nirik: yup asking them to stay active until such a time as we have sorted more things out
16:52:47 <nirik> #topic trac instance setup
16:52:54 <mharris> Hey, I said that last bit with my best Groucho Marks impersonation on.
16:52:55 <nirik> ok, I setup our trac instance some.
16:53:01 <zaniyah> Sonar_Guy: Can't have these lower class oiks putting people off of using Fedora just because of their poor speech
16:53:14 <nirik> https://fedorahosted.org/irc-support-sig/newtplticket
16:53:22 <nirik> there's a template for feedback tickets
16:53:25 <nirik> and one for meeting items
16:53:54 <Khaytsus> Can someone document exactly what and when to use the trac?  Maybe on the trac itself..  When to use this when to not use this, etc...
16:54:01 <thomasj> Dinner time now, sorry. But i would like to vote +1 for having the trac send mails to our list.
16:54:35 <mharris> The best thing to do if you need to use trac, is to get a lackey to do it for you.
16:54:38 <nirik> Khaytsus: yeah, we should. We can on the front page.
16:54:47 <mharris> :)
16:54:49 * nirik guesses he's they lacky here. ;)
16:55:05 <nirik> currently it requires you to login with a fedora account in order to file a new ticket.
16:55:09 <EvilBob> nirik: Dave has said in the past that he could do it
16:55:14 <Khaytsus> Well you dont want ME to do it, It'd be a big FIIK or something ;)
16:55:34 <nirik> I'd be happy to let anyone else in the group who wishes to take lead on it deal with it further. ;)
16:55:43 <Khaytsus> I have logged an enhancement to fpaste on there since I saw some from francisco there, but seemed to me that it should be in BZ not trac.
16:56:09 <mharris> nirik: you do a great job
16:56:17 <EvilBob> fpaste the site or the software?
16:56:21 <mharris> +1 for nirik, who's with me?
16:56:33 <mharris> :)
16:56:37 <Khaytsus> IRL meeting for me...  I guess I'll read the logs later..
16:56:40 <nirik> mharris: thanks. I nominate you to run the meetings now. ;)
16:57:19 <mharris> nirik: if people can keep up with my non-24-hour sleep phase disorder, bad time management, etc. sure!
16:57:22 <mharris> :)
16:57:28 <nirik> :)
16:57:39 <zaniyah> I have to go too
16:57:40 <nirik> anyhow, I can make trac send to the list... sounds like everyone wants that.
16:57:49 <Sonar_Guy> nirik: +1
16:57:52 <nirik> we could make it so anyone can file tickets...
16:57:57 <nirik> but then it's a spammer haven.
16:58:11 <EvilBob> nirik: I think it would be worth it to try
16:58:30 <mharris> naw, require authentication
16:58:44 <EvilBob> just so we don't alienate the alienated
16:59:07 <nirik> yeah, I can see people getting madder (?) at not being able to leave feedback
16:59:18 <mharris> authentication + recaptcha + skill testing question + monty python trivia question
16:59:33 <nirik> blue, no! red, arrrrrrgh
16:59:38 <mharris> hehhehehe
16:59:47 <EvilBob> nirik: plus there is always the random drive by that is very happy that can't say thanks
16:59:51 <nirik> also people may then bypass this and send to the list...
17:00:09 <nirik> I guess I am ok with enabling anon, but get ready for spam in the list. ;)
17:00:17 <EvilBob> nirik: does the list accept non-members posting?
17:00:27 <nirik> EvilBob: not currently, no.
17:00:32 <nirik> they would have to subscribe.
17:00:47 <nirik> again, we could change that, but it results in tons of spam.
17:00:48 <mharris> please dont
17:01:16 <EvilBob> nirik: so now there is a place where messages are held for non-sub?
17:01:28 <nirik> no, it just rejects non subscriber posts.
17:01:34 <nirik> we could again change that.
17:01:49 <mharris> you can set it up so non-sub posts go to a moderation queue, but believe me, you don't want to do that
17:01:51 * nirik thinks we should discuss this further on list too.
17:01:57 <EvilBob> nirik: Why not set that up and send the password to all alias members to keep an eye on
17:02:01 <nirik> mharris: I manage a few lists like that... it's not too bad.
17:02:03 <Southern_Gentlem> moderated on all post except memebers?
17:02:05 <mharris> unless you want to go through 30000000000 posts weekly to find what isn't spam and let them through
17:02:36 <nirik> we could... but do we want feedback to the list?
17:02:38 <EvilBob> iF we all chip in and keep on top of it it should not be hard
17:02:39 <mharris> I used to admin the dri* lists, and various @redhat.com lists, and it was a bazillion tonnes of spam.
17:02:44 <nirik> with trac we have a template at least.
17:02:52 <mharris> moderation amounted to "select all" <delete>
17:02:55 <nirik> with the list I am pretty sure we will get:
17:03:02 <nirik> $FOO is a jerk! you suxxor!
17:03:15 * nirik has to go very soon.
17:03:17 <mharris> although I think eventually mailman updated and had the built in ability to automate that
17:03:30 <nirik> how about we discuss on list the trac/mailman settings?
17:03:37 <EvilBob> K
17:03:44 <Sonar_Guy> +1
17:03:55 <nirik> #action discuss settings for list/trac further on list.
17:03:59 <EvilBob> seperate threads please
17:04:02 <nirik> #topic open floor
17:04:06 <nirik> EvilBob: +1
17:04:12 <nirik> ok, anything for open floor?
17:04:28 * nirik will close out in a minute if not.
17:04:36 <EvilBob> Please when you are starting a new thread on the list do not reply to an earlier random message
17:04:48 <mharris> EvilBob: +1000
17:05:10 <mharris> People do that on Facebook too, and it's annoying as hell.
17:06:18 <nirik> thanks for coming everyone!
17:06:21 <nirik> #endmeeting