kde-sig
LOGS
14:04:13 <jreznik> #startmeeting kde-sig -- http://fedoraproject.org/wiki/SIGs/KDE/Meetings/2010-08-03
14:04:13 <zodbot> Meeting started Tue Aug  3 14:04:13 2010 UTC.  The chair is jreznik. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:13 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
14:04:26 <jreznik> #meetingname kde-sig
14:04:26 <zodbot> The meeting name has been set to 'kde-sig'
14:04:59 <jreznik> #chair Kevin_Kofler than rdieter_work rnovacek SMParrish
14:04:59 <zodbot> Current chairs: Kevin_Kofler SMParrish jreznik rdieter_work rnovacek than
14:05:09 <jreznik> #topic roll call
14:05:53 <jreznik> #chair rdieter
14:05:53 <zodbot> Current chairs: Kevin_Kofler SMParrish jreznik rdieter rdieter_work rnovacek than
14:06:11 <Kevin_Kofler> Present.
14:06:25 <jreznik> who's present?
14:06:28 <rnovacek> I'm here
14:06:34 * than is present
14:06:35 * SMParrish here
14:08:15 <jreznik> #info Kevin_Kofler jreznik rnovacek than SMParrish present
14:08:43 <jreznik> #topic agenda
14:09:21 <Kevin_Kofler> 4.5.0
14:09:39 <jreznik> alpha changes deadline today
14:10:03 <Kevin_Kofler> If we have time: how dist-git affects our workflow. (For example, I've seen jreznik using the good old "copy specfile from devel" routine, but I think we're supposed to use actual git merges instead.)
14:10:46 <jreznik> Kevin_Kofler: indeed - I had the same problem as Neil...
14:10:59 <Kevin_Kofler> Actually, the kde-settings commit was a git merge, the goddard-kde-theme one was not a real merge. Unless I misunderstood git's commit messages.
14:11:37 <jreznik> Kevin_Kofler: you are right
14:11:52 <jreznik> I'm dist-git newbie :)
14:12:02 <Kevin_Kofler> We all are. :-)
14:12:12 <jreznik> anything else to be added to agenda?
14:12:18 <Kevin_Kofler> But I think we should discuss the more important topics first.
14:12:35 <than> KDE 4.5.0
14:12:36 <jreznik> Kevin_Kofler: actually merging is nice thing - if it is working :D
14:12:42 <jreznik> than: already there
14:12:52 <jreznik> well, let's start
14:13:16 <jreznik> #topic 4.5.0 status
14:13:34 <than> ok, i'm importing 4.5.0 into git
14:14:29 <than> the kde-4.5 importshould be done today
14:15:18 <jreznik> than: great, I saw you're working on it
14:15:33 <jreznik> what about kdepim & translations?
14:15:45 <jreznik> it's already talked on kde-packagers list
14:16:21 <than> as i understand last meeting we don't want to ship kdepim-4.5 in f14
14:16:52 <Kevin_Kofler> But this means we also need the translations from 4.4, not 4.5.
14:16:53 <jreznik> than: yes but that means we have to ship 4.4 kdepim translations with 4.5 ones for the rest
14:17:02 <Kevin_Kofler> (for kdepim only)
14:17:09 <than> Kevin_Kofler: yes for kdepim
14:17:11 <Kevin_Kofler> (and kdepim-runtime, actually)
14:17:21 <than> we need kde-l10n from 4.4
14:17:55 <jreznik> but for the rest 4.5 l10n
14:18:10 <than> jreznik: exactly
14:18:20 <Kevin_Kofler> That's the problem.
14:18:29 <Kevin_Kofler> And it's only NOW that upstream thinks of this?
14:18:36 <than> Kevin_Kofler: where is the problem?
14:18:42 <Kevin_Kofler> I don't know any practical way to package this.
14:19:05 <Kevin_Kofler> Doubling the size of the already extremely huge kde-l10n SRPM strikes me as an awfully bad idea.
14:19:38 <than> Kevin_Kofler: double size is really bad
14:20:06 <Kevin_Kofler> We need to loop through all the languages, svn diff the 4.5 branch of kdepim and kdepimlibs against the 4.4 branch and then apply all those patches to revert kdepim and kdepim-runtime from 4.5 to 4.4.
14:20:20 <Kevin_Kofler> Or actually, the 4.5.0 tag against the 4.4.5 tag.
14:20:36 <Kevin_Kofler> Or maybe against the 4.5 branch, but we need to start from the tag or the patch might not apply.
14:20:41 <Kevin_Kofler> *against the 4.4 branch
14:20:46 <Kevin_Kofler> 4.5.0 tag against 4.4 branch
14:20:55 <jreznik> ideally it would be better to let upstream to solve this
14:21:02 <Kevin_Kofler> How?
14:21:04 <jreznik> all distros asked for it on kde-packagers
14:21:18 <jreznik> so they ship tarball with 4.4 kdepim translations
14:21:21 <Kevin_Kofler> Sooner or later we'll have kdepim 4.5.x and then there will be distros wanting 4.4 and others wanting 4.5.
14:21:47 <Kevin_Kofler> Do you think upstream should produce 2 sets of kde-l10n tarballs, one with kdepim 4.5 translations and one with 4.4 ones?
14:21:54 <jreznik> it should be coupled - official kdepim release = official kde-l10n tarballs
14:22:19 <Kevin_Kofler> That might not help us though.
14:22:34 <Kevin_Kofler> We don't necessarily want to start shipping kdepim 4.5 when upstream does.
14:22:51 <than> Kevin_Kofler: or we only ship 4.5 translation for kdepim
14:23:02 <Kevin_Kofler> We'll want to ship it ASAP in the new post-branch Rawhide, and we might not ship it for a while if ever on <= F14.
14:23:29 <jreznik> for rawhide, l10n is not a big deal
14:24:42 <Kevin_Kofler> And for releases? Will the first kdepim 4.5.x release be a suitable update for a Fedora release which shipped with 4.4? Can we even answer that question now?
14:26:41 <than> Kevin_Kofler: if the first kdepim 4.5.x release is enough stable
14:26:55 <jreznik> new kdepim should be definitely be postponed to 4.6 and 4.5 should be shipped as is... this is just a mess and I don't recall any features with such mangling with releases - it just waits for it's time
14:29:06 <Kevin_Kofler> The problem is, at this point we'll have the same l10n problem again.
14:29:21 <Kevin_Kofler> Because then upstream will definitely ship the 4.5 translations in kde-l10n.
14:29:33 <Kevin_Kofler> Unless we can get them to ship 2 sets of kde-l10n tarballs for the lifetime of 4.5.x.
14:29:45 <Kevin_Kofler> But I'm not sure whether it's practical for them to do that.
14:30:24 <than> i don't think there're 2 sets of kde-l10n
14:31:25 <Kevin_Kofler> There isn't now, but there really needs to be to solve this problem.
14:32:03 <Kevin_Kofler> On our end, I think the patch-based approach is the only practical one. It'll require a bit of shell scripting (loops mainly).
14:32:34 <than> Kevin_Kofler: i agree with you, it seems only practical one
14:33:41 <than> Kevin_Kofler: or we only ship 4.5 translations
14:33:46 <than> for kdepim
14:34:44 <jreznik> let's wait for upstream's answer on "using kdepim 4.4. with kde 4.5" thread
14:37:11 <than> we will only provide l10-4.5 temporary before we have a solution for this
14:38:20 <jreznik> Kevin_Kofler: do you agree?
14:38:40 <jreznik> I would wait one week and if it wouldn't be solved, let's go with custom patch
14:38:40 <Kevin_Kofler> Let's wait for upstream.
14:38:48 <jreznik> looks we're not alone
14:38:54 <Kevin_Kofler> But we can't push 4.5 as a stable update to stable releases before this is sorted out.
14:39:07 <Kevin_Kofler> +1 to waiting 1 week and not more.
14:39:27 <jreznik> #agreed to provide l10n-4.5 temporary until upstream answers (max 1. week, otherwise custom patch)
14:40:03 <jreznik> #info kdepim l10n decision scheduled for next meeting
14:40:11 <jreznik> ok, let's move
14:40:24 <jreznik> #topic alpha changes deadline today
14:40:55 <jreznik> according to schedule, today is alpha changes deadline
14:41:31 <jreznik> I prepared laughlin-kde-theme (only copy from goddard yet as wp is not final one) as design team wants new wp in alpha
14:42:05 <than> jreznik: is it already built ?
14:42:17 <jreznik> than: yes
14:42:24 <Kevin_Kofler> Is it already filed in Bodhi?
14:42:29 <jreznik> #link https://admin.fedoraproject.org/updates/goddard-kde-theme-13.0.1-2.fc14,laughlin-kde-theme-13.91.0-1.fc14,kde-settings-4.5-3.fc14
14:42:39 <Kevin_Kofler> Don't forget that we need to file "updates" (freeze overrides) for everything in F14 now.
14:43:13 <jreznik> #link https://admin.fedoraproject.org/updates/goddard-backgrounds-13.0.0-2.fc14,laughlin-backgrounds-13.91.0-1.fc14 <- background
14:43:24 <jreznik> Kevin_Kofler: where?
14:43:38 <Kevin_Kofler> In Bodhi. You already did it, I see. :-)
14:44:17 <jreznik> but I'd like someone to test it actually if it's correct - it took me a lot of nerves with dist-git and I could oversee something :)
14:44:27 <Kevin_Kofler> (BTW, I really don't like this, I miss the times where the final freeze happened on Preview (now Beta), not on Alpha. Freezing so early is just extra bureaucracy.)
14:45:02 <than> jreznik: i can take a look at this
14:45:28 <jreznik> than: thanks, it should be ok but you know, more eyes...
14:45:48 <than> jreznik: +1
14:46:22 <jreznik> I wanted to test F14 alpha TC1 but images does not work - broken python - no anaconda
14:47:02 <Kevin_Kofler> Yeah, there are at least 2 live image blockers. :-(
14:47:03 <jreznik> #info than to help with laughlin-kde-theme validation for Fedora 14 alpha
14:47:44 <jreznik> anything else for alpha from our side?
14:47:45 <than> rawhide is just broken because of new python
14:47:58 <jreznik> kde 45 blockers?
14:48:04 <Kevin_Kofler> Our live image is oversized. :-(
14:48:11 <Kevin_Kofler> 715 MiB last I checked.
14:48:29 <Kevin_Kofler> That's ~12-15 MiB too many.
14:48:49 <than> Kevin_Kofler: f14 live image ?
14:48:53 <Kevin_Kofler> Yes.
14:49:27 <than> who is the maintainer for our live image?
14:49:43 <Kevin_Kofler> svahl, but he doesn't have much time for Fedora anymore.
14:49:54 <Kevin_Kofler> He's at work when we have our meetings and he also generally seems to have little time.
14:49:58 <Kevin_Kofler> I think he could use some help.
14:50:41 <than> we have to drop some apps from live image
14:50:44 * jreznik don't like 700 MB size restriction...
14:51:55 <Kevin_Kofler> I think the main reason we're oversized is that we now get both gtk2 and gtk3 dragged in. :-(
14:52:01 <Kevin_Kofler> But there's not much we can do about that. :-(
14:52:25 * than thinks everyone has dvd nowadays
14:52:39 <Kevin_Kofler> Plus, that we STILL don't have LZMA SquashFS.
14:52:52 <Kevin_Kofler> This is quite sad, the code has existed for months, but we still don't have it in Fedora. :-(
14:53:05 <Kevin_Kofler> Mainly because the kernel developers want to wait for Mr. Torvalds to bless it.
14:53:11 <Kevin_Kofler> Why do we need to wait for Linus?
14:53:13 <jreznik> than: the problem is not everyone - eastern countries...
14:53:37 <mjg59> Kevin_Kofler: Because maintaining non-upstream patches turns out to be a significant burden
14:53:48 <mjg59> If people want the patch, work with upstream on getting it mainline
14:54:00 <Kevin_Kofler> mjg59: But that patch is extremely important for our live images.
14:54:08 <mjg59> Kevin_Kofler: Then work with upstream on getting it mainline
14:54:17 <Kevin_Kofler> We have to drop stuff from our live images, leading to an inferior user experience, just because you guys don't want to ship it!
14:54:25 <than> Kevin_Kofler: do you a url where i can take a look at the live image project?
14:54:40 <mjg59> There's no "want" about it.
14:54:46 <mjg59> Even if we wanted to, we wouldn't
14:54:48 <Kevin_Kofler> than: You mean the kickstart file of the KDE spin?
14:54:55 <than> Kevin_Kofler: yes
14:55:02 <Kevin_Kofler> mjg59: It's a "want".
14:55:16 <Kevin_Kofler> It's the Fedora maintainers' decision what to ship in Fedora.
14:55:27 <Kevin_Kofler> If they don't ship it, it's because they don't want to ship it.
14:55:37 <mjg59> I want to ship the code. I don't want to maintain the code.
14:55:54 <mjg59> If it's something you care about, get it mainline. It's only C.
14:55:56 <jreznik> we don't like such a big patches because of the same issue - rebasing is bad
14:56:03 <Kevin_Kofler> than: http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=tree
14:56:14 <Kevin_Kofler> fedora-livecd-kde.ks is ours.
14:56:15 <than> Kevin_Kofler: thanks
14:56:38 <jreznik> but usually we try to maintain it for some time before it's finally upstreamed (it it's worth)
14:57:04 <Kevin_Kofler> I'm personally quite patch-happy, I don't have qualms shipping large patches if they're worth it and I can deal with rebasing them.
14:57:06 <mjg59> jreznik: We had several cases where people wanted large patches in Fedora and we carried them for some time without any indication that they were getting upstream
14:57:24 <jreznik> Kevin_Kofler, than: we need someone as replacement for svahl to take a look on live image, any volunteer?
14:57:27 <Kevin_Kofler> I've done insane rebases/forward-/backports at times, even some which people believed impossible. :-)
14:57:44 <mjg59> jreznik: It's not practical for the kernel maintainers to attempt to upstream every patch that people want, so we have to push the burden back onto them
14:58:01 <nucleo> FYI:  I will be on vacation until September without internet access.
14:58:42 <jreznik> mjg59: it's nonsense to have not-every-upstreamed patches, but it's ok to maintain patch temporary before it's finally upstreamed... but I don't know what's the problem here, so... ;-)
14:59:28 <than> jreznik: yes, we really need volunteer here
14:59:30 <Kevin_Kofler> I see upstream as the source of tarballs we patch.
14:59:32 <jreznik> #info Kevin_Kofler has magic rebases/forward-/backports foo like no one else :)
14:59:42 <Kevin_Kofler> Patching is what packagers are for. :-)
15:00:14 <jreznik> ok, let's ask on mailing list for someone interested in
15:00:41 <mjg59> jreznik: We'll carry something if it looks like it's heading upstream, but the LZMA patch has been supposedly being mainlined for ages with no sign that it's actually getting there
15:00:44 <jreznik> #info look for someone interested in helping svahl with live image
15:00:44 <thomasj_> Ok, i missed the meeting almost completely
15:00:57 <Kevin_Kofler> I guess the Alpha will just be oversized.
15:00:58 <jreznik> let's move to #fedora-kde
15:01:01 <Kevin_Kofler> Won't be the first time either.
15:01:05 <jreznik> Kevin_Kofler: agree
15:01:07 <mjg59> jreznik: The best thing that could be done would be for people who are interested in the code to work on getting it mainline. If there's progress in that respect then we'd be much more likely to carry it.
15:01:13 <jreznik> than: do you agree?
15:01:23 <than> it's ok
15:01:32 <jreznik> #agreed to oversized alpha
15:01:37 <jreznik> #endmeeting