fedora_insight
LOGS
18:00:00 <stickster> #startmeeting Fedora Insight -- Agenda: https://fedoraproject.org/wiki/Insight#Meeting_agenda
18:00:00 <zodbot> Meeting started Thu Jul 29 18:00:00 2010 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:00 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
18:00:06 <stickster> #topic Roll call!
18:00:10 * rbergeron 
18:00:19 * stickster 
18:00:30 <stickster> #chair rbergeron
18:00:30 <zodbot> Current chairs: rbergeron stickster
18:00:39 <rbergeron> thanks, i needed to sit down :)
18:01:23 * rbergeron looks around
18:01:27 <smooge> here
18:01:39 * mizmo Máirín
18:02:00 * jsmith lurks
18:02:25 <jsmith> (Teaching a class for my ex-employer this week, but keeping an eye on the channel)
18:03:05 <stickster> Is gwerra around?
18:03:18 <rbergeron> he was like... a very short time ago
18:03:39 * stickster gives 30 sec and then will move on
18:03:54 * rbergeron just hailed him back in -mktg even though he's here, too
18:04:06 <stickster> OK, moving on
18:04:14 <stickster> #topic Review action items
18:04:21 <stickster> #link http://meetbot.fedoraproject.org/fedora-meeting/2010-07-22/fedora_insight.2010-07-22-18.01.html <-- last week's minutes
18:04:35 <stickster> #info 1 <-- done
18:04:54 <stickster> smooge and I talked about the FakeFAS, it did disappear from pt3 but we are going to set up a new one on pt4
18:05:10 <stickster> smooge is fixing a sudo problem for me so I can work on that :-)
18:05:23 <stickster> #action smooge Finish fixing sudo problem on pt4
18:05:48 <rbergeron> how did it disappear?
18:05:54 <stickster> I think it happened during a rebuild
18:05:57 <rbergeron> not to be offtopic - but
18:05:58 <rbergeron> ahh
18:05:59 * gwerra is here
18:06:08 * rbergeron just wonders if we did something incorrectly, or something.
18:06:08 <stickster> Hi gwerra!
18:06:21 <stickster> rbergeron: Nope, I think it was missing dependency info that we were using it.
18:06:27 <rbergeron> ahhhh.
18:06:37 <stickster> #action stickster to set up new FakeFAS, with help from smooge, and make sure pt4 info page shows we're using it.
18:06:50 <stickster> #info 2 <-- underway
18:06:53 <smooge> stickster, let me know if its not working now
18:06:57 <stickster> smooge: Thanks!
18:07:22 <stickster> smooge: Working fine now, thanks!
18:07:42 <stickster> OK, #3 is the Insight page and plan
18:07:54 <stickster> I will confess I had very little time to work on this in the past week because of other $DAYJOB stuff
18:08:02 <stickster> But I am putting some muscle into it tomorrow and the weekend.
18:08:38 <stickster> #info 3 <-- stickster was too bogged to do this, but is working on it over the next few days
18:08:51 <stickster> #action stickster to work on [[Insight]] wiki page and updated project plan
18:08:53 <rbergeron> you mean the insight wiki page?
18:08:56 <rbergeron> ah, you clarified. :)
18:08:58 <stickster> :-)
18:09:31 <stickster> #info 4 <-- done/worksforme
18:09:35 <stickster> OK, that's it for review stuff
18:09:39 <stickster> Shall we move on?
18:09:44 <rbergeron> yes plz.
18:09:45 <rbergeron> :)
18:09:53 <stickster> #topic Test instance
18:10:13 <stickster> OK, the big news is that smooge got us a new public test box built
18:10:26 <stickster> #info Test instance is now on publictest4.fedoraproject.org
18:10:45 <stickster> I'll be adding a Drupal 6 installation to that box, in accordance with the wiki instructions
18:11:55 <stickster> #action stickster to add drupal6 from the RPM package pending (and almost finished) in review
18:12:32 <stickster> Also, I'll be adding FakeFAS as seen eariler, so we can fiddle with people and groups without disturbing any of the production systems
18:12:53 <stickster> #info important note: People should use *different* passphrase for FakeFAS than what they use for the real FAS system
18:13:04 <stickster> It shouldn't be considered secure.
18:13:08 * rbergeron nods
18:13:23 <stickster> #info Important(er) note: Don't use any passphrase you care about someone knowing :-)
18:13:26 <rbergeron> will the new FAS be a copy /restore of old FAS or completely new?
18:13:50 <rbergeron> of oldFakeFas
18:13:52 <rbergeron> i mean :)
18:14:02 <stickster> rbergeron: I don't know if there's any value in sync'ing it, unless lots of other people need to use it (in which case they could build their own instances, I suppose)
18:14:09 <stickster> smooge: What do you think?
18:14:45 <smooge> one sec
18:14:55 <smooge> completely new
18:15:11 <stickster> smooge: Yeah, I agree
18:15:14 <gwerra> stickster: we should make a new one
18:15:16 <rbergeron> okay :)
18:15:17 <smooge> I don't think I can copy stuff from existing fas. will have to ask mmcgrath what populatesit
18:15:58 <stickster> smooge: Do you have to do some sort of copy to just get a new one off the ground? Or is that only required if we wanted to copy in some data?
18:16:50 * stickster would suspect starting a brand new instance with no one in it shouldn't need any copying, since it's intended to work that way for any project that decides to use FAS
18:17:10 * rbergeron nods
18:17:14 <smooge> stickster, I have no idea. this is my first time dealing with this
18:17:20 <stickster> smooge: OK, we'll figure it out
18:17:45 <stickster> We have the action item above already, this is just one aspect of that work :-)
18:17:51 * stickster may just try it and see how it goes
18:18:03 <stickster> The worst that happens is we start over, and the best is that I can learn and document FAS setup
18:18:32 <stickster> Oh, I should #topic.
18:18:34 <stickster> #topic FakeFAS
18:18:55 <stickster> #info See above for action item on FakeFAS. smooge and stickster will try their hand at it, and learn/document in the process.
18:19:31 <stickster> #info the FakeFAS is being set up so that we can use/test the AuthFAS plugin too.
18:20:07 <stickster> gwerra: Since you're here also, and I know you were keen to work on theme stuff, let's talk about that a bit, is that OK?
18:20:32 <gwerra> stickster: sure
18:20:33 <stickster> #topic Themes, modules and devel SOP
18:20:52 <stickster> What we want to do is *not* to just edit stuff in the /usr/share/drupal6 area directly.
18:21:09 <stickster> That's a sure route to confusion, don't want to go down that road
18:21:34 <stickster> (1) Theme and module development to live in /etc/drupal6/all/
18:22:03 <stickster> gwerra: In fact, here's what I did when I was working on AuthFAS...
18:22:12 <gwerra> stickster: well /etc is usually just configs, we can use /var/drupal or something
18:22:35 <stickster> gwerra: Actually, using /etc is how the packages are set up for both drupal and drupal6 IIRC
18:23:17 <stickster> Here's what I did
18:23:31 <stickster> 1. Start a git repo for my work
18:23:43 <stickster> 2. Clone it into /etc/drupal6/all/modules/
18:23:44 <gwerra> stickster: Fix the drupal6 package then :) , /etc/drupal6/* doesn't look like a good idea to me
18:23:57 <stickster> gwerra: You're welcome to comment on the review bug  :-)
18:24:05 <gwerra> stickster: bug number?
18:24:13 <stickster> gwerra: Don't recall, but search for 'drupal6'
18:24:30 * stickster thinks this is bikeshedding
18:24:35 <stickster> Regardless of where the stuff goes...
18:24:50 <stickster> 2. Clone repo into <someplace where the module/theme will live>
18:25:34 <stickster> 3. Use branches for rough tries, and check them out onto pt4 to try work periodically
18:25:42 <stickster> When happy, merge and push
18:26:34 <stickster> Which makes a lot more sense to me than just 'sudo $EDITOR /usr/share/drupal6/stuff' which can break the RPM database integrity and other yuckiness.
18:26:44 <stickster> smooge: gwerra: What do you think?
18:27:07 <stickster> #link https://bugzilla.redhat.com/show_bug.cgi?id=569833 <-- drupal6 review
18:28:08 <smooge> correct /usr is verbotten. whehter it is /etc/ or /var or /var/www/site/ does not matter that much to me
18:28:44 <gwerra> stickster: that sounds good to me (sorry I was too busy reading the review)
18:29:01 <stickster> smooge: Me neither, and I'm not going to bother the reviewer about it. It would also require a change in SELinux policy to move stuff too
18:29:22 <stickster> s/reviewer/packager+reviewer/
18:29:48 <stickster> OK, so shorthand:
18:30:03 <pcalarco> greetings all
18:30:06 <smooge> stickster, correct. I will let the FPC deal with that
18:30:15 <gwerra> pcalarco: hello
18:30:23 <stickster> #info Team will use repo to manage theme and module stuff, and will not edit things live on /usr to avoid losing work in case of a rebuild or outage
18:30:28 <stickster> #undo
18:30:28 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x1d3a7d90>
18:30:31 <stickster> #agreed Team will use repo to manage theme and module stuff, and will not edit things live on /usr to avoid losing work in case of a rebuild or outage
18:30:40 <stickster> Oh, I should have chaired more people
18:30:45 <stickster> Hi pcalarco! It's great to see you!
18:30:53 <stickster> #chair gwerra smooge mizmo pcalarco
18:30:53 <zodbot> Current chairs: gwerra mizmo pcalarco rbergeron smooge stickster
18:31:17 <stickster> So it's good to have agreement there, before we do any real work.
18:31:22 <stickster> What's equally important is...
18:31:24 <gwerra> stickster: btw do we have mockups for the theme? I can start working next week
18:31:37 <stickster> gwerra: I think we can continue with the original mockups
18:31:59 <stickster> It looked great, we just have to do some fiddling to make it work on a diff. platform
18:32:08 <gwerra> Yup
18:32:16 * stickster finds his thought back again...
18:32:21 <stickster> So it's good to have agreement there, before we do any real work.
18:32:23 <stickster> What's equally important is...
18:32:27 <stickster> #topic Project plan
18:32:46 <stickster> Stepping back a little, we really want to start with a plan that helps us judge our progress better.
18:33:06 <stickster> We kept running into problems where it was hard to say whether we were on target
18:33:35 <stickster> mizmo: I'm glad you came by for this meeting, because one of the things I want to do in the plan is to take into account uses people will have beyond just "publish the news"
18:34:18 <stickster> We don't want to try and do everything at once, but it will be good to have some people paying attention to the project who are thinking about what we can provide w/Drupal later on
18:34:44 <mizmo> yeh
18:34:48 * stickster is trying to do this in a lightweight, Fedora-like process but with something resembling some order
18:34:55 <mizmo> the new article series in the website would be well-managed by a system like drupal
18:34:58 <stickster> i.e. get all the requirements/targets down on the wiki first
18:35:11 <mizmo> it could also provide a great gateway for new contribs to follow mailing lists
18:35:17 <stickster> Yup
18:35:44 <stickster> And we'll need to get some idea of how long putting all these things will take, before we decide on scope for the first bits, vs, what we add in later stages
18:36:00 * stickster thinks FWN is a shoe-in, because we promised that first.
18:36:13 <stickster> But regardless, we don't need to make the whole list here in this meeting
18:36:23 <stickster> I'm going to propose something via the wiki, and then write to the logistics@ list about it.
18:37:01 <mizmo> kk
18:37:02 <stickster> #action stickster to put the proposed plan on the wiki (linked from the [[Insight]] page) and then we'll edit/come together on the details.
18:37:45 <gwerra> I have to run now, got some college work to finish before I crash
18:37:53 <stickster> gwerra: Understood -- thanks for being here
18:37:59 <stickster> gwerra: You're on logistics list, right?
18:38:05 * stickster asks in general if everyone is
18:38:11 * rbergeron is
18:38:23 <gwerra> stickster: yup
18:38:25 <smooge> is
18:38:32 <stickster> We're trying to keep conversations there so that people from lots of teams can see what's going on without a lot of cross posting.
18:39:02 <pcalarco> is
18:40:05 <stickster> OK, good on us then :-)
18:40:45 <stickster> Did anyone want to say or ask anything about the project plan?
18:40:58 * rbergeron raises hand
18:41:28 <stickster> rbergeron: You're on, fire away!
18:41:34 <rbergeron> Can we - and maybe this isn't the right place for it - but somewhere detail the plan wrt development spot and some guidelines - checking things in and out, not doing them live, etc?
18:41:54 <stickster> rbergeron: Yes, definitely.
18:42:06 <rbergeron> because I think we had a lot of trouble with that last time around - and I think setting up some expectations up front, either in "the plan" or elsewhere - or having that stuff discussed as a point on the project plan - would probably save us time in the long run.
18:42:19 <stickster> Now that we have those ground rules established above, I'll make sure to detail them in or linked from the plan.
18:42:37 <stickster> #info stickster will definitely include the development process in or linked from the project plan
18:43:02 <stickster> That way we don't end up with people making changes in a bunch of different ways to the point that we can't figure out where the "live" or "recorded" changes rae
18:43:03 <stickster> *are
18:43:26 * stickster holds floor open for a minute for anyone else
18:43:37 <stickster> Anything else on project plan?
18:44:23 <stickster> #topic AOB (all other business)
18:44:40 <stickster> OK, anything not on the agenda that we need to start thinking about, that's not part of planning?
18:45:11 <stickster> #meetingname Fedora Insight
18:45:11 <zodbot> The meeting name has been set to 'fedora_insight'
18:45:15 * stickster should have done that earlier :-)
18:45:29 <rbergeron> doh :)
18:45:38 <rbergeron> So - one other point of interest / something to think about:
18:45:38 <stickster> 's OK, meetbot knows how to deal with it
18:45:42 <stickster> rbergeron: Go!
18:46:23 <rbergeron> bethlynn asked me last night about if Fedora was planning on doing an Activity Day at OLF (ohio linux fest) - I said, I'm not sure, it might be a good idea to ask around to some of the groups working on things to see if they are interested / have something that could be done in a FAD.
18:46:30 <rbergeron> That event is ... September 10ish.
18:46:55 <rbergeron> so, just as a thought - I don't know what our project plan looks like yet (:D) or if it would fit up with those dates, or if we have stuff that could be better done as a group wrt Fedora Insight.
18:47:02 <rbergeron> Basically just throwing it out there. :)
18:47:59 * stickster won't be able to organize a FAD for this because he's not going to OLF, but would be totally excited about finding a piece of the work that would work well at a FAD, and letting someone run with ti
18:48:00 <stickster> *it
18:48:42 <stickster> I've not felt like all our recent FADs did well at turning out actual, shiny new work product, so I'd recommend keeping the focus tight and well-defined
18:49:43 <stickster> #info Ohio Linux Fest is coming up September 10, possibility for a tightly focused FAD on some aspect of Insight if there's (1) a group that is eager to do the work, and (2) someone who's eager to organize the FAD event
18:49:56 <stickster> rbergeron: Sound good?
18:50:24 <rbergeron> indeed.
18:50:31 * Southern_Gentlem runs
18:50:56 <stickster> OK, since things have quieted, I'm going to call meeting in 60 sec unless there's something further
18:53:03 <stickster> OK
18:53:06 <stickster> #endmeeting