spins-sig
LOGS
20:59:01 <brunowolff> #startmeeting
20:59:02 <zodbot> Meeting started Mon Jul 26 20:59:01 2010 UTC.  The chair is brunowolff. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:59:02 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
20:59:10 <brunowolff> #meetingname spins-sig
20:59:10 <zodbot> The meeting name has been set to 'spins-sig'
20:59:18 <brunowolff> #chair bruno nirik
20:59:18 <zodbot> Current chairs: bruno brunowolff nirik
20:59:30 <nirik> you're early. ;)
20:59:39 <brunowolff> #topic Who's here?
20:59:46 <brunowolff> About a minute.
21:00:09 * nirik is around.
21:00:15 * brunowolff is here
21:00:38 <brunowolff> I told the Music guy to show up.
21:01:27 <brunowolff> #topic blackscreen bug FYI
21:01:39 <brunowolff> The blackscreen bug should get fixed tonight.
21:01:55 <brunowolff> I have an approved patch that I will apply tonight.
21:02:19 <brunowolff> I also plan to build a new livecd-tools package (and a new spin-kickstarts) tonight.
21:02:21 <nirik> hurray.
21:02:29 <nirik> where was the bug?
21:02:52 <brunowolff> We needed to change livecd-creator (live.py) to match the new location.
21:03:23 <nirik> ah ha. ok.
21:03:29 <brunowolff> The file we use isn't used by anaconda, so the problem wasn't noticed by the anaconda guys and they didn't think to warn us.
21:03:43 <nirik> that doesn't do anything for the can't find root bug tho, right?
21:03:45 <brunowolff> The patch will handle the new and old location.
21:04:08 <brunowolff> That way generic-logos will still work (though i'll file a bug asking them to match fedora-logos) and
21:04:30 <brunowolff> it should allow building from older repos on F14+.
21:04:44 <brunowolff> #topic ext3 mount issue
21:05:00 <brunowolff> The ext3 image mounting problem is puzzling.
21:05:09 <nirik> yeah. ;(
21:05:18 <brunowolff> I don't see that when I compose live images.
21:05:31 <nirik> interesting. Rawhide host?
21:05:52 <brunowolff> I use a rawhide host to build.
21:05:55 <nirik> we tried to isolate any changes that could have happened when it started occuring, but nothing really looked likely.
21:06:03 <brunowolff> It's i686.
21:06:19 <brunowolff> Maybe there is a x86_86 bug in something?
21:06:20 <nirik> I've only been testing this x86_64 ones... could this be arch specific?
21:06:41 <nirik> do the i686 nightlys show the issue?
21:06:54 <brunowolff> There was a release of the tools to resize and the like around the time people noticed this.
21:07:02 <brunowolff> Maybe there is an arch specific bug.
21:07:14 <nirik> it started happening before the livecd-tools update. ;(
21:07:22 <brunowolff> Yes the i686 nightly images have the problem.
21:07:30 <nirik> huh.
21:07:39 <brunowolff> But maybe building on x86_64 triggers a bug.
21:07:57 <nirik> xfce-x86_64-20100714.16.iso -> no problem, xfce-x86_64-20100717.15.iso -> broken
21:08:04 * pbrobinson is here, sorry for being late
21:08:17 <brunowolff> Not the livecd-tools update; I'm thinking og the ext-utils (not sure of the exact name) update.
21:09:02 <nirik> e2fsprogs?
21:09:12 <brunowolff> Peter, we are talking about the ext3 images not being mountable problem.
21:09:18 <brunowolff> That's the one.
21:09:32 <nirik> I can try reverting that and see if it changes anything.
21:09:48 <nirik> that was changed on the 13th, but might not have been in the 14ths rawhide.
21:10:15 <brunowolff> That's kind of what I was thinking.
21:10:43 <brunowolff> Maybe there is a gcc 4.5 bug that broke the rebuild or maybe a new bug was introduced.
21:11:11 <brunowolff> How do we test seeing if it is an arch specific e2fsprogs bug.
21:11:14 <nirik> I'll try another compose run when todays are done.
21:11:29 <nirik> I am just going to revert that package back and see if they start working.
21:12:08 <brunowolff> #action nirik will do some testing to see if maybe there is an arch specific bug in e2fsprogs from the build on the 13th.
21:12:41 <brunowolff> #link https://bugzilla.redhat.com/show_bug.cgi?id=615443
21:13:02 <brunowolff> The link is for the bug tracking that issue, in case you find something concrete.
21:13:36 <brunowolff> Do you guys have any other ideas for avenues to approach for this?
21:14:18 <pbrobinson> no, not really
21:14:29 <brunowolff> OK, for now we'll move on.
21:14:42 <brunowolff> #topic bruno on vacation
21:15:12 <brunowolff> I will miss next Monday's meeting for sure and a good chance I won't make the one after that either.
21:15:31 <brunowolff> And even if I get back home before the meeting I probably won't be up to speed on stuff.
21:15:42 <nirik> cool. Hope you are going somewhere fun
21:16:12 <brunowolff> We could just cancel the next two meetings or I could just warn people they are maybes?
21:16:33 <brunowolff> I am going to the WBC, to mostly run the multiplayer Titan tournament.
21:16:34 <nirik> I could try and run things...
21:16:52 <brunowolff> OK, I'll do the  maybe warning.
21:17:17 <brunowolff> #action brunowolff will email spins to say that meetings the next two Monday's are iffy.
21:17:34 <brunowolff> #topic test plans and process doc
21:18:12 <brunowolff> I didn't get any further on the test plan and process documentation. I doubt I will before i leave as working on making the
21:18:20 <brunowolff> spins work, seems to be more important.
21:18:47 <brunowolff> If anyone feels like working on this jump in, but we'll still have time to do it after I get back.
21:19:13 <brunowolff> I think that is pretty much just FYI.
21:19:22 <pbrobinson> the spins org side of things seems to be in good stead.
21:19:39 <brunowolff> #topic BR spin and ntp
21:19:43 <pbrobinson> I worked today on getting the MeeGo one building, I think tomorrow should be much better
21:19:59 <brunowolff> Thanks!
21:20:24 <brunowolff> We had a request to change the ntp config of the BR spin to use some local ntp service.
21:20:56 <brunowolff> I suggested that the people providing the service join the ntp.org pool and the spin owner concurred.
21:21:07 <brunowolff> So I think that issue is closed for now.
21:21:22 <brunowolff> #topic Music spin
21:21:29 <pbrobinson> agreed on ntp
21:21:37 <brunowolff> Is anyone representing the Music spin here?
21:21:55 <brunowolff> #link https://fedoraproject.org/wiki/Music_Creation_Lite_Spin
21:22:07 <brunowolff> #link http://members.iinet.net.au/~timmsy/spin/fedora-livecd-music-creation.ks
21:22:44 <brunowolff> As I commented in the mailing list, I don't think the ks file is OK and would need some work to review and possibly dealing
21:22:52 <brunowolff> with petitions for exceptions.
21:23:27 <brunowolff> I can't see doing that this late, especially since we are short handed and we have a lot of issues getting ready for alpha right now.
21:23:59 <brunowolff> My inclination is to deny this spin for F14.
21:24:31 <brunowolff> Also the submission was late.
21:24:32 <nirik> yeah, I would say the same...
21:24:39 <nirik> try again for f15.
21:24:42 <pbrobinson> and it seems there's no one here to represent the spin. But then it seems the person might be in Australia so it might be hard with TZ
21:24:46 <nirik> and work on it until then.
21:25:09 <brunowolff> Proposal: Music spin is declined for F14, but application for F15 is open.
21:25:12 <brunowolff> +1
21:25:16 <nirik> +1
21:25:46 <pbrobinson> maybe give them a day to get it up to speed or at least commit to doing so in a short time frame
21:25:57 <pbrobinson> but I tend to agree its very late
21:26:16 <brunowolff> The spin needs more than a days worth of work to get in shape.
21:26:55 <brunowolff> The ks file turns off servers and removes key packages.
21:27:16 <pbrobinson> servers or services?
21:27:23 <brunowolff> Services
21:27:48 <brunowolff> /sbin/chkconfig --level 4 atd off
21:27:49 <brunowolff> /sbin/chkconfig --level 4 avahi-daemon off
21:27:49 <brunowolff> /sbin/chkconfig --level 4 cpuspeed off
21:27:49 <brunowolff> /sbin/chkconfig --level 4 crond off
21:27:49 <brunowolff> /sbin/chkconfig --level 4 ip6tables off
21:27:49 <brunowolff> /sbin/chkconfig --level 4 ntpd off
21:27:51 <brunowolff> /sbin/chkconfig --level 4 mdmonitor off
21:28:17 <nirik> level 4?
21:28:30 <brunowolff> They are worried that services will break jack.
21:28:32 <pbrobinson> what's wrong with that? In SoaS/Moblin/Design we removed most of those so we didn't have to turn them off
21:28:43 <brunowolff> I am not sure how much testing they have done to confirm that.
21:28:48 * nirik wonders where runlevel 4 is used.
21:28:59 <pbrobinson> level 4 isn't generally used
21:29:01 <brunowolff> They are also targeting a CD, which doesn't seem to make much sense.
21:29:22 <brunowolff> I think there may be a useful spin idea here, but it's not ready for prime time.
21:29:29 <pbrobinson> well targetting a CD isn't a bad thing. We target for less than that for SoaS/Moblin
21:30:06 <brunowolff> They aren't likely to want to run this on a CD if there are turning off services to reduce latency.
21:30:42 <brunowolff> I'd like to have them think about what it is they are trying to provide.
21:31:18 <brunowolff> Another issue is that they originally targeted rpmfusion and maybe they would be better off being a remix.
21:31:51 <pbrobinson> well we don't directly target CDs, we target being able to install to less than 1Gb. So if they are targetting small devices that's not such a bad thing. But yes they need to define what they wish to achieve.
21:32:21 <pbrobinson> and I don't believe there's any issues with turning off services within a spin.
21:32:49 <nirik> well, I think turning things off is bad for when people install from them...
21:32:55 <brunowolff> Changing the default config of services is supposed to require an exception from the Spins SIG.
21:33:01 <pbrobinson> I believe a spin needs to provide core Fedora features like selinux, network manager etc but other than that are free to install/enable what they like
21:33:07 <nirik> ie, the above you will get no cron or mdmonitor, so you raid could die and not notify you, etc.
21:33:34 <pbrobinson> brunowolff: I disagree
21:33:37 <brunowolff> They also remove the wireless firmware which breaks working wireless.
21:33:55 <brunowolff> Well the policy was set in the past.
21:34:22 <pbrobinson> mdmonitor is only of use if you have raid. No netbooks do. An there are no default cron jobs installed so why is it necessarily needed
21:35:03 <brunowolff> I think you are coming from the MeeGo perspective. MeeGo is pretty much loaded with exceptions.
21:35:11 <pbrobinson> brunowolff: I remove HBA firmware which would break servers that boot off the SANs. Should we remove MeeGo spins because of that?
21:35:38 <brunowolff> Most spins aren't going to be approved to do the things MeeGo does.
21:35:43 <pbrobinson> no, I'm coming from the fact that there are so many exceptions that they shouldn't be called exceptions.
21:36:16 <nirik> so spins should be allowed to disable/enable whatever they like?
21:36:17 <pbrobinson> for example in a virtualisation environment you'll never have wifi or raid. So why bloat it.
21:36:37 <pbrobinson> nirik: if they are no use to the spin why not?
21:36:56 <nirik> how do you know they are of no use?
21:37:09 <nirik> ie, a music spin may be installed by a music student.
21:37:10 <pbrobinson> my understanding of spins was that as long as they don't disable things thinks that are core to Fedora such as selinux there is no issues
21:37:19 <nirik> they may have raid on that box or use it for day to day stuff, etc.
21:37:21 <brunowolff> We want a number of things on a spin to just work.
21:37:51 <nirik> anyhow, I think it's fine to make sensible changes, but we shouldn't go disabling everything all the time or doing so without others looking and seeing that the rationale is reasonable.
21:38:10 <brunowolff> And we want people to be able to install from the spin and add other stuff and not have gotchas from an oddball config defined in the spin.
21:38:11 <pbrobinson> so we should continue to install and mta and a http server just because it might be used?
21:38:41 <pbrobinson> so we ship with everything and have a massively slow boot
21:38:55 <brunowolff> In some cases yes, since they are needed for logging.
21:39:01 <nirik> boy is that not what I said... :)
21:39:16 <nirik> I think we are driving into the weeds.
21:39:23 <pbrobinson> like the new atom procesors support virtualisation extentions so I should install them just in case someone wants to run it on a netbook
21:39:29 <brunowolff> Anyway, the policy is what it is at this time. We can reopen discussion on the policy at a later date.
21:39:50 <nirik> Back to the music spin: I think they should be allowed to disable things that make sense, but I am not sure all the things they do do make sense and would love to hear rationale.
21:40:09 <brunowolff> As far as Music goes we had 2 +1s and one obstain. So I think that spin is deferred until F15.
21:40:19 <pbrobinson> brunowolff: but the default is to root and its not set during install to go anywhere else and the only thing in the default desktop that goes to mail is anacron which in F-14 will be set to log to messages
21:40:57 <brunowolff> #agreed music spin is deferred until F15
21:41:15 <brunowolff> #topic livecd-deskop yum remove FYI
21:41:48 <brunowolff> I removed the yum remove from post since it was broken on the nightly compose servers in any case.
21:42:03 <brunowolff> I did let desktop know.
21:42:45 <brunowolff> #topic spin-kickstarts build
21:43:02 <brunowolff> I am going to try to get a build of spin-kickstarts done tonight.
21:43:39 <brunowolff> This will help people building images on F14 since the F13 version currently there refers to at least one package that was replaced in F14.
21:44:05 <brunowolff> Does anyone have any changes that they'd really lie to see in this build?
21:44:16 <nirik> not off hand
21:44:21 <brunowolff> (That haven't already been comitted?)
21:44:49 <brunowolff> So I am hoping to have a new livecd-creator and spin-kickstart package.
21:45:24 <pbrobinson> not that I'm aware of. SoaS should be OK and I think MeeGo too.
21:45:28 <brunowolff> Possibly also I'll update the devel version of squashfs-tools as well. The changes there are most xattr cleanup and should cause a problem.
21:45:46 <pbrobinson> should? :-P
21:45:50 <brunowolff> We'll do other builds for beta, GA and maybe updates.
21:45:59 <brunowolff> shouldn't
21:46:35 <brunowolff> But I won't be around next week and may not be able to get a chance to do them remotely next week.
21:47:11 <pbrobinson> is there a process to respin them if necessary?
21:47:12 <brunowolff> If anyone really needs an update in alpha, the instructions for building the packages are linked from the Spins SIG wiki.
21:47:20 <pbrobinson> cool.
21:47:58 <brunowolff> #topic Others?
21:48:17 <brunowolff> Does anyone have anything else they want to discuss today?
21:48:22 * nirik has nothing.
21:48:48 <brunowolff> #action brunowolff will reply back to the Music Spin request on the list.
21:49:14 <brunowolff> #action brunowolff will email out the meeting summary
21:49:24 <brunowolff> #endmeeting