fedora_docs
LOGS
23:00:22 <Sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
23:00:22 <zodbot> Meeting started Wed Jul 21 23:00:22 2010 UTC.  The chair is Sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:00:22 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:00:22 <Sparks> #meetingname Fedora Docs
23:00:22 <zodbot> The meeting name has been set to 'fedora_docs'
23:00:22 <Sparks> #topic Roll Call
23:00:32 * Gearoid is here
23:00:39 * Sparks is here
23:01:59 * stickster 
23:02:08 * crantila is here, barely
23:02:09 * bcotton is here
23:03:32 <Sparks> Okay, let's get started.
23:03:42 <Sparks> #topic Follow up on last week's action items
23:04:01 <Sparks> #action jjmcd to have doc-publican-rpm packaged and submitted for review by 21 July (overdue)
23:04:09 <Sparks> rudi_: rudi to come back with additional information on getting docs-writers building packages in koji for docs.fp.o
23:04:25 <rudi_> Yep -- real progress this week
23:04:35 <Sparks> excellent. go for it
23:05:01 <rudi_> So we now have a roadmap in place -- http://fedoraproject.org/wiki/Automating_publishing
23:05:09 <rudi_> with some specific goals.
23:05:21 <rudi_> The first one is to get Publican built for the infra repo
23:05:29 <Sparks> #link http://fedoraproject.org/wiki/Automating_publishing
23:05:47 <rudi_> And the immediate prerequisites for that are to get a number of deps built for EPEL
23:05:53 <rudi_> I'm working on that already
23:06:12 <rudi_> of the 8 deps, 3 are now built and about to go into testing
23:06:26 <rudi_> The maintainer of one of the others has also replied in the affirmative
23:06:50 <Sparks> excellent
23:06:54 <Sparks> sounds like you've been busy
23:07:06 <rudi_> Yeah :)
23:07:51 <Sparks> We can go into this some more in a bit.
23:08:02 <Sparks> #action Sparks Work on magazine article work about the guides and docs.fp.o
23:08:26 <Sparks> quaid: You around?
23:08:50 <Sparks> #action quaid to discuss on the list about Beacon and web-based XML editors for Docs use.
23:09:03 <Sparks> #topic Fedora 14 Schedule
23:09:42 <Sparks> Anyone have anything else on the F14 schedule?
23:10:34 <stickster> Sparks: Dumb question, but did jjmcd get the changes he sought?
23:10:41 <Sparks> Not sure
23:11:09 * stickster not sure if there *were* specific changes left to seek
23:11:14 * stickster bows out for lack of info
23:11:27 <stickster> #info Further changes to the schedule should be relayed to poelcat immediately.
23:11:36 <Sparks> concur
23:11:44 <Sparks> #action Publican
23:11:49 <Sparks> #undo
23:11:49 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x1d1df310>
23:11:56 <Sparks> #topic Publican
23:12:27 <rudi_> So I hope I've summed up the state of play on that wiki page...
23:12:36 <rudi_> Does anybody have any questions?
23:12:51 <rudi_> Does that roadmap make sense to people?
23:13:04 <Sparks> Looks good to me
23:13:53 <Sparks> rudi_: Will this be done in time for F14?
23:14:04 <rudi_> I really, really hope so, for all our sakes :)
23:14:05 <rudi_> But...
23:14:22 <rudi_> EPEL has some strict rules
23:14:35 <rudi_> and packages need to spend at least two weeks in testing before going stable
23:14:55 <rudi_> So I really need to get those packagers involved
23:15:58 <rudi_> I've also volunteered to maintain the EPEL5 branch for any of those packages for any packager who doesn't want to head down the EPEL path
23:16:41 <Sparks> heh
23:17:10 <Sparks> Okay.  Anything you need from me or anyone else?
23:17:39 <rudi_> Not unless anyone knows any of the maintainers on that list and can put in a good word for how important this is for Docs :)
23:18:25 <Sparks> A note to the list might be a good idea
23:18:39 <rudi_> Docs list?
23:18:41 <Sparks> Yeah
23:18:45 <rudi_> Will do
23:18:48 <stickster> epel-devel-list@redhat.com
23:18:52 <Sparks> That too
23:18:53 <stickster> That might also be useful
23:19:09 <rudi_> Thanks stickster :)
23:19:19 <Sparks> Anything else?
23:19:24 <rudi_> Not from me
23:19:29 <Sparks> #topic Release Notes
23:19:35 <Sparks> jjmcd isn't here tonight.
23:19:53 <Sparks> I think the beats are being reset this week, though.
23:20:25 <stickster> #link http://poelstra.fedorapeople.org/schedules/f-14/f-14-docs-tasks.html
23:20:43 <Sparks> #action rudi_ to send a message to EPEL devel and docs discussing his EPEL packages need for Publican
23:22:19 <Sparks> #link https://fedoraproject.org/wiki/Docs/Beats
23:23:01 <Sparks> If anyone is interested in working on a beat sign up using that link above.
23:23:17 <Sparks> Questions?
23:24:06 <Sparks> #topic Guide Status
23:24:14 <stickster> Which link?
23:24:23 <stickster> Ah
23:24:25 * stickster lost it
23:24:36 <Sparks> stickster: And now you have me questioning myself.
23:24:38 <Sparks> :)
23:25:12 <rudi_> All quiet at the moment, as far as I can see
23:25:33 <Sparks> Anyone have any questions or comments?
23:25:48 * stickster thinks things will probably heat up after the Alpha is RC
23:25:54 <Sparks> Yes
23:25:59 <stickster> At least... I hope they will!
23:26:00 <rudi_> Yeah; this is the calm before the storm :)
23:26:11 <crantila> okay, I'll bite
23:26:37 <crantila> if you're looking for something to do, please help proof-read the Musicians' Guide!  One chapter or one section is enough to help
23:27:07 <crantila> comments from previous proof-readers are surrounded !! like this !! in exclamation marks, so it's things that are already going to be fixed
23:27:09 <Sparks> crantila: Is that in fedorahosted?
23:27:18 <crantila> links forthcoming
23:27:39 <crantila> all drafts available here: https://fedoraproject.org/wiki/User:Crantila/FSC/Drafts
23:27:49 <Sparks> #link https://fedoraproject.org/wiki/User:Crantila/FSC/Drafts
23:27:57 <crantila> two focus areas are Qtractor, here; https://fedoraproject.org/wiki/User:Crantila/FSC/Sequencers/Qtractor
23:28:08 <crantila> and Audacity, here: https://fedoraproject.org/wiki/User:Crantila/FSC/Recording/Audacity
23:28:18 <Sparks> Looks like you've been busy.
23:28:38 <crantila> the Guide should be moving into fedorahosted gradually within the next few weeks
23:28:46 <rudi_> crantila -- how are we tracking now towards the end of the week?
23:29:31 <crantila> the SuperCollider mini-textbook is at about 2000+ lines currently, and I'm three-quarters done
23:29:45 <rudi_> Still think that Sunday is attainable?
23:29:48 <crantila> that puts completion all drafts by Saturday
23:29:57 <rudi_> Awesome :D
23:29:58 <crantila> two days should be enough
23:30:36 <crantila> so... Audacity and Qtractor are popular programs, and I'm appreciate special attention for those chapters
23:30:49 <crantila> I would appreciate**
23:30:51 <rudi_> So folks; that's the point at which there should be a complete first draft...
23:31:00 <crantila> thanks!
23:31:07 <rudi_> So proofreading, comments and feedback are needed *now* :)
23:31:29 <crantila> and I'm willing to entertain almost anything
23:32:55 <mprice> I am willing to help with those since I'm new
23:33:08 <crantila> thank you for volunteering; just pick a section, and go
23:33:11 <crantila> (I'm new, too)
23:34:06 <Sparks> Okay, anyone else?
23:34:27 * bcotton has made progress on teh printing chapter for the UG
23:34:49 <bcotton> I hope to have a first draft finished and available before I leave for a vacation on Friday afternoon
23:34:58 <Sparks> excellent
23:35:21 * Gearoid will finally get working on the accessibility guide this week
23:35:48 <bcotton> as a result of working on the printing chapter (plus also applying to grad school and lots of "fun" projects at work and being lazy), the RPM guide hasn't moved forward very much. if anyone wants to pitch in, see https://fedoraproject.org/wiki/User:Bcotton/RPM_Guide_tasks
23:35:51 <Sparks> I should remind people to strike out items that they complete on the F14 Goals page:
23:35:54 <Sparks> #link https://fedoraproject.org/wiki/Docs_Project_guide_goals_for_F14
23:36:38 <Sparks> Anyone else?
23:37:05 <Sparks> #topic Outstanding BZ Tickets
23:37:16 <Sparks> #link http://tinyurl.com/lbrq84
23:37:34 <Sparks> #info 97 open tickets
23:38:00 <Sparks> #info 28 new tickets
23:38:30 <Sparks> Has everyone read the procedures for working with documentation bugs?
23:38:33 <Sparks> #link #link https://fedoraproject.org/wiki/Handling_Docs_Project_bugs
23:38:39 <Sparks> #undo
23:38:39 <zodbot> Removing item from minutes: <MeetBot.items.Link object at 0x2ad577314ed0>
23:38:43 <Sparks> #link https://fedoraproject.org/wiki/Handling_Docs_Project_bugs
23:39:59 <Sparks> Anyone have any comments or questions about the procedure?
23:40:32 <bcotton> it's not clear to me how the QA person fits into this
23:40:59 <bcotton> it sounds like the QA person is only invovled after a bug has been patched, and before the reporter is notified
23:41:33 <bcotton> which seems a bit...unneeded in that case?  it seems saner to me that the ticket would be marked VERIFIED *Before* a patch is committed.   EOF
23:41:34 <Sparks> bcotton: The patch needs to be verified by a QA person
23:42:25 <Sparks> Yes, in theory a patch shouldn't be committed until it has been verified
23:44:19 <Sparks> bcotton: I guess the process didn't really talk about committing to the repo
23:44:21 <bcotton> From my perspective, it seems like the ticket statii aren't intuitively labelled and/or the steps are slightly out of order, but my perspective has been known to be a bit....suboptimal before
23:45:20 <Sparks> Well, I'm open to suggestions.
23:45:23 <Sparks> and it is a wiki!
23:45:55 <bcotton> sparks: now that i re-read it, it does say attach the patch to the bug, so that makes more sense as written, but i'm thinking that the people most likely to actually submit a patch probably already have repo access, so they'd just commit the patch directly?
23:47:00 <Sparks> In a perfect world the commit would occur after the QA
23:47:13 <bcotton> i've got no specific suggestions at the moment, and this certainly beats having no procedure, so i'm content to give it a +1 and then make some edits later if i have real ideas
23:47:27 <Sparks> Okay
23:47:29 <Sparks> anyone else?
23:47:38 <bcotton> i think it's a good start, we might just want to flesh it out more at some point
23:47:43 * bcotton is done for real now
23:48:29 <Sparks> #topic Open floor discussion
23:48:35 <Sparks> Okay, anyone have anything else?
23:49:28 <Sparks> Anyone?
23:49:30 <Sparks> Anything?
23:50:09 <Sparks> Okay, thanks everyone for coming out today!
23:50:24 <Sparks> #endmeeting