fedora_docs
LOGS
23:00:10 <Sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
23:00:10 <zodbot> Meeting started Wed Jul  7 23:00:10 2010 UTC.  The chair is Sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:00:10 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:00:11 <Sparks> #meetingname Fedora Docs
23:00:11 <zodbot> The meeting name has been set to 'fedora_docs'
23:00:11 <Sparks> #topic Roll Call
23:00:31 * Sparks is here
23:00:45 * jjmcd 
23:00:49 * crantila is here
23:01:19 * jmtaylor waves
23:01:40 <Sparks> quaid: You here tonight?
23:01:59 * rudi is here
23:02:10 <jjmcd> quaid fingers prolly work out from tweeting all dat
23:02:15 <jjmcd> day
23:02:41 <Sparks> he is a tweeting monster isn't her
23:02:47 <Sparks> s/her/he
23:03:39 <Sparks> Okay, let's get started.
23:03:49 <Sparks> #topic Follow up on last week's action items
23:03:59 <Sparks> #action jjmcd to have doc-publican-rpm packaged and submitted for review by 14 July
23:04:09 <jjmcd> Working on it but a little behind
23:04:18 <Sparks> Ok
23:04:23 <Sparks> rudi_ and nb to come back with additional information on getting docs-writers building packages in koji for docs.fp.o
23:04:24 <jjmcd> got tagged for a surprise pres on saturday, eating up my time
23:04:31 <Sparks> heh
23:04:49 <Sparks> rudi: Got anything to talk about with the koji thing?
23:05:13 <rudi> Sparks -- sorry, not much progress this week (Publican 2.0 kinda ate up the time), but:
23:05:57 <rudi> One obvious thing I hadn't really considered previously is that we're going to have to be building those docs packages for EL5, not Fedora, since that's what the server is running...
23:06:34 <rudi> So maybe the current Koji instance isn't the best place to be doing this anyway
23:06:58 <Sparks> Can this be a self-contained instance on the same server?
23:07:33 <rudi> Don't know; that's something I'll need to find out
23:07:36 <Sparks> Okay.
23:08:01 <Sparks> #action rudi to come back with additional information on getting docs-writers building packages in koji for docs.fp.o
23:08:11 <Sparks> #action quaid to bring to the list a discussion about Beacon and web-based XML editors for Docs use.
23:08:20 <Sparks> #action quaid will kindly ask poelcat to put up taskjuggler schedule sources in a f'hosted repo, pref. git
23:08:33 <Sparks> Sparks to discuss bug maintenance on the list
23:08:47 <Sparks> Okay, I did this and I'll bring it up later in the meeting
23:09:19 <Sparks> #action Sparks Work on magazine article work about the guides and docs.fp.o
23:09:44 <Sparks> This is in progress.  I'm currently working with Marketing on this.
23:10:07 <Sparks> I think that is all the old topics.  Anyone have anything else old before moving on?
23:10:27 <Sparks> #topic Fedora 14 Schedule
23:10:40 <Sparks> I think we've had some input on the list about the Fedora 14 schedule
23:11:17 <Sparks> #link http://poelstra.fedorapeople.org/schedules/f-14/f-14-docs-tasks.html
23:11:18 * jjmcd gave a quick look over John's updates.  On the surface looks good.  Haven't had the time for the fine-toothcomb thing yet
23:11:45 <Sparks> jjmcd: Okay, I'm assuming you'll be working with poelcat on that via the Docs list, correct?
23:11:46 <jjmcd> Probably won't until after 7.16, either
23:11:50 <jjmcd> roger
23:11:58 <Sparks> ok
23:12:03 <Sparks> Anyone else?
23:12:37 <Sparks> #topic Publican
23:12:54 <Sparks> rudi: Want to talk about the latest release of Publican that went stable earlier today?
23:13:07 <rudi> Thanks for the Karma everyone :D
23:13:51 <rudi> Basically, there's a whole bunch of bug fixes in there, and the web publishing component is now part of the stable release
23:14:38 <rudi> We're now *so close* to automating the whole process :)
23:15:00 <Sparks> #link https://fedoraproject.org/wiki/Publishing_a_document_with_Publican
23:15:06 <jjmcd> automation is a lovely thing
23:15:11 * jjmcd has some q's for rudi after the meeting if he has time
23:15:18 <rudi> So thanks to everyone who got behind us on this -- many of the bugs and issues came out of the docs and trans communities
23:15:22 <rudi> Absolutely
23:15:30 <rudi> But yeah, that's about the size of it :)
23:15:59 <Sparks> excellent.
23:16:06 <Sparks> Anyone have any questions for rudi?
23:16:17 <Sparks> Or any questions about Publican?
23:16:18 <bethlynn> is publican now part of the workflow?
23:16:29 <rudi> bethlynn -- has been for about 18 months now
23:16:36 <jjmcd> bethlynn has been since ~F10
23:16:42 <Sparks> bethlynn: It is the middle and end portion of the workflow
23:17:03 <jjmcd> ooohhh oooohhh see the workflow document
23:17:20 <bethlynn> should we add it the new how to use publican to the "needs some love" workflow page
23:17:29 <Sparks> It creates the final files for consumption and then publishes those files to the web
23:18:02 <jjmcd> We need detail under the bubbles, and the how to use publican is certainly a part of that
23:18:28 <bethlynn> https://fedoraproject.org/wiki/Docs_Project_workflow
23:18:32 <rudi> bethlynn -- there's actually a complete Publican User Guide in the "Contributor Documentation" section of d.fp.o
23:19:16 <Sparks> #link https://fedoraproject.org/wiki/Docs_Project_workflow
23:19:24 <jjmcd> bethlynn, I should remove the needs love template, or modify the words, since what is visible is now up to date
23:19:25 <crantila> a brief overview on the Wiki might still be nice
23:19:31 <rudi> Oh absolutely
23:21:16 <Sparks> bethlynn: Can you and jjmcd work together after the meeting to clean up those pages?
23:21:20 <bethlynn> jjmcd: absolutely.... "this is out of date" does not help wiki gardeners.... "this is out of date because..." helps because you can remove the love tag when stuff gets fixed
23:21:59 <bethlynn> sure. jjmcd, I'll be online after the meeting
23:22:01 <jjmcd> bethlynn, yes, it was out of date a few weeks ago, what is visible now is up to date, but a lot of detail below the line needs to be reworked and incorporated
23:22:30 <jjmcd> (if you look at the source a LOT of stuff is commented out)
23:22:55 <Sparks> Okay, anything else on the Publican topic?
23:23:32 <Sparks> #topic Release Notes
23:23:38 <Sparks> jjmcd: Anything on the RNs?
23:24:02 <jjmcd> Not really.  I see where jmtaylor worked on a bug but git and the list don't agree
23:24:16 <jjmcd> Not a lot happening right now
23:24:17 <jjmcd> .
23:24:34 <jjmcd> Coming up on the schedule is arranging beat writers, so that is the next big thing
23:24:45 <Sparks> Okay, maybe you can work with jmtaylor afterwards and clean that up?
23:24:56 <jjmcd> If you would like to be a beat writer, raise your hand. If you already were, you will be hearing from me
23:25:20 <jjmcd> Sparks, I won't be very coherent until after the 15th, maybe a few days sooner
23:25:26 <Sparks> Okay
23:26:15 <Sparks> #topic Guide Status
23:26:40 <Sparks> I'm proud to say that I posted a patch for a four year old bug today!  :)
23:27:06 * jjmcd added info to a Publican bug today
23:27:23 <rudi> Yeah, thanks jjmcd
23:27:24 <Sparks> Instructions for obtaining information on CVEs in updates will be included in the Security Guide for F14.
23:27:48 <jjmcd> rudi, sorry so sleaux.  Don't boot windoze all that often
23:27:51 <Sparks> Is anyone in need of assistance with anything?
23:27:57 <Sparks> for their guide?
23:28:12 <jjmcd> darn
23:28:28 * jjmcd could use lots of assistance, but not with a guide
23:28:35 <Sparks> heh
23:29:44 <Sparks> Anyone else have anything?
23:30:19 <Sparks> #topic Outstanding BZ Tickets
23:30:26 <Sparks> #link https://bugzilla.redhat.com/buglist.cgi?query_format=advanced&classification=Fedora&product=Fedora%20Documentation&bug_status=NEW&bug_status=ASSIGNED
23:30:47 <Sparks> #info 93 open bugs
23:31:11 <Sparks> #info 24 new bugs
23:31:50 <Sparks> bcotton: I see a few bugs open with your name on them for the RPM Guide.  Need any help with those?
23:32:50 <Sparks> I also see a bunch for silas as well.
23:33:00 <bcotton> sparks: not particularly at the moment, i just need to sit myself down and work on them
23:33:15 <rudi> Mostly filed by himself as his "todo" list I think
23:33:21 <Sparks> bcotton: It looks like your bugs might be as old as the one I worked on today!
23:33:32 <Sparks> rudi: Yeah, I think so
23:33:36 <rudi> He's on leave right now
23:33:38 <Sparks> bcotton: Understood
23:33:41 <Sparks> rudi: Ahhh
23:33:49 <bcotton> sparks: no doubt. most of the rpm guide bugs are from around the time the guide was last updated, i think :-)
23:34:07 <Sparks> bcotton: Probably
23:34:26 <rudi> Just a reminder to all (including myself) that we are now 7 weeks away from branching for F14 -- let's work as many of these as we can!
23:34:28 <Sparks> well if anyone needs any help fixing a bug bring it up on the list so we can try to help
23:36:17 <Sparks> #topic Open floor discussion
23:36:19 * jmtaylor nods and offers to help with any bugs someone needs a hand with
23:36:26 <Sparks> Okay, anyone have anything they want to discuss?
23:37:56 <Sparks> Anything at all...
23:38:42 <Sparks> Okay then.  Good meeting all!
23:38:49 <Sparks> Thanks for coming out!
23:38:53 <Sparks> #endmeeting