summer_coding_sig
LOGS
15:00:36 <quaid> #startmeeting
15:00:36 <zodbot> Meeting started Wed Jun 16 15:00:36 2010 UTC.  The chair is quaid. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:36 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:00:44 <quaid> #meetingname Summer Coding SIG
15:00:44 <zodbot> The meeting name has been set to 'summer_coding_sig'
15:01:03 <quaid> #topic Welcome, say howdy as a roll call until ~:05
15:01:06 <abadger1999> hey
15:01:07 <quaid> howdy :)
15:01:31 <Shrink> howdy
15:01:55 <pilhuhn> hi
15:03:42 * quaid has his coffee now :)
15:04:11 <quaid> first early morning cup in some days, but this AM I think I need the kick
15:06:39 <quaid> ok!
15:07:33 <quaid> #link https://fedoraproject.org/wiki/Summer_Coding_SIG#Agenda
15:07:50 <quaid> #topic Review of tasks last week + Trac discussion
15:08:10 <quaid> OK, I'm going to pull up the notes from last week and bump the incomplete tasks forward ...
15:08:49 <quaid> #link http://meetbot.fedoraproject.org/fedora-meeting/2010-06-09/summer-coding-sig.2010-06-09-15.03.html
15:08:58 <quaid> ... then we can talk a bit about Trac ...
15:09:36 <quaid> #action Ticket to design team for t-shirt design, maybe larger design theme
15:09:49 <quaid> #action See who wants to help with t-shirt production
15:10:01 * pwbarnes pops in.
15:10:11 <pilhuhn> SWI:ESP 1:0
15:10:15 <quaid> #action JBoss Community logos and Indifex logos in different sponsorship positions
15:10:38 <quaid> sweet, we've got pilhuhn on #wclive!
15:11:02 <pilhuhn> lol - not really
15:11:32 <quaid> #action s/JBoss.org/JBss Community/g across all wiki, etc.
15:11:51 <quaid> #action schedule for Sep-Feb
15:11:58 <quaid> #action plan for Sep-Feb
15:12:06 <quaid> #action plan for infrastucture
15:12:42 <quaid> #action quaid working with RHT partner managers on sponsorship plans
15:12:58 <quaid> #action Do students need to submit proof of enrollment?
15:13:10 <quaid> #action Work out specifics for mid-term and final stipend delivery
15:13:18 <quaid> if you see any missing ...
15:13:22 <quaid> or should be added ...
15:14:01 <quaid> #action Wiki page of active projects with lots of good links, etc. (cross-ref with who sent "yes accepted" email)
15:14:22 <quaid> #action if anyone is missing from the "yes accepted" response, contact mentor and student ASAP
15:15:30 <quaid> #action quaid Configure Trac instance, load all current tasks, assign
15:15:48 <quaid> OK, I'm willing to stop there  with my list
15:16:11 <quaid> so, a while ago we ordered a Trac instance at ...
15:16:23 <quaid> #link https://fedorahosted.org/summer-coding
15:16:57 <quaid> at some point we might get to having tooling that supports admin/organizing, but I doubt it will have a reason to support this side of things ...
15:17:27 <quaid> so for now until changed, we'll start using Trac to managed SIG and program tasks
15:17:54 <quaid> (if anything because that's the one and only solution offered by Fedora Hosted :) )
15:18:03 <quaid> if there are no questions or comments ...
15:18:19 <pwbarnes> To prepare for "some point", we should come up with a clear outline of what we would need in an admin/organizing solution so that we have a target for anyone that wants to start working on it.
15:19:36 <pwbarnes> That might even constitute an idea page.
15:20:11 <quaid> #action Define what is needed on admin/organizing side for e.g. FSoC app to potentially provide; make a wiki page that might be a future idea page.
15:20:30 <quaid> yeah, agreed :)
15:22:18 <quaid> ok, ff
15:22:29 <quaid> sorry, network flub for a moment
15:22:35 <quaid> ok, ready to move on ...
15:22:54 <quaid> #topic Project naming to Fedora Marketing
15:23:03 <quaid> #link http://lists.fedoraproject.org/pipermail/marketing/2010-June/013029.html
15:23:09 <quaid> so, a heads up and please participate etc. ...
15:23:23 <quaid> I had a brainwave the other day that we should engage Fedora Marketing on a new name
15:23:34 <quaid> given all the problems that "Summer Coding" hass
15:24:03 <quaid> we're just starting discussions, and if Robyn and I push on it we can keep it moving ...
15:24:52 <quaid> #info Current name "Summer Coding" is hemisphere-specific and coding-specific, where we want to be 2x/year and ready for "any" contribution.
15:25:25 <quaid> #info Fedora Marketing team requested to help with new name brainstorming, no Trac ticket for this in Marketing queue yet
15:25:27 <rbergeron> :)
15:27:01 <quaid> rbergeron: oh, you've got an IRC highlight on "Robyn", too? :)
15:27:18 <quaid> anyway, not much else here ...
15:27:43 <pilhuhn> s= Students in FSoC :)
15:27:44 <quaid> #action quaid to email SIG about naming discussion in Marketing; will bring stuff back to SIG along the way.
15:27:59 <rbergeron> no - was just watching and saw you talking about the thing we will pick an appropriate acronym for :)
15:28:15 <rbergeron> :D
15:28:17 <quaid> do.not.get.rrix.started
15:28:33 <quaid> ok, now that we've beat that horse a bit ...
15:28:45 <quaid> #topic Project planning for next session
15:29:14 <quaid> #action quaid Make a Sep-Feb planning wiki page
15:29:47 <quaid> to be honest ...
15:30:16 <quaid> I've taken it as a given that we _should_ do a program for Sep to Feb to capture the southern hemisphere long school break aka "summer break"
15:30:34 <quaid> while this is up as a topic ...
15:30:42 <quaid> is there anyone who thinks it's *not* a good idea?
15:31:01 <pilhuhn> Actually .. what about some 'rolling' period
15:31:14 <quaid> how does that work?
15:31:32 <pilhuhn> Students here have break from ~Feb 15th to Apr 15th and then Jul 15th to Oct 15th
15:31:45 * quaid smacks his head
15:31:54 <pilhuhn> So that will not fit the US or Southern schedule
15:32:05 <quaid> yep
15:32:21 <quaid> myself? rolling_schedule++
15:32:39 <pilhuhn> So basically while we may have fixed dates until an application must be in to be considered for FSoC, they could be able to execute when it fits
15:32:53 <quaid> ah, interesting ....
15:33:02 <quaid> so, would that be 2 or 4 fixed dates?
15:33:50 <quaid> e.g. maybe we just have a target every quarter for N or N+1 blocks of time (where N = "roughly now", and +1 = "roughly within the next few months but before the next fixed application date")
15:33:59 <pilhuhn> perhaps soemthing like apr 1 for summer and oct 1 for winter for submission be in, but coding could then be in e.g. june to dec or jan to may timeframe
15:34:21 <quaid> that would work
15:34:23 <quaid> too
15:34:53 <pilhuhn> I don't think we as SIG should have too many dates to look through submissions etc
15:35:05 <quaid> since that is similar to the "best" rhythm that Google worked out, with things ready a few months in advance and a chance for projects/students to work out odd schedules.
15:35:12 <quaid> pilhuhn: good sanity check :)
15:35:32 <pwbarnes> Might want to start with the two-fixed-date structure, then consider increasing it once we have more of the administration infrastructure in place.
15:36:17 <pilhuhn> pwbarnes: yes. But we should not end up each month to go through one submission to find out if this is the best one for the next period :-)
15:36:26 <quaid> agreed
15:36:28 * abadger1999 notes that finding time for all menotring duties is hard.
15:36:49 <pwbarnes> Agreed.
15:36:51 <quaid> 2x per year for each organizing block has a good feel to it
15:36:54 <pilhuhn> I think two or three submission deadlines would pile up enough submissions for each to have enough submissions to pick the best ones
15:37:05 <quaid> cf. Fedora 6 month release
15:37:11 <abadger1999> So having too many points where mentors must be involved in feedback/evaluation/etc will burn out hte mentor pool.
15:37:23 <quaid> oh,hmmm ... we'd want to really NOT be reading applications and finishing a release at the same time ...
15:37:37 <pwbarnes> I would certainly not expect all mentors to participate in all sessions.
15:37:49 <quaid> pwbarnes: agreed
15:38:13 <quaid> I reckon if we get 10% to 20% generic mentor participation each session, that would be good
15:38:22 <quaid> just keep growing the overall mentor pool
15:38:49 <quaid> individual project mentors are different, they have a more specific agenda and would be willing to expend the energy because they are volunteering specifically for that.
15:39:19 <pwbarnes> I doubt we can always avoid conflicts with releases, since schedules are subject to at least some slipping, so I think we just need to make allowances for the potentially-increased load.
15:40:26 <quaid> well ... Oct 1 as a deadline might work
15:40:41 <quaid> if we can make it Oct 15 that will absorb impact and mean "reading applications _after_ the release"
15:41:13 <quaid> Apr 1 might be perfect, it might be in the thick of things ...
15:41:16 <quaid> poelcat: you around?
15:41:26 <poelcat> quaid: yes
15:41:58 <quaid> poelcat: hey, got a rule-of-thumb scheduling around Fedora question for you
15:42:17 <quaid> we're looking at asking mentors to read student applications 2x/year
15:42:39 <quaid> w/ the rough "oct 1/may 1" release for Fedora ...
15:43:07 <quaid> what are good windows/weeks on an average year to figure that people might not be distracted by
15:43:16 <quaid> their own release activities and the tumult around them
15:44:01 <quaid> pilhuhn: I know this is a bit mono-focused, even w/in Fedora sub-projects do things not on that "Fedora 6 month release cycle", but it's such a big drum beat that I want to acknowledge it
15:44:32 <quaid> i.e., we'll never have perfection nor should try, just want to not do avoid obvious scheduling conflicts if we can.
15:45:45 * rrix stumbles in
15:46:21 <quaid> hey
15:46:41 <pilhuhn> of course - and it also makes sense to syncronize with Fedora as Fedora is the main driver here
15:47:01 <quaid> #agreed 2x/year application review cycle, with student project to start on schedule agreed with mentor to allow for the varied schedules in the world.
15:47:35 <quaid> #agreed review the 2x/year after first 12 months (or so) to see if there is value or a way to increase
15:48:06 <pwbarnes> poelcat: So, if we want to avoid asking mentors to review student applications and fighting for release readiness at the same time, what are the best/worst timeframes to schedule application reviews for.
15:48:28 <quaid> #action get algorhythm(s) out to the FSoC project so they are aware of the planning here
15:48:48 <pilhuhn> and allow for students to code within some window after the review, so we can accomodate more high school off time around the globe
15:49:11 <poelcat> quaid: the first month after a release things are usually very quiet
15:49:32 <Shrink> I'm listening, but get it listed in a wiki page.
15:50:16 <quaid> poelcat: that works for Oct I think ...
15:50:24 <poelcat> quaid: so in the case of F14/15... the next windows are RIGHT_NOW and November
15:50:57 <quaid> sadly we need more like "mid-October" and "mid-April"
15:51:19 <pwbarnes> Hrmm... I think the ideal review periods are right in the thick of things.
15:51:27 <quaid> yep
15:51:56 <quaid> the only other way is to actually require people to set things up many more months in advance
15:52:05 <quaid> i.e., move the review periods back a few months
15:52:37 <pwbarnes> Either that, or make the review window larger and hope mentors are able to conduct reviews in the midst of the madness.
15:53:12 <quaid> yeah, like January for May+ starts, and June for Aug+ starts
15:53:21 <quaid> right, multiple weeks for review ...
15:54:18 <quaid> poelcat: well, at least we have this --- the quiet times are when the coding often starts for many school calendars, so at least our mentors are available when it matters the most :)
15:54:33 <quaid> how about ...
15:55:01 <quaid> Session 1 review period: 21 Feb to 7 Apr
15:55:20 <quaid> Session 2 review period: 23 Sep to 7 Nov
15:55:32 <quaid> wow, that's too soon :)
15:55:40 * quaid thinking of this coming Sep
15:56:17 <pwbarnes> I am thinking we could shave a week off of the start of that, or have a one-week "soft" deadline for student applications.  I would like to give students at least a little more time to get applications in.
15:56:27 <quaid> sorry, that was a weird sessiokn 2 math mistake ...
15:56:55 <quaid> Session 2 review period: 23 Oct to 7 Nov
15:57:15 <quaid> pwbarnes: for example ...?
15:57:52 <pwbarnes> Did you also mean a two week session 1 review period rather than 1 1/2 months?
15:59:04 <quaid> yes, I meant 2 weeks, see fix two lines above
15:59:10 <quaid> well, four lines above now :)
15:59:20 <Shrink> Ok people, I will leave.
15:59:58 <quaid> #idea Session 1 review period: 21 Feb to 07 Apr, Session 2 review period: 24 Oct to 07 Nov
16:00:15 <pwbarnes> Late March - early April session 1 review period and late October - early November session 2 review period works for me.
16:00:19 <quaid> #idea Give students more time, including a soft and hard deadline
16:00:33 <quaid> sorry, I'm still crazy with that math, eh?
16:00:49 <pwbarnes> So, when did Fairy Tale Farm open the vinyard?
16:01:02 <quaid> heh, not much room for a vineyard here
16:01:10 <pilhuhn> or if we say "coding time is 4 month", then allow to start/end the 4 month within a 6/7 month time frame
16:01:55 <quaid> #idea "coding time is 4 months" and allow that start/end of 4 month to be within a 6+ month time frame
16:02:48 <pwbarnes> Anyway, we could use "soft" deadlines and let the first week of the multi-week review period also be the last week of the application period.  I do not think that would be too complicated, and it would let us compact the timeframe a little bit, if we decide that is needed.
16:02:59 <quaid> #idea Session 1 review: 24 Mar to 07 Apr.  Session 2 review: 24 Oct to 07 Nov [FIXED]
16:03:08 <quaid> cool
16:03:32 <quaid> I think we have the basic structure and agreement that a rolling program would work and is desireable
16:03:42 <pwbarnes> Agreed.
16:03:43 <quaid> #agreed we have the basic structure and agreement that a rolling program would work and is desireable
16:03:52 <quaid> yay!
16:04:06 <quaid> ok, let's wrap up so as to be efficient and move on, plenty of work to do already :)
16:04:15 <quaid> any other stuff?
16:04:31 <quaid> Channel: does anyone need this channel immediately?
16:04:42 <tibbs|h> FPC doesn't meet this week.
16:04:52 * pilhuhn has to leave ...
16:05:02 <quaid> thanks pilhuhn
16:06:23 <quaid> ok, finishing up ...
16:06:27 <quaid> #endmeeting