spins-sig
LOGS
21:01:59 <brunowolff> #startmeeting
21:01:59 <zodbot> Meeting started Mon Jun  7 21:01:59 2010 UTC.  The chair is brunowolff. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:59 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
21:02:05 <brunowolff> #help
21:02:16 <brunowolff> #halp
21:02:58 <brunowolff> #chair brunowolff nirik
21:02:58 <zodbot> Current chairs: brunowolff nirik
21:03:23 <nirik> #meetingname spins-sig
21:03:23 <zodbot> The meeting name has been set to 'spins-sig'
21:03:33 <brunowolff> #topic who's here?
21:03:41 * nirik is here, sorta. ;)
21:03:42 * brunowolff is here
21:04:02 <brunowolff> It looks like just us two.
21:04:12 <brunowolff> What do you want to try to tackle today?
21:04:26 <nirik> whats your wiki page for topics again?
21:04:43 <brunowolff> Unless this is a bad meeting time for you, changing the meeting time with just the two of us is pointless.
21:05:01 <brunowolff> https://fedoraproject.org/wiki/Spins_SIG_Meetings
21:05:37 <nirik> this time is normally fine with me.
21:05:58 <brunowolff> I'll agree to chair meetings for now, as I want to work on that skill, and you get to do it a lot.
21:06:10 <brunowolff> I don't see that as being the same as leading the team.
21:06:16 <nirik> yeah.
21:06:37 <nirik> I will reluctantly lead things... but I would suggest we make one more attempt at finding someone...
21:06:47 <nirik> perhaps a devel list post / wiki page advertising the position.
21:07:11 <nirik> ?
21:07:21 <brunowolff> I think we can live without a vision leader for now.
21:07:22 <nirik> or do you think it's not worth bothering trying?
21:07:37 <brunowolff> We also need to work out wrangling.
21:08:10 <brunowolff> For F14 we my have to split wrangling duties up and assign spins to people to review.
21:08:40 <nirik> that would be fine with me.
21:08:54 <nirik> perhaps we can get gnome/kde folks more interested in helping out.
21:09:32 <nirik> or make some level of input required for other spins maintainers.
21:09:51 <brunowolff> For posting wanted ads, does posting to the spins list make sense?
21:10:11 <nirik> well, we already posted there... we can try again, but it doesn't seem like it got any interest.
21:10:58 <brunowolff> #topic recruiting
21:11:07 <nirik> ha, I was just going to do that. ;)
21:11:28 <nirik> I can try and ping all the f13 cycle spin maintainers (if I can find their contact info)
21:11:55 <brunowolff> I think we need to recruit people with the ability to review spins, especially complicated ones as those take more time and need more skill.
21:12:22 <nirik> some of the #fedora folks have been playing with various spins. I can see if any of them are interested...
21:12:25 <nirik> in helping out.
21:12:48 <brunowolff> I'd also like to get someone with an overall vision of how spins can help Fedora and try to accomplish goals related to that.
21:13:27 <brunowolff> #action nirik will post on #fedora to try to recruit spin reviewers.
21:13:34 <nirik> well, one thing long term that I think would be nice is to make some way someone can install what the spin does from any fedora install.
21:14:07 <nirik> ie, 'I have fedora of any kind here, and want to try out kde... 'kde-spin setup'' or something... that sets up things the same way the spin would have.
21:14:33 <brunowolff> That should get added to a wish list.
21:15:16 <brunowolff> #action bruno will make sure there is a wish list and nirik's idea of installing spins from a release is noted.
21:15:42 <nirik> #action nirik will also ping existing spin owners.
21:15:54 <nirik> Anything more on recruiting?
21:15:55 <brunowolff> I think there is a lot to figure out for that wish, but for now the main thing is to record the idea.
21:16:14 <brunowolff> At some point we will need to go to the board for help.
21:16:16 <nirik> yeah, not easy
21:16:29 <brunowolff> I don't think we are that point yet, but might be next week.
21:16:45 <nirik> well, not sure what the Board can do off hand...
21:17:21 <brunowolff> Stump for us. Coerce someone. Maybe decide to make spins informal.
21:17:44 <nirik> yeah, if it gets down to just 2 of us who care, perhaps we shouldn't make them anymore. :)
21:18:00 <nirik> welcome dcr226
21:18:11 <dcr226> nirik, thanks, hi
21:18:27 * fenris02 waves
21:18:32 <nirik> we are just talking about trying to get more folks helping out the spins sig.
21:18:38 <brunowolff> #topic referring to spins meeting logs
21:19:06 <brunowolff> I was wondering if when a meeting gets named, there is an easy way to refer to the logs.
21:19:16 <nirik> brunowolff: I invited dcr226 and fenris02 in... they both have been messing with spins/live media of late.
21:19:21 <brunowolff> The way I was recorsding in the past was labor intensive.
21:19:39 <nirik> sadly, I think you need the dates at least.
21:19:54 <brunowolff> Yech.
21:20:13 <nirik> http://meetbot.fedoraproject.org/fedora-meeting/2010-06-07/spins-sig.2010-06-07-21.01.log.txt
21:20:23 <brunowolff> #action bruno will look into how to point to meeting logs and may make an RFE for meetbot.
21:20:57 <nirik> how could it be easier without being overlapping with older meetings?
21:21:23 <brunowolff> A directory with just the spins sig meetings sorted by date.
21:21:34 <nirik> yeah, perhaps we could do something with that via links.
21:22:17 <brunowolff> Then I just need a fixed link from the spins page and the meetings page.
21:22:18 <nirik> it would be good for other groups too.
21:22:55 <brunowolff> It might make sense to have subdirectories for the brief and full logs.
21:23:24 <brunowolff> Or even each log type.
21:23:49 <brunowolff> But I think the summary and full html logs would be the main two of interest.
21:24:02 <nirik> well, figure out whats best, perhaps it can be a FES ticket.
21:24:10 <brunowolff> I think that has that covered for now.
21:24:22 <brunowolff> Let's do meeting time check?
21:24:30 <brunowolff> #topic meeting time
21:24:39 <nirik> this is fine with me.
21:24:44 <brunowolff> How does this time work for you guys for the next few months?
21:24:53 <nirik> dcr226 / fenris02 you guys interested in getting more involved?
21:24:54 <nirik> :)
21:25:12 <dcr226> I am, for sure
21:25:14 <brunowolff> If you are you don't want the meeting time to be a blocker.
21:25:35 <fenris02> yes, certainly.
21:26:17 <brunowolff> Is this time OK for at least the near future?
21:26:18 <dcr226> certainly with appliance-type spins, and testing and so on (where applicable)
21:27:15 <brunowolff> There is sort of a standing agenda at https://fedoraproject.org/wiki/Spins_SIG_Meetings
21:27:36 <brunowolff> We aren't going to get that all covered today, but it's some things we want to look at over time.
21:29:14 <brunowolff> If someone wanted to look at Dan Walsh's proposal for things that might be of concern and possible alternative ways to do what
21:29:42 <brunowolff> he wants that would be a nice project. Juts make some notes on things that need to be looked at more closely.
21:30:13 <brunowolff> We don't a lot of guidelines on tricky things, mostly on the simple stuff.
21:31:28 <brunowolff> OK, not seeing any complaints about time, we'll keep it for now.
21:32:09 * nirik nods.
21:32:14 <nirik> what other topics can we do today?
21:32:41 <brunowolff> #topic kickstart branching for f14
21:32:51 <brunowolff> Any idea what we want to do here?
21:33:21 <brunowolff> Do we want to use master until very close to the release with side branches for alpha and beta?
21:33:35 <nirik> yes, thats what we have done in the past.
21:33:39 <brunowolff> Do we want to branch at the F14 branch?
21:33:42 <nirik> http://git.fedorahosted.org/git/?p=spin-kickstarts.git
21:34:05 <nirik> hum. well, we could do that at branch I guess.
21:34:10 <brunowolff> With git it isn't too hard to push changes to both master and F14.
21:34:37 <brunowolff> It might be best to do more or less what we did last time.
21:34:48 <nirik> see also the proposed dates I had:
21:34:50 <nirik> http://lists.fedoraproject.org/pipermail/spins/2010-May/001153.html
21:34:59 <brunowolff> I was asking because Paul wants us to work on a schedule and that would be part of it I think.
21:35:14 <nirik> yes, related.
21:35:49 <brunowolff> Let's assume we'll do the same as last time for now,
21:35:58 <nirik> ok.
21:36:25 <nirik> changes after branching should be small, so people could sit on big changes and only push them after f14 was released.
21:36:41 <brunowolff> #action bruno will flesh out nirik's schedule suggestions and we can review/vote on it next week.
21:37:22 <nirik> ok.
21:38:13 <brunowolff> I probably can't promise too much else before next week as I have a lot of other Fedora stuff to do.
21:39:07 <nirik> yeah.
21:39:22 <brunowolff> #topic responding to Paul
21:39:40 <brunowolff> What kind of response are we able to give to Paul now?
21:39:55 <nirik> well, this is: http://lists.fedoraproject.org/pipermail/spins/2010-May/001143.html ?
21:40:01 <brunowolff> We still don't have a wrangler.
21:40:02 <nirik> the schedule changes should be part of it.
21:40:11 <nirik> I will step up to do it for now...
21:40:24 <nirik> but I will gladly step aside for someone else who wants to do it. ;)
21:40:46 <nirik> I think also we should change are process to be less passive.
21:41:04 <nirik> ie, spin owners MUST answer sometimes or their spin is dropped.
21:41:21 <brunowolff> Or moved to custom.
21:41:31 <nirik> yeah, or just not produced.
21:41:48 <nirik> [ ] - my wiki page has been updated for f14 and is ready and valid.
21:42:08 <nirik> [ ] - I have tested my spin with the nightlies and it's go for Alpha. Please make it.
21:42:11 <brunowolff> Are you ready to do suggested process stuff or should we wait a bit on that?
21:42:12 <nirik> [ ] - I have tested my spin with the nightlies and it's go for Beta. Please make it.
21:42:20 <nirik> etc
21:42:50 <nirik> well, I have no objections... do we want to let other people chime in?
21:42:52 <brunowolff> Yeah, that might get rid of some of the iso's.
21:43:19 <brunowolff> I was more about you having time to write something up in a short time frame.
21:43:26 <brunowolff> I like that direction.
21:44:01 <brunowolff> I would expect a lot more help from Spin owners. Most of them should be regulars in this meeting.
21:44:23 <nirik> yeah.
21:44:30 <brunowolff> Sort of related, do you know what happened with moblin?
21:44:51 <brunowolff> Did we need to tell Jesse something or did a web page need to get updated that didn't?
21:45:12 <nirik> How about this: I will mail spin owners and mention to them proposed process changes, and ask if anyone would step up to be spins wrangler. Then we make changes "official" next week if no objections.
21:45:12 * dcr226 is happy to work on a spin that's been left for dead, that would still be useful
21:45:41 <brunowolff> OK, that sounds good.
21:45:48 <nirik> well, peter wasn't sure moblin would land in time.
21:45:57 <nirik> since moblin merged into meego.
21:46:06 <nirik> so it sounded like the spin was not going to happen.
21:46:10 <nirik> then it did land and did happen.
21:46:31 <brunowolff> I remember some of that, but I am not sure how releng gets the list of iso's that are supposed to be published.
21:46:47 <brunowolff> And design team for that matter.
21:46:52 <nirik> he was looking at a wiki page.
21:46:59 <nirik> the spins wrangler should update that.
21:47:15 <brunowolff> In some sense moblin might have landed too late.
21:47:26 <nirik> but currently the wiki had passive voice: "the wiki page would be updated"
21:47:33 <nirik> but it didn't say who or when
21:48:39 <nirik> #action nirik will mail spin owners. asking if any would be spins wrangler, and noting dates and proposed process changes.
21:48:52 <brunowolff> #action Nirik will write up proposed changes to the spin process and send it to spin owners along with a request for wrangler volunteers.
21:49:20 <brunowolff> #topic master branch changes
21:49:33 <brunowolff> Did you look at what I did in the master branch?
21:49:59 <brunowolff> In particular changing the custom spins (all two of them) to use ../ so that the extra copies of stuff could be dropped?
21:50:09 <brunowolff> The l10n stuff already had done that?
21:50:32 <brunowolff> I think going forward that is going to cause less problems.
21:50:47 <nirik> yep. That looked fine to me.
21:51:10 <brunowolff> #action brun will write up the documentation for rebuilding spin-kickstarts on the wiki using the new README as a base.
21:51:27 <brunowolff> #action bruno will write up the documentation for rebuilding spin-kickstarts on the wiki using the new README as a base.
21:51:43 <brunowolff> OK. I won't backport that to F13.
21:52:27 <brunowolff> That's probably enough for today, as I am not going to get any more done before next week anyway.
21:52:45 <brunowolff> #action bruno will adjust agenda
21:52:48 <nirik> I'd like to note that nightlies are building against rawhide and going ok.
21:53:04 <brunowolff> I'll update the agenda to add details or remove resolved items.
21:53:14 <brunowolff> That's good.
21:53:37 <brunowolff> I saw dependency issues and wasn't sure if things were really building.
21:54:02 <brunowolff> Do you use the rawhide spin-kickstarts or the git repo for these?
21:55:02 <nirik> git repo
21:55:04 <nirik> head
21:55:31 <brunowolff> Aside for a git question
21:56:36 <brunowolff> The actual branch name is 'master'. Is 'head' the latest version of 'master'?
21:56:57 <brunowolff> Because in my reading it looks like every branch has a 'head'.
21:57:25 <brunowolff> Is 'head' sort of a short hand for the latest version in the development branch?
21:58:23 <nirik> yeah, thats more applicable for other vcses...
21:58:29 <nirik> but yes, Master branch head.
21:58:36 <nirik> newest version.
21:58:45 <brunowolff> OK. Thanks that clears things up a bit.
21:59:00 <brunowolff> I'm still learning git, though I like it.
21:59:29 <brunowolff> I think we have covered enough for today, but does anyone have anything else they want covered today?
21:59:41 * nirik thinks
21:59:47 <brunowolff> Otherwise I'll be ending in 1 minute.
22:00:55 <nirik> oh.
22:01:08 <brunowolff> Go ahead.
22:01:12 <nirik> one other idea I had... can/should we gateway git commits to the spins sig list?
22:01:19 <brunowolff> Yes.
22:01:26 <brunowolff> Can you do that?
22:01:29 <nirik> that way we could see when people land changes late, or etc.
22:01:50 <brunowolff> I remember thinking we should do that in the past.
22:01:59 <nirik> yeah, I think I can set that up possibly.
22:02:11 <nirik> or get some infra folks to help do so
22:02:20 <brunowolff> I can't remember if infrastructure needs to do that.
22:02:38 <nirik> It might be a commit hook they need to add.
22:02:38 <brunowolff> I thought they did, but maybe there is a knob to do it.
22:03:09 <brunowolff> #action nirik will look iinto having spin-kickstart commits gated to the spins list.
22:03:16 <nirik> can do
22:03:27 <brunowolff> Anything else for today?
22:03:33 <nirik> nope
22:03:38 <brunowolff> #endmeeting