bugzappers
LOGS
15:06:16 <adamw> #startmeeting Bugzappers meeting 2010-06-01
15:06:16 <zodbot> Meeting started Tue Jun  1 15:06:16 2010 UTC.  The chair is adamw. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:16 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
15:06:25 <adamw> #topic gathering\
15:06:30 <adamw> who's around?
15:06:39 * nokia3510 salutes
15:06:46 <tcpip40001> hi
15:06:47 * nirik is here.
15:06:55 <adamw> whee. hey, everyone.
15:07:04 <adamw> nokia3510: oh, i got your PM last night, feel free to hit me up in PM after the meeting
15:07:16 <nokia3510> thanks, will do
15:07:41 <adamw> okay, so...
15:07:57 * poelcat 
15:08:02 <adamw> #topic follow-ups: housekeeping
15:08:39 <adamw> not sure if tk009 is around, but maybe poelcat can fill us in
15:08:39 <adamw> poelcat: is housekeeping for f13 looking good?
15:08:51 <poelcat> https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora13#Fedora_11_EOL_Closure
15:08:57 <poelcat> i sent to test list
15:09:17 <poelcat> yes, things are good
15:09:52 <adamw> that looks good to me, fwiw
15:10:04 <adamw> small note - should we change the email address of the user we use for such automated changes?
15:10:13 <adamw> does fedora-triage-list@redhat.com even 'exist'?
15:10:19 <poelcat> adamw: yes
15:10:25 <adamw> ah, okay then
15:10:46 <tk009> ls
15:10:49 <poelcat> adamw: historically it was to discuss triage
15:10:49 <tk009> =)
15:10:57 <adamw> tk009: hiya
15:11:03 <adamw> tk009: you have anything to add on housekeeping front?
15:11:10 <poelcat> everything thought it was better to stay concentrated on the test list
15:11:10 <tk009> sorry no
15:11:29 <adamw> poelcat: we could change the address to test list then, just for neatness, i guess.
15:11:37 <adamw> tk009: no problem, poelcat says we're in good shape
15:11:48 <poelcat> adamw: that would be a mess since then test list would get bugzilla mail
15:11:57 <adamw> poelcat: ah, i see
15:12:08 <adamw> ignore me then!
15:12:27 <adamw> lessee, the only other follow-up we have is mcepl - mcepl, around?
15:12:33 <poelcat> i agree it is kind of goofy the way it currently is, though there doesn't seem to be anything better
15:12:44 <mcepl> yes
15:12:47 <adamw> okey
15:12:55 <adamw> #topic follow-ups: triage scripts
15:13:10 <adamw> mcepl: any new news on triage scripts? how's the rewrite coming?
15:14:52 <mcepl> I get into yet another spiral of self-destruction^H^H^H^H^H^Hrewrite .... after I experienced a religous experience after reading http://ehsanakhgari.org/blog/2010-05-31/my-experience-jetpack-sdk
15:14:57 <adamw> heh heh
15:15:03 <mcepl> and I am now working on really large rewrite
15:15:25 <mcepl> hopefully it should be done fast, but the result should be .xpi module on addon.mozilla.org ;)
15:15:35 <adamw> that kinda hooks up with a question I had - firefox keeps politely informing me that Jetpack is obsolete and there is some sort of New Hotness, but I don't really get the setup
15:15:54 <adamw> so the idea is that you (the writer) can now use Jetpack-y techniques to build something that winds up just being a normal Mozilla extension?
15:16:13 <mcepl> the New Hotness doesn't contain yet all what I would officially need (it should come in 0.5), but the guy in the blogpost shows some dirty tricks how to get around it.
15:16:13 <tk009> its not ready for prime time from what I read
15:16:20 <mcepl> yes
15:16:26 <mcepl> no, it certainly isn't
15:16:36 <adamw> since when has THAT ever stopped us =)
15:16:57 <mcepl> I've made a lot of cleanup in my previous cleanup (which you haven't got yet) so things should look much better now
15:17:33 <adamw> in case anyone's feeling like they jumped in on page 132 - we have Firefox scripts for aiding triage, which you can get at https://fedoraproject.org/wiki/BugZappers/Tools . these are written to use the Jetpack Firefox extension, which - as we're discussing above - Mozilla has decided they want to sort of redo a bit.
15:17:36 <mcepl> adamw: https://fedorahosted.org/bugzilla-triage-scripts/ ... but really, you will probably reedit some files yourself
15:18:21 <adamw> well, the current 'public' release seems to work okay, so is it alright for us to just keep using that until you're ready to drop something new on us?
15:18:48 <mcepl> adamw: well, I would have a bit correction on that "redo a bit" part. When I complained, there is no good conversion path between -prototype (what we use now) and -SDK, the answer I've got was: "Yes, you should forgot fast whatever you learned before"
15:19:10 <adamw> ah, heh. so it has the same name but it's something really different?
15:19:12 <mcepl> i think there is no much worth to use this in-between step.
15:19:14 * nirik wonders how possible a chromium one would be. ;)
15:19:16 <mcepl> completely
15:19:37 <mcepl> but, immensly better ... following non-firefox standards (CommonJS) etc.
15:19:44 <adamw> okay. so for those of us playing along at home, easiest to just stick with the jetpack script and jetpack prototype extension until you let us know the jetpack-SDK created extension is available.
15:19:56 <mcepl> yes, definitively
15:19:57 <tk009> 6-12 months
15:20:12 <adamw> okay, thanks
15:20:35 <mcepl> BTW, if I understand correctly (and I haven't studied that) the result should be much more standard-following then whatever Chrome has now.
15:21:09 <adamw> okay
15:21:31 <mcepl> but I don't understand much of chrome extensions ... if anybody wants to port my scripts to Chromium he is certainly welcome
15:21:59 <adamw> noted
15:22:07 <mcepl> (just aside, I have just finished building out of curiousity webm-containing chromium for RHEL-6; based on http://spot.fedorapeople.org/chromium/)
15:22:24 <adamw> #info mcepl is working on re-re-re-writing the triage scripts using Jetpack-SDK, which is a completely different beast from the Jetpack prototype we are using now
15:22:51 <adamw> #info this would result in the scripts being available simply as a Firefox extension for download from Mozilla, and should make them easier to port to other browsers
15:23:04 <mcepl> well, hopefully (on the last part ;))
15:23:08 <adamw> =)
15:23:14 <adamw> thanks mcepl
15:23:21 <mcepl> more like using non-browser libraries and stuff
15:23:29 <mcepl> there IS server-side Javascript
15:23:41 <mcepl> </report> HOWGH
15:23:53 <adamw> so, that's all we had for follow-ups...
15:24:00 <adamw> next up:
15:24:02 <adamw> #topic kernel triage
15:24:07 <adamw> i believe nirik has a bit of an update for us
15:24:27 <nirik> yeah, I poked a bit more on the wiki page and posted again to the fedora kernel list for feedback.
15:24:44 <nirik> also mcepl provided some good feedback. Some of which I need to still add.
15:24:47 <nirik> http://fedoraproject.org/wiki/KernelBugTriage
15:25:08 <adamw> excellent, glad you're still plugging away on it
15:25:13 <adamw> is there anything the rest of us can help with?
15:25:21 <nirik> I'd like to get another round of feedback from kernel folks and then perhaps try out 10-20 bugs and see what needs adjusting.
15:25:58 <nirik> any feedback on stock responses or things I missed in the wiki page would be most welcom.
15:26:02 <nirik> welcome even
15:26:05 <adamw> cool
15:26:12 <adamw> so we should take a look at the wiki page and pass on any thoughts
15:26:26 <mcepl> nirik: did you get even my second round of comments?
15:26:53 <mcepl> I think I can dig it up from my IRC logs if needed
15:26:53 <nirik> mcepl: yeah, I was away from keyboard, but I saw them.
15:26:56 <nirik> http://lists.fedoraproject.org/pipermail/kernel/2010-May/002465.html
15:26:57 <mcepl> ok
15:27:01 <nirik> is my post to the kernel list.
15:27:26 <nirik> I got them... need to add those/modify the wiki page based on those still. Will do that today if I can.
15:27:47 <adamw> #info nirik is still working on kernel triage: he has updated the wiki page further and asked for a second round of feedback from the kernel team
15:27:53 <adamw> #link http://fedoraproject.org/wiki/KernelBugTriage
15:28:09 <adamw> #info feedback on the wiki page and any suggestions for additions would be welcomed
15:28:39 <nirik> rawhide currently only has about 75 bugs, a number of which are already assigned or whatever.
15:28:54 <nirik> 264 for f13, so it's a bigger target.
15:29:03 <adamw> still, both seem like manageable numbers
15:29:08 <nirik> yeah.
15:29:31 <nirik> f12 -> 812
15:29:43 <adamw> so f13 is clearly much less buggy!
15:29:44 <adamw> we win
15:30:12 <nirik> (unless my queries are wrong. ;)
15:30:28 <nirik> anyhow, any feedback welcome.
15:30:29 <adamw> heh
15:30:32 <adamw> okay, thanks
15:30:58 <adamw> let's see, i don't think we have anytihng else; we don't need to talk about f14 till closer to branch point, i think, that's when all the housekeeping happens
15:31:08 * adamw wonders if oxf13 or notting are lurking
15:31:35 <mcepl> nirik: one comment, which I would like to hear feedback from adamw and other Bugzappers.
15:31:44 <nirik> sure, fire away.
15:31:57 <mcepl> when reading https://fedoraproject.org/wiki/KernelBugTriage ... the stock comments have very different tone than the Bugzappers' ones
15:32:17 <mcepl> I was telling it to you yesterday, but I would like to get a feedback
15:32:23 <adamw> that's true
15:32:29 <adamw> it would make sense to make them more consistent
15:32:30 <nirik> yeah, they were left over from the orig version of the page.
15:32:43 <mcepl> we are much more business-like ... "singular tense, instead of pliural" ... etc. What do we think?
15:32:43 <nirik> I'd be happy to make them match the other bugzappers messages.
15:33:51 <mcepl> my hope would be that reporters' would feel like bugzappers actually know what they are tlaking about and cooperate more willingly
15:34:01 <nirik> Basically that page was written by Chris Brown...who singlehandedly was doing kernel triage for a while.
15:34:04 <adamw> yeah, i think we should have kernel messages follow current bugzappers style rather than vice versa
15:34:20 <nirik> that may even have been before bugzappers existed. ;)
15:34:34 <nirik> anyhow, no objection to me to using the normal bugzapper style.
15:34:36 <adamw> way back in the mists of time, huh :)
15:34:39 <adamw> nope, none at all
15:35:24 <nirik> if someone would be willing to edit the page for that, that would be great, or I can look at doing so later.
15:35:53 <adamw> #agreed kernel triage stock messages should be synced with bugzappers stock messages, anyone can go ahead and do this
15:36:05 <adamw> we may even be able to just combine them into one page and retire some of the kernel-specific ones...
15:36:39 <nirik> that would be fine too.
15:36:50 <mcepl> nirik: actually, yes, the origin is in some internal RH common stock messages ... now thirty times completely rewritten
15:37:02 <nirik> yeah.
15:37:15 <adamw> okey dokey
15:37:23 <adamw> so, i think we can go on to...
15:37:25 <adamw> #topic open floor
15:37:29 <nirik> that wiki page was imported from moin. ;)
15:37:51 <adamw> anyone have a story to sing, a dream to share, a unicorn to set free?
15:39:15 <adamw> aww, no unicorns?
15:39:17 <adamw> *single tear*
15:39:50 <mcepl> if pointed well, that tear can do some good work!
15:39:55 <nirik> oh, I have a quick query:
15:40:08 <adamw> go for it
15:40:47 <nirik> I see folks joining bugzappers pretty regularly... is there any sense on how many stay active? is there a good retention on folks moving forward? or do many end up not being very active? or we don't have any idea?
15:41:29 <adamw> the last one, unfortunately :/
15:41:35 <tcpip40001> once upon a time I did a research about that
15:41:37 <adamw> this was something triage metrics was meant to solve, and, well, yeah
15:41:51 <adamw> maybe we should give up on _that_ unicorn and set up some more basic bugzilla searches to give us a rough idea
15:41:55 <tk009> mentors is the answer not metrics
15:42:22 <tk009> people leave cause there is no one to help guide them
15:42:34 * mcepl notes that unicorns are much more real than bug-triage metrics system ....
15:42:41 <nirik> ha
15:42:43 <mcepl> tk009: +1000
15:42:44 <tk009> like if zapping isnt their thing we are much helping finding the right place for them
15:42:50 <tk009> are not*
15:42:52 * nokia3510 tends to agree with tk009
15:43:24 <tk009> I have always though of the zappers as an intro to the project
15:43:31 <tk009> a place to start
15:43:59 <tcpip40001> as tk009 says is more useful to spend the time mentoring than researching what is doing everyone
15:44:02 <nirik> yeah, it's easy to join and start doing something.
15:44:34 <tk009> most zappers are going it solo
15:44:44 <tk009> self starter kind of thing
15:44:53 <adamw> yeah, it's a nice idea. we keep hitting it from various angles but never quite making it fly
15:45:14 <mcepl> adamw: what is the nice idea?
15:46:12 <tk009> no easy solution to this one
15:46:32 <adamw> mcepl: some sort of post-signup-assistance for new zappers
15:47:05 <mcepl> well, we shout at them consistently that #fedora-bugzappers is the place
15:47:12 * mcepl is guilty not being there enough
15:47:28 <tk009> you can't be there all the time, none of us can
15:47:28 <mcepl> aside from actually being there, what else we should do?
15:47:53 <adamw> yeah, it's tricky
15:47:58 <adamw> as tk009 says, no easy solution
15:48:01 <nokia3510> aggressive publicity ? :)
15:48:05 <jagledy> sombody mentioned screen casts in the emails.
15:48:16 <tk009> I was the one that mentioned that
15:48:43 <tk009> I have been thinking about doing a few that would show how and what we do
15:49:02 <nokia3510> perhaps a better presence on dedicated forums ? I can talk to leigh123linux on fedora forums on that
15:49:05 <mcepl> yeah, and I was waiting that somebody will tell me to show somewhere ...
15:49:07 <adamw> yeah, it's a nice idea, no-one's done 'em yet =)
15:49:21 <adamw> nokia3510: i read the forums, but forums are a terrible terrible interface for getting collaborative work done
15:49:26 <mcepl> OK, -1 on that ... I won't spend any time on fora ... sorry
15:49:29 <adamw> mailing list is much better from that perspective
15:49:52 <adamw> i don't think we've lost anyone yet because they wanted to use the forums rather than the mailing list? willing to be proved wrong, though
15:50:16 <tk009> if it happened in was not a loss
15:50:32 <adamw> nokia3510: you can see how people love the forums around here =)
15:50:33 <tk009> I read the forums all the time
15:50:49 <nokia3510> adamw: sorry, I meant perhaps more pointers on this direction would be welcome, not spending time on forums
15:50:56 * nirik puts forums 3rd in his time... so I seldom get there anymore.
15:51:44 <adamw> nokia3510: ah, i see. it's a bit tricky to maintain a visible 'presence' in forums though, you can only do it by posting there a lot
15:51:53 <adamw> and we can't really post about bugzapping stuff in the forums
15:52:07 <tk009> says the guy that is up to like 1700 posts
15:52:31 <tk009> true on that last bit
15:52:56 <mcepl> nokia3510: I mean, if you want to be our ambassador on fora, feel free to be officially commissioned ;)
15:53:19 <nokia3510> I'll try :)
15:53:35 <adamw> tk009: sure, but I don't post about bugzapping much :)
15:53:49 <tk009> you help and are visible
15:53:54 <tk009> that is what matters
15:54:00 <tk009> they know who adamw is
15:54:13 <tk009> love him or hate him =P
15:54:23 <tcpip40001> the most important point of information is the wiki,,,, I wish there was some kind of bugzappers wiki index to browse everything related from there, and maybe there was not neccesary to send all those links to new bugzappers but one
15:54:25 <adamw> as long as you respect my iron fist it's all good
15:54:44 <adamw> tcpip40001: the front page is meant to act as an index more or less
15:54:53 <adamw> tcpip40001: you should be able to get to every bugzapper-related page from the front paeg
15:54:53 <adamw> https://fedoraproject.org/wiki/BugZappers
15:55:01 <mcepl> and isn't there are a BugZappers category?
15:55:05 <adamw> i think so...
15:55:15 <adamw> oh, hmm, maybe just the qa category
15:55:17 <mcepl> err, no ... it's QA
15:55:31 <tk009> it was change a couple months back
15:55:37 <tk009> changed*
15:55:38 <adamw> but definitely if you think we can add more to the front page, please suggest it...
15:56:16 <tcpip40001> for example the kernel triaging page looks very important
15:56:31 <adamw> hold on folks i have to go pick up a parcel
15:56:32 <adamw> brb
15:56:50 <tcpip40001> but fill the main page with those links could make it cumbersome
15:56:55 <nirik> tcpip40001: yeah, it should be in the same categories, etc... of course it's not done yet.
15:58:06 <tk009> the wiki is constant change, always evolving. As adamw said please do speak up if you see things that could be better
15:59:33 <tcpip40001> ok,,,,, in the other hand, I want to state that F13 feels much faster and stable than F11 or F12 ,,, and the QA has raised the bar of this release thank you all for this great release
15:59:53 <adamw> the kernel triage page is kind of a special case because it's an old page that doesn't actually reflect current practice and needs updating
16:00:01 <adamw> that's why it hasn't been included in the bugzappers wiki structure yet
16:00:50 <nokia3510> how about having a link to the latest bugzapper meetings log in the main page ?
16:01:17 <tk009> there is a meeting link
16:01:24 <adamw> not a log link, though
16:01:34 <adamw> it's a nice idea - i'd just worry that it might get stale (we'd forget to do it :>)
16:01:51 * adamw is always scared of putting anything in a wiki which can go stale quickly
16:01:56 <adamw> because in the end it almost always does
16:02:09 <nirik> how about a thing noting that meeting logs are in meetbot.fedoraproject.org, etc.
16:02:25 <adamw> that would work, ypu
16:02:33 <nokia3510> thanks nirik, that was my point
16:02:52 <nirik> of course would need some poking around to find it.
16:03:13 <adamw> right, but at least you'd know where to look...
16:03:24 <nirik> adamw: it would help to #meetingname bugzappers this.
16:03:42 <nirik> it uses that for the filename...
16:03:44 <nirik> if set
16:04:09 <adamw> nirik: d'oh, that's the tagh
16:04:16 <adamw> i always forget it
16:04:19 <tk009> me as well
16:04:34 <nirik> yeah, I have a file here for meetings that I add all that stuff to, so I can just paste it.
16:05:20 <tk009> we are over time and not sure if someone is after us
16:05:23 <adamw> yeah
16:05:28 <adamw> thanks for the input everyone
16:05:39 <adamw> let's get out of here and eat some cookies =)
16:05:52 <nirik> you can do the meetingname anytime. ;)
16:06:07 <adamw> i think it then starts a new log under the new name from that point on though?
16:06:24 <adamw> i seem to recall when jlaska uses it for qa meetings, you get two lines under a generic name, then the rest of the meeting under the qa name
16:06:41 <nirik> yeah, because it logs as the meeting goes on.
16:06:50 <nirik> but once meeting is ended it should write out the name I thought.
16:06:55 <adamw> oh, okay.
16:06:57 <adamw> well let's try it
16:07:02 <adamw> #meetingname bugzappers
16:07:02 <zodbot> The meeting name has been set to 'bugzappers'
16:07:04 <nirik> if not it would be a bug, IMHO
16:07:08 <adamw> we'll see =)
16:07:11 <adamw> thanks again everyone
16:07:14 <adamw> #endmeeting