fedora-meeting
LOGS
23:00:37 <sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
23:00:38 <zodbot> Meeting started Wed Apr 28 23:00:37 2010 UTC.  The chair is sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:00:40 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:00:45 <sparks> #topic Roll Call
23:00:47 * sparks 
23:00:50 * jjmcd 
23:00:50 * rudi_ is here
23:00:52 * Gearoid 
23:00:55 * ke4qqq 
23:01:17 * Emad78 is here
23:01:46 * gbinns 
23:02:20 * nb here
23:02:23 <sparks> Okay, lots of stuff to talk about so lets get started.
23:02:26 <nb> stickster, sparks can we cover my parts first if possible? I am not sure how long i will be able to remain
23:02:35 <sparks> nb: Yep
23:02:47 <sparks> #topic git repo conversion
23:02:51 <sparks> nb: Go
23:03:07 <nb> conversion is basically done, you can go ahead and pull ssh://git.fedorahosted.org/git/docs/web.git and commit to it
23:03:18 <nb> the sync script is not running yet, will have it done when i get home in a few hours
23:03:22 <nb> but i tested it and it is working fine
23:03:32 <nb> any member of docs group has commit access
23:03:44 <nb> i tested the sync script and it works ok
23:03:55 * noriko sorry here
23:03:57 <sparks> nb: So you commit to it and it magically appears on the web?
23:04:02 <nb> sparks, every hour
23:04:12 <sparks> excellent
23:04:19 <ke4qqq> nb: commit mail setup?
23:04:20 <nb> at 5 mins past the hour it pulls from git onto bapp01, and then at 10 mins past the hour the proxies sync it
23:04:27 <nb> ke4qqq, no, i need to do that
23:04:36 <ke4qqq> nb - if you want I'll take care of that
23:04:36 <sparks> #info docs.fp.o backend has now moved to git
23:04:50 <sparks> #info the web-frontend syncs with git every hour.
23:04:59 <jjmcd> we had talked about organizing it.  Any issues with a commit that turns out to be a massive change?
23:05:04 <nb> the other discussion we had on irc today was the idea of making docs be the commit group for the docs repos too
23:05:26 <nb> that's the way it was historically until we moved to git for all the docs
23:05:44 <jjmcd> One concern I have is that there is a lot of old stuff in the docs group
23:05:58 <jjmcd> Perhaps some maintenance is in order
23:05:58 <ke4qqq> is there?? I thought sparks cleaned that out regularly
23:06:17 <jjmcd> Have to admit, I haven't really looked hard lately
23:06:25 <sparks> ke4qqq: I do not because I seem to get flac everytime I do...  of course it is from one person.
23:06:27 <ke4qqq> there's also a number of docs that aren't under /git/docs - is the plan to migrate them under docs?
23:06:36 <nb> ke4qqq, i can do if we want
23:07:02 <nb> but docs being commit group is independent of if they are under /git/docs
23:07:08 <ke4qqq> that's probably something the docs group needs to go identify - see the repos that aren't under docs/
23:07:16 <ke4qqq> and give you a list
23:08:39 <ke4qqq> sparks: feel free to task me with that - I'll push such a list to the m-l first and then elsewhere
23:09:12 <sparks> ke4qqq: What do you want to do?
23:09:29 <ke4qqq> identify the guides/other items that aren't under docs/
23:09:49 <sparks> #action ke4qqq to identify the guides/other items that aren't under docs/
23:09:58 <ke4qqq> so that they are all under that group for easy of managing things from infras perspective
23:10:04 <sparks> Works for me
23:10:40 <jjmcd> nb, any reason why sometimes when you look at git on the web you get mirror-manager
23:11:03 <jjmcd> seems to be only last week or so
23:12:51 <sparks> I'll ask a question I had while nb has paused...
23:13:11 <sparks> Who needs help with git?
23:13:27 <Emad78> I can always use help
23:13:36 <nb> Can look
23:13:38 <sparks> Okay... how about this...
23:13:41 <nb> I am semi here
23:13:53 <sparks> after the meeting we'll help people with git in #fedora-docs.
23:14:07 <ke4qqq> nb does this mean we can do away with the scores of docs fas groups?
23:14:10 <nb> Do we want to move them all under docs? And use docs as group?
23:14:14 <nb> Yes we could
23:14:39 <nb> We can't delete but we can inactive them and just not use them
23:15:08 <rudi_> +1 to one group to rule them all
23:15:10 <sparks> Does anyone have a problem with just using the docs group as a master key to all repos and to docs.fp.o?
23:15:11 <ke4qqq> that makes life a lot simpler
23:15:14 <jjmcd> I think we may want to talk about that for a bit, tho
23:15:16 <nb> Less complexity that way
23:16:00 <jjmcd> But perhaps in another forum when there is more time, tho
23:16:15 <rudi_> If we want to get translators more involved in publishing translated docs, would we just add them to the docs group? Or allow cvsl10n to push to the site repo as well?
23:16:33 <sparks> rudi_: We could
23:16:34 <nb> Adding to docs is easier
23:16:43 <rudi_> +1 easier :)
23:16:47 <nb> But theoretically could use setfacl
23:16:47 <sparks> I think a lot of the translators are already in docs.
23:18:07 <sparks> Okay, so lets table the making docs the master key until next week.
23:18:23 <sparks> Good?
23:18:26 <nb> It's 2 parts too
23:18:38 <sparks> 2 parts?
23:18:44 <nb> The group having access, and moving under docs/*
23:18:53 <sparks> Good point
23:18:56 <nb> 1 is easy 2 requires coordination
23:19:15 <nb> We could go ahea and do 1 and wait on 2
23:19:18 <jjmcd> After zeroday we'll have a quiet spell
23:19:20 <ke4qqq> yes 2 will break things for those not paying attention
23:19:28 <sparks> Okay...
23:19:49 <sparks> #idea Make the docs group a master key to all git repos
23:20:02 <sparks> #idea move all git repos under docs/
23:20:13 <sparks> Tabled until next week.
23:20:21 <sparks> all in favor?
23:20:24 <sparks> +1
23:20:50 <jjmcd> +1
23:20:53 <rudi_> +1
23:21:04 <nb> I'd suggest going ahead and doing 1 beore the freeze
23:21:09 <nb> But can wait if we want
23:21:27 <sparks> We don't have much time do we?
23:21:30 <jjmcd> I think that is the one that needs the most discussion, but that is apparently just me
23:21:30 <nb> +1 to deferring moving all to docs/*
23:21:41 <nb> I can have the group changes done tonight
23:21:46 <ke4qqq> I am slightly concerned because of l10n - for pre freeze - are we sure we won't disrupt them by changing perms
23:21:53 <nb> It just takes a couple chgrps
23:22:17 <nb> I can doublecheck to make sure everyone is in docs group
23:23:39 <sparks> Can someone move this discussion to the docs list?
23:23:52 <nb> Ok
23:24:02 <nb> Well karsten already started it
23:24:04 <nb> Kind of
23:24:21 <sparks> nb: Can you follow up to that message with the addtional thoughts?
23:24:28 <nb> Yeah
23:24:41 <sparks> thanks.
23:24:48 <sparks> Okay, anything else on this topic?
23:25:04 * sparks notes we just blew the schedule out the window
23:25:07 <nb> FYI pushing to git is ok Noe
23:25:08 <nb> Now
23:25:14 <nb> Just won't sync yet
23:25:16 <sparks> nb: Cool
23:25:21 <nb> Gtg now
23:25:27 <jjmcd> thanks nb
23:25:29 <rudi_> Thanks nb
23:25:32 <nb> Email me or ping me
23:25:33 <nb> And I'll read scrollback
23:26:05 <sparks> Okay... let's start with the top of the agenda, now.
23:26:22 <sparks> #topic Follow up on last week's action items
23:26:30 * jjmcd marked his done items so we don't have to spend time on them
23:26:41 <sparks> stickster noted that his items weren't due until next week so...  not a problem.
23:26:46 <jjmcd> stickster did 2 but 3 is next week
23:26:59 <jjmcd> but we do need to re-add it as an action
23:27:16 <sparks> I did #6 but need to bring up SELF on the list
23:27:32 <sparks> #action stickster On 2010-05-04 UTC 0001, build {S,}RPM, get it into Package CVS, build in koji, push to bodhi.
23:28:03 <sparks> rudi_: what's up with #4 and #5?
23:28:41 <rudi_> #4 -- I made a large post to docs-list a few days back
23:28:51 <rudi_> Tech demo is in place and live
23:29:26 <rudi_> Since the move to "Option 1" is already underway, I hope to implement "Option 1.5" for f13
23:29:33 <sparks> okay
23:29:44 <rudi_> In other words, using git to manage indexes generated by Publican
23:29:51 <sparks> cool
23:30:01 <rudi_> I've already got hosting for the menu and welcome page stuff
23:30:04 <rudi_> (thanks ke4qqq)
23:30:11 <rudi_> But haven't checked it in yet
23:30:22 <rudi_> I'd appreciate any feedback on the content of the welcome page
23:30:39 <rudi_> because if it's OK, I can then hand it off to get translated!
23:30:44 <sparks> Where is it?
23:30:57 <jjmcd> link in ml
23:31:21 <sparks> ml?
23:31:30 <jjmcd> mailing list
23:31:40 <sparks> Ah
23:31:43 <sparks> ok
23:31:53 <rudi_> http://publictest8.fedoraproject.org/fedoradocs/public_html/en-US/index.html
23:31:57 <sparks> rudi_: Did you get with laubersm?
23:32:11 <sparks> #link http://publictest8.fedoraproject.org/fedoradocs/public_html/en-US/index.html
23:32:30 <rudi_> She got with me; UG appears complete now and is in L10N
23:32:53 <sparks> #action stickster Fix Live image information and respond to thread pointing to next regular build on fp.o
23:33:06 <sparks> rudi_: Did you backport the IG?
23:33:18 <sparks> #action sparks to take the FAD @ SELF discussion to the Docs list
23:33:18 <rudi_> still underway; ETA 24-48 hrs
23:33:43 <sparks> #action rudi Backport IG material covering Anaconda UI revamp (ETA 24-48 hrs from today's meeting)
23:34:04 <sparks> #action ianweller to put together a "taskforce" to help give some love to the wiki
23:34:16 <sparks> Okay, anything else?
23:34:43 <sparks> #topic Schedule review
23:34:54 <sparks> #link http://poelstra.fedorapeople.org/schedules/f-13/f-13-docs-tasks.html
23:35:04 <sparks> #info Release notes lines 43-48
23:35:12 <sparks> #info Guides line 6
23:35:23 <jjmcd> RelNotes is on track
23:35:25 <sparks> We are fourteen days away from release!
23:35:32 <sparks> jjmcd: +1
23:35:56 <sparks> Does anyone have a guide to be released for F13 that is not in the hands of L10N?
23:36:03 <XulWork> 16:35 <@fedbot> XulWork: 2 weeks, 5 days, 15 hours, 24 minutes, and 22 seconds
23:36:15 <XulWork> more like 20 days
23:36:29 <ke4qqq> sparks: yes
23:36:30 <sparks> Really?  Oh, I bet it isn't updated on the schedule!
23:36:40 <ke4qqq> IQSG isn't it in l10n's hands
23:36:44 <sparks> No it is.
23:36:47 <sparks> Hmmm
23:36:51 <rudi_> IG and IQSG
23:36:55 <sparks> Okay, I must have looked at something wrong.
23:37:08 <sparks> what's going on with the IG and IQSG?
23:37:31 <rudi_> I'm backporting the Anaconda updates from the RHEL6 IG
23:37:40 <rudi_> There are massive changes
23:37:56 <sparks> :(
23:38:22 <rudi_> But like I said above, very nearly there now
23:38:40 <sparks> Okay
23:38:45 <ke4qqq> We think, from the IQSG those are mostly in place - but honestly haven't had a chance to read through it - Emad78 and bcotton have done the majority of the work. I think we may be lacking screenshots, which I think is part of rudi_'s work
23:39:01 <sparks> Okay...
23:39:07 <rudi_> Yeah, the problem is that those files need to be synced against the IG....
23:39:16 <ke4qqq> yep
23:39:17 <rudi_> But anyway, I'm untangling the spaghetti...
23:39:34 <sparks> Anyone have anything else for the schedule?
23:40:07 <sparks> #topic Release Notes
23:40:21 <jjmcd> OK, POTs went out MOnday
23:40:28 <sparks> jjmcd: Is all the info on the agenda current?
23:40:43 <sparks> #info POTS went out Monday
23:40:45 <jjmcd> I did pick up on a bug from F10 I think that affects doc-publican-rpm
23:41:03 <jjmcd> but the poster had some code in the spec that he wanted that didn't work
23:41:17 <jjmcd> and hasn't yet responded to a request for more explanation
23:41:36 <jjmcd> Also, you hopefully have all read stickster's thread on closing the beats
23:41:52 <jjmcd> If nobody has any objections/suggestions, I'll go ahead and do that
23:42:05 <sparks> So the text in L10N's hands are frozen, correct?
23:42:09 <jjmcd> correct
23:42:29 <jjmcd> And we want corrections in BZ not on the wiki
23:42:32 <sparks> #link https://translate.fedoraproject.org/projects/p/docs-release-notes/c/f13/
23:42:47 * sparks hopes for NO zero-day updates
23:43:01 <jjmcd> So, any comments on closing the beats?
23:43:26 <sparks> Go for it
23:43:28 <Emad78> I'll help if you want it.
23:43:44 <jjmcd> cool, I think I'll make a template so it will be easy
23:44:57 <jjmcd> sparks you want to #action it?
23:45:04 <sparks> jjmcd: go for it
23:45:18 <jjmcd> #action jjmcd to close beats
23:45:27 * sparks is pretty sure anyone can talk to zodbot
23:45:28 <jjmcd> I didn't notice you #char me
23:45:33 <jjmcd> Ahhh, OK
23:45:49 <sparks> Okay, anything else?
23:45:55 <jjmcd> I still need to spend some time with rudi
23:46:02 <sparks> after?
23:46:18 <jjmcd> I don't completely understand all he did with Tech Notes, but they are with L10N so that's what matters
23:46:28 <jjmcd> Yes, probably after today even
23:46:32 <sparks> ok
23:46:37 <sparks> move on?
23:46:44 <jjmcd> #eof on RN
23:46:50 <sparks> #topic Guide Status
23:47:17 <sparks> #link https://fedoraproject.org/wiki/Docs_Project_meetings#Guides
23:47:30 <sparks> I sent out a message earlier today asking for everyone to please update the guide.
23:48:04 <sparks> IG and IQSG are both still showing F13
23:48:18 <sparks> opps...IG and IQSG are both still showing F12
23:48:32 <rudi_> That's correct; that's the last complete version
23:48:59 <sparks> rudi_: But you'll have a version for F13?
23:49:06 <rudi_> Yes
23:49:30 <sparks> Okay, I interpret that F# as to the latest version in development not released.
23:49:36 <rudi_> Ah OK
23:49:40 <rudi_> I'll update
23:49:53 * sparks should probably make that clearer as it isn't now.
23:50:12 <rudi_> We should probably also change "Translated" to "In translation"
23:50:22 <sparks> Anyone know anything about the Deployment Guide?
23:50:25 <rudi_> Otherwise nothing there will *ever* say "Yes" :)
23:50:40 <rudi_> perspectival was working on the DG
23:50:48 <sparks> rudi_: True
23:50:58 <rudi_> I know there's been work towards an F13 version
23:51:12 <sparks> rudi_: Do you have a status on it or can you get one by next week?
23:51:28 <rudi_> I don't have a current status; but I will get one
23:51:49 <sparks> #action rudi_ to get a status on the Deployment Guide
23:51:52 <sparks> rudi_: Thank you
23:52:11 <sparks> rudi_: Anything on the SELinux guides from radsy?
23:52:13 <rudi_> NP, and sorry for the slowness from RH this cycle
23:52:29 <rudi_> Rasdsy is here today... let me look
23:52:43 <rudi_> Hmmm, but not in his chair :)
23:52:51 <sparks> jjmcd: Did you do the color code on that table?
23:52:51 <rudi_> I will get status on that too
23:52:54 <sparks> thanks
23:52:59 <jjmcd> no
23:53:01 <rudi_> I did
23:53:08 <jjmcd> and I haven't quite figured it out
23:53:12 <sparks> rudi_: That's right!  Can you provide a key or something?
23:53:22 <rudi_> NP
23:53:38 <sparks> #action rudi_ to get status on SELinux Guides or, better yet, get radsy to a meeting
23:54:00 <sparks> Okay, anyone need any help with their guide?
23:54:28 <sparks> Anyone have anything else on this topic?
23:54:55 <sparks> #topic Outstanding BZ Tickets
23:55:01 <sparks> #link https://bugzilla.redhat.com/buglist.cgi?query_format=advanced&classification=Fedora&product=Fedora%20Documentation&bug_status=NEW&bug_status=ASSIGNED
23:55:30 <sparks> #info 86 open bugs
23:55:44 <sparks> #info 11 new bugs
23:55:47 <radsy> hello
23:55:53 <sparks> radsy: Hi!  Give me a sec
23:56:39 <sparks> If you have time to work on bugs please do!  If you need some help trying to get one fixed come on up on IRC and ask.
23:56:45 <sparks> Anyone have anything else on this?
23:57:02 <sparks> #topic Guide Status
23:57:20 <sparks> radsy: You have the SELinux Guides and the Wireless Guides.  Can you give us a status, please?
23:58:00 <radsy> sparks, for all guides, it's mainly just a refresh for f13
23:58:21 <radsy> there are some gui updates for selinux which will be covered
23:58:42 <rudi_> (oh, and Managing Confined Services guide?)
23:58:45 <radsy> I plan to circle back heavily for F14 as RHEL is taking up a lot of time.
23:58:51 <sparks> Understood
23:59:03 <sparks> So what guides will you be releasing for F13?
23:59:30 <radsy> sparks, confined services, selinux user guide, security guide, wireless guide
23:59:46 <radsy> can i get a reminder of GA deadline?
00:00:27 <sparks> 18 May
00:00:32 <radsy> easy :)
00:00:39 <sparks> so the day before to get everything pushed to docs.fp.o
00:01:04 <radsy> day before = the only way to fly
00:01:41 <sparks> :)
00:01:44 <radsy> also, I have sponsored probably 5 people for contribs, but no appearances on irc :(
00:01:53 <sparks> :(
00:02:29 <radsy> so I am leaving translation folk out in the cold a little, but it's going to be a close call for GA
00:02:32 <sparks> I'm working with Gearoid with the Accessibility Guide.  As soon as he gets up to speed with Publican I'm going to let him run with it.
00:02:49 <sparks> radsy: Isn't some of it already translated?
00:03:08 <radsy> sparks, yes a few
00:03:13 <sparks> Okay
00:03:23 <sparks> Anyone have anything else on this topic?
00:03:56 <sparks> #topic Everything else
00:04:08 <sparks> Okay, anyone have anything else before we secure for the evening?
00:04:48 <sparks> Well, thanks everyone for coming out tonight.
00:05:11 <sparks> We'll meet up in #fedora-docs for drinks afterwards.
00:05:18 <sparks> Last call... anyone else?
00:05:49 <sparks> Okay, thanks everyone
00:05:53 <sparks> #endmeeting