fedora-meeting
LOGS
23:00:13 <sparks> #startmeeting Docs Project Meeting - Agenda: http://fedoraproject.org/wiki/Docs_Project_meetings
23:00:14 <zodbot> Meeting started Wed Apr 21 23:00:13 2010 UTC.  The chair is sparks. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:00:15 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:00:24 <sparks> #topic Roll Call
23:00:25 * sparks 
23:00:26 * stickster 
23:00:28 * jjmcd 
23:00:36 * Emad78 is here, in and out.
23:00:43 * rudi is here
23:00:50 * Gearoid is here
23:01:00 <sparks> #chair stickster
23:01:00 <zodbot> Current chairs: sparks stickster
23:01:01 <stickster> Hiya Gearoid :-)
23:01:05 <sparks> #chair jjmcd
23:01:06 <zodbot> Current chairs: jjmcd sparks stickster
23:01:11 <Gearoid> hello stickster
23:01:27 <stickster> Is nb here?
23:01:46 * gbinns is here
23:02:31 <sparks> Kudos to RH for their release of RHEL 6 BETA...  Will be looking for that at a server near me!  :)
23:02:32 <stickster> OK... hit it sparks!
23:02:40 <sparks> Okay, let's get going.
23:02:55 <sparks> #topic Follow up on last week's action items
23:02:58 <rudi> Thanks sparks :) It's been a tough couple of months :)
23:03:17 <sparks> stickster: You have #1
23:03:34 <stickster> #info rudi, radsy, noriko, etc... all are superfolks for being able to do as much as they've done for Fedora during RHEL6 crunch time
23:03:48 <stickster> Thank you to everyone from RH down under who helped
23:03:57 <sparks> +1
23:04:28 <stickster> #info stickster AI #1 -- done. goddard-backgrounds RPM is ready in repos. laubersm knows and is ready to roll
23:04:38 * jjmcd did #2
23:04:51 <sparks> #info sparks and jjmcd completed #2
23:05:02 <jjmcd> #3 not time for yet
23:05:07 <stickster> sparks: Some of those are lookaheads -- we can do #action again this time for them
23:05:13 <stickster> Makes them easier to track next week
23:05:15 <sparks> stickster: Thanks
23:05:15 <nb> now i am
23:05:28 <stickster> #action jjmcd Stop the cron job that brings in new POT stuff after 2010-04-26, UTC 2359
23:05:42 <stickster> #info stickster AI #5 -- done
23:05:54 <sparks> #action stickster Send reminder to L10n on 2010-04-21 that last POT changes are coming on 2010-04-26
23:05:55 <stickster> #action stickster Send reminder to L10n on 2010-04-29 that final relnotes translations are due on 2010-05-03
23:05:55 <jjmcd> #5 is next week but I saw #4
23:05:57 <stickster> #undo
23:05:58 <zodbot> Removing item from minutes: <MeetBot.items.Action object at 0x1959fa10>
23:06:07 <sparks> Opps
23:06:08 <stickster> :-)
23:06:10 <stickster> np, we're good
23:06:22 * jjmcd and stickster did #6
23:06:32 <stickster> #info jjmcd and stickster AI #6 -- done. talked after meeting about SRPM
23:06:44 <stickster> #action stickster On 2010-05-04 UTC 0001, build {S,}RPM, get it into Package CVS, build in koji, push to bodhi.
23:06:56 <stickster> #action rudi Run testing of publican publishing of JS/non-JS graceful HTML pages around 2010-05-11, a week before GA
23:07:04 <stickster> That brings us to #9
23:07:23 <jjmcd> laubersm said she was on schedule, prolly wouldn't be here tonight
23:07:23 <stickster> I wasn't watching IRC closely today, anyone know how Susan did with the office tools bit in the UG?
23:07:24 <sparks> jjmcd: You talked to laubersm about the office tools, right?
23:07:30 <stickster> heh
23:07:44 <jjmcd> SHe has a piece from Lewis I think to drop in
23:07:53 <rudi> stickster -- actually I hope I can demo something before the end of the meeting
23:07:56 <sparks> #info laubersm said she was on schedule for #9
23:08:04 <jjmcd> Was very pleased with his work
23:08:10 <stickster> :-) Awesome!
23:08:33 <sparks> #info sparks did #10... L10N really likes having the POTs early and they really like the individual POTs!
23:08:42 <stickster> SUPERB!
23:08:53 <jjmcd> Yes, MeTom dropped by said the new stuff was great
23:09:03 <jjmcd> and they like having the fedorapeople copies nightly
23:09:10 <stickster> rudi: Did you have a chance to ask laubersm about other changes beyond the NM and Printing chapters?
23:09:12 <jjmcd> MrTOm
23:09:20 <rudi> stickster; sorry, I failed
23:09:25 <sparks> Yes... Mr Tom gave kudos to the new Transifex and there was some love on the lists, too
23:09:38 <stickster> rudi: Shall we #action you again for that, or do you need to handoff to someone?
23:09:46 <rudi> No, I'll take it
23:09:55 <sparks> #action rudi Ask laubersm about other changes beyond the NM chapter and the to-be-added Printing chapter
23:10:07 <sparks> That brings us to nb
23:10:31 <sparks> Of course we've reserved time for that later unless nb needs to bail out early
23:10:37 <stickster> nb: We have 15 minutes set for you in the agenda, starting in 15 minutes -- is that workable for you?
23:11:28 <nb> should be
23:11:30 <stickster> OK, we'll come back to nb I think :-)
23:11:33 <stickster> ah!
23:11:34 <stickster> cool.
23:11:35 <sparks> excellent
23:11:42 <sparks> Okay... anything else before moving on?
23:11:48 <stickster> nada
23:11:54 <sparks> #topic Schedule review
23:12:06 <sparks> #link http://poelstra.fedorapeople.org/schedules/f-13/f-13-docs-tasks.html
23:12:16 <sparks> #info Release notes lines 43-48
23:12:23 <jjmcd> On Release notes, most of the things on the schedule are happening, we start the big crunch for the last wiki content tonight
23:12:25 <sparks> #info Guides line 6
23:12:26 <stickster> We probably want to look out to about line 53
23:12:37 <stickster> But I think everything there is totally under control
23:12:43 <stickster> starting tonight, as jjmcd said
23:13:14 <sparks> jjmcd: Any issues with the Release Notes and the schedule?
23:13:16 <stickster> We'll be working on hitting up all the wiki beats to find content that's changed, and get it into the git repo
23:13:24 <jjmcd> Nope
23:13:33 <jjmcd> stickster, did you see my post on the list?
23:13:35 <sparks> jjmcd: Was a message sent out about "wiki freeze"?
23:13:36 <stickster> #info Porting content happens starting tonight, getting beat changes into the git repo
23:13:51 <stickster> jjmcd: This was regarding the table?
23:13:53 <jjmcd> Documentation_beats was updated to reflect changes since beta
23:13:55 <jjmcd> yes
23:14:25 <stickster> jjmcd: Agreed on what you said there about new folks
23:14:26 <jjmcd> So if there is a 1 in wiki and a 0 in publican there is new content
23:14:32 <stickster> jjmcd: As far as mw-render -- there's no need to use it, actually
23:14:44 <stickster> It takes less time to port by hand at this point than to re-run mw-render and deal with all the changes it causes
23:14:55 <jjmcd> Probably right
23:15:12 <stickster> As long as you're using an XML-aware editor of choice, should be pretty quick
23:15:20 <stickster> quaid and I used to do the whole thing in one night more or less
23:15:29 <jjmcd> Emad78 is already working on the printing beat
23:15:35 <stickster> Nice, Emad78!
23:15:42 <rudi> Yeah; I've yet to come across an anything-to-XML tool that doesn't suck less than scraping it by hand...
23:15:49 <stickster> rudi: right on
23:16:08 <jjmcd> rudi, when you have entire wiki pages, mw-render does seem to help, but nowhere near perfect
23:16:28 <jjmcd> At least it doesn't take more time than manual!
23:16:47 <stickster> Yeah, if you have a long page at first, it can save time. If you're only pulling in a change you can just look at the wiki history/diff and do the change by hand in the XML
23:16:55 <jjmcd> exactly
23:17:00 <stickster> Anyway sparks -- I think we're cool
23:17:21 <sparks> Okay
23:17:30 <stickster> I do think we ought to put a new copy of en-US on docs.fp.o just for good measure
23:17:34 <sparks> Starting the 26th all guides need to be build daily...
23:17:45 <sparks> so L10N can see what's happening with their translations.
23:17:49 <jjmcd> release notes are being built daily
23:17:58 <stickster> jjmcd: Do the developers know where to find them?
23:18:01 <stickster> They may, I don't know
23:18:04 <jjmcd> L10N does
23:18:10 <sparks> Does everyone who leads a guide have their guide already in Transifex?
23:18:19 <jjmcd> fedorapeople.org/groups/docs
23:18:26 <stickster> jjmcd: I think the issue is, if someone panics and says, "Yikes, is ___ in the relnotes?" we want them to see the current status
23:18:28 <rudi> sparks -- no, and I'm the worst offender
23:18:33 <sparks> #info Accessibility Guide, readme-burning-isos, and security guide are being translated now.
23:18:44 <stickster> jjmcd: But... we've been giving repeated warnings
23:18:45 <rudi> #info Virt Guide is also being translated now
23:18:51 <jjmcd> Yes we have
23:18:55 <sparks> rudi: What's missing?
23:19:03 <jjmcd> and we've actually been getting those warnings out this time
23:19:06 <rudi> sparks -- IG and IQSG
23:19:14 <stickster> jjmcd: and *on* time too!
23:19:28 <sparks> rudi: What do you need to get POTs out for those?
23:19:49 <rudi> sparks -- finish backporting the RHEL6 stuff for the anaconda UI redesign
23:20:12 <rudi> Shouldn't be long now that I can focus back in the Fedora space
23:20:38 <sparks> rudi: Okay.  If you need anything just let me know and I'll see if I can squeeze out a few more minutes in the day.
23:20:43 <jjmcd> rudi, I need to know what magic you worked with the technical notes so I can build them
23:20:56 <sparks> Anything else on this topic?
23:21:06 <rudi> Bascially, if you look at the Guides Table, you'll see the white (still outstanding) guides are the ones with RH leads
23:21:15 <rudi> By some funny coincidence ;)
23:21:30 <sparks> #action sparks to send a message to the list reminding everyone to do daily builds and to make sure they are watching their translations.
23:21:35 <stickster> Are we still in schedule review?
23:21:42 <rudi> jjmcd -- OK -- we can talk after
23:21:47 * stickster doesn't know whether we covered relnotes and guides already as part of this
23:21:50 <sparks> stickster: Yes
23:21:52 <stickster> ok
23:22:25 <rudi> stickster +1
23:22:53 <jjmcd> There are three beats that need some prose, an opportunity for new contributors who might not be comfortable with publican yet
23:22:54 <sparks> stickster: yeah, I think we crammed everything in there.
23:23:15 <stickster> OK, I think we end up doing that sometimes :-)
23:23:19 <stickster> It means our minutes end up less readable
23:23:21 * sparks knows one that is good with XML already
23:23:36 <stickster> Let's #topic and I'll try to get zoddie to capture stuff for us
23:23:38 <stickster> #topic Release notes
23:23:40 <quaid> rudi: for the record, for one-way conversions, I'd rather use mw-render and fix, it does a good chunk of the work; when the wiki source is properly written (cf. our markup guidelines), it seems to save 60% of the work.
23:24:28 <stickster> #info Relnotes content porting to start after this meeting, on schedule
23:24:49 <jjmcd> #info Beats with red zeros are open hunting for new contributors who aren't ready to face publican
23:25:13 <jjmcd> 7 languages at 100%, 4 more >90
23:25:17 <stickster> #info jjmcd has marked as '1' in the wiki column has changed since Beta
23:25:39 <stickster> jjmcd: Can you, uh, just change that column header then?
23:25:44 <stickster> "Wiki good" is now inaccurate
23:25:54 <jjmcd> Roger that
23:25:57 <stickster> #action jjmcd Fix columns on https://fedoraproject.org/wiki/Documentation_Beats table
23:26:02 <jjmcd> #link https://fedoraproject.org/wiki/Category:Documentation_beats
23:26:15 <jjmcd> heh - you got the link in there
23:26:20 <stickster> np :-)
23:26:40 <stickster> #info mw-render probably not needed for remaining work unless a sudden large beat appearance happens
23:27:09 <stickster> one more item on this topic
23:27:20 <stickster> The Live Images beat as published is out of whack
23:27:37 <stickster> I thought we had removed the content about the 1 GB default Desktop Live image
23:27:57 <stickster> I can take care of that tonight
23:28:15 <jjmcd> Also, we need some weasel words around PowerPC
23:28:17 <stickster> #action stickster Fix Live image information and respond to thread pointing to next regular build on fp.o
23:28:28 <stickster> jjmcd: Can you track down what those should be?
23:28:40 <jjmcd> Yes
23:29:22 <jjmcd> I have another thing I would like that is actually technical notes
23:29:29 <jjmcd> But that was part of rn's
23:30:07 <jjmcd> Most of the creation of that is automatic.  I have documented the process but i would like someone else to do it to see where I slipped into klingon in my description
23:30:18 <stickster> #action jjmcd Find out what language we need to change regarding PowerPC and fix in git master
23:30:46 <stickster> jjmcd: Let's hit someone up on the list for it
23:30:52 <jjmcd> sounds good
23:31:25 <stickster> #action jjmcd Send request to list for someone to follow his instructions for generating Technical Notes to find any gaps or problems
23:31:52 <jjmcd> I don't like it when only one person knows how to do something
23:32:00 <stickster> I think we covered everything else here and we're running behind
23:32:02 <stickster> #topic Guide status
23:32:15 * stickster checks back in log to see what we didn't call out for minutes
23:32:33 <stickster> #info see above in "Schedule review" section for #info items
23:33:03 <stickster> I think the only thing there is rudi's work on backporting
23:33:08 <sparks> yes
23:33:21 <stickster> #action rudi Backport IG material covering Anaconda UI revamp
23:33:43 * stickster hands back to sparks for gavel to nb
23:34:19 <sparks> Okay, anything else before we move on to cvs -> git discussion?
23:34:30 <stickster> nada
23:34:35 <sparks> #topic git repo conversion (nb from last week)
23:34:41 * jjmcd is chomping at the bit to see nb's work
23:34:41 <sparks> nb: Take it away!
23:34:42 * nb here
23:34:57 <nb> http://git.fedorahosted.org/git/docs/web.git
23:35:04 <nb> it exists, i havne't got the build part set up yet
23:35:07 <nb> the proposal is to scrap php
23:35:12 <nb> and just use static html for everything
23:35:23 <nb> i'll have to re-import when we actually change
23:35:54 <nb> My proposal for the switch (when ready) is to remove everyone from the CVSROOT/avail, make a final import, and then let people push to git
23:37:02 <jjmcd> so a git commit/push is essentially a publish?
23:37:19 <quaid> ... and that's to replace the as-built until the Magical CMS appears?
23:37:27 <nb> yes
23:37:45 <nb> basically my import is just copying /srv/web/docs.fedoraproject.org (which is what is actually at the website)
23:37:47 <stickster> quaid: Right, and it shouldn't take long to put this up because it's following the template of the current website in fedora-web
23:37:49 <nb> which is after the php is done
23:38:16 * noriko needs to be away, and catch up rest later.
23:39:07 <stickster> nb: Is it worthwhile at all to really CVS import the history of that area?
23:39:12 <stickster> I'm thinking it's really not.
23:39:19 <nb> we aren't cvs importing it
23:39:30 <nb> its actually me making a new repo and then adding and committing the current website
23:39:31 <stickster> Right, so our git history would start in present day
23:39:33 <nb> yes
23:39:42 <stickster> Including all the content there, including old versions?
23:39:49 <nb> since we are completely changing everything (we will be having static html now)
23:40:00 <nb> yes, everything that is at docs.fp.org at the moment will be in the new repo
23:40:05 <stickster> OK
23:40:29 <stickster> nb: And that would live in, e.g. static/ correct?
23:40:40 <stickster> Since it's pre-translated and not like the data/content/ stuff?
23:40:54 <nb> hmm, right now i just have it all at docs/web.git
23:40:58 * stickster referring to the locations that the websites team uses in all other repos
23:41:01 <nb> i don't have a separate static or data/content
23:41:05 <stickster> Ah
23:41:13 <stickster> Well...
23:41:18 <nb> its not really necessary if we are doing pure static html
23:41:26 <sparks> nb: Do you have a timeline on doing all this?
23:41:30 * stickster thinking about the rest of the site though.
23:41:47 <nb> sparks, hopefully pre-f13 freeze
23:41:51 <stickster> nb: The site also has content *around* the docs, which could be translatable if we follow the way that the Websites team has done for their fedora-web repo
23:42:26 <nb> oops
23:42:29 <nb> yeah, we could do that
23:42:35 <rudi> In a few minutes I can demonstrate a slightly different take; but +1 that this is infinitely better than what we have now!
23:42:38 <stickster> I don't think there's any value in us putting a git repo up just to copy documents there, unless we gain a couple things: 1. site-wide templating; 2. translation of the non-docs content
23:43:24 <jjmcd> stickster, besides making pushing simpler/faster, it also makes infra's stuff faster
23:43:26 <stickster> s/any/as much/   <-- respecting that we have a --publish flag in publican still up to use
23:43:49 <stickster> jjmcd: Yeah, I'd just like to build on what the Websites team has already figured out for us
23:43:49 <rudi> And far less error-prone :/
23:44:00 <stickster> Which also includes the ability for anyone to run a sandbox locally with very little work
23:44:19 <jjmcd> Something to be said for stealing work alrady done
23:44:23 <stickster> nb: Are you familiar with the fedora-web repo?
23:44:34 <nb> stickster, some
23:44:47 <nb> stickster, we could make something like that
23:44:53 <nb> although if we do that, we may want to target post-f13
23:45:00 <jjmcd> stickster, are you thinking about translating the menu and such?
23:45:17 <stickster> We could easily leverage that.  The only thing that would live in data/content/, where most of their regular sites live, is things like the index.html and drafts.html page.
23:45:24 <stickster> Everything else that we publish is already translated
23:45:27 <nb> yeah
23:45:31 <stickster> and could live in the static/ section
23:45:39 <nb> i can get with ricky and mmcgrath
23:45:44 <stickster> jjmcd: The menu and everything else we could essentially just copy from fedora-web
23:45:47 <nb> i think they are the main ones that know about the setup of how stuff works
23:45:53 <stickster> They get translated at "no cost"
23:45:56 * laubersm slips in out of the rain
23:46:08 <stickster> nb: You might want to just make sure that they don't want us to "invade" their fedora-web repo itself
23:46:23 <stickster> I assumed the amount of data we'd be importing would make that an unpleasant option for them
23:46:30 <stickster> But you never know
23:46:38 <quaid> do we have old content?
23:46:44 <stickster> Right now they have fp.o, spins.fp.o, boot.fp.o, talk.fp.o...
23:46:45 <stickster> quaid: yes
23:46:46 <quaid> that could be archived, etc.
23:46:57 <stickster> quaid: We keep it on the site because people still hit it for old versions
23:47:02 <nb> the whole fedora-web is only 191M
23:47:04 <quaid> oh, they do?  ok
23:47:07 <nb> and ours is like 10x that
23:47:13 <stickster> nb: Right
23:47:29 <quaid> but
23:47:32 <quaid> only 10% of it is active
23:47:42 <nb> quaid, true
23:47:47 <quaid> could we put the non-active in an archive repo and never touch it?
23:48:01 <quaid> i.e., as we sunset a release we sunset the docs from fedora-web.git
23:48:08 <quaid> (if we ye gods forbid are still doing this in six months)
23:48:16 <stickster> Hm
23:48:30 * quaid likes the no-using-slow-CVS idea of updating, at the least
23:48:32 <stickster> I guess it could work, ricky could likely just have that stuff come down to static/ directly as needed
23:48:53 <nb> yeah we could make a docs/web-archive.git or something, and only allow select people to push to there if we want
23:49:00 <stickster> It would be pretty ugly of us to require someone to pull down a 2 GB repo just to help publish something
23:49:45 * sparks checks his watch
23:50:16 <quaid> stickster: honestly? that's stopped me recently, my cvs is so out of date and I hate the wait to update.
23:50:25 <stickster> yeah
23:50:27 <stickster> Let's move on
23:50:34 <stickster> nb: Let's discuss this on the docs@ list please
23:50:41 <nb> ok
23:50:47 <stickster> #action nb to bring plan to docs@ list that we can discuss to figure out the fine points
23:51:01 <stickster> #info we want to do something that's not too high a cost in time.
23:51:04 <stickster> sparks: take it away
23:51:04 <sparks> Okay, anything else on this topic?
23:51:16 <sparks> #topic FAD @ SELF
23:51:20 <sparks> Okay, real quick...
23:51:35 <sparks> How many Docs folks are going to be at SELF this summer?
23:51:39 * stickster 
23:51:50 * laubersm is a maybe
23:51:51 * sparks is trying to figure out if it's worth doing something Docs-centric
23:52:05 * jjmcd won't be there
23:52:24 <sparks> Okay...  I think I actually like quaid's thought earlier to make it a new user/new contributor meet-and-greet thing
23:52:28 <sparks> for all of Fedora
23:52:32 <sparks> not just Docs
23:52:40 <sparks> Thoughts?
23:52:52 <stickster> That could work
23:53:11 <stickster> I may have an idea germinating for FAD work but a couple things have to land first -- might be a couple of days
23:53:14 <sparks> #info ke4qqq is supposed to be getting back to sparks about the number of people that have signed up for SELF that said they would attend a FAD.
23:53:21 <stickster> Nice!
23:53:59 <sparks> stickster: You ready to talk about your idea or do you want to wait?
23:54:36 <stickster> It can wait for now
23:54:38 <gbinns> /whois sparks
23:54:42 <stickster> I'll have more later
23:54:47 <stickster> gbinns: Infidel! ;-)
23:54:51 <gbinns> haha
23:54:54 <sparks> stickster: Okay...
23:55:02 <gbinns> I'm trying to figure out what FAD and SELF are without interrupting.
23:55:03 <gbinns> sorry
23:55:03 <stickster> All hail sparks
23:55:11 <stickster> gbinns: Ah, FAD = Fedora Activity Day
23:55:26 <stickster> SELF = Southeast Linux Fest http://southeastlinuxfest.org/
23:55:27 <sparks> #action sparks to take the FAD @ SELF discussion to the Docs list
23:55:28 <rudi> (sorry to be out of sync guys -- http://publictest8.fedoraproject.org/fedoradocs/public_html/ )
23:55:38 <stickster> FAD: http://fedoraproject.org/wiki/FAD
23:55:52 <sparks> stickster: TU
23:55:59 <gbinns> got it, thanks stickster
23:56:00 <stickster> Ooo
23:56:05 <stickster> rudi: Wowsers
23:56:07 <sparks> rudi: Nice
23:56:15 <rudi> SVGs aren't being served properly
23:56:15 <stickster> Um, our work here is done...?
23:56:19 <rudi> So you'll see broken logos
23:56:42 <sparks> stickster: Yes...
23:56:57 <sparks> #topic New Publican-based web pages
23:57:02 * stickster just laughing that there's this whole site publishing thing :-D
23:57:15 <stickster> nb: Might want to see that above... :-)
23:57:38 <sparks> #link http://publictest8.fedoraproject.org/fedoradocs/public_html/
23:57:43 * nb likes that
23:57:54 * stickster too
23:57:59 <rudi> So still very rough around the edges -- but I've been pushed for time ;)
23:58:07 <stickster> understandable ;-)
23:58:27 <stickster> Well, this obviates the need for a git repo
23:58:35 * ianweller is here
23:58:37 <sparks> rudi: How does Publican know about the other docs or does one person have to build everything?
23:58:38 <stickster> If we can just copy things straight to a content area
23:58:57 * stickster notes he has a hard stop at :00 but will return at :30 for content porting
23:59:05 <rudi> sparks -- Publican maintains an sqllite database of the content
23:59:25 <rudi> You can see it sitting up here -- http://publictest8.fedoraproject.org/fedoradocs/
23:59:26 <jjmcd> that's cheating
23:59:34 <sparks> Ahh
23:59:47 <stickster> rudi: So there's some mod_perl stuff checking that as the server goes?
00:00:14 <sparks> Can everyone hang around another five minutes?
00:00:25 <rudi> stickster -- not quite; the database gets updated when somebody runs "publican install_book" or "publican remove_book"
00:00:35 <stickster> O-ho
00:00:50 <stickster> rudi: So you can just copy that like everything else?
00:00:55 <rudi> So to make this work, writers and translators need to:
00:00:56 <sparks> so there is a publican backend on the server
00:01:09 * stickster will tune back in later for rest of story
00:01:20 <rudi> 1. ssh into a machine that we use as a build server
00:01:35 <rudi> 2. git clone/svn co/whatever the book down from the repo
00:02:01 <rudi> 3. build the book on that server (which must have Publican installed)
00:02:25 <rudi> 4. run "publican install_book" to install the book to the website.
00:03:10 <stickster> OK, so this would require a RFR (request) to Infrastructure to get a build server...
00:03:14 <rudi> 5. either the "build server" now pushes the updated files across to the web server, or the web server sucks content down from the build server at some interval
00:03:18 <stickster> and group access sufficient to do what was needed.
00:03:26 <rudi> Well, we could also do the building on the web server itself...
00:03:33 <rudi> but I don't think we really want to do that....
00:03:36 * stickster suspects not
00:03:38 <sparks> #action rudi to bring all this information to the Docs list for further explanation/discussion
00:03:41 <rudi> :D
00:03:45 <rudi> Yep
00:03:52 * stickster also suspects he needs to run afk, back by :30 in #fedora-docs
00:04:05 * jjmcd gotta run too
00:04:13 <sparks> rudi: Anything else?
00:04:44 <rudi> That's basically it; the whole thing can be automated further, but I can detail that all on docs list now that we have a working copy as an example
00:04:53 <rudi> Thanks and sorry for running over :)
00:04:55 <sparks> Excellent.  Thanks!
00:05:01 <sparks> #topic Outstanding BZ Tickets
00:05:12 <sparks> #link https://bugzilla.redhat.com/buglist.cgi?query_format=advanced&classification=Fedora&product=Fedora%20Documentation&bug_status=NEW&bug_status=ASSIGNED
00:05:19 <sparks> #info 93 Open Tickets
00:05:24 <sparks> #info 15 New
00:05:30 <sparks> #info 78 Assigned
00:05:47 <sparks> If you have a free moment and you don't know what to work on, that would be a good place to start.
00:05:58 <sparks> #topic All other business
00:06:04 <sparks> Okay, anyone have anything else?
00:06:08 <gbinns> yeah
00:06:13 <sparks> gbinns: Go!
00:06:30 <gbinns> haha, ok so one area i understand could use some improvement is the wiki
00:06:35 * rudi just remembered he has one more thing too
00:06:37 <gbinns> in particular the following....
00:06:46 <gbinns> 1. https://fedoraproject.org/wiki/Category:Pages_that_need_love
00:07:21 <gbinns> and 2. making sure pages are as efficiently optimized as possible according to popularity, as seen here: https://fedoraproject.org/awstats/fedoraproject.org/awstats.fedoraproject.org.urldetail.html
00:07:32 <sparks> gbinns: Yes!  There are lots of wiki pages that need some love
00:07:58 <laubersm> and categories and archiving and renaming....
00:08:04 <Emad78> I'm willing to give some love to some of the wiki's
00:08:25 <gbinns> so i'm a huge noob with linux, and i am just getting to know everyone (hence all of the /whois' and questions on a regular basis), how would i go about making sure these pages are efficiently optimized?
00:08:25 <sparks> ianweller: What's your availability now days?
00:08:40 <gbinns> (and a huge noob with fedora in general, btw)
00:08:44 <ianweller> sparks: in two to three weeks i should be more than available
00:08:50 * laubersm learned much from ianweller when getting started in Docs
00:09:07 <sparks> ianweller: Do you want to lead the fight on cleaning up the wiki?
00:09:20 <sparks> ianweller: Looks like you have some warriors that can help you out.
00:09:22 <ianweller> i love fights, especially wikifights
00:09:26 <Emad78> ianweller: I'm willing to get my hands in there and help out.
00:09:27 <sparks> heh
00:10:06 <Gearoid> also if there is anything you guys think I would be helpful with, sign me up ;)
00:10:14 <sparks> #action ianweller to put together a "taskforce" to help give some love to the wiki
00:10:23 <ianweller> sparks: ... in a few weeks
00:10:29 <sparks> ianweller: Worksforme
00:10:33 <ianweller> \o/
00:10:43 <sparks> ianweller: Would you put something on the list, please?
00:10:52 <ianweller> docs@l.fp.o list?
00:10:56 <gbinns> if there is anything that can be done now, count me in, i'd also love to work with ian in a few weeks
00:11:05 <sparks> ianweller: Yes
00:11:08 <ianweller> k
00:11:25 <ianweller> i shall do so when i am done fixing my RAID
00:11:25 * quaid is willing to help find, clean, and write process docs
00:11:33 * laubersm notes that quaid was voluteering over in Docs to help ...
00:11:40 <quaid> yeah, like that :)
00:11:41 <sparks> and here!
00:11:59 <quaid> I love to clean up the wiki and stuff, but I feel so lonely when I do it because ... we don't have a culture and regular group doing it.
00:12:01 <laubersm> Figures - I never type fast enough...
00:12:06 <gbinns> i'm just confused for example, on pages that need love
00:12:15 <sparks> Gearoid: ianweller is the wiki czar and would appreciate the help.  Of course I'm going to get you working on the Accessibility Guide more, too!
00:12:18 <sparks> :)
00:12:32 <quaid> #link http://lists.fedoraproject.org/mailman/listinfo/wiki
00:12:33 <Gearoid> sure thing sparks!
00:12:42 <quaid> we can take out discussion there,too
00:12:58 <gbinns> in other words, how would one know what to do to improve a page on bengali fonts?
00:13:16 <quaid> wow
00:13:27 <quaid> maybe we should just start going over those pages
00:13:31 <quaid> one at a time in #fedora-docs
00:13:39 <laubersm> It is like herding cats
00:13:41 <ianweller> it is
00:13:41 <quaid> and as we answer "WTF?!?" we can write it down somewhere
00:13:44 <ianweller> +1 to quaid
00:13:46 <quaid> so we don't haveto think so hard next time :)
00:13:51 <gbinns> haha
00:14:31 <quaid> I write regularly on ~4 mediawiki instances and love that I can use Fedora Project wiki rules as an upstream (between me and Wikimedia)
00:14:38 <sparks> :)
00:14:56 <sparks> Okay, we can take this to #fedora-docs after the meeting.
00:14:59 <laubersm> Ambassadors have a challenge going right now for spiffing up the most active pages
00:15:03 <sparks> Anyone have anything else?
00:15:53 <quaid> laubersm: good idea for target pages to fix and learn on
00:16:06 <gbinns> yeah, thanks all for letting me contribute, definitely looking forward to being part of the team! it's great meeting everyone.
00:16:50 <laubersm> quaid, there are probably some other stats in there that can be leveraged
00:17:02 <sparks> Okay, I think that's all for tonight!  The wiki gardening conversation can move to #fedora-docs immediately following the meeting.
00:17:23 <sparks> If no one had anything else...
00:17:24 <sparks> 5
00:17:28 <sparks> 4
00:17:31 <sparks> 3
00:17:39 <sparks> rudi: Did you say you had something else?
00:17:56 <laubersm> 2.9
00:18:03 <sparks> 2
00:18:09 <sparks> 1\
00:18:17 <sparks> Okay, thanks everyone!
00:18:20 <sparks> #endmeeting