fedora-qa
MINUTES

#fedora-meeting: Fedora Quality Assurance

Meeting started by jlaska at 15:00:05 UTC (full logs).

Meeting summary

  1. Waiting for participants ... (jlaska, 15:00:24)
  2. Previous meeting follow-up (jlaska, 15:05:39)
  3. Fedora 13 RC test status (jlaska, 15:07:31)
    1. Blocker review - Last friday we had our first F-13-RC blocker meeting, and another is scheduled for this week (jlaska, 15:10:12)
    2. http://poelstra.fedorapeople.org/schedules/f-13/f-13-quality-tasks.html (maxamillion, 15:10:29)
    3. Acceptance test - This thursday a test run is scheduled for a new post-beta anaconda build (jlaska, 15:10:46)
    4. 2010-04-29 - Test 'Final' Test Compose (jlaska, 15:11:19)
    5. 2010-05-06 - Test 'Final' RC (jlaska, 15:11:26)
    6. 2010-04-22 - https://fedoraproject.org/wiki/Test_Day:2010-04-22_StorageFiltering (jlaska, 15:12:44)
    7. 2010-04-29 - Preupgrade test day (https://fedoraproject.org/wiki/Test_Day:2010-04-29_Preupgrade) (jlaska, 15:13:00)
    8. F-13 QA retrospective - now accepting ideas for improvement https://fedoraproject.org/wiki/Fedora_13_QA_Retrospective (jlaska, 15:16:21)
    9. https://fedoraproject.org/wiki/XFCE_Test_Day:Tentative (maxamillion, 15:19:30)

  4. Bodhi QA workflow status check-in (jlaska, 15:20:09)
    1. fenris02 asked how to update boot.fedoraproject.org with F-13-Beta (jlaska, 15:21:34)
    2. http://git.fedorahosted.org/git/?p=fedora-infrastructure.git;a=blob;f=bfo/pxelinux.cfg/fedora_install.conf;h=26acb46afa285f999356c912305395294240b0dd;hb=HEAD (jlaska, 15:22:54)
    3. ACTION: jlaska + fenris02 to review whether F-13-Beta is an option for boot.fedoraproject.org (jlaska, 15:23:45)
    4. adamw asked lmacken and mathieu for a heads up as to when the improved feedback system will be available (jlaska, 15:30:18)

  5. Proventesters check-in (jlaska, 15:31:23)
    1. As a nice April fools joke, maxamillion sent out the proventesters draft (http://lists.fedoraproject.org/pipermail/test/2010-April/089847.html) (jlaska, 15:32:00)

  6. Package Acceptance Test Plan check-in (jlaska, 15:36:20)
    1. https://fedoraproject.org/wiki/User:Kparal/Proposal:Package_update_acceptance_test_plan (kparal, 15:36:56)
    2. kparal asked for additional input on the package update acceptance test plan (jlaska, 15:46:14)
    3. ACTION: kparal will bother other QA members if they have some comments to the test plan :) (jlaska, 15:46:46)

  7. Proventesters check-in (jlaska, 15:48:10)
    1. maxamillion notes, "it looks like we're ready to move forward with the proposal" (jlaska, 15:48:33)
    2. ACTION: maxamillion - send Proventester draft to test@l.fp.org for final review (jlaska, 15:54:52)
    3. ACTION: maxamillion - Request new proventester FAS group (jlaska, 15:55:25)

  8. AutoQA check-in (jlaska, 15:56:07)
    1. Test results sent to autoqa-results will include a link to the autotest results for additional details (patches under review) (jlaska, 15:59:31)
    2. Getting URLs of test results from AutoQA testruns is nearly finished (jskladan, 15:59:41)
    3. https://fedorahosted.org/pipermail/autoqa-results/2010-April/016011.html (jlaska, 16:01:18)
    4. the beakerlib-based initscript test is now in production and sending results (jlaska, 16:01:46)
    5. made a progress on the ResultsDB front. We have finished the db schema <https://fedoraproject.org/wiki/AutoQA_resultsdb_schema> and accepted a input API <https://fedoraproject.org/wiki/AutoQA_resultsdb_API> (jlaska, 16:03:26)
    6. Next steps ... prototyping the resultsdb and using an XMLRPC based API to populate with results (jlaska, 16:06:12)
    7. Next steps ... Creating a front-end which will be used for review/publish the data (jlaska, 16:06:36)
    8. https://fedoraproject.org/wiki/Test_Package_Sanity (kparal, 16:08:04)
    9. https://fedorahosted.org/autoqa/milestone/Package%20Sanity%20Tests (kparal, 16:08:09)
    10. code for sanity tests is in AutoQA pst branch (kparal, 16:10:15)
    11. http://git.fedorahosted.org/git/?p=autoqa.git;a=shortlog;h=refs/heads/pst (jlaska, 16:10:25)

  9. Open discussion - <Your topic here> (jlaska, 16:18:23)
    1. AutoQA depcheck - we have enough info about current bodhi to write a update watcher, but it may have some shortcomings and will soon be obsoleted (jlaska, 16:22:42)
    2. AutoQA - we have a proposed storage encoding for putting test plan metadata in the wiki, and some code to pull that data back out as nice python dicts (jlaska, 16:24:13)
    3. https://fedorahosted.org/autoqa/ticket/137 has the link to the parsing code (wwoods, 16:25:13)


Meeting ended at 16:26:06 UTC (full logs).

Action items

  1. jlaska + fenris02 to review whether F-13-Beta is an option for boot.fedoraproject.org
  2. kparal will bother other QA members if they have some comments to the test plan :)
  3. maxamillion - send Proventester draft to test@l.fp.org for final review
  4. maxamillion - Request new proventester FAS group


Action items, by person

  1. fenris02
    1. jlaska + fenris02 to review whether F-13-Beta is an option for boot.fedoraproject.org
  2. jlaska
    1. jlaska + fenris02 to review whether F-13-Beta is an option for boot.fedoraproject.org
  3. kparal
    1. kparal will bother other QA members if they have some comments to the test plan :)
  4. maxamillion
    1. maxamillion - send Proventester draft to test@l.fp.org for final review
    2. maxamillion - Request new proventester FAS group


People present (lines said)

  1. jlaska (174)
  2. kparal (39)
  3. maxamillion (28)
  4. adamw (23)
  5. jskladan (19)
  6. wwoods (16)
  7. fenris02 (8)
  8. zodbot (4)
  9. Oxf13 (3)
  10. _lmr_ (2)


Generated by MeetBot 0.1.4.