fedora_docs
LOGS
23:00:39 <stickster> #startmeeting Fedora Docs
23:00:40 <zodbot> Meeting started Wed Apr 14 23:00:39 2010 UTC.  The chair is stickster. Information about MeetBot at http://wiki.debian.org/MeetBot.
23:00:42 <stickster> #meetingname Fedora Docs
23:00:42 <zodbot> Useful Commands: #action #agreed #halp #info #idea #link #topic.
23:00:45 <zodbot> The meeting name has been set to 'fedora_docs'
23:00:52 <stickster> Hi everybody!
23:00:55 <stickster> #topic Roll call
23:00:57 * stickster 
23:01:03 * sparks 
23:01:07 * Emad78 here
23:01:10 * Subfusc 
23:01:12 * jjmcd 
23:02:06 * stickster gives it a minute more in case we get a rudi, a quaid, or anyone else.
23:02:51 * ianweller is hereish
23:03:09 <stickster> Hi ianweller! Subfusc I haven't seen before either, but that may be because *I'm* not here sometimes!
23:03:29 * rudi is here
23:03:45 <stickster> #info present stickster sparks Emad78 Subfusc jjmcd rudi ianweller
23:03:52 <stickster> #topic Last week's action items
23:03:52 <Subfusc> stickster: I'm here representing fedora-tour today. You might have heard of us
23:03:58 <stickster> Awesome Subfusc!
23:04:15 <stickster> Agenda:
23:04:16 <stickster> #link https://fedoraproject.org/wiki/Docs_Project_meetings#Agenda_for_Next_Meeting
23:04:19 <jjmcd> action item #1 - done
23:04:35 <stickster> #link http://meetbot.fedoraproject.org/fedora-meeting/2010-04-07/fedora_docs.2010-04-07-23.00.html <-- last week's minutes and action items
23:04:44 <stickster> #info jjmcd completed #1
23:04:49 <jjmcd> whoops, jumped the gun
23:04:49 <stickster> #info stickster completed #2
23:04:52 <stickster> np jjmcd!
23:04:54 <jjmcd> Not #2 however
23:04:58 <stickster> Enthusiasm duly noted ;-)
23:05:24 * jjmcd will get on that, prolly thu pm or fri
23:05:49 <stickster> Does anyone know if laubersm did #3 -- note to Design team concerning wallpaper?
23:06:06 <stickster> laubersm left us some notes for later, but I didn't see anything about that in her notes
23:06:14 <jjmcd> don't know, and I don't know whether sparks even knew he was on item #2
23:06:41 <stickster> Looks like not
23:07:01 <stickster> design-team@ archives say negatory
23:07:05 <stickster> That's OK, we can reassing
23:07:08 <stickster> *reassign, even.
23:07:28 <stickster> #action stickster will pick up laubersm action item from last week (#3 -- note to Design team re wallpaper refresh)
23:07:31 <sparks> I'm #2?
23:07:45 <jjmcd> action item #2 from last week
23:08:10 <stickster> sparks: You're in action item #2, blogs to thank people who rolled out Transifex rollout -- jjmcd, you and I are all on it, but we did get one done, which is a success :-)
23:08:12 <stickster> More would be nice
23:08:28 <stickster> But it's at your discretion
23:08:31 <sparks> jjmcd: I saw that and then saw that stickster had done so...  but I will follow through as well.
23:08:35 * franciscod comes running in
23:08:53 <stickster> AI #4 is on ke4qqq and me to get content into Beta announcement -- this was done too
23:09:00 <jjmcd> Yeah, the thought was to blog-bomb them with thanks becuz out job is now so much easier
23:09:10 <stickster> #info stickster + ke4qqq completed #4
23:09:17 <stickster> jjmcd: Exactly
23:09:28 <stickster> We're saving so much time now because of the work those folks did for us on the back end
23:09:30 <stickster> So...
23:09:46 <stickster> Anyone want to put a hand up and say "I'll get a blog like that done by next week"?
23:09:55 * sparks 
23:09:59 * jjmcd 
23:10:23 <stickster> #action sparks jjmcd Blog a thank you to the Transifex roll out team in the next week
23:10:32 <stickster> #link http://marilyn.frields.org:8080/~paul/wordpress/?p=3128 <-- FYI
23:10:38 <stickster> OK, time to move on then
23:10:47 <stickster> Any objections?
23:10:52 <stickster> (or a +1)
23:11:05 <jjmcd> +1
23:11:17 <stickster> #topic Docs schedule review
23:11:19 <stickster> #link http://poelstra.fedorapeople.org/schedules/f-13/f-13-docs-tasks.html
23:11:42 <stickster> Line 41 is basically where we're at now
23:11:58 <stickster> The wiki freeze happens on Monday 2010-04-19
23:12:59 <stickster> At that point we're in a week-long task to pick up all final changes that are in the wiki beats since we last did a snapshot of content, and put those changes into the git repo for release-notes
23:13:10 <stickster> rudi: We are still going to use 'master' branch for that, right?
23:13:25 <stickster> And that gets merged to 'f13' for translators?
23:13:26 <rudi> Yep; master branch for everything
23:13:30 <stickster> rudi: Awesome, thanks
23:13:39 <rudi> Then refresh f13 every Mon/Thurs
23:13:42 <stickster> Right
23:13:50 <jjmcd> We put changes into the master branch and monday and thurs cron does his magic and moves it to f13
23:14:18 <stickster> OK, the next major scheduled items then are:
23:14:29 <stickster> #info 2010-04-26 -- produce the final POT files for F13 GA
23:14:46 <jjmcd> which basically means stopping the cron job
23:14:58 <stickster> jjmcd: Right
23:15:10 <stickster> #info Any cron job that is moving POT files needs to stop on 2010-04-19
23:15:19 <stickster> Publishing is fine though!
23:15:47 <jjmcd> Publishing drafts should continueuntil xlation end
23:15:48 <stickster> #info 2010-04-29 -- Remind translators of the deadline on 2010-05-03
23:15:59 <stickster> #info 2010-05-03 -- translation ends
23:16:17 <stickster> Oxf13: If you're around...
23:16:24 <Oxf13> I'm around.
23:16:36 <stickster> I want to confirm a date with you -- 2010-05-05 is an OK deadline for the Docs team to deliver a final fedora-release-notes package?
23:17:48 * stickster notes 2010-05-06 on rel-eng calendar is currently the date to compose the 'final' RC
23:18:17 <stickster> #info 2010-05-06 is final RC compose by Fedora Rel-Eng
23:18:31 <stickster> Oxf13: ^^
23:18:38 <Oxf13> 5-5 would be the absolute latest it could be tagged as stable.
23:18:42 <stickster> OK
23:18:57 <stickster> Oxf13: So... we will get all final translations on 2010-05-03, UTC 2359
23:19:11 <stickster> Oxf13: We *probably* could have a package done right afterward. It's a lot easier than it used to be.
23:19:25 <Oxf13> nod
23:19:29 <stickster> All rigth
23:19:31 <stickster> *right even
23:20:08 <sparks> ?
23:20:11 <stickster> #info 2010-05-03, but NLT 2010-05-05 -- deliver RPM to rel-eng and have it tagged
23:20:33 <stickster> Anybody have anything else for schedule review? We'll cover the action items for the relnotes that we just talked about after I change the topic.
23:20:40 <stickster> Oops, looks like we lost BNE
23:20:50 <Oxf13> stickster: I should note that the delivery mechanism is different now
23:20:55 * jjmcd should be able to have a package by 0300 05-04, but needs a sparks or stickster around to push it
23:21:09 <Oxf13> you would "deliver" the rpm to bodhi, and request it be pushed through testing and then into stable
23:21:25 <jjmcd> oh wait
23:21:26 <Oxf13> that request into stable has to be done prior to 5-4, so that it'll be in the stable tree come 5-5
23:21:42 * jjmcd will be out of town, so someone else will need to build the rpm
23:21:48 <stickster> Oxf13: OK, we'll be cutting it close but jjmcd and I can deliver the package into bodhi by the evening of 2010-05-03 US time
23:22:03 <stickster> jjmcd: I can do that, but you and I need to make sure the instructions are complete and correct.
23:22:07 <stickster> jjmcd: Let's cover that in a sec
23:22:09 <jjmcd> Yes,
23:22:36 <stickster> Oxf13: Sound reasonable? If we have it in bodhi testing on 2010-05-03 evening, we even have a few people around who can test and karma it.
23:22:39 <Oxf13> ok, if you deliver 5-3, it can go into testing 5-4, get some testing and be requested stable on 5-4, which means it'll show up in the stable repo for 5-5
23:22:53 <stickster> Oxf13: OK, that will be the plan.
23:23:03 <Oxf13> feel free to ping me when it's going stable so that I can make sure it goes in for 5-5's compose
23:23:13 <stickster> Oxf13: I'll make a note so that in the next release cycle we leave a *teensy* bit more time there.
23:23:19 <Oxf13> k
23:23:23 <stickster> Thanks Oxf13!
23:23:27 <Oxf13> np
23:23:41 <stickster> jjmcd: We'll move on to the relnotes topic and then do all the details about where/when.
23:23:58 <stickster> Move on? Or need more time? (+/-1 to moving on)
23:23:58 * nb here
23:24:02 <jjmcd> we can hit that afterwards
23:24:09 <sparks> ?
23:24:13 <jjmcd> i++
23:24:13 <stickster> sparks: Go ahead
23:24:18 <sparks> jjmcd: What are you using to build the multi-lang RPM for the RN?
23:24:21 <stickster> heh, C=speak
23:24:30 <stickster> sparks: Let's cover that in the relnotes topic.
23:24:35 <sparks> stickster: Ok
23:24:36 <jjmcd> d-p-r with some manual intervention
23:24:51 * stickster is going to keep these meetings on schedule.
23:25:05 <jjmcd> +1 to that
23:25:07 <stickster> #topic Release Notes
23:25:14 <stickster> OK, *now* let's talk about relnotes tasks
23:25:25 <stickster> First, thanks rudi, jjmcd, and everyone else who helped make Beta relnotes awesome.
23:25:58 <stickster> Now, let's talk about the next phas
23:25:59 <stickster> *phase
23:26:05 <stickster> #info see above for schedule information
23:26:08 <stickster> So...
23:26:39 <stickster> Our unanswered questions are, who is going to ensure that we pick up the new PO, roll a SRPM, build it in koji, and push to bodhi?
23:26:51 <stickster> rudi: sparks: jjmcd: Did I miss any open questions above?
23:27:04 <stickster> Ah, who stops the cron job
23:27:12 <jjmcd> stickster, I can give you step by step instructions and test them multiple times
23:27:14 <jjmcd> I do
23:27:18 <stickster> OK
23:28:19 <stickster> Does that need to stop on 2010-04-19, or 2010-04-26?
23:28:23 <stickster> rudi: ^^
23:28:31 <jjmcd> 26
23:28:40 <stickster> Yeah, I thought so. Thanks, I needed the head check!
23:28:45 <stickster> the 19th was the *original* date for that
23:28:47 <jjmcd> final pots 4-26
23:28:49 <stickster> #action jjmcd Stop the cron job that brings in new POT stuff after 2010-04-26, UTC 2359
23:28:52 <rudi> jjmcd +1
23:29:15 <stickster> What about the reminder to translators of the deadline?
23:29:23 <stickster> That happens on 2010-04-29
23:29:26 <jjmcd> 4/21 ?
23:29:56 <stickster> Ah, right jjmcd, there are *two reminders
23:30:09 <stickster> One on 2010-04-21 that the last POT is coming on 2010-04-26
23:30:17 <jjmcd> Yes
23:30:21 <stickster> And one on 2010-04-29 that the translation deadline is coming on 2010-05-03
23:30:43 <stickster> I'm open to taking them, unless someone really wants to do it
23:30:59 <jjmcd> I'd be good with that
23:31:29 <stickster> #action stickster Send reminder to L10n on 2010-04-21 that last POT changes are coming on 2010-04-26
23:31:51 * sparks wishes there was a "send at this date/time" in Thunderbird
23:31:53 <stickster> #action stickster Send reminder to L10n on 2010-04-29 that final relnotes translations are due on 2010-05-03
23:32:08 <stickster> sparks: at + mail?
23:32:19 <sparks> ?
23:32:33 <stickster> sparks: Go right ahead!
23:32:37 <sparks> No...
23:32:48 <sparks> I was saying I don't understand "at + mail"
23:33:20 <stickster> Oh, the 'at' command schedules a job on your system, and you could e.g. "cat mymsg.txt | mail -s 'Reminder' <recipient>"
23:33:24 <stickster> man at
23:33:36 <sparks> cool
23:33:42 <stickster> Hee hee, I'm still a pedant :-)
23:33:51 <stickster> A couple minutes left here --
23:34:12 <stickster> OK, picking up the PO, building the SRPM, getting that into Package CVS, building in koji, and pushing to bodhi
23:34:20 <stickster> That's a lot shorter task than it used to be
23:34:40 <stickster> #info Last task set is picking up the PO, building the SRPM, getting that into Package CVS, building in koji, and pushing to bodhi -- on 2010-05-03 right after L10n is done
23:34:57 <stickster> jjmcd: If I can follow the instructions for building the SRPM, I think we're golden here
23:35:03 * jjmcd thinks the po mystically appears
23:35:03 <stickster> I can do all the rest lickety-split
23:35:08 <stickster> Yup
23:35:15 <stickster> Should be pushed in already by Tx
23:35:29 <jjmcd> And the rpm is a piece of caks.  A few manual steps, but nothing really burdensome
23:35:48 <stickster> jjmcd: Can we meet after this meeting to just go over it real quick? I can do a test locally here without building/pushing anything officially.
23:35:54 <jjmcd> Yes
23:36:02 <stickster> #action jjmcd stickster Meet after this meeting to go over the RPM/SRPM building
23:36:34 <stickster> #action stickster On 2010-05-04 UTC 0001, build {S,}RPM, get it into Package CVS, build in koji, push to bodhi.
23:36:43 <stickster> OK, I think we're good for relnotes then, right?
23:37:01 <stickster> I don't want anyone to think I'm hogging things, just trying to pitch in where I can in this particular case :-)
23:37:16 * stickster is happy to add more people to maintainership or anything else required.
23:37:20 <jjmcd> I appreciate it since I will be hanging out with a bunch of cops that day
23:37:29 <stickster> Right on
23:37:36 <stickster> Move on, then?
23:37:43 <jjmcd> 3 days at a homeland security conference
23:37:45 <sparks> +1
23:37:48 <jjmcd> +1
23:37:58 <stickster> #topic Release Notes -- content party
23:38:11 <stickster> I proposed moving this back a week and didn't see any strong objections, and one +1 on list.
23:38:20 <stickster> Anyone else have a thumbs-up/down or comment?
23:38:24 <jjmcd> I had already moved that on my calendar since the whole sked slipped
23:38:34 <sparks> +1
23:38:40 <stickster> Cool, that's probably the right move then
23:38:40 <jjmcd> and we are likely to have more wiki updates between now and then
23:38:43 <stickster> Yeah
23:38:53 * stickster sent another poke himself to the devel@ list
23:38:56 <stickster> All rigth
23:39:01 <stickster> oh for goodness' sake :-\
23:39:19 <stickster> #agreed Content party moved back a week, to happen on 2010-04-21 and 2010-04-24
23:39:48 <stickster> This next bug topic came up in the context of release notes
23:39:55 <stickster> #topic JavaScript bug
23:39:55 <stickster> #link https://bugzilla.redhat.com/show_bug.cgi?id=544656
23:40:12 * jjmcd defers to rudi's expertise on that one
23:40:22 <stickster> rudi: You say there's a plan for this, can you tell us about it in < 5 min?
23:40:42 * stickster eyes clock grimly
23:41:16 <stickster> OK, we'll come back to that
23:41:24 <stickster> #info deferred until later in the meeting
23:41:35 <stickster> #topic Guide Status
23:41:37 <rudi> Yeah; basically, the Publican 2.0 Beta has a web publishing feature built into it that creates JavaScript menus that fall back gracefully to html
23:41:47 <stickster> #undo
23:41:47 <zodbot> Removing item from minutes: <MeetBot.items.Topic object at 0x2b03b363ded0>
23:42:06 <stickster> rudi: Oh, that's brilliant then! Is it something we'll have in F13 though?
23:42:15 <stickster> We're nearing development freeze
23:42:25 <rudi> We've been using this module (separate from Publican) internally in RH for years so it's very well tested
23:42:34 <rudi> It won't be in F13's Publican
23:42:42 <rudi> (before GA)
23:42:51 <stickster> Ah, so the idea is to... publish through a Rawhide box then?
23:43:06 <rudi> Kinda, yeah
23:43:07 <sparks> rudi: Does that mean one person has to build everything for it to generate that page?
23:43:13 <rudi> Hopefully not :)
23:43:17 * stickster thinks it's not vital that the publishing feature be *in* F13 to use it to publish F13 docs, but it does need to be understood by everyone how to do it
23:43:25 <rudi> Absolutely
23:43:38 <rudi> I plan to use the feature to build the menus
23:43:39 <stickster> rudi: Is that in the SVN already?
23:43:44 <rudi> Yes it is
23:43:45 <stickster> (for Publican, I mean)
23:43:48 <stickster> Awesome!
23:43:52 <rudi> Yeah; in the trunk
23:44:07 <sparks> rudi: Can you publish an example of the page?
23:44:18 <rudi> But we're still playing whack-a-mole with some 1.6 bugs that's delaying 2.0 testing
23:44:29 <rudi> Jeff's fedora people page:
23:44:34 <quaid> is someone maintaining separate RPMS we can install $anywhere of the latest Publican?
23:44:35 <stickster> rudi: sparks: Good idea, and I would like to make sure we test the publishing about a week before GA date
23:44:50 <rudi> http://jfearn.fedorapeople.org
23:44:54 <jjmcd> FWIW, the release-notes rpm uses Javascript and handles non-javascript browsers as well
23:45:13 <rudi> stickster +1
23:45:29 <stickster> rudi: Can I ask you to head that part up? Testing OOA 2010-05-11?
23:45:49 <stickster> OOA = on or about, sorry for jargon folks
23:46:00 <rudi> quaid -- maybe; I'll see what's needed to support our publishing effort
23:46:06 <rudi> stickster -- done
23:46:25 <stickster> #action rudi Run testing of publican publishing of JS/non-JS graceful HTML pages around 2010-05-11, a week before GA
23:46:38 <stickster> We want to make sure that works well on docs.fp.o before a thousand people hit it at once
23:47:06 <stickster> OK, guide status
23:47:27 <stickster> Moving on
23:47:31 <stickster> #topic Guide status
23:47:40 <stickster> Let me dump laubersm's comments here
23:47:43 <stickster> #link https://fedoraproject.org/wiki/User:Laubersm/F13_UG_Update_Checklist
23:47:43 <stickster> Above link has all the details and status.
23:47:43 <stickster> known open items (which I will get to eventually but welcome others help sooner)
23:47:43 <stickster> lewis41 needs help with the Network Manager chapter
23:47:43 <stickster> .bug 508025
23:47:44 <stickster> Is still open and up for grabs to the best of my knowledge.
23:47:45 <zodbot> stickster: Bug 508025 User Guide needs a chapter on printing - https://bugzilla.redhat.com/show_bug.cgi?id=508025
23:47:46 <stickster> #action laubersm to finish office tools this week
23:47:48 <stickster> #info thanks to Eli Madrinich, Nathan Thomas, David Nalley, Paul Frields, Ruediger Landmann for helping with the User Guide updates. If I missed anyone, please let me know so I can update the Contributors and Revision History correctly.
23:48:11 <stickster> So lewis41 needs help with the NM chapter
23:48:21 <stickster> That's a pretty big change, I imagine
23:48:31 <stickster> I'll be honest, I don't know if I can take care of this one
23:48:58 <stickster> The printing chapter was discussed earlier too -- I think I did offer to lend a hand there if possible
23:49:05 <stickster> Let me #info this for the minutes
23:49:17 <stickster> #info lewis41 needs help with the NetworkManager chapter of the User Guide
23:49:57 <stickster> #info We also need a chapter on Printing
23:50:22 <rudi> I also promised Noriko that for f13 I'd implement a way to credit translators on these major docs in a more timely fashion by including a link to a wiki page
23:50:25 <stickster> *: Did we say that printing chapter would be just adding a printer at the desktop that's already been configured?
23:50:44 <rudi> So I need to set up such a page and include a link in the contributors section
23:51:09 <rudi> The question is -- are we ready to drop this to L10N as is; and add the other chapters as they become available?
23:51:34 <stickster> rudi: I think we probably should, but changes will come in for the NM chapter
23:51:47 <stickster> And to whatever else laubersm still has cooking
23:52:07 <rudi> OK yeah
23:52:09 <stickster> So the fallout is that L10n may get hit with changes midstream
23:52:22 <stickster> We should probably ask them about this
23:52:58 <rudi> I'll ask laubersm what's expected outside the NM chapter
23:53:02 <stickster> sparks: Can you take the action item of emailing trans@ list and asking whether they would rather get a POT drop of the User Guide now, and maybe have some midstream changes, or get it later and have less time?
23:53:27 <sparks> stickster: Yes
23:53:43 <stickster> #action sparks Email trans@ list by Thu 2010-04-15 and ask whether they would rather get a POT drop of the User Guide now, and maybe have some midstream changes, or get it later and have less time
23:53:46 <stickster> Thanks sparks
23:53:51 <stickster> rudi: Cool
23:54:11 <stickster> #action rudi Ask laubersm about other changes beyond the NM chapter and the to-be-added Printing chapter
23:54:23 <stickster> So
23:54:31 <stickster> The Security Guide and the A11y Guide are on the agenda
23:54:36 <stickster> sparks: Did you need to speak to them?
23:54:54 <sparks> stickster: I was just going to give an update
23:54:56 <stickster> Before we get to that
23:55:01 * stickster holds up gavel
23:55:11 <stickster> #topic Meeting extension
23:55:20 <stickster> Can everyone here do an extra 15 minutes this evening/morning?
23:55:25 <nb> +1
23:55:28 <stickster> +1
23:55:28 <sparks> +1
23:55:30 <jjmcd> +1
23:55:53 <rudi> +1
23:56:00 <stickster> Anyone else?
23:56:04 * stickster waits 20 sec
23:56:23 <Subfusc> +1
23:56:40 <stickster> #agreed Meeting goes until 0015 UTC
23:56:46 <stickster> #topic Security Guide and A11y Guide
23:56:50 <stickster> Take it away sparks!
23:57:18 <sparks> #info The Security Guide has had a few updates since F12 and the POTs have been generated and are being worked.
23:58:00 <sparks> #info The Accessibility Guide has had updates and is being translated as well.
23:58:08 <sparks> And all is right with the world.
23:58:12 <stickster> SUPERB!
23:58:28 <stickster> #agreed sparks rocks for getting these guides rolling and into L10n
23:58:38 <jjmcd> agreed
23:58:46 <stickster> Anything else we need to know sparks? Or move on?
23:58:48 <sparks> L10n has been rocking on getting those docs translated!
23:58:50 <sparks> +1
23:59:07 <stickster> #agreed L10N ROCKS IT THE MOST, DADDY-O.
23:59:25 <stickster> sparks: jjmcd: ^^ You can use that in your blogs ;-)
23:59:35 <stickster> All righty then
23:59:50 <stickster> git conversion
23:59:53 <jjmcd> shaunm was at a doc conference that had a lot of non FOSS members
00:00:05 <jjmcd> said FOSS seems to be miles ahead on xlation
00:00:05 <stickster> Oh
00:00:25 <stickster> jjmcd: Just in terms of efficiency?
00:00:26 <jjmcd> Just an interesting datapoint
00:00:36 <stickster> I think there are a couple dimensions to it
00:00:37 <jjmcd> I got the impression in terms of getting it done
00:00:45 <stickster> I think our natural scalability is MILES ahead.
00:00:51 <jjmcd> Yes
00:00:58 <stickster> At the same time, there are still frontiers ahead of us for the tools we make for L10n'ers
00:01:25 <jjmcd> Sure, but at least we're not fighting M$ Word
00:01:25 <stickster> There's more to do, but regardless of that, the FOSS translation community is one of the finest examples of collaboration on the planet, IMHO.
00:01:33 <jjmcd> Absolutely
00:01:48 <jjmcd> I learned a lot when a net.friend started working on that
00:01:56 <jjmcd> from outside Fedora
00:02:26 <stickster> Excellent
00:02:43 <stickster> All right, out of respect for everyone's time, moving on
00:02:49 <stickster> #topic Git for docs.fp.o
00:02:58 <stickster> So here in a nutshell is what I wanted to discuss
00:03:06 * nb has some too
00:03:19 <stickster> Our website maintainers already use git to manage most of the web sites
00:03:22 <stickster> fp.o
00:03:25 <stickster> spins.fp.o
00:03:38 <stickster> talk.fp.o
00:03:39 <stickster> start.fp.o
00:03:44 <stickster> fh.o
00:03:48 <stickster> ...and so forth
00:04:05 <stickster> I think we should just take a page from their book, and do ours the same way.
00:04:15 <stickster> They already have a complete L10n infrastructure for the sites *themselves*
00:04:27 <stickster> And there's no crazy shuttling in and out of PHP
00:04:31 <stickster> It's all straight HTML
00:04:49 <stickster> However
00:05:01 <stickster> The wrinkle is... how the Publican publishing system would interact with this.
00:05:06 <stickster> So
00:05:11 <stickster> Rather than gum up the works
00:05:20 <stickster> I just wanted to suggest an idea like this...
00:06:10 <stickster> Well wait,
00:06:16 <stickster> Before I do that -- what do *you* guys think?
00:06:22 * stickster shuts up
00:06:35 <jjmcd> getting away from cvs would be a godsend
00:06:38 * nb had been kind of working on a solution which the first step of it was basically moving how we do it in cvs to git
00:06:39 <sparks> +1
00:07:04 * nb needs to get us a publictest server to test on
00:07:20 <stickster> nb: So how do you envision that working?
00:07:30 <stickster> It sounds like everyone wants this around yesterday
00:07:50 <stickster> But we can wait a bit if you've got a plan in motion
00:07:50 <nb> stickster, basically the first step would be basically cvsimporting /cvs/fedora/web/html/docs into git.fedorahosted.org/git/docs/web.git
00:08:02 <nb> and then making the build script pull from there
00:08:06 <stickster> Right, I had figured as much
00:08:08 <nb> which shouldnt take too long to get set up
00:08:16 <nb> and then i can make more changes however the docs team wants it
00:08:49 <nb> stickster, jjmcd sparks does that sound like you were wanting?
00:08:50 <nb> thoughts?
00:08:58 <jjmcd> YES!
00:08:58 <stickster> nb: It sounds like it to me.
00:09:10 <stickster> nb: How much time do you estimate this is going to take to complete?
00:09:35 <stickster> On the Websites/Infra side, I doubt it's too much work -- basically changing their scripts to pull from a git repo instead of (shudder) CVS.
00:09:42 * nb agrees
00:09:50 <nb> i think i could have it done within a few days
00:09:51 <stickster> But they will certainly want it well tested first.
00:10:00 <nb> do we want to target before or after f13?
00:10:03 <stickster> nb: Can you be prepared to present your work at the next Docs meeting, do you think?
00:10:04 <nb> infra freezes soon iirc
00:10:26 <nb> 2 weeks before release iirc
00:10:31 <stickster> nb: Infra freeze will start 2010-05-04
00:10:34 <stickster> That's about three weeks from now
00:10:36 <nb> oh ok
00:10:41 <nb> we should be able to definately get before then
00:10:45 <nb> .nextdocsmeeting
00:10:59 <stickster> .nextmeeting docs
00:11:00 <nb> do we meet every week or 2 weeks?
00:11:02 <jjmcd> woo-hoo
00:11:09 <stickster> Hm, zoddie may not know about us.
00:11:11 <stickster> nb: Every week.
00:11:18 <nb> I think i should be able to
00:11:36 <stickster> nb: So can you have a working git repo, with preserved history/email, and a publictest ready by then?
00:12:00 <nb> I should be able to
00:12:03 <stickster> #info nb is working on a solution to this, and is going to kick it into high gear, woo!
00:12:04 <nb> cvsimport is generally pretty easy
00:12:09 <sparks> WOOT!
00:12:10 <nb> and i don't think the build changes will be that hard
00:12:11 <stickster> nb: http://fedoraproject.org/wiki/Importing_Docs_CVS_modules_to_git
00:12:26 <stickster> That shouldn't be too different whether it's Docs CVS or the old Web CVS.
00:12:37 <stickster> The important thing is maintaining author history
00:12:52 <stickster> Well, that's not the only important thing... but it's important nonetheless :-D
00:13:00 <nb> yeah
00:13:06 <stickster> Okay nb -- I'm going to put you down to present your work next meeting, OK?
00:13:28 <nb> ok
00:13:39 <stickster> #info nb Present a git repo conversion and a docs site in testing at next Docs meeting -- 2010-04-21 UTC 2300
00:13:44 <stickster> #undo
00:13:45 <zodbot> Removing item from minutes: <MeetBot.items.Info object at 0x2b03b317b590>
00:13:49 <stickster> #action nb Present a git repo conversion and a docs site in testing at next Docs meeting -- 2010-04-21 UTC 2300
00:14:02 <stickster> All right, that's all I have for tonight
00:14:09 <stickster> Anyone else in the ... uh, 60 sec left?
00:14:53 <stickster> OK, that looks like a no
00:15:02 <stickster> Thanks for coming everyone!
00:15:04 <stickster> #endmeeting